Overview

[image]

PDFTron SilverDox SDK
Overview
Send Feedback

SilverDox: View PDF, XPS, Office, … in Silverlight.

SilverDox is a feature-rich and highly customizable Silverlight document viewer component that enables Silverlight applications with flawless and efficient viewing of PDF, XPS, MS Office, and other document formats.

Using SilverDox SDK developers can quickly add PDF, XPS, and universal document viewing capabilities to their Silverlight applications.

SilverDox SDK includes a royalty free Silverlight document viewing control and a document publisher that can directly convert from PDF, XPS, MS Office, and any printable document to Silverlight.

intro image 002

The highly customizable viewer can be freely distributed along with the documents on any web-site. Among many advanced features the viewer includes support for resolution independent vector graphics, text search and highlighting, printing, and fast incremental download. The viewer is ideally suited for use on netbooks, smart phones, and other portable devices with limited CPU or memory resources.

SilverDox viewer does not require any server side technology to work. Users can upload their Silverlight documents to any web site and can send links to their documents without any programming.

Also because SilverDox documents are standards compliant web optimized subset of XPS format, the files can be viewed, printed, and manipulated using WPF, .NET, or any other XPS technology.

Features

· Direct, high-quality conversion from PDF, XPS, EMF, and image formats to Silverlight optimized XPS (XOD).

· Safe for concurrent conversion in multi-threaded applications.

· Direct conversion from MS Office (Word, Excel, PowerPoint, etc.) to Silverlight XPS (XOD).

· Conversion from any printable document to Silverlight XPS via a virtual printer driver.

· Free viewing control that can be used on any website.

· Resolution independent vector graphics and zoom.

· High quality printing.

· All files are automatically optimized for web viewing.

· Text selection, highlighting, copy & paste.

· Programmatic text search.

· Highly customizable control through templates or source code.

· Preserves links, text, and color.

· Fast and optimized incremental downloading.

· Supports a number of built-in page presentation and rotation modes.

· Low-memory footprint.

Benefits

· Lightweight & no dependencies - The Silverlight viewer is very lightweight (only 250 kb!) and has no dependencies, which means that the host application will load without any delays.

· Top performance with small and stable memory use - The Silverlight viewer offers top performance as well as small and stable memory footprint when viewing, downloading, or printing large and complicated documents with thousands of pages.

· Smooth document viewing experience - Because documents are loaded incrementally and in the background, the UI is always responsive.

· Fast - The publishing process guarantees that images will load quickly and incrementally.

· High accuracy - Accurately view any PDF or XPS document. Graphical elements which can't be mapped accurately can be selectively rasterized to maintain the appearance of the original document.

· Full support for PDF and XPS specification - The document publisher supports full XPS and PDF specification (including HD Photo, TIFF, CMYK, ICC profiles, JBIG2, JPEG2000, encryption, Type3, CFF, CID, etc.).

· No need for server side technology - A URL link is all that is needed to view the document.

· Documents are optimized for online viewing - Many PDF or XPS documents are the end result of a print/spool process and are not suitable for publishing on the web. Also, files may contain huge images suitable only for offset printing, or may be interleaved, contain replicated fonts, and other features that would bloat or slow down the Silverlight viewer or the HTTP communication channel. SilverDox documents (.XOD) are a standards-compliant and web-optimized subset of the XPS format and the files can be viewed, printed, and manipulated using WPF, .NET, or any other XPS technology.

· Automatic thumbnail generation - SilverDox guarantees that thumbnails are always available which improves document browsing and navigation experience.

· Easy text access - Easy text access allows simple implementation of full-text search in the client or on the server side.

· Simple and customizable API - Simple to use API provides a set of ready-to-use, customizable controls as well as a set of building blocks to build new controls from scratch.

· DRM support - Simple extensions for Digital Rights Management (DRM).

· Open - SilverDox documents are based on open standards such as Open XML Paper Specification, ISO 32000, etc. This means that SilverDox documents can be viewed and processed using WPF, .NET, or any other API supporting XPS or Open Packaging Conventions (OPC). Closed systems can stifle innovation and growth.

· Free Viewer - The SilverDox viewing component is free with the required SilverDox document publisher license.

For more benefits please see http://www.pdftron.com/pdfnet/benefits.html.

Send comments on this topic to info@pdftron.com

© 2010-2012 PDFTron Systems, Inc. All Rights Reserved.


Introduction

[image]

PDFTron SilverDox SDK
Introduction
Send Feedback

Introduction to SilverDox

This document will step you through getting up and running with SilverDox. By the end of the document, you will understand the basic architecture of a SilverDox based solution, know how to convert existing documents to Silverlight documents, how to view the documents, and where to go next.

SilverDox Architecture

A SilverDox based solution is composed of two main parts:

1. A SilverDox Publisher, which is responsible for converting documents to Silverlight XPS (also known as XOD).

2. A SilverDox Client, which is a Silverlight based application capable of viewing XOD files.

The basic workflow of a SilverDox based solution is to use the a SilverDox Publisher component to convert input files (PDF, DOC, DOCX, JPG, etc.) to XOD, and then use the SilverDox client to view the resulting XOD file. A XOD file is simply an XPS file that has been optimized for online viewing. For more information please refer to see the SilverDox FAQ.

The SilverDox Publisher will typically reside at a central location such as a file server, and the clients will be used on remote computers to view the files. Note that the client computers require nothing to be installed beyond a web browser and the Silverlight plug-in as the Silverlight components are served on-demand from a web server, and then executed on a remote machine.

The SilverDox Publisher comes in two flavors:

1. Aa command line interface (CLI) executable called DocPub, which can be downloaded here.

2. Aa .NET, JAVA, or C/C++ API (pdftron.PDF.Convert.ToSilverlight()) which is an add-on to PDFNet SDK. For an example of how to use this API, please see the Silverlight sample project.

To embed document viewing in your Silverlight solution use SilverDox SDK, which can be downloaded here. To get up and running quickly, source code for several sample clients is included as part of the SDK. The sample code may be used as-is, or as a starting point to create a viewer customized for your particular needs.

Getting Started: Converting a Document

The first step is to convert a document to XOD with one of thea SilverDox pPublisher components. The publisher we will use here is the DocPub CLI executable.

Step 1: Download the SilverDox Publisher CLI file from http://www.pdftron.com/silverdox/downloads.html and unzip the archive.

Inside there are 7 files:

File | Description
docpub32.exe | A 32-bit command-line interface executable for converting documents to XOD files.
docpub64.exe | A 64-bit command-line interface executable for converting documents to XOD files.
legal.txt | Legal notice.
license.pdf | Software license agreement.
test32.bat | A sample script that will use docpub32.exe to convert documents in several ways. Right-click on the file and choose edit to see the script’s contents.
test64.bat | A script that will use docpub64.exe to convert documents in several ways. Right-click on the file and choose edit to see the script’s contents.
usage.txt | A text file Eexplainsing all of the possible dDocPpub switches and contains illustrating several examples.

Step 2: We will convert the license.pdf file to a XOD. While holding down the shift-key, right click on or inside the “SilverDoxPublisherCLI” folder you just unzipped and choose “Open command window here”. A command prompt will open. To convert license.pdf to license.xod, type the following (replacing 32 with 64 if using a 64-bit OS), and then press return:

docpub32 -f xod license.pdf

What did that mean?

Entry | Meaning
docpub32 | Launches document publisher utility.
-f | A switch indicating the output format will be specified in the next argument.
xod | The output format is to be xod.
license.pdf | The name of the source file to be converted.

If you look inside the SilverDoxPublisherCLI folder, there will be a new file, “license.xod”. This is the converted Silverlight xps file that can be opened with a SilverDox viewer, and concludes our use of the publisher. To view “license.xod”, we now turn our attention to the SilverDox client.

Getting Started: Viewing a Document

Step 3: To view the newly created license.xod file, we will use one of the sample clients located on the PDFTron’s SilverDox samples webpage. Open your internet browser and point it to the PDFTron Samples web page, located at http://www.pdftron.com/silverdox/samplecode.html. Click on the image below the heading “ReaderControl Sample” to open a new browser window containing a SilverDox client. (If you do not have a recent version of Silverlight installed on your computer, you may be prompted to download and install it.) This sample SilverDox client is written to automatically open a document located on pdftron.com, but we will now use it to open the document that was just converted.

Step 4: To open an open file dialog, click the button that looks like a folder:

Navigate to where the file was converted, and open the converted XOD file. You will now see the file, and be able to navigate the document. You can explore the capabilities of this particular client using the toolbar buttons to navigate, zoom, change the page layout, search or print the document. The sidebar provides the ability to navigate using thumbnails, search the entire document at once, and, for documents that contain an outline, navigate by clicking on bookmark headings.

Figure 1: The ReaderControl Client Displaying License.xod

This concludes the client portion of this guide. If you wish, you may now try converting other files present on your computer to XOD, and view them using SilverDox client.

Next Steps

The next step would be to create and compile your own client. For a step-by-step tutorial on creating your first client, download the SilverDox Viewer SDK (http://www.pdftron.com/silverdox/downloads.html) and look at the documentation’s “Getting Started” article. You can also open the SDK’s samples folder containing 5 sample projects, including the completed tutorial project and the project that builds the client used in this guide.

© 2010 PDFTron Systems, Inc. All Rights Reserved. All other trademarks are the property of their respective owners.


Getting Started Tutorial

[image]

PDFTron SilverDox SDK
Getting Started Tutorial
Send Feedback

SilverDox DocumentViewer Tutorial

Introduction

Creating a Silverlight Application

Adding a SilverDox DocumentViewer

Loading a Document into DocumentViewer

Loading a Document from an HTTP Server

Loading a Document from the Local File System

Creating external controls to communicate with DocumentViewer

Binding To Dependency Properties in XAML

Changing DocumentViewer Properties in Code-Behind

Introduction

The SilverDox DocumentViewer is a full-featured control used to display Silverlight XPS documents (i.e. ‘.xod’ files) published using SilverDox Publisher. This tutorial will show you how to use some of the basic features of the toolkit such as loading a remote or local document and displaying the document in the viewer.

If you are interested to immediately use a high-level document viewer you can use ReaderControl located in the ‘Samples’ folder. The use of this control is showcased in ‘Samples\ReaderControlSample’ sample. The sample viewer control can be directly embedded into a Silverlight application and it offers out-of-the-box functionality for a thubmanail and Bookmark navigation, text search, document printing, and full screen mode.

In case you have very specific requirements and modifications to ReaderControl or DocumentViewer do not meet your needs, you may extend DocumentViewer or create a new custom viewer to display a Silverlight document (PDFTron.SilverDox.Document).

The tutorial assumes use of VisualStudio 2010. A finished tutorial project is located at SilverDoxSdk\Samples\SilverDoxTutorial

Creating a Silverlight Application

1. Create a new Silverlight Application project in Visual Studio 2010.

Figure 1: New Project Dialog

2. In the dialog box that follows, accept the defaults while making sure that you are using at least Silverlight 4.

Figure 2: Silverlight Application Options

Adding a SilverDox DocumentViewer

3. Next, add the SilverDox library from the SDK as a Reference in your project. Right click on References in the solution explorer. Select Add References... to bring up the Add Refereces dialog. The SilverDox library can be added to the project by browsing to the dll under the Browse tab. The library is located in SilverDoxSdk\Bin\SilverDox.dll

Figure 3: Solution After Adding the SilverDox dll

4. Now, add the DocumentViewer control in xaml by first adding the SilverDox controls namespace. Double click on MainPage.xaml file to edit the xaml file.

CopyMainPage.xaml
xmlns:sdox="clr-namespace:PDFTron.SilverDox.Controls;assembly=SilverDox"

5. Next, add the DocumentViewer control just as one would for any other control. You can also set the viewer’s visual properties such as margins and background color. Replace the default Grid with the following:

CopyMainPage.xaml
    <Grid x:Name="LayoutRoot" Background="White">
        <sdox:DocumentViewer x:Name="MyDocumentViewer"
                             Margin="5"
                             Background="LightGray"/>
    </Grid>

If you run the project now, you will see a blank document viewer. We will now add code to load a document into the viewer from an HTTP server.

Loading a Document into DocumentViewer

All documents are loaded into a DocumentViewer via its LoadAsync function. LoadAsync has two parameters: an object which implements the IPartRetriever interface and a callback. The IPartRetriever object is used to load a document, and the callback function is called when the document loading has begun.

There are two IPartRetriever classes defined in the namespace PDFTron.SilverDox.IO: HttpPartRetriever and LocalPartRetriever. As their names suggest, HttpPartRetriever fetches documents from a HTTP server, and LocalPartRetriever fetches documents from the local file system.

Loading a Document from an HTTP Server

6. Right click on MainPage.xaml in Solution Explorer and select View Code to edit MainPage.xaml.cs. Add the following using statements:

CopyMainPage.xaml.cs
using PDFTron.SilverDox.IO;
using PDFTron.SilverDox.Controls;

7. and change the MainPage class to look as follows:

CopyMainPage.xaml.cs
public partial class MainPage : UserControl
{
    public MainPage()
    {
        InitializeComponent();
        LoadDocument();
    }
    public void LoadDocument()
    {
        Uri documentUri = new Uri("http://www.pdftron.com/silverdox/samples/ClientBin/PDFTron_PDF2XPS_User_Manual.xod");
        HttpPartRetriever myHttpPartRetriever = new HttpPartRetriever(documentUri);
        this.MyDocumentViewer.LoadAsync(myHttpPartRetriever, OnLoadAsyncCallback);
    }
    public void OnLoadAsyncCallback(Exception ex)
    {
        if (ex != null)
        {
            //An error has occurred
            System.Diagnostics.Debug.WriteLine(ex.StackTrace);
            MessageBox.Show("Error loading document: " + ex.Message);
        }
        MyDocumentViewer.SetFitMode(DocumentViewer.FitModes.Panel, DocumentViewer.FitModes.None);
    }
}

If you now run the project, you will see the DocumentViewer display a document. You will be able to scroll through the document as well as right-click to access a contextual menu to select and copy text, zoom in and out, and set fit to page/width.

Loading a Document from the Local File System

Due to Silverlight’s security restrictions, a FileStream from an arbitrarily located file must be obtained via an OpenFileDialog. While loading a local file is not directly included in this tutorial, the following code snippet shows how to use an OpenFileDialog and LocalPartRetriever to load a document. Note that the method LoadLocalDocument must be user-initiated (i.e. LoadLocalDocument must be called as the result of a user action such as clicking a button), or a security exception will be thrown.

CopyMainPage.xaml.cs
private LocalPartRetriever MyRetriever;
public void LoadLocalDocument()
{
    OpenFileDialog dlg = new OpenFileDialog();
    dlg.Multiselect = false;
    dlg.Filter = "XOD Files (*.xod)|*.xod";

    // open dialog
    bool ok = (bool)dlg.ShowDialog();

    if (ok)
    {
        if (MyRetriever as LocalPartRetriever != null)
            ((LocalPartRetriever) MyRetriever).Dispose();
        FileStream fileStream = dlg.File.OpenRead();
        MyRetriever = new LocalPartRetriever(fileStream);
        MyDocumentViewer.LoadAsync(MyRetriever, OnLoadAsyncCallback);
    }
}

Creating external controls to communicate with DocumentViewer

Now that we have a basic DocumentViewer, we can add controls to access and change the state of the DocumentViewer. There are two ways controls communicate with the DocumentViewer: by binding to DocumentViewer ‘s dependency properties in the XAML (or code-behind), or by calling functions and changing properties of the DocumentViewer object in the code-behind.

Binding To Dependency Properties in XAML

DocumentViewer has dependency properties such as zoom, current page number, and tool mode. A one-way binding allows us to get information from the DocumentViewer, e.g. getting the total number of pages in the current document, while a two-way binding allows getting and setting information from the DocumentViewer, e.g. getting or setting the currently displayed page number.

8. Edit the main part of the XAML file as follows, which adds text below the viewer to indicate how many pages are currently in the document, and which is currently displayed.

CopyMainPage.xaml
   <Grid x:Name="LayoutRoot" Background="White">
        <StackPanel>
            <sdox:DocumentViewer x:Name="MyDocumentViewer"
                             Margin="5"
                             Background="LightGray"
                             Height="500"
                             Width="500"/>
            <StackPanel Orientation="Horizontal" HorizontalAlignment="Center">
                <TextBox x:Name="CurrentPageNumberTextBox" VerticalAlignment="Center"
                         HorizontalAlignment="Left" Width="30"
                         Text="{Binding CurrentPageNumber,
                         ElementName=MyDocumentViewer,Mode=TwoWay}"/>
                <TextBlock Text="of " VerticalAlignment="Center"/>
                <TextBlock x:Name="PageCountTextBox" VerticalAlignment="Center"
                           HorizontalAlignment="Left" Width="30"
                           Text="{Binding PageCount, ElementName=MyDocumentViewer}"/>
            </StackPanel>
        </StackPanel>
    </Grid>

Note that the currently displayed page is bound with a two-way binding, so that changing the text of the currently displayed page text box (and then clicking on the viewer so that the text box loses focus) will cause the viewer to scroll to that page.

Changing DocumentViewer Properties in Code-Behind

DocumentViewer properties may also be changed by directly altering them in code.

9. Edit the XAML as shown below to include two buttons for changing the current page.

CopyMainPage.xaml
    <Grid x:Name="LayoutRoot" Background="White">
        <StackPanel>
            <sdox:DocumentViewer x:Name="MyDocumentViewer"
                             Margin="5"
                             Background="LightGray"
                             Height="500"
                             Width="500"/>
            <StackPanel Orientation="Horizontal" HorizontalAlignment="Center">
                <TextBlock x:Name="CurrentPageNumberTextBox" VerticalAlignment="Center"
                           HorizontalAlignment="Left" Width="30"
                           Text="{Binding CurrentPageNumber,
                           ElementName=MyDocumentViewer,Mode=TwoWay}"/>
                <TextBlock Text="of " VerticalAlignment="Center"/>
                <TextBlock x:Name="PageCountTextBox" VerticalAlignment="Center"
                           HorizontalAlignment="Left" Width="30"
                           Text="{Binding PageCount, ElementName=MyDocumentViewer}"/>
            </StackPanel>
            <StackPanel Orientation="Horizontal" HorizontalAlignment="Center">
                <Button x:Name="PreviousPageButton" Content="Previous Page" Width="100"
                        Click="PreviousPageButton_Click"/>
                <Button x:Name="NextPageButton" Content="Next Page" Width="100"
                        Click="NextPageButton_Click"/>
            </StackPanel>
        </StackPanel>
    </Grid>

Each button has its click event attached to a method in the code-behind that changes the CurrentPageNumber property.

10. Add the following two methods to MainPage.xaml.cs that define the functionality of the previous and next page buttons.

CopyMainPage.xaml.cs
private void PreviousPageButton_Click(object sender, RoutedEventArgs e)
{
     MyDocumentViewer.CurrentPageNumber -= 1;
}
private void NextPageButton_Click(object sender, RoutedEventArgs e)
{
     MyDocumentViewer.CurrentPageNumber += 1;
}

If you run the project, the viewer should resemble what is shown below in Figure 4.

Figure 4: DocumentViewer with External Controls.


System Requirements

[image]

PDFTron SilverDox SDK
System Requirements
Send Feedback

System requirements:

For Silverlight document Viewer:

· Silverlight 4 on Windows or Mac and a Silverlight compatible browser.

For Silverlight Document Publisher:

· Windows (Windows 7, Vista, XP, Windows Server editions), Linux, or Mac.

· [Optional] MS Office 2007 or higher for direct import from MS Office.


Samples Read Me

[image]

PDFTron SilverDox SDK
Samples Read Me
Send Feedback

This topic contains the following sections.

  • Tutorial Sample
  • ReaderControl Sample
  • FlipBook Sample
  • FileBrowser Sample
  • Annotations Sample

This document contains a brief description of the included sample projects, found in SilverDoxSDK/Samples.

Live versions of these samples are available on the PDFTron website

Tutorial Sample

This is the simplest sample, illustating basic useage of a DocumentViewer to display a .xod file. The sample shows how to send and receive information to a DocumentViewer via data binding and direct method calls.

A step-by-step description of creating this sample is in the Getting Started section.

Figure 1: DocumentViewer with External Controls.

ReaderControl Sample

This sample shows the use of ReaderControl, which is a viewer built using DocumentViewer. The code for ReaderControl (a user control) is made available in SilverDoxSdk/Samples/ReaderControl.

Reader Control Sample

Figure 2: A ReaderControl created by the Reader Control Sample. A ReaderControl provies buttons for page navigation, a zoom slider, pan and text select modes, full text search, a thumbnail viewer and a bookmark viewer.

FlipBook Sample

This sample does not use a DocumentViewer or ReaderControl, but rather acquires canvases directly from a Document, and uses the open-source Silverlight BookControls project to display the Document's pages.

Figure 3: The FlipBook Sample

FileBrowser Sample

The FileBrowser sample implements a thumbnail-based file browser to load different documents into a ReaderControl.

Figure 4: The FileBrowser Sample

Annotations Sample

The Annotations sample shows the basic use of the Annotations framework, and now to extend it to create custom annotations.

Figure 5: The Annotations Sample


Part Retrievers

[image]

PDFTron SilverDox SDK
Part Retrievers
Send Feedback

SilverDox Part Retrievers

SilverDox client is using part retrievers (a class deriving from the interface IPartRetriever) to access remote or local files. The role of a part retriever is to make required parts of the document available to the Silverlight viewer. The following part retrievers are available out of the box:

1. LocalPartRetriever, which is typically used to retrieve documents from the local file system. This part retriever is constructed using a seekable Stream, such as a FileStream. Note, however, that any seekable Stream (e.g. a MemoryStream) can be used, expanding the number of scenarios in which this retriever could be used.

2. HttpPartRetriever which is used to retrieve a Silverlight files from an HTTP server that supports byte-serving. Byte serving allows the retriever to transfer arbitrary parts of the file, allowing whatever page is visible to be transferred before other pages that have not yet been transferred. This is the preferred part retriever when requesting previously-converted documents from a web server.

3. HttpStreamingPartRetriever which is used to retrieve a document from an HTTP server that does not support byte-serving, or optionally when the document is converted to Silverlight XPS (XOD) on demand. This retriever transfers the entire document in order from beginning to end, with pages and thumbnails displayed as each page arrives.

The following section describes how to choose between an HttpPartRetriever and an HttpStreamingPartRetriever.

HttpPartRetriever or HttpStreamingPartRetriever?

As stated above, the HttpPartRetreiver must be used in conjunction with a web server that supports byte-serving (http://en.wikipedia.org/wiki/Byte_serving). Byte-serving is used to transfer a file from a server to client in an out-of-order fashion, i.e. the middle or end of the file can be transferred before the beginning. This is a useful feature in SilverDox because when a user scrolls to an unloaded page of a partially loaded document, the page’s content can be prioritized and immediately transferred, allowing near instant viewing of the page without waiting for intervening pages to load. If the converted Silverlight document is available when the document is requested, and the web server supports byte-serving, the HttpPartRetriever will give the best user experience and optimal performance. HttpStreamingPartRetriever is designed to be used in situations when a remote web server does not support byte-serving or if the document must be converted on-demand. There are situations when even though the HTTP server supports byte-serving, the HttpStreamingPartRetriever is the preferred part retriever. For example:

· The HttpStreamingPartRetriever may provide a better user experience in the case that documents are converted on demand. This is because converting large documents can require some time, and having the client wait until the conversion process is complete (so that the document can be byte-served) is undesirable. In this scenario, the HttpStreamingPartRetriever is the better choice because it can begin to transfer the document to the client when the conversion process begins. This allows the client to see results very quickly and for the document to be converted and transferred concurrently.

· The HttpStreamingPartRetriever may be required when the document is only available via a URL with dynamic content, because most web servers do not support byte-serving in this situation. This could be the case if the documents are stored in a database, and the documents cannot be temporarily written to the file system and assigned a static URL.

See the decision tree below to help in deciding which part retriever to use.

Decision Tree for Choosing a SilverDox Part Retriever

Document Loading and DocumentViewer Behavior

A part retriever has three properties which control how a Document object and DocumentViewer object will load and display Silverlight document (i.e. a XOD file). Below is the API documentation for each property, and a table stating the default value for each part retriever and why that value is usually (or always) the best choice for that retriever.

Property: bool BackgroundLoadDocument { get; set; }

Description: Gets or sets whether the Document will continue to load in the background during idle periods.

Remarks: Background loading is only useful for HttpPartRetriever. HttpStreamingPartRetriever inherently loads all resources, and LocalPartRetriever is sufficiently fast that background loading provides no advantage.

Property: bool ShowThumbnailBeforePageContent { get; set; }

Description: Gets or sets whether the viewer will display an enlarged thumbnail of a document's page when the page is scrolled to but has not yet been loaded.

Remarks: Showing an enlarged thumbnail on a full page before the content is available is useful for HttpPartRetriever because the time to acquire the entire page content can be noticeable, but the time to acquire a thumbnail is minimal. LocalPartRetriever does not need to show a thumbnail first because the entire page content can be quickly retrieved, and HttpStreamingPartRetriever loads page content before any thumbnails, so it is not possible to show a thumbnail first.

Property: bool UseDocumentThumbnailIfAvailable { get; set; }

Description: Gets or sets whether the method Document.LoadThumbnailAsync() will use pre-generated page thumbnails (if they are available in the document), or will create thumbnail created from the page contents.

Remarks: If a document contains pre-rendered thumbnails, the viewer has the option to use them, or alernatively, to generate thumbnails internally by rendering and scaling the page content. Using the built-in thumbnails is preferred except for the case of HttpStreamingPartRetriever, when it is faster to display internally generated thumbnails.

 | LocalPartRetriever | HttpPartRetriever | HttpStreamingPartRetriever
BackgroundLoadDocument | false | true | false
ShowThumbnailBeforePageContent | false | true | false
UseDocumentThumbnailIfAvailable | true | true | false

Table 1: Default values for a Part Retriever’s properties which affect how a Document is loaded, and how a DocumentViewer displays it.


ReaderControl JavaScript Tutorial

[image]

PDFTron SilverDox SDK
ReaderControl JavaScript Tutorial
Send Feedback

Introduction

The SilverDox ReaderControl is viewer built using SilverDox DocumentViewer control. A ReaderControl provides buttons for page navigation, a zoom slider, pan and text select modes, full text search, a thumbnail viewer and a bookmark viewer.

The ReaderControl sample included in SilverDoxSdk/Samples/ReaderControl allows users to take advantage of JavaScript and Silverlight interoperability. This means that users can control, interact, and communicate with the SilverDox ReaderControl using JavaScript code embedded or added in the HTML page which hosts the control.

This tutorial describes the steps to get started using JavaScript code to interact with the SilverDox ReaderControl provided out-of-the box. A sample HTML page with HTML controls and JavaScript code communicating with the SilverDox ReaderControl can be found at SilverDoxSDK\Samples\ReaderControlSample\ReaderControlSample.Web

Using JavaScript with the ReaderControl

1. Create an HTML page.

2. Add the following on the <head> tag of the HTML page.

CopyAdded to HTML header
<script type="text/javascript" src="ReaderControl.js"></script>

This will allow you to use the ReaderControl class in your JavaScript code.

3. Add the following code within the <body> tag of the HTML page to embed the Silverlight control.

CopyAdded to HTML body
<script type="text/javascript">
var readerCtrl = new
ReaderControl("rc1",
"ReaderControlSample.xap",
false, null);
</script>

The script above will create and reader a SilverDox ReaderControl plugin on the HTML page.

4. It is now possible to use the “readerCtrl” variable to invoke ReaderControl’s methods. For example, the following code demonstrates how to load a document:

CopyTo load a document (in Silverlight)
readerCtrl.loadDocument("http://www.pdftron.com/sample.xod", "");

This code can be added to an HTML control’s onclick event handler. For example, the code below loads a document when the HTML button control is clicked:

CopyTo load a document (in Silverlight)
<input type="button" value="Load" onclick="readerCtrl.loadDocument('http://www.pdftron.com/sample.xod', '');" />

Please refer to the API documentation for other methods which can be used. The API reference can be found at http://www.pdftron.com/silverdox/jsdoc/

5. Save the HTML page. Make sure to put both ReaderControl.js, and ReaderControlSample.xap on the same directory as the HTML page.


Frequently Asked Questions

[image]

PDFTron SilverDox SDK
Frequently Asked Questions
Send Feedback

What is SilverDox?

SilverDox is a library for publishing and viewing PDF, XPS, and other documents in Silverlight. Besides PDF and XPS, SilverDox allows conversion from MS Office and any printable document format to Silverlight. The files can be viewed in a fast, feature-rich SilverDox viewing component for Silverlight or using any other XPS consumer.

Silverlight Document Publisher is available as a command-line utility (called DocPub) or as an add-on option to PDFNet SDK .

Who should use SilverDox SDK?

SilverDox is designed for Silverlight developers who need to add online and offline document viewing capabilities to their Silverlight applications.

Which document formats are supported by SilverDox?

SilverDox Document Publisher offers direct support for PDF, XPS, EMF, MS Office, PNG, BMP, TIFF, GIF, JPEG and any other printable document format. MS Office formats (e.g. Word, Publisher, Excel, Outlook, PowerPoint, etc.) are supported either via interop or through a virtual printer driver. Publishing from any other printable documents (such as RTF, DWG, DGM, TXT, SVG, etc.) to Silverlight XPS (i.e. XOD) is done through a virtual printer driver.

What is XPS?

"XPS" stands for "XML Paper Specification" and is a document format as well as the native print spooler format in Microsoft's Windows. The XPS document format consists of XML markup that defines the layout of a document and the visual appearance of each page along with rendering rules for distributing, archiving, rendering, processing and printing the documents. Just like PDF, the XPS document format enables users to view, print, and archive any type of documents without the original program that created them and without loss of fidelity.

What is a XOD file?

XOD is an XPS document optimized for Silverlight viewing. For example, to view a XOD file in Microsoft WPF viewer, simply change the extension to XPS. The only reason why we call these XPS files 'XOD' is to differentiate files optimized for viewing in Silverlight from non-optimized files.

Why is a XOD file better than a generic XPS file for online viewing?

We differentiate between SilverDox XPS files (XOD) and generic XPS files for the same reason various PDF creators differentiate between 'Print' and 'Web' optimized documents.

Generic XPS files may contain features such as color schemes, TIFF, HDPhoto, and different flavors of PNG and JPEG that are not supported in Silverlight. Implementation of these features would complicate and bloat the Silverlight client and would also negatively affect the viewing performance. Currently there is no viewer that reliably implements the full XPS specification. Even if someone were to implement a generic viewer it would run into crashes, as well as performance and memory issues when processing many documents. The main reason for this is that Silverlight was not designed to deal with the images sizes and number of graphical elements that can frequently occur in some pre-press and graphically rich documents. Due to the potential for interleaved parts in an XPS package, as well as large images, the viewer would not be able to guarantee an efficient viewing experience. Furthermore, generic XPS documents do not need to contain thumbnails, a feature which is important for efficient online document navigation. Text search may not work as expected, etc.

SilverDox solves all of the above issues by normalizing PDF or generic XPS files to an XPS subset optimized for Silverlight. For example, pages which are too complex can be simplified or pre-rasterized while preserving search capability, large images are down-sampled, uncompressed data is compressed, duplicated streams, and invisible page content are removed, etc. This guarantees that all SilverDox documents will be rendered accurately, reliably, and efficiently.

What is the difference between SilverDox Document Publisher and PDF2XPS?

SilverDox Document Publisher components (PDFNet SDK or DocPub) can export two flavors of XPS: one is optimized for high-quality printing and archiving and the other for viewing in Silverlight (also known as .xod). PDF2XPS can only generate XPS for printing and archiving.

For more information describing the differences between Silverlight XPS and PDF2XPS output, please see 'Why is a XOD file better than a standard XPS file for online viewing?' FAQ item.

Can SilverDox process and view any PDF or XPS document?

The Silverlight Document Publisher supports the entire PDF and XPS Specification and is regularly tested against a large sample of test documents. The converter can work with and repair many damaged or malformed documents.

Some document features that can be directly represented in Silverlight (such as certain PDF shadings and blend modes) are rasterized on an object level in order to preserve document accuracy. The Silverlight Document Viewer currently supports most XPS features via XOD files except for the ‘VisualBrush’ element and Viewport & Viewbox property of 'ImageBrush'. The support for these attributes will be added as part of the next product update.

How does SilverDox Work?

The Silverlight Document Publisher optimizes PDF, XPS, MS Office, or any other printable document to a web-optimized Silverlight XPS document (which we refer to as .XOD). The file can be viewed in any XPS viewer including the free SilverDox viewer for Silverlight. The simple to use API provides a set of ready-to-use, customizable controls as well as a set of building blocks to build new controls from scratch.

How is SilverDox licensed?

SilverDox viewer is licensed for free with the required SilverDox document publisher license (Server or OEM). Source code licensing for the SilverDox viewer component is available upon request.

How do I enable SharePoint 2010 to support SilverDox?

SilverDox’s HttpPartRetriever requires that the web server support byte-range requests. SharePoint 2010 / IIS 7.5 supports byte-range requests, but only when disk-based caching is enabled. Disk-based caching is disabled by default, so to support SilverDox, it must be turned on. To turn it on, follow the steps described in the Microsoft article Configuring cache settings for a Web application (SharePoint Server 2010). Note that in step 10, you will have to add the file extension “xod”. Other file type extensions may be removed if you do not wish to cache them.


PDFTron.SilverDox.Controls Namespace

[image]

PDFTron SilverDox SDK
PDFTron.SilverDox.Controls Namespace
Send Feedback
Contains built-in controls for presenting a Document.

Classes

 | Class | Description
Public class | DocumentViewer | A full-featured control used for displaying a Document. The viewer supports text selection and text search, and several page view modes.
Public class | FullTextSearchControl | A control that implements a full document text search for a document displayed in a DocumentViewer. The search results are displayed in a ListBox. Clicking on a search result will cause the DocumentViewer to navigate to the corresponding page.
Public class | ThumbnailsControl | A control that displays thumbnail images of the document in a DocumentViewer. Clicking on a thumbnail will cause the DocumentViewer to navigate to the corresponding page, and scrolling DocumentViewer will cause the currently displayed page in the ThumbnailsControl to be highlighted.

Enumerations

 | Enumeration | Description
Public enumeration | DocumentViewer..::..DisplayModes | Lists the possible modes for DisplayMode, which controls which pages the viewer will display.
Public enumeration | DocumentViewer..::..FitModes | Lists common modes of viewing a document's pages.
Public enumeration | DocumentViewer..::..ToolModes | DocumentViewer supports 'built-in' tool modes which change the behavior of the viewer.


DocumentViewer Class

[image]

PDFTron SilverDox SDK
DocumentViewer Class
Members See Also Send Feedback
A full-featured control used for displaying a Document. The viewer supports text selection and text search, and several page view modes.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class DocumentViewer : Control,
    INotifyPropertyChanged
Visual Basic
Public Class DocumentViewer _
    Inherits Control _
    Implements INotifyPropertyChanged
Visual C++
public ref class DocumentViewer : public Control,
    INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
PDFTron.SilverDox.Controls..::..DocumentViewer

See Also

DocumentViewer Members
PDFTron.SilverDox.Controls Namespace


DocumentViewer Members

[image] [image]

PDFTron SilverDox SDK
DocumentViewer Members
DocumentViewer Class Constructors Methods Fields Properties Events See Also Send Feedback

The DocumentViewer type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentViewer | Constructs a DocumentViewer.

Methods

 | Name | Description
Public method | CloseDocument | Closes the current document leaving a blank viewer.
Public method | DisplayBookmark | Scrolls the viewer so that the position of the bookmark is in the upper-left corner of the viewer.
Public method | DisplayFirstPage | Scrolls the viewer so that the upper-left corner of the Document's first page is in the upper-left corner of the viewer.
Public method | DisplayLastPage | Scrolls the viewer so that the upper-left corner of the Document's last page is in the upper-left corner of the viewer.
Public method | GetCanvas | Gets the canvas of a currently displayed page.
Public method | GetCanvasAtPoint | Gets the page number and canvas element at a given screen location.
Public method | GetSelectedText | Returns the selected text in the current document
Public method | LoadAsync | Loads a .xod document into the viewer.
Public method | OnApplyTemplate | (Overrides OnApplyTemplate()()()().) (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnContentKeyDown | Called in response to a KeyDown event in the DocumentViewer's viewing area.
Protected method | OnContentKeyUp | Called in response to a KeyUp event in the DocumentViewer's viewing area.
Protected method | OnContentLoaded | Called in response to the Loaded event of the DocumentViewer's viewing area.
Protected method | OnContentMouseEnter | Called in response to a MouseEnter event in the DocumentViewer's viewing area.
Protected method | OnContentMouseLeave | Called in response to a MouseLeave event in the DocumentViewer's viewing area.
Protected method | OnContentMouseLeftButtonDown | Called in response to a MouseLeftButtonDown event in the DocumentViewer's viewing area.
Protected method | OnContentMouseLeftButtonUp | Called in response to a MouseLeftButtonUp event in the DocumentViewer's viewing area.
Protected method | OnContentMouseMove | Called in response to a MouseMove event in the DocumentViewer's viewing area.
Protected method | OnContentMouseRightButtonDown | Called in response to a MouseRightButtonDown event in the DocumentViewer's viewing area.
Protected method | OnContentMouseRightButtonUp | Called in response to a MouseRightButtonUp event in the DocumentViewer's viewing area.
Protected method | OnContentMouseWheel | Called in response to a MouseWheel event in the DocumentViewer's viewing area.
Public method | RefreshTemplate | Used to refresh the DocumentViewer after it has been assigned a new template to change the page layout.
Public method | RotateClockwise | Rotates all pages in the currently displayed document clockwise by 90 degrees.
Public method | RotateCounterClockwise | Rotates all pages in the currently displayed document counter-clockwise by 90 degrees.
Public method | ScrollToAnnotation | Adjusts the document viewer's x and y position so it focuses on the given annotation.
Public method | SearchTextAsync | Searches for a particular text string on the currently displayed Document, starting on the current page (see CurrentPageNumber).
Public method | SetFitMode | Sets how the document will scale to fit the size of the scrollviewer's viewport.
Public method | ZoomTo | Adjusts the viewer's zoom factor, and positions the point (x,y) at the upper left corner of the viewer.

Fields

Name | Description
FitModeHeightProperty | For binding to FitModeHeight.
FitModeWidthProperty | For binding to FitModeWidth.

Properties

 | Name | Description
Public property | AnnotationManager | Manages the annotations displayed over the Document's pages displayed in the viewer.
Public property | CurrentPageNumber | Get or set the page number of the currently displayed page.
Public property | CustomCursor | The cursor to use when in ToolMode is set to Custom.
Public property | DefaultFitModeHeight | Defines the FitModeHeight that will be set when a new document is opened. Initially set to null, in which case a new document will be with the same FitModeHeight as the current document.
Public property | DefaultFitModeWidth | Defines the FitModeWidth that will be set when a new document is opened. Initially set to null, in which case a new document will be with the same FitModeWidth as the current document.
Public property | DefaultZoomLevel | Defines the default Zoom level when a new document is openened with FitModeWidth and FitModeHeight set to PageViewModes.Zoom. If set to null, a new document will open with the same zoom level as the current document.
Public property | DisplayMode | The mode that controls which pages the viewer will display.
Public property | Document | The Document that is currently being displayed by the viewer.
Public property | FitModeHeight | Read if the document's Zoom property will be adjusted so that the height of the current page or panel will exactly fit into the available space. This parameter is set with the method SetFitMode(DocumentViewer..::..FitModes, DocumentViewer..::..FitModes).
Public property | FitModeWidth | Read if the document's Zoom property will be adjusted so that the width of the current page or panel will exactly fit into the available space. This parameter is set with the method SetFitMode(DocumentViewer..::..FitModes, DocumentViewer..::..FitModes).
Public property | PageCount | The number of pages in the currently displayed document.
Public property | Scale |
Public property | ToolMode | Changes the behavior of the viewer. See DocumentViewer..::..ToolModes for valid settings and their descriptions.
Public property | Zoom | Used to get or set the magnification factor of the displayed pages.

Events

 | Name | Description
Public event | AnnotationPopupContentChanged | Occurs when the user manually changes the contents of a popup NOTE: Does not trigger when PopupContents is set programatically
Public event | AnnotationResized | Occurs when an annotation is resized
Public event | AnnotationsAdded | Occurs when an annotation is added
Public event | AnnotationsCreated | Occurs when an annotation is created via. a tool
Public event | AnnotationsDeselected | Occurs when an annotation is deselected
Public event | AnnotationsDragged | Occurs when annotations are dragged by the user; WARNING: triggered a ton of times when user is move dragging annotations
Public event | AnnotationsMoveCompleted | Occurs when the user finishes moving annotations (i.e the mouse is released)
Public event | AnnotationsRemoved | Occurs when an annotation is removed
Public event | AnnotationsSelected | Occurs when an annotation is selected
Public event | PropertyChanged | Notification event that is raised when a bound property changes.
Public event | ToolModeChanged | Occurs when the DocumentViewer tool mode is changed

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


DocumentViewer Constructor

[image]

PDFTron SilverDox SDK
DocumentViewer Constructor
DocumentViewer Class See Also Send Feedback
Constructs a DocumentViewer.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public DocumentViewer()
Visual Basic
Public Sub New
Visual C++
public:
DocumentViewer()

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


DocumentViewer Fields

[image] [image]

PDFTron SilverDox SDK
DocumentViewer Fields
DocumentViewer Class See Also Send Feedback

The DocumentViewer type exposes the following members.

Fields

Name | Description
FitModeHeightProperty | For binding to FitModeHeight.
FitModeWidthProperty | For binding to FitModeWidth.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


FitModeHeightProperty Field

[image]

PDFTron SilverDox SDK
DocumentViewer..::..FitModeHeightProperty Field
DocumentViewer Class See Also Send Feedback
For binding to FitModeHeight.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public static readonly DependencyProperty FitModeHeightProperty
Visual Basic
Public Shared ReadOnly FitModeHeightProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ FitModeHeightProperty

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


FitModeWidthProperty Field

[image]

PDFTron SilverDox SDK
DocumentViewer..::..FitModeWidthProperty Field
DocumentViewer Class See Also Send Feedback
For binding to FitModeWidth.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public static readonly DependencyProperty FitModeWidthProperty
Visual Basic
Public Shared ReadOnly FitModeWidthProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ FitModeWidthProperty

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


DocumentViewer Methods

[image] [image]

PDFTron SilverDox SDK
DocumentViewer Methods
DocumentViewer Class See Also Send Feedback

The DocumentViewer type exposes the following members.

Methods

 | Name | Description
Public method | CloseDocument | Closes the current document leaving a blank viewer.
Public method | DisplayBookmark | Scrolls the viewer so that the position of the bookmark is in the upper-left corner of the viewer.
Public method | DisplayFirstPage | Scrolls the viewer so that the upper-left corner of the Document's first page is in the upper-left corner of the viewer.
Public method | DisplayLastPage | Scrolls the viewer so that the upper-left corner of the Document's last page is in the upper-left corner of the viewer.
Public method | GetCanvas | Gets the canvas of a currently displayed page.
Public method | GetCanvasAtPoint | Gets the page number and canvas element at a given screen location.
Public method | GetSelectedText | Returns the selected text in the current document
Public method | LoadAsync | Loads a .xod document into the viewer.
Public method | OnApplyTemplate | (Overrides OnApplyTemplate()()()().) (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnContentKeyDown | Called in response to a KeyDown event in the DocumentViewer's viewing area.
Protected method | OnContentKeyUp | Called in response to a KeyUp event in the DocumentViewer's viewing area.
Protected method | OnContentLoaded | Called in response to the Loaded event of the DocumentViewer's viewing area.
Protected method | OnContentMouseEnter | Called in response to a MouseEnter event in the DocumentViewer's viewing area.
Protected method | OnContentMouseLeave | Called in response to a MouseLeave event in the DocumentViewer's viewing area.
Protected method | OnContentMouseLeftButtonDown | Called in response to a MouseLeftButtonDown event in the DocumentViewer's viewing area.
Protected method | OnContentMouseLeftButtonUp | Called in response to a MouseLeftButtonUp event in the DocumentViewer's viewing area.
Protected method | OnContentMouseMove | Called in response to a MouseMove event in the DocumentViewer's viewing area.
Protected method | OnContentMouseRightButtonDown | Called in response to a MouseRightButtonDown event in the DocumentViewer's viewing area.
Protected method | OnContentMouseRightButtonUp | Called in response to a MouseRightButtonUp event in the DocumentViewer's viewing area.
Protected method | OnContentMouseWheel | Called in response to a MouseWheel event in the DocumentViewer's viewing area.
Public method | RefreshTemplate | Used to refresh the DocumentViewer after it has been assigned a new template to change the page layout.
Public method | RotateClockwise | Rotates all pages in the currently displayed document clockwise by 90 degrees.
Public method | RotateCounterClockwise | Rotates all pages in the currently displayed document counter-clockwise by 90 degrees.
Public method | ScrollToAnnotation | Adjusts the document viewer's x and y position so it focuses on the given annotation.
Public method | SearchTextAsync | Searches for a particular text string on the currently displayed Document, starting on the current page (see CurrentPageNumber).
Public method | SetFitMode | Sets how the document will scale to fit the size of the scrollviewer's viewport.
Public method | ZoomTo | Adjusts the viewer's zoom factor, and positions the point (x,y) at the upper left corner of the viewer.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


CloseDocument Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..CloseDocument Method
DocumentViewer Class See Also Send Feedback
Closes the current document leaving a blank viewer.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void CloseDocument()
Visual Basic
Public Sub CloseDocument
Visual C++
public:
void CloseDocument()

Remarks

This does not need to be called when switching documents, only if the current document is to be closed and replaced by a blank viewer.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


DisplayBookmark Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..DisplayBookmark Method
DocumentViewer Class See Also Send Feedback
Scrolls the viewer so that the position of the bookmark is in the upper-left corner of the viewer.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void DisplayBookmark(
    Bookmark bookmark
)
Visual Basic
Public Sub DisplayBookmark ( _
    bookmark As Bookmark _
)
Visual C++
public:
void DisplayBookmark(
    Bookmark^ bookmark
)

Parameters

bookmark
Type: PDFTron.SilverDox.Documents..::..Bookmark
The bookmark that specifies the location to scroll to.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


DisplayFirstPage Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..DisplayFirstPage Method
DocumentViewer Class See Also Send Feedback
Scrolls the viewer so that the upper-left corner of the Document's first page is in the upper-left corner of the viewer.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void DisplayFirstPage()
Visual Basic
Public Sub DisplayFirstPage
Visual C++
public:
void DisplayFirstPage()

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


DisplayLastPage Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..DisplayLastPage Method
DocumentViewer Class See Also Send Feedback
Scrolls the viewer so that the upper-left corner of the Document's last page is in the upper-left corner of the viewer.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void DisplayLastPage()
Visual Basic
Public Sub DisplayLastPage
Visual C++
public:
void DisplayLastPage()

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


GetCanvas Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..GetCanvas Method
DocumentViewer Class See Also Send Feedback
Gets the canvas of a currently displayed page.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Canvas GetCanvas(
    int pageNumber
)
Visual Basic
Public Function GetCanvas ( _
    pageNumber As Integer _
) As Canvas
Visual C++
public:
Canvas^ GetCanvas(
    int pageNumber
)

Parameters

pageNumber
Type: System..::..Int32
The page number of the requested canvas.

Return Value

The canvas element representing the page. If the page is not visible, return value is null.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


GetCanvasAtPoint Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..GetCanvasAtPoint Method
DocumentViewer Class See Also Send Feedback
Gets the page number and canvas element at a given screen location.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public KeyValuePair<int, Canvas> GetCanvasAtPoint(
    Point point
)
Visual Basic
Public Function GetCanvasAtPoint ( _
    point As Point _
) As KeyValuePair(Of Integer, Canvas)
Visual C++
public:
KeyValuePair<int, Canvas^> GetCanvasAtPoint(
    Point point
)

Parameters

point
Type: System.Windows..::..Point
A point relative to the overall Silverlight plug-in content area.

Return Value

The canvas element and its page number at the location specified in point.

Remarks

If the point is generated from a mouse event, the passed point should be the point returned by MouseEventArgs.GetPosition(null).

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


GetSelectedText Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..GetSelectedText Method
DocumentViewer Class See Also Send Feedback
Returns the selected text in the current document

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string GetSelectedText()
Visual Basic
Public Function GetSelectedText As String
Visual C++
public:
String^ GetSelectedText()

Return Value

[Missing <returns> documentation for "M:PDFTron.SilverDox.Controls.DocumentViewer.GetSelectedText"]

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


LoadAsync Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..LoadAsync Method
DocumentViewer Class See Also Send Feedback
Loads a .xod document into the viewer.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void LoadAsync(
    IPartRetriever partRetriever,
    Action<Exception> callback
)
Visual Basic
Public Sub LoadAsync ( _
    partRetriever As IPartRetriever, _
    callback As Action(Of Exception) _
)
Visual C++
public:
void LoadAsync(
    IPartRetriever^ partRetriever,
    Action<Exception^>^ callback
)

Parameters

partRetriever
Type: PDFTron.SilverDox.IO..::..IPartRetriever
A concrete instance of IPartRetriever.
callback
Type: System..::..Action <(Of <(<' Exception >)>)>
A callback function that is called when its Document property has been initilized.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


OnApplyTemplate Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..OnApplyTemplate Method
DocumentViewer Class See Also Send Feedback
(Overrides OnApplyTemplate()()()().)

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override void OnApplyTemplate()
Visual Basic
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


OnContentKeyDown Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..OnContentKeyDown Method
DocumentViewer Class See Also Send Feedback
Called in response to a KeyDown event in the DocumentViewer's viewing area.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected virtual void OnContentKeyDown(
    Object sender,
    KeyEventArgs e
)
Visual Basic
Protected Overridable Sub OnContentKeyDown ( _
    sender As Object, _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnContentKeyDown(
    Object^ sender,
    KeyEventArgs^ e
)

Parameters

sender
Type: System..::..Object
The object where the event occured.
e
Type: System.Windows.Input..::..KeyEventArgs
The data for the event.

Remarks

The OnContentKeyDown method is called in response to the KeyDown event. This method allows derived classes to override or extend the response to the KeyDown event.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


OnContentKeyUp Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..OnContentKeyUp Method
DocumentViewer Class See Also Send Feedback
Called in response to a KeyUp event in the DocumentViewer's viewing area.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected virtual void OnContentKeyUp(
    Object sender,
    KeyEventArgs e
)
Visual Basic
Protected Overridable Sub OnContentKeyUp ( _
    sender As Object, _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnContentKeyUp(
    Object^ sender,
    KeyEventArgs^ e
)

Parameters

sender
Type: System..::..Object
The object where the event occured.
e
Type: System.Windows.Input..::..KeyEventArgs
The data for the event.

Remarks

The OnContentKeyUp method is called in response to the KeyUp event. This method allows derived classes to override or extend the response to the KeyUp event.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


OnContentLoaded Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..OnContentLoaded Method
DocumentViewer Class See Also Send Feedback
Called in response to the Loaded event of the DocumentViewer's viewing area.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected virtual void OnContentLoaded(
    Object sender,
    RoutedEventArgs e
)
Visual Basic
Protected Overridable Sub OnContentLoaded ( _
    sender As Object, _
    e As RoutedEventArgs _
)
Visual C++
protected:
virtual void OnContentLoaded(
    Object^ sender,
    RoutedEventArgs^ e
)

Parameters

sender
Type: System..::..Object
The object where the event occured.
e
Type: System.Windows..::..RoutedEventArgs
The data for the event.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


OnContentMouseEnter Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..OnContentMouseEnter Method
DocumentViewer Class See Also Send Feedback
Called in response to a MouseEnter event in the DocumentViewer's viewing area.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected virtual void OnContentMouseEnter(
    Object sender,
    MouseEventArgs e
)
Visual Basic
Protected Overridable Sub OnContentMouseEnter ( _
    sender As Object, _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnContentMouseEnter(
    Object^ sender,
    MouseEventArgs^ e
)

Parameters

sender
Type: System..::..Object
The object where the event occured.
e
Type: System.Windows.Input..::..MouseEventArgs
The data for the event.

Remarks

The OnContentMouseEnter method is called in response to the MouseEnter event. This method allows derived classes to override or extend the response to the MouseEnter event.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


OnContentMouseLeave Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..OnContentMouseLeave Method
DocumentViewer Class See Also Send Feedback
Called in response to a MouseLeave event in the DocumentViewer's viewing area.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected virtual void OnContentMouseLeave(
    Object sender,
    MouseEventArgs e
)
Visual Basic
Protected Overridable Sub OnContentMouseLeave ( _
    sender As Object, _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnContentMouseLeave(
    Object^ sender,
    MouseEventArgs^ e
)

Parameters

sender
Type: System..::..Object
The object where the event occured.
e
Type: System.Windows.Input..::..MouseEventArgs
The data for the event.

Remarks

The OnContentMouseLeave method is called in response to the MouseLeave event. This method allows derived classes to override or extend the response to the OnContentMouseLeave event.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


OnContentMouseLeftButtonDown Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..OnContentMouseLeftButtonDown Method
DocumentViewer Class See Also Send Feedback
Called in response to a MouseLeftButtonDown event in the DocumentViewer's viewing area.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected virtual void OnContentMouseLeftButtonDown(
    Object sender,
    MouseButtonEventArgs e
)
Visual Basic
Protected Overridable Sub OnContentMouseLeftButtonDown ( _
    sender As Object, _
    e As MouseButtonEventArgs _
)
Visual C++
protected:
virtual void OnContentMouseLeftButtonDown(
    Object^ sender,
    MouseButtonEventArgs^ e
)

Parameters

sender
Type: System..::..Object
The object where the event occured.
e
Type: System.Windows.Input..::..MouseButtonEventArgs
The data for the event.

Remarks

The OnContentMouseLeftButtonDown method is called in response to the MouseLeftButtonDown event. This method allows derived classes to override or extend the response to the MouseLeftButtonDown event.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


OnContentMouseLeftButtonUp Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..OnContentMouseLeftButtonUp Method
DocumentViewer Class See Also Send Feedback
Called in response to a MouseLeftButtonUp event in the DocumentViewer's viewing area.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected virtual void OnContentMouseLeftButtonUp(
    Object sender,
    MouseButtonEventArgs e
)
Visual Basic
Protected Overridable Sub OnContentMouseLeftButtonUp ( _
    sender As Object, _
    e As MouseButtonEventArgs _
)
Visual C++
protected:
virtual void OnContentMouseLeftButtonUp(
    Object^ sender,
    MouseButtonEventArgs^ e
)

Parameters

sender
Type: System..::..Object
The object where the event occured.
e
Type: System.Windows.Input..::..MouseButtonEventArgs
The data for the event.

Remarks

The OnContentMouseLeftButtonUp method is called in response to the MouseLeftButtonUp event. This method allows derived classes to override or extend the response to the MouseLeftButtonUp event.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


OnContentMouseMove Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..OnContentMouseMove Method
DocumentViewer Class See Also Send Feedback
Called in response to a MouseMove event in the DocumentViewer's viewing area.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected virtual void OnContentMouseMove(
    Object sender,
    MouseEventArgs e
)
Visual Basic
Protected Overridable Sub OnContentMouseMove ( _
    sender As Object, _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnContentMouseMove(
    Object^ sender,
    MouseEventArgs^ e
)

Parameters

sender
Type: System..::..Object
The object where the event occured.
e
Type: System.Windows.Input..::..MouseEventArgs
The data for the event.

Remarks

The OnContentMouseMove method is called in response to the MouseMove event. This method allows derived classes to override or extend the response to the MouseMove event.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


OnContentMouseRightButtonDown Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..OnContentMouseRightButtonDown Method
DocumentViewer Class See Also Send Feedback
Called in response to a MouseRightButtonDown event in the DocumentViewer's viewing area.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected virtual void OnContentMouseRightButtonDown(
    Object sender,
    MouseButtonEventArgs e
)
Visual Basic
Protected Overridable Sub OnContentMouseRightButtonDown ( _
    sender As Object, _
    e As MouseButtonEventArgs _
)
Visual C++
protected:
virtual void OnContentMouseRightButtonDown(
    Object^ sender,
    MouseButtonEventArgs^ e
)

Parameters

sender
Type: System..::..Object
The object where the event occured.
e
Type: System.Windows.Input..::..MouseButtonEventArgs
The data for the event.

Remarks

The OnContentMouseRightButtonDown method is called in response to the MouseRightButtonDown event. This method allows derived classes to override or extend the response to the MouseRightButtonDown event.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


OnContentMouseRightButtonUp Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..OnContentMouseRightButtonUp Method
DocumentViewer Class See Also Send Feedback
Called in response to a MouseRightButtonUp event in the DocumentViewer's viewing area.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected virtual void OnContentMouseRightButtonUp(
    Object sender,
    MouseButtonEventArgs e
)
Visual Basic
Protected Overridable Sub OnContentMouseRightButtonUp ( _
    sender As Object, _
    e As MouseButtonEventArgs _
)
Visual C++
protected:
virtual void OnContentMouseRightButtonUp(
    Object^ sender,
    MouseButtonEventArgs^ e
)

Parameters

sender
Type: System..::..Object
The object where the event occured.
e
Type: System.Windows.Input..::..MouseButtonEventArgs
The data for the event.

Remarks

The OnContentMouseRightButtonUp method is called in response to the MouseRightButtonUp event. This method allows derived classes to override or extend the response to the MouseRightButtonUp event.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


OnContentMouseWheel Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..OnContentMouseWheel Method
DocumentViewer Class See Also Send Feedback
Called in response to a MouseWheel event in the DocumentViewer's viewing area.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected virtual void OnContentMouseWheel(
    Object sender,
    MouseWheelEventArgs e
)
Visual Basic
Protected Overridable Sub OnContentMouseWheel ( _
    sender As Object, _
    e As MouseWheelEventArgs _
)
Visual C++
protected:
virtual void OnContentMouseWheel(
    Object^ sender,
    MouseWheelEventArgs^ e
)

Parameters

sender
Type: System..::..Object
The object OnContentMouseWheel.
e
Type: System.Windows.Input..::..MouseWheelEventArgs
The data for the event.

Remarks

The OnContentMouseWheel method is called in response to the MouseWheel event. This method allows derived classes to override or extend the MouseLeftButtonDown response to the event.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


RefreshTemplate Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..RefreshTemplate Method
DocumentViewer Class See Also Send Feedback
Used to refresh the DocumentViewer after it has been assigned a new template to change the page layout.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void RefreshTemplate()
Visual Basic
Public Sub RefreshTemplate
Visual C++
public:
void RefreshTemplate()

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


RotateClockwise Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..RotateClockwise Method
DocumentViewer Class See Also Send Feedback
Rotates all pages in the currently displayed document clockwise by 90 degrees.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void RotateClockwise()
Visual Basic
Public Sub RotateClockwise
Visual C++
public:
void RotateClockwise()

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


RotateCounterClockwise Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..RotateCounterClockwise Method
DocumentViewer Class See Also Send Feedback
Rotates all pages in the currently displayed document counter-clockwise by 90 degrees.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void RotateCounterClockwise()
Visual Basic
Public Sub RotateCounterClockwise
Visual C++
public:
void RotateCounterClockwise()

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


ScrollToAnnotation Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..ScrollToAnnotation Method
DocumentViewer Class See Also Send Feedback
Adjusts the document viewer's x and y position so it focuses on the given annotation.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void ScrollToAnnotation(
    Annotation annotation
)
Visual Basic
Public Sub ScrollToAnnotation ( _
    annotation As Annotation _
)
Visual C++
public:
void ScrollToAnnotation(
    Annotation^ annotation
)

Parameters

annotation
Type: PDFTron.SilverDox.Documents.Annotations..::..Annotation
The annotation to move the document viewer to

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


SearchTextAsync Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..SearchTextAsync Method
DocumentViewer Class See Also Send Feedback
Searches for a particular text string on the currently displayed Document, starting on the current page (see CurrentPageNumber).

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void SearchTextAsync(
    string pattern,
    TextSearch..::..SearchModes mode,
    Action<TextSearch..::..OnTextSearchAsyncCallbackArgs> searchNextCompleteCallback
)
Visual Basic
Public Sub SearchTextAsync ( _
    pattern As String, _
    mode As TextSearch..::..SearchModes, _
    searchNextCompleteCallback As Action(Of TextSearch..::..OnTextSearchAsyncCallbackArgs) _
)
Visual C++
public:
void SearchTextAsync(
    String^ pattern,
    TextSearch..::..SearchModes mode,
    Action<TextSearch..::..OnTextSearchAsyncCallbackArgs^>^ searchNextCompleteCallback
)

Parameters

pattern
Type: System..::..String
The string to search for.
mode
Type: PDFTron.SilverDox.Documents.Text..::..TextSearch..::..SearchModes
The options for search, controlling options such as case sensitivity and search direction.
searchNextCompleteCallback
Type: System..::..Action <(Of <(<' TextSearch..::..OnTextSearchAsyncCallbackArgs >)>)>
A callback function that is called within SearchTextAsync()()()(), which is used to deliver the results of the last search operation.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


SetFitMode Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..SetFitMode Method
DocumentViewer Class See Also Send Feedback
Sets how the document will scale to fit the size of the scrollviewer's viewport.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void SetFitMode(
    DocumentViewer..::..FitModes fitModeWidth,
    DocumentViewer..::..FitModes fitModeHeight
)
Visual Basic
Public Sub SetFitMode ( _
    fitModeWidth As DocumentViewer..::..FitModes, _
    fitModeHeight As DocumentViewer..::..FitModes _
)
Visual C++
public:
void SetFitMode(
    DocumentViewer..::..FitModes fitModeWidth,
    DocumentViewer..::..FitModes fitModeHeight
)

Parameters

fitModeWidth
Type: PDFTron.SilverDox.Controls..::..DocumentViewer..::..FitModes
Controls if the document's Zoom property will be adjusted so that the width of the current page or panel will exactly fit into the available space.
fitModeHeight
Type: PDFTron.SilverDox.Controls..::..DocumentViewer..::..FitModes
Controls if the document's Zoom property will be adjusted so that the height of the current page or panel will exactly fit into the available space.

Remarks

If both fitModeWidth and fitModeHeight are set, the smaller of the two zoom factors will be used. This allows for "fit page" behavior.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


ZoomTo Method

[image]

PDFTron SilverDox SDK
DocumentViewer..::..ZoomTo Method
DocumentViewer Class See Also Send Feedback
Adjusts the viewer's zoom factor, and positions the point (x,y) at the upper left corner of the viewer.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void ZoomTo(
    double x,
    double y,
    double zoom
)
Visual Basic
Public Sub ZoomTo ( _
    x As Double, _
    y As Double, _
    zoom As Double _
)
Visual C++
public:
void ZoomTo(
    double x,
    double y,
    double zoom
)

Parameters

x
Type: System..::..Double
The number of units that the scroll viewer is scrolled to the right.
y
Type: System..::..Double
The number of units that the scroll viewer is scrolled down.
zoom
Type: System..::..Double
The zoom value. The content is zoomed before it is scrolled.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


DocumentViewer Properties

[image] [image]

PDFTron SilverDox SDK
DocumentViewer Properties
DocumentViewer Class See Also Send Feedback

The DocumentViewer type exposes the following members.

Properties

 | Name | Description
Public property | AnnotationManager | Manages the annotations displayed over the Document's pages displayed in the viewer.
Public property | CurrentPageNumber | Get or set the page number of the currently displayed page.
Public property | CustomCursor | The cursor to use when in ToolMode is set to Custom.
Public property | DefaultFitModeHeight | Defines the FitModeHeight that will be set when a new document is opened. Initially set to null, in which case a new document will be with the same FitModeHeight as the current document.
Public property | DefaultFitModeWidth | Defines the FitModeWidth that will be set when a new document is opened. Initially set to null, in which case a new document will be with the same FitModeWidth as the current document.
Public property | DefaultZoomLevel | Defines the default Zoom level when a new document is openened with FitModeWidth and FitModeHeight set to PageViewModes.Zoom. If set to null, a new document will open with the same zoom level as the current document.
Public property | DisplayMode | The mode that controls which pages the viewer will display.
Public property | Document | The Document that is currently being displayed by the viewer.
Public property | FitModeHeight | Read if the document's Zoom property will be adjusted so that the height of the current page or panel will exactly fit into the available space. This parameter is set with the method SetFitMode(DocumentViewer..::..FitModes, DocumentViewer..::..FitModes).
Public property | FitModeWidth | Read if the document's Zoom property will be adjusted so that the width of the current page or panel will exactly fit into the available space. This parameter is set with the method SetFitMode(DocumentViewer..::..FitModes, DocumentViewer..::..FitModes).
Public property | PageCount | The number of pages in the currently displayed document.
Public property | Scale |
Public property | ToolMode | Changes the behavior of the viewer. See DocumentViewer..::..ToolModes for valid settings and their descriptions.
Public property | Zoom | Used to get or set the magnification factor of the displayed pages.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


AnnotationManager Property

[image]

PDFTron SilverDox SDK
DocumentViewer..::..AnnotationManager Property
DocumentViewer Class See Also Send Feedback
Manages the annotations displayed over the Document's pages displayed in the viewer.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public AnnotationManager AnnotationManager { get; set; }
Visual Basic
Public Property AnnotationManager As AnnotationManager
    Get
    Set
Visual C++
public:
property AnnotationManager^ AnnotationManager {
    AnnotationManager^ get ();
    void set (AnnotationManager^ value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


CurrentPageNumber Property

[image]

PDFTron SilverDox SDK
DocumentViewer..::..CurrentPageNumber Property
DocumentViewer Class See Also Send Feedback
Get or set the page number of the currently displayed page.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public int CurrentPageNumber { get; set; }
Visual Basic
Public Property CurrentPageNumber As Integer
    Get
    Set
Visual C++
public:
property int CurrentPageNumber {
    int get ();
    void set (int value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


CustomCursor Property

[image]

PDFTron SilverDox SDK
DocumentViewer..::..CustomCursor Property
DocumentViewer Class See Also Send Feedback
The cursor to use when in ToolMode is set to Custom.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Cursor CustomCursor { get; set; }
Visual Basic
Public Property CustomCursor As Cursor
    Get
    Set
Visual C++
public:
property Cursor^ CustomCursor {
    Cursor^ get ();
    void set (Cursor^ value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


DefaultFitModeHeight Property

[image]

PDFTron SilverDox SDK
DocumentViewer..::..DefaultFitModeHeight Property
DocumentViewer Class See Also Send Feedback
Defines the FitModeHeight that will be set when a new document is opened. Initially set to null, in which case a new document will be with the same FitModeHeight as the current document.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Nullable<DocumentViewer..::..FitModes> DefaultFitModeHeight { get; set; }
Visual Basic
Public Property DefaultFitModeHeight As Nullable(Of DocumentViewer..::..FitModes)
    Get
    Set
Visual C++
public:
property Nullable<DocumentViewer..::..FitModes> DefaultFitModeHeight {
    Nullable<DocumentViewer..::..FitModes> get ();
    void set (Nullable<DocumentViewer..::..FitModes> value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


DefaultFitModeWidth Property

[image]

PDFTron SilverDox SDK
DocumentViewer..::..DefaultFitModeWidth Property
DocumentViewer Class See Also Send Feedback
Defines the FitModeWidth that will be set when a new document is opened. Initially set to null, in which case a new document will be with the same FitModeWidth as the current document.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Nullable<DocumentViewer..::..FitModes> DefaultFitModeWidth { get; set; }
Visual Basic
Public Property DefaultFitModeWidth As Nullable(Of DocumentViewer..::..FitModes)
    Get
    Set
Visual C++
public:
property Nullable<DocumentViewer..::..FitModes> DefaultFitModeWidth {
    Nullable<DocumentViewer..::..FitModes> get ();
    void set (Nullable<DocumentViewer..::..FitModes> value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


DefaultZoomLevel Property

[image]

PDFTron SilverDox SDK
DocumentViewer..::..DefaultZoomLevel Property
DocumentViewer Class See Also Send Feedback
Defines the default Zoom level when a new document is openened with FitModeWidth and FitModeHeight set to PageViewModes.Zoom. If set to null, a new document will open with the same zoom level as the current document.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Nullable<double> DefaultZoomLevel { get; set; }
Visual Basic
Public Property DefaultZoomLevel As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> DefaultZoomLevel {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


DisplayMode Property

[image]

PDFTron SilverDox SDK
DocumentViewer..::..DisplayMode Property
DocumentViewer Class See Also Send Feedback
The mode that controls which pages the viewer will display.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public DocumentViewer..::..DisplayModes DisplayMode { get; set; }
Visual Basic
Public Property DisplayMode As DocumentViewer..::..DisplayModes
    Get
    Set
Visual C++
public:
property DocumentViewer..::..DisplayModes DisplayMode {
    DocumentViewer..::..DisplayModes get ();
    void set (DocumentViewer..::..DisplayModes value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


Document Property

[image]

PDFTron SilverDox SDK
DocumentViewer..::..Document Property
DocumentViewer Class See Also Send Feedback
The Document that is currently being displayed by the viewer.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Document Document { get; private set; }
Visual Basic
Public Property Document As Document
    Get
    Private Set
Visual C++
public:
property Document^ Document {
    Document^ get ();
    private: void set (Document^ value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


FitModeHeight Property

[image]

PDFTron SilverDox SDK
DocumentViewer..::..FitModeHeight Property
DocumentViewer Class See Also Send Feedback
Read if the document's Zoom property will be adjusted so that the height of the current page or panel will exactly fit into the available space. This parameter is set with the method SetFitMode(DocumentViewer..::..FitModes, DocumentViewer..::..FitModes).

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public DocumentViewer..::..FitModes FitModeHeight { get; private set; }
Visual Basic
Public Property FitModeHeight As DocumentViewer..::..FitModes
    Get
    Private Set
Visual C++
public:
property DocumentViewer..::..FitModes FitModeHeight {
    DocumentViewer..::..FitModes get ();
    private: void set (DocumentViewer..::..FitModes value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


FitModeWidth Property

[image]

PDFTron SilverDox SDK
DocumentViewer..::..FitModeWidth Property
DocumentViewer Class See Also Send Feedback
Read if the document's Zoom property will be adjusted so that the width of the current page or panel will exactly fit into the available space. This parameter is set with the method SetFitMode(DocumentViewer..::..FitModes, DocumentViewer..::..FitModes).

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public DocumentViewer..::..FitModes FitModeWidth { get; private set; }
Visual Basic
Public Property FitModeWidth As DocumentViewer..::..FitModes
    Get
    Private Set
Visual C++
public:
property DocumentViewer..::..FitModes FitModeWidth {
    DocumentViewer..::..FitModes get ();
    private: void set (DocumentViewer..::..FitModes value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


PageCount Property

[image]

PDFTron SilverDox SDK
DocumentViewer..::..PageCount Property
DocumentViewer Class See Also Send Feedback
The number of pages in the currently displayed document.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public int PageCount { get; private set; }
Visual Basic
Public Property PageCount As Integer
    Get
    Private Set
Visual C++
public:
property int PageCount {
    int get ();
    private: void set (int value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


Scale Property

[image]

PDFTron SilverDox SDK
DocumentViewer..::..Scale Property
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:PDFTron.SilverDox.Controls.DocumentViewer.Scale"]

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public double Scale { get; set; }
Visual Basic
Public Property Scale As Double
    Get
    Set
Visual C++
public:
property double Scale {
    double get ();
    void set (double value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


ToolMode Property

[image]

PDFTron SilverDox SDK
DocumentViewer..::..ToolMode Property
DocumentViewer Class See Also Send Feedback
Changes the behavior of the viewer. See DocumentViewer..::..ToolModes for valid settings and their descriptions.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public DocumentViewer..::..ToolModes ToolMode { get; set; }
Visual Basic
Public Property ToolMode As DocumentViewer..::..ToolModes
    Get
    Set
Visual C++
public:
property DocumentViewer..::..ToolModes ToolMode {
    DocumentViewer..::..ToolModes get ();
    void set (DocumentViewer..::..ToolModes value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


Zoom Property

[image]

PDFTron SilverDox SDK
DocumentViewer..::..Zoom Property
DocumentViewer Class See Also Send Feedback
Used to get or set the magnification factor of the displayed pages.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public double Zoom { get; set; }
Visual Basic
Public Property Zoom As Double
    Get
    Set
Visual C++
public:
property double Zoom {
    double get ();
    void set (double value);
}

Remarks

Note that setting the property will cause the viewer's FitModeWidth and FitModeHeight properties to change to None.

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


DocumentViewer Events

[image] [image]

PDFTron SilverDox SDK
DocumentViewer Events
DocumentViewer Class See Also Send Feedback

The DocumentViewer type exposes the following members.

Events

 | Name | Description
Public event | AnnotationPopupContentChanged | Occurs when the user manually changes the contents of a popup NOTE: Does not trigger when PopupContents is set programatically
Public event | AnnotationResized | Occurs when an annotation is resized
Public event | AnnotationsAdded | Occurs when an annotation is added
Public event | AnnotationsCreated | Occurs when an annotation is created via. a tool
Public event | AnnotationsDeselected | Occurs when an annotation is deselected
Public event | AnnotationsDragged | Occurs when annotations are dragged by the user; WARNING: triggered a ton of times when user is move dragging annotations
Public event | AnnotationsMoveCompleted | Occurs when the user finishes moving annotations (i.e the mouse is released)
Public event | AnnotationsRemoved | Occurs when an annotation is removed
Public event | AnnotationsSelected | Occurs when an annotation is selected
Public event | PropertyChanged | Notification event that is raised when a bound property changes.
Public event | ToolModeChanged | Occurs when the DocumentViewer tool mode is changed

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


AnnotationPopupContentChanged Event

[image]

PDFTron SilverDox SDK
DocumentViewer..::..AnnotationPopupContentChanged Event
DocumentViewer Class See Also Send Feedback
Occurs when the user manually changes the contents of a popup NOTE: Does not trigger when PopupContents is set programatically

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public event EventHandler<AnnotationPopupContentChangedEventArgs> AnnotationPopupContentChanged
Visual Basic
Public Event AnnotationPopupContentChanged As EventHandler(Of AnnotationPopupContentChangedEventArgs)
Visual C++
public:
 event EventHandler<AnnotationPopupContentChangedEventArgs^>^ AnnotationPopupContentChanged {
    void add (EventHandler<AnnotationPopupContentChangedEventArgs^>^ value);
    void remove (EventHandler<AnnotationPopupContentChangedEventArgs^>^ value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


AnnotationResized Event

[image]

PDFTron SilverDox SDK
DocumentViewer..::..AnnotationResized Event
DocumentViewer Class See Also Send Feedback
Occurs when an annotation is resized

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public event EventHandler<AnnotationResizedEventArgs> AnnotationResized
Visual Basic
Public Event AnnotationResized As EventHandler(Of AnnotationResizedEventArgs)
Visual C++
public:
 event EventHandler<AnnotationResizedEventArgs^>^ AnnotationResized {
    void add (EventHandler<AnnotationResizedEventArgs^>^ value);
    void remove (EventHandler<AnnotationResizedEventArgs^>^ value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


AnnotationsAdded Event

[image]

PDFTron SilverDox SDK
DocumentViewer..::..AnnotationsAdded Event
DocumentViewer Class See Also Send Feedback
Occurs when an annotation is added

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public event EventHandler<AnnotationsEventArgs> AnnotationsAdded
Visual Basic
Public Event AnnotationsAdded As EventHandler(Of AnnotationsEventArgs)
Visual C++
public:
 event EventHandler<AnnotationsEventArgs^>^ AnnotationsAdded {
    void add (EventHandler<AnnotationsEventArgs^>^ value);
    void remove (EventHandler<AnnotationsEventArgs^>^ value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


AnnotationsCreated Event

[image]

PDFTron SilverDox SDK
DocumentViewer..::..AnnotationsCreated Event
DocumentViewer Class See Also Send Feedback
Occurs when an annotation is created via. a tool

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public event EventHandler<AnnotationsEventArgs> AnnotationsCreated
Visual Basic
Public Event AnnotationsCreated As EventHandler(Of AnnotationsEventArgs)
Visual C++
public:
 event EventHandler<AnnotationsEventArgs^>^ AnnotationsCreated {
    void add (EventHandler<AnnotationsEventArgs^>^ value);
    void remove (EventHandler<AnnotationsEventArgs^>^ value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


AnnotationsDeselected Event

[image]

PDFTron SilverDox SDK
DocumentViewer..::..AnnotationsDeselected Event
DocumentViewer Class See Also Send Feedback
Occurs when an annotation is deselected

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public event EventHandler<AnnotationsEventArgs> AnnotationsDeselected
Visual Basic
Public Event AnnotationsDeselected As EventHandler(Of AnnotationsEventArgs)
Visual C++
public:
 event EventHandler<AnnotationsEventArgs^>^ AnnotationsDeselected {
    void add (EventHandler<AnnotationsEventArgs^>^ value);
    void remove (EventHandler<AnnotationsEventArgs^>^ value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


AnnotationsDragged Event

[image]

PDFTron SilverDox SDK
DocumentViewer..::..AnnotationsDragged Event
DocumentViewer Class See Also Send Feedback
Occurs when annotations are dragged by the user; WARNING: triggered a ton of times when user is move dragging annotations

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public event EventHandler<AnnotationsEventArgs> AnnotationsDragged
Visual Basic
Public Event AnnotationsDragged As EventHandler(Of AnnotationsEventArgs)
Visual C++
public:
 event EventHandler<AnnotationsEventArgs^>^ AnnotationsDragged {
    void add (EventHandler<AnnotationsEventArgs^>^ value);
    void remove (EventHandler<AnnotationsEventArgs^>^ value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


AnnotationsMoveCompleted Event

[image]

PDFTron SilverDox SDK
DocumentViewer..::..AnnotationsMoveCompleted Event
DocumentViewer Class See Also Send Feedback
Occurs when the user finishes moving annotations (i.e the mouse is released)

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public event EventHandler<AnnotationsMoveCompletedEventArgs> AnnotationsMoveCompleted
Visual Basic
Public Event AnnotationsMoveCompleted As EventHandler(Of AnnotationsMoveCompletedEventArgs)
Visual C++
public:
 event EventHandler<AnnotationsMoveCompletedEventArgs^>^ AnnotationsMoveCompleted {
    void add (EventHandler<AnnotationsMoveCompletedEventArgs^>^ value);
    void remove (EventHandler<AnnotationsMoveCompletedEventArgs^>^ value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


AnnotationsRemoved Event

[image]

PDFTron SilverDox SDK
DocumentViewer..::..AnnotationsRemoved Event
DocumentViewer Class See Also Send Feedback
Occurs when an annotation is removed

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public event EventHandler<AnnotationsEventArgs> AnnotationsRemoved
Visual Basic
Public Event AnnotationsRemoved As EventHandler(Of AnnotationsEventArgs)
Visual C++
public:
 event EventHandler<AnnotationsEventArgs^>^ AnnotationsRemoved {
    void add (EventHandler<AnnotationsEventArgs^>^ value);
    void remove (EventHandler<AnnotationsEventArgs^>^ value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


AnnotationsSelected Event

[image]

PDFTron SilverDox SDK
DocumentViewer..::..AnnotationsSelected Event
DocumentViewer Class See Also Send Feedback
Occurs when an annotation is selected

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public event EventHandler<AnnotationsEventArgs> AnnotationsSelected
Visual Basic
Public Event AnnotationsSelected As EventHandler(Of AnnotationsEventArgs)
Visual C++
public:
 event EventHandler<AnnotationsEventArgs^>^ AnnotationsSelected {
    void add (EventHandler<AnnotationsEventArgs^>^ value);
    void remove (EventHandler<AnnotationsEventArgs^>^ value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


PropertyChanged Event

[image]

PDFTron SilverDox SDK
DocumentViewer..::..PropertyChanged Event
DocumentViewer Class See Also Send Feedback
Notification event that is raised when a bound property changes.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


ToolModeChanged Event

[image]

PDFTron SilverDox SDK
DocumentViewer..::..ToolModeChanged Event
DocumentViewer Class See Also Send Feedback
Occurs when the DocumentViewer tool mode is changed

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public event EventHandler<ToolModeChangedEventArgs> ToolModeChanged
Visual Basic
Public Event ToolModeChanged As EventHandler(Of ToolModeChangedEventArgs)
Visual C++
public:
 event EventHandler<ToolModeChangedEventArgs^>^ ToolModeChanged {
    void add (EventHandler<ToolModeChangedEventArgs^>^ value);
    void remove (EventHandler<ToolModeChangedEventArgs^>^ value);
}

See Also

DocumentViewer Class
PDFTron.SilverDox.Controls Namespace


DocumentViewer.DisplayModes Enumeration

[image]

PDFTron SilverDox SDK
DocumentViewer..::..DisplayModes Enumeration
DocumentViewer Class See Also Send Feedback
Lists the possible modes for DisplayMode, which controls which pages the viewer will display.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public enum DisplayModes
Visual Basic
Public Enumeration DisplayModes
Visual C++
public enum class DisplayModes

Members

Member name | Value | Description
AllPages | 0 | All pages will be visible.
SinglePage | 1 | Only the current page will be visible. Intended to be used where the viewer's ItemsPanelTemplate is a vertically orriented stack panel, with the HorizontalAlignment and VerticalAlignment attributes set to Center. This is the default ItemsPanelTemplate.
DualPageFacing | 2 | Up to two pages will be visible, with an odd numbered page rendered first. Intended to be used where the viewer's ItemsPanelTemplate is set to the FacingPanel layout Panel found in the ReaderControl sample project, with the CoverFacing attribute set to false. (SilverDoxSdk\Samples\ReaderControl\Utility\FacingPanel.cs)
DualPageCoverFacing | 3 | Up to two pages will be visible, with an even numbered page rendered first. Intended to be used where the viewer's ItemsPanelTemplate is set to the FacingPanel layout Panel found in the ReaderControl sample project, with the CoverFacing attribute set to true. (SilverDoxSdk\Samples\ReaderControl\Utility\FacingPanel.cs)

See Also

PDFTron.SilverDox.Controls Namespace


DocumentViewer.FitModes Enumeration

[image]

PDFTron SilverDox SDK
DocumentViewer..::..FitModes Enumeration
DocumentViewer Class See Also Send Feedback
Lists common modes of viewing a document's pages.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public enum FitModes
Visual Basic
Public Enumeration FitModes
Visual C++
public enum class FitModes

Members

Member name | Value | Description
None | 0 | Zoom level is not constrained.
Page | 1 | Zoom level is constrained such that the current page's width or height will exactly fill the available space.
Panel | 2 | Zoom level is constrained such that the current document's layout panel's width or height will exactly fill the available space. The layout panel is the width and height of the entire scrollable content.

See Also

PDFTron.SilverDox.Controls Namespace


DocumentViewer.ToolModes Enumeration

[image]

PDFTron SilverDox SDK
DocumentViewer..::..ToolModes Enumeration
DocumentViewer Class See Also Send Feedback
DocumentViewer supports 'built-in' tool modes which change the behavior of the viewer.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public enum ToolModes
Visual Basic
Public Enumeration ToolModes
Visual C++
public enum class ToolModes

Members

Member name | Value | Description
Pan | 0 | The mouse can be used to pan the document.
TextSelect | 1 | The mouse can be used to select text.
PanAndAnnotationEdit | 2 | The mouse can be used to pan the document except when it is over an annotion, when it can be used to select/move/resize the annotation.
AnnotationEdit | 3 | The mouse can be used to select/move/resize annotations.
AnnotationCreateCustom | 4 | The mouse can be used to create a custom annotation that derives from Annotation. Note that AnnotationCreator must be set to a static method defined by the custom annotation that returns a new annotation.
AnnotationCreateEllipse | 5 | The mouse can be used to create Ellipse annotations.
AnnotationCreateFreeHand | 6 | The mouse can be used to create FreeHand annotations.
AnnotationCreateLine | 7 | The mouse can be used to create Line annotations.
AnnotationCreateRectangle | 8 | The mouse can be used to create Rectangle annotations.
AnnotationCreateSticky | 9 | The mouse can be used to create Sticky annotations.
AnnotationCreateTextHighlight | 10 | The mouse can be used to create TextHighlight annotations.
AnnotationCreateTextStrikeout | 11 | The mouse can be used to create TextStrikeout annotations.
AnnotationCreateTextUnderline | 12 | The mouse can be used to create TextUnderline annotations.
Custom | 13 | The mouse behavior is defined by the user, and will not select text or cause the document to pan. The DocumentViewer does not implement any keyboard or mouse behaviour in response to keyboard or mouse events when in Custom tool mode.

See Also

PDFTron.SilverDox.Controls Namespace


FullTextSearchControl Class

[image]

PDFTron SilverDox SDK
FullTextSearchControl Class
Members See Also Send Feedback
A control that implements a full document text search for a document displayed in a DocumentViewer. The search results are displayed in a ListBox. Clicking on a search result will cause the DocumentViewer to navigate to the corresponding page.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class FullTextSearchControl : ListBox
Visual Basic
Public Class FullTextSearchControl _
    Inherits ListBox
Visual C++
public ref class FullTextSearchControl : public ListBox

Remarks

The DataContext of this control must be set to a DocumentViewer.

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ItemsControl
System.Windows.Controls.Primitives..::..Selector
System.Windows.Controls..::..ListBox
PDFTron.SilverDox.Controls..::..FullTextSearchControl

See Also

FullTextSearchControl Members
PDFTron.SilverDox.Controls Namespace


FullTextSearchControl Members

[image] [image]

PDFTron SilverDox SDK
FullTextSearchControl Members
FullTextSearchControl Class Constructors Methods Fields Properties See Also Send Feedback

The FullTextSearchControl type exposes the following members.

Constructors

 | Name | Description
Public method | FullTextSearchControl | Initializes a new instance of the FullTextSearchControl class.

Methods

 | Name | Description
Public method | Search | Searches the entire document for the specified string and populates the control's ListBox with the results.
Public method | SearchWithOptions | Searches the document with options: IsCaseSensitive, WholeWordOnly and SearchTerm

Fields

Name | Description
IsCaseSensitiveProperty | Identifies the IsCaseSensitive depencency property.
SearchTermProperty | Identifies the SearchTerm depencency property.
WholeWordOnlyProperty | Identifies the WholeWordOnly depencency property.

Properties

 | Name | Description
Public property | IsCaseSensitive | Gets or sets a value that indicates whether the search term is case sensitive.
Public property | PageStringFormat | The format string for displaying page number as a string. This string is in the .NET composite format, where {0} defines the page number.
Public property | SearchTerm | Gets or sets a value that is to be searched in the DocumentViewer
Public property | WholeWordOnly | Gets or sets a value that indicates wether the search term should be match whole words only.

See Also

FullTextSearchControl Class
PDFTron.SilverDox.Controls Namespace


FullTextSearchControl Constructor

[image]

PDFTron SilverDox SDK
FullTextSearchControl Constructor
FullTextSearchControl Class See Also Send Feedback
Initializes a new instance of the FullTextSearchControl class.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public FullTextSearchControl()
Visual Basic
Public Sub New
Visual C++
public:
FullTextSearchControl()

See Also

FullTextSearchControl Class
PDFTron.SilverDox.Controls Namespace


FullTextSearchControl Fields

[image] [image]

PDFTron SilverDox SDK
FullTextSearchControl Fields
FullTextSearchControl Class See Also Send Feedback

The FullTextSearchControl type exposes the following members.

Fields

Name | Description
IsCaseSensitiveProperty | Identifies the IsCaseSensitive depencency property.
SearchTermProperty | Identifies the SearchTerm depencency property.
WholeWordOnlyProperty | Identifies the WholeWordOnly depencency property.

See Also

FullTextSearchControl Class
PDFTron.SilverDox.Controls Namespace


IsCaseSensitiveProperty Field

[image]

PDFTron SilverDox SDK
FullTextSearchControl..::..IsCaseSensitiveProperty Field
FullTextSearchControl Class See Also Send Feedback
Identifies the IsCaseSensitive depencency property.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public static readonly DependencyProperty IsCaseSensitiveProperty
Visual Basic
Public Shared ReadOnly IsCaseSensitiveProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ IsCaseSensitiveProperty

See Also

FullTextSearchControl Class
PDFTron.SilverDox.Controls Namespace


SearchTermProperty Field

[image]

PDFTron SilverDox SDK
FullTextSearchControl..::..SearchTermProperty Field
FullTextSearchControl Class See Also Send Feedback
Identifies the SearchTerm depencency property.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public static readonly DependencyProperty SearchTermProperty
Visual Basic
Public Shared ReadOnly SearchTermProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SearchTermProperty

See Also

FullTextSearchControl Class
PDFTron.SilverDox.Controls Namespace


WholeWordOnlyProperty Field

[image]

PDFTron SilverDox SDK
FullTextSearchControl..::..WholeWordOnlyProperty Field
FullTextSearchControl Class See Also Send Feedback
Identifies the WholeWordOnly depencency property.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public static readonly DependencyProperty WholeWordOnlyProperty
Visual Basic
Public Shared ReadOnly WholeWordOnlyProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ WholeWordOnlyProperty

See Also

FullTextSearchControl Class
PDFTron.SilverDox.Controls Namespace


FullTextSearchControl Methods

[image] [image]

PDFTron SilverDox SDK
FullTextSearchControl Methods
FullTextSearchControl Class See Also Send Feedback

The FullTextSearchControl type exposes the following members.

Methods

 | Name | Description
Public method | Search | Searches the entire document for the specified string and populates the control's ListBox with the results.
Public method | SearchWithOptions | Searches the document with options: IsCaseSensitive, WholeWordOnly and SearchTerm

See Also

FullTextSearchControl Class
PDFTron.SilverDox.Controls Namespace


Search Method

[image]

PDFTron SilverDox SDK
FullTextSearchControl..::..Search Method
FullTextSearchControl Class See Also Send Feedback
Searches the entire document for the specified string and populates the control's ListBox with the results.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void Search(
    string searchString,
    TextSearch..::..SearchModes textSearchModes
)
Visual Basic
Public Sub Search ( _
    searchString As String, _
    textSearchModes As TextSearch..::..SearchModes _
)
Visual C++
public:
void Search(
    String^ searchString,
    TextSearch..::..SearchModes textSearchModes
)

Parameters

searchString
Type: System..::..String
The string to search for in the DocumentViewer's Document.
textSearchModes
Type: PDFTron.SilverDox.Documents.Text..::..TextSearch..::..SearchModes
The TextSearch..::..SearchModes for the search. Only WholeWord and CaseSensitive are relevant for the whole document search.

See Also

FullTextSearchControl Class
PDFTron.SilverDox.Controls Namespace


SearchWithOptions Method

[image]

PDFTron SilverDox SDK
FullTextSearchControl..::..SearchWithOptions Method
FullTextSearchControl Class See Also Send Feedback
Searches the document with options: IsCaseSensitive, WholeWordOnly and SearchTerm

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void SearchWithOptions()
Visual Basic
Public Sub SearchWithOptions
Visual C++
public:
void SearchWithOptions()

See Also

FullTextSearchControl Class
PDFTron.SilverDox.Controls Namespace


FullTextSearchControl Properties

[image] [image]

PDFTron SilverDox SDK
FullTextSearchControl Properties
FullTextSearchControl Class See Also Send Feedback

The FullTextSearchControl type exposes the following members.

Properties

 | Name | Description
Public property | IsCaseSensitive | Gets or sets a value that indicates whether the search term is case sensitive.
Public property | PageStringFormat | The format string for displaying page number as a string. This string is in the .NET composite format, where {0} defines the page number.
Public property | SearchTerm | Gets or sets a value that is to be searched in the DocumentViewer
Public property | WholeWordOnly | Gets or sets a value that indicates wether the search term should be match whole words only.

See Also

FullTextSearchControl Class
PDFTron.SilverDox.Controls Namespace


IsCaseSensitive Property

[image]

PDFTron SilverDox SDK
FullTextSearchControl..::..IsCaseSensitive Property
FullTextSearchControl Class See Also Send Feedback
Gets or sets a value that indicates whether the search term is case sensitive.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool IsCaseSensitive { get; set; }
Visual Basic
Public Property IsCaseSensitive As Boolean
    Get
    Set
Visual C++
public:
property bool IsCaseSensitive {
    bool get ();
    void set (bool value);
}

See Also

FullTextSearchControl Class
PDFTron.SilverDox.Controls Namespace


PageStringFormat Property

[image]

PDFTron SilverDox SDK
FullTextSearchControl..::..PageStringFormat Property
FullTextSearchControl Class See Also Send Feedback
The format string for displaying page number as a string. This string is in the .NET composite format, where {0} defines the page number.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string PageStringFormat { get; set; }
Visual Basic
Public Property PageStringFormat As String
    Get
    Set
Visual C++
public:
property String^ PageStringFormat {
    String^ get ();
    void set (String^ value);
}

See Also

FullTextSearchControl Class
PDFTron.SilverDox.Controls Namespace


SearchTerm Property

[image]

PDFTron SilverDox SDK
FullTextSearchControl..::..SearchTerm Property
FullTextSearchControl Class See Also Send Feedback
Gets or sets a value that is to be searched in the DocumentViewer

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string SearchTerm { get; set; }
Visual Basic
Public Property SearchTerm As String
    Get
    Set
Visual C++
public:
property String^ SearchTerm {
    String^ get ();
    void set (String^ value);
}

See Also

FullTextSearchControl Class
PDFTron.SilverDox.Controls Namespace


WholeWordOnly Property

[image]

PDFTron SilverDox SDK
FullTextSearchControl..::..WholeWordOnly Property
FullTextSearchControl Class See Also Send Feedback
Gets or sets a value that indicates wether the search term should be match whole words only.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool WholeWordOnly { get; set; }
Visual Basic
Public Property WholeWordOnly As Boolean
    Get
    Set
Visual C++
public:
property bool WholeWordOnly {
    bool get ();
    void set (bool value);
}

See Also

FullTextSearchControl Class
PDFTron.SilverDox.Controls Namespace


ThumbnailsControl Class

[image]

PDFTron SilverDox SDK
ThumbnailsControl Class
Members See Also Send Feedback
A control that displays thumbnail images of the document in a DocumentViewer. Clicking on a thumbnail will cause the DocumentViewer to navigate to the corresponding page, and scrolling DocumentViewer will cause the currently displayed page in the ThumbnailsControl to be highlighted.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class ThumbnailsControl : UserControl
Visual Basic
Public Class ThumbnailsControl _
    Inherits UserControl
Visual C++
public ref class ThumbnailsControl : public UserControl

Remarks

The DataContext of this control must be set to a DocumentViewer.

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..UserControl
PDFTron.SilverDox.Controls..::..ThumbnailsControl

See Also

ThumbnailsControl Members
PDFTron.SilverDox.Controls Namespace


ThumbnailsControl Members

[image] [image]

PDFTron SilverDox SDK
ThumbnailsControl Members
ThumbnailsControl Class Constructors Methods Properties See Also Send Feedback

The ThumbnailsControl type exposes the following members.

Constructors

 | Name | Description
Public method | ThumbnailsControl | Initializes a new instance of the ThumbnailsControl class.

Methods

 | Name | Description
Public method | InitializeComponent | InitializeComponent

Properties

 | Name | Description
Public property | ScaleFactor | The scaling factor of the displayed thumbnails.

See Also

ThumbnailsControl Class
PDFTron.SilverDox.Controls Namespace


ThumbnailsControl Constructor

[image]

PDFTron SilverDox SDK
ThumbnailsControl Constructor
ThumbnailsControl Class See Also Send Feedback
Initializes a new instance of the ThumbnailsControl class.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public ThumbnailsControl()
Visual Basic
Public Sub New
Visual C++
public:
ThumbnailsControl()

See Also

ThumbnailsControl Class
PDFTron.SilverDox.Controls Namespace


ThumbnailsControl Methods

[image] [image]

PDFTron SilverDox SDK
ThumbnailsControl Methods
ThumbnailsControl Class See Also Send Feedback

The ThumbnailsControl type exposes the following members.

Methods

 | Name | Description
Public method | InitializeComponent | InitializeComponent

See Also

ThumbnailsControl Class
PDFTron.SilverDox.Controls Namespace


InitializeComponent Method

[image]

PDFTron SilverDox SDK
ThumbnailsControl..::..InitializeComponent Method
ThumbnailsControl Class See Also Send Feedback
InitializeComponent

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void InitializeComponent()
Visual Basic
Public Sub InitializeComponent
Visual C++
public:
void InitializeComponent()

See Also

ThumbnailsControl Class
PDFTron.SilverDox.Controls Namespace


ThumbnailsControl Properties

[image] [image]

PDFTron SilverDox SDK
ThumbnailsControl Properties
ThumbnailsControl Class See Also Send Feedback

The ThumbnailsControl type exposes the following members.

Properties

 | Name | Description
Public property | ScaleFactor | The scaling factor of the displayed thumbnails.

See Also

ThumbnailsControl Class
PDFTron.SilverDox.Controls Namespace


ScaleFactor Property

[image]

PDFTron SilverDox SDK
ThumbnailsControl..::..ScaleFactor Property
ThumbnailsControl Class See Also Send Feedback
The scaling factor of the displayed thumbnails.

Namespace: PDFTron.SilverDox.Controls
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public double ScaleFactor { get; set; }
Visual Basic
Public Property ScaleFactor As Double
    Get
    Set
Visual C++
public:
property double ScaleFactor {
    double get ();
    void set (double value);
}

See Also

ThumbnailsControl Class
PDFTron.SilverDox.Controls Namespace


PDFTron.SilverDox.Documents Namespace

[image]

PDFTron SilverDox SDK
PDFTron.SilverDox.Documents Namespace
Send Feedback
Contains the Document class and support classes. The support classes support document Bookmarks, the creation of Links, and access to document Metadata.

Classes

 | Class | Description
Public class | Bookmark | Represents a bookmark in a Document. Bookmarks typically represent an outline of the document, and as each bookmark is usually associated with a specific page in a document, they are typically used to facilitate navigation.
Public class | Document | Represents a document with individual pages (canvases) that can be displayed on screen and printed.
Public class | Document..::..OnLoadCanvasAsyncCallbackArgs | Arguments used as a parameter in the user defined callback function provided to LoadCanvasAsync(Int32, Action<(Of <<'(Document..::..OnLoadCanvasAsyncCallbackArgs>)>>), Action<(Of <<'(Document..::..OnLoadCanvasAsyncCallbackArgs>)>>), Action<(Of <<'(Link>)>>)).
Public class | Document..::..OnLoadPartAsyncCallbackArgs | Arguments used as a parameter in the user defined callback function provided to LoadPartAsync(String, Action<(Of <<'(Document..::..OnLoadPartAsyncCallbackArgs>)>>), Object).
Public class | Document..::..OnLoadThumbnailAsyncCallbackArgs | Arguments used as a parameter in the user defined callback function provided to LoadThumbnailAsync(Int32, Action<(Of <<'(Document..::..OnLoadThumbnailAsyncCallbackArgs>)>>)).
Public class | Link | A link that is placed on a Document page. Links, which are used to navigate somewhere when clicked on, may point to an external URI, or a location within the document.
Public class | Metadata | A dictionary containing document metadata, such as the document's author and creation date.
Public class | PageInfo | Describes a page in terms of its dimensions, resources and whether all the resources have been fully loaded. A collection of PageInfo objects is created when a Document is initilized, and are accessible via Document's Pages property. Note that PageInfo does not contain the page content, which can be acquired using the LoadCanvasAsync(Int32, Action<(Of <<'(Document..::..OnLoadCanvasAsyncCallbackArgs>)>>), Action<(Of <<'(Document..::..OnLoadCanvasAsyncCallbackArgs>)>>), Action<(Of <<'(Link>)>>)) method.


Bookmark Class

[image]

PDFTron SilverDox SDK
Bookmark Class
Members See Also Send Feedback
Represents a bookmark in a Document. Bookmarks typically represent an outline of the document, and as each bookmark is usually associated with a specific page in a document, they are typically used to facilitate navigation.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class Bookmark
Visual Basic
Public Class Bookmark
Visual C++
public ref class Bookmark

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents..::..Bookmark

See Also

Bookmark Members
PDFTron.SilverDox.Documents Namespace


Bookmark Members

[image] [image]

PDFTron SilverDox SDK
Bookmark Members
Bookmark Class Properties See Also Send Feedback

The Bookmark type exposes the following members.

Properties

 | Name | Description
Public property | Children | A collection of child bookmarks.
Public property | Name | The name of the bookmark.
Public property | PageNumber | The page which the bookmark references.
Public property | Parent | The parent of this bookmark.
Public property | VerticalOffset | The number of units down the page which represents the location that the bookmark references. Each unit is 1/96th of an inch.

See Also

Bookmark Class
PDFTron.SilverDox.Documents Namespace


Bookmark Properties

[image] [image]

PDFTron SilverDox SDK
Bookmark Properties
Bookmark Class See Also Send Feedback

The Bookmark type exposes the following members.

Properties

 | Name | Description
Public property | Children | A collection of child bookmarks.
Public property | Name | The name of the bookmark.
Public property | PageNumber | The page which the bookmark references.
Public property | Parent | The parent of this bookmark.
Public property | VerticalOffset | The number of units down the page which represents the location that the bookmark references. Each unit is 1/96th of an inch.

See Also

Bookmark Class
PDFTron.SilverDox.Documents Namespace


Children Property

[image]

PDFTron SilverDox SDK
Bookmark..::..Children Property
Bookmark Class See Also Send Feedback
A collection of child bookmarks.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public ObservableCollection<Bookmark> Children { get; internal set; }
Visual Basic
Public Property Children As ObservableCollection(Of Bookmark)
    Get
    Friend Set
Visual C++
public:
property ObservableCollection<Bookmark^>^ Children {
    ObservableCollection<Bookmark^>^ get ();
    internal: void set (ObservableCollection<Bookmark^>^ value);
}

See Also

Bookmark Class
PDFTron.SilverDox.Documents Namespace


Name Property

[image]

PDFTron SilverDox SDK
Bookmark..::..Name Property
Bookmark Class See Also Send Feedback
The name of the bookmark.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string Name { get; internal set; }
Visual Basic
Public Property Name As String
    Get
    Friend Set
Visual C++
public:
property String^ Name {
    String^ get ();
    internal: void set (String^ value);
}

See Also

Bookmark Class
PDFTron.SilverDox.Documents Namespace


PageNumber Property

[image]

PDFTron SilverDox SDK
Bookmark..::..PageNumber Property
Bookmark Class See Also Send Feedback
The page which the bookmark references.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Nullable<int> PageNumber { get; internal set; }
Visual Basic
Public Property PageNumber As Nullable(Of Integer)
    Get
    Friend Set
Visual C++
public:
property Nullable<int> PageNumber {
    Nullable<int> get ();
    internal: void set (Nullable<int> value);
}

See Also

Bookmark Class
PDFTron.SilverDox.Documents Namespace


Parent Property

[image]

PDFTron SilverDox SDK
Bookmark..::..Parent Property
Bookmark Class See Also Send Feedback
The parent of this bookmark.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Bookmark Parent { get; internal set; }
Visual Basic
Public Property Parent As Bookmark
    Get
    Friend Set
Visual C++
public:
property Bookmark^ Parent {
    Bookmark^ get ();
    internal: void set (Bookmark^ value);
}

See Also

Bookmark Class
PDFTron.SilverDox.Documents Namespace


VerticalOffset Property

[image]

PDFTron SilverDox SDK
Bookmark..::..VerticalOffset Property
Bookmark Class See Also Send Feedback
The number of units down the page which represents the location that the bookmark references. Each unit is 1/96th of an inch.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Nullable<double> VerticalOffset { get; internal set; }
Visual Basic
Public Property VerticalOffset As Nullable(Of Double)
    Get
    Friend Set
Visual C++
public:
property Nullable<double> VerticalOffset {
    Nullable<double> get ();
    internal: void set (Nullable<double> value);
}

See Also

Bookmark Class
PDFTron.SilverDox.Documents Namespace


Document Class

[image]

PDFTron SilverDox SDK
Document Class
Members See Also Send Feedback
Represents a document with individual pages (canvases) that can be displayed on screen and printed.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class Document
Visual Basic
Public Class Document
Visual C++
public ref class Document

Remarks

The easiest way to display a document is to use a DocumentViewer.

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents..::..Document

See Also

Document Members
PDFTron.SilverDox.Documents Namespace


Document Members

[image] [image]

PDFTron SilverDox SDK
Document Members
Document Class Constructors Methods Properties See Also Send Feedback

The Document type exposes the following members.

Constructors

 | Name | Description
Public method | Document | Constructs an empty Document.

Methods

 | Name | Description
Public method | CancelRequest | Cancels outstanding requests that have been made for resources associated with the specified page.
Public method | LoadAsync | Initilizes a Document so that it can be used to load page canvases.
Public method | LoadCanvasAsync | Loads the canvas for a given page number.
Public method | LoadPartAsync | Loads the specified part. This is a low-level method that would not normally be used unless creating a custom document viewer with very specific loading requirements.
Public method | LoadThumbnailAsync | Loads a thumbnail image for a particular page.
Public method | Print | Invokes the system's print dialog box, allowing the user to print the document.

Properties

 | Name | Description
Public property | Bookmarks | The collection of bookmarks created when the Document is initilized.
Public property | Metadata | The metadata associated with the document. Metadata contains information such as the document's author and creation date.
Public property | Pages | A collection PageInfo objects describing every page in the document.

See Also

Document Class
PDFTron.SilverDox.Documents Namespace


Document Constructor

[image]

PDFTron SilverDox SDK
Document Constructor
Document Class See Also Send Feedback
Constructs an empty Document.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Document()
Visual Basic
Public Sub New
Visual C++
public:
Document()

See Also

Document Class
PDFTron.SilverDox.Documents Namespace


Document Methods

[image] [image]

PDFTron SilverDox SDK
Document Methods
Document Class See Also Send Feedback

The Document type exposes the following members.

Methods

 | Name | Description
Public method | CancelRequest | Cancels outstanding requests that have been made for resources associated with the specified page.
Public method | LoadAsync | Initilizes a Document so that it can be used to load page canvases.
Public method | LoadCanvasAsync | Loads the canvas for a given page number.
Public method | LoadPartAsync | Loads the specified part. This is a low-level method that would not normally be used unless creating a custom document viewer with very specific loading requirements.
Public method | LoadThumbnailAsync | Loads a thumbnail image for a particular page.
Public method | Print | Invokes the system's print dialog box, allowing the user to print the document.

See Also

Document Class
PDFTron.SilverDox.Documents Namespace


CancelRequest Method

[image]

PDFTron SilverDox SDK
Document..::..CancelRequest Method
Document Class See Also Send Feedback
Cancels outstanding requests that have been made for resources associated with the specified page.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void CancelRequest(
    int pageNumber
)
Visual Basic
Public Sub CancelRequest ( _
    pageNumber As Integer _
)
Visual C++
public:
void CancelRequest(
    int pageNumber
)

Parameters

pageNumber
Type: System..::..Int32
The number of the page for which requests will be canceled.

Remarks

Note that HTTP does not allow requests to be revoked. Requests that have not yet been issued to a server will be canceled, and server responses to requests that have been issued will be ignored.

See Also

Document Class
PDFTron.SilverDox.Documents Namespace


LoadAsync Method

[image]

PDFTron SilverDox SDK
Document..::..LoadAsync Method
Document Class See Also Send Feedback
Initilizes a Document so that it can be used to load page canvases.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void LoadAsync(
    IPartRetriever partRetriever,
    Action<Exception> callback
)
Visual Basic
Public Sub LoadAsync ( _
    partRetriever As IPartRetriever, _
    callback As Action(Of Exception) _
)
Visual C++
public:
void LoadAsync(
    IPartRetriever^ partRetriever,
    Action<Exception^>^ callback
)

Parameters

partRetriever
Type: PDFTron.SilverDox.IO..::..IPartRetriever
A concrete instance of a IPartRetriever. There are two built-in concrete implementations of IPartRetriever: LocalPartRetriever, which is used to access files on the local file system, and HttpPartRetriever, which is used to access files on a web server.
callback
Type: System..::..Action <(Of <(<' Exception >)>)>
A callback function that is called when the Document has been intilized.

Remarks

This method must be the first method called on a new instance of a Document

See Also

Document Class
PDFTron.SilverDox.Documents Namespace


LoadCanvasAsync Method

[image]

PDFTron SilverDox SDK
Document..::..LoadCanvasAsync Method
Document Class See Also Send Feedback
Loads the canvas for a given page number.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void LoadCanvasAsync(
    int pageNumber,
    Action<Document..::..OnLoadCanvasAsyncCallbackArgs> onLoadCanvasCallback,
    Action<Document..::..OnLoadCanvasAsyncCallbackArgs> onLoadCanvasAndResourcesCallback,
    Action<Link> onLinkReadyCallback
)
Visual Basic
Public Sub LoadCanvasAsync ( _
    pageNumber As Integer, _
    onLoadCanvasCallback As Action(Of Document..::..OnLoadCanvasAsyncCallbackArgs), _
    onLoadCanvasAndResourcesCallback As Action(Of Document..::..OnLoadCanvasAsyncCallbackArgs), _
    onLinkReadyCallback As Action(Of Link) _
)
Visual C++
public:
void LoadCanvasAsync(
    int pageNumber,
    Action<Document..::..OnLoadCanvasAsyncCallbackArgs^>^ onLoadCanvasCallback,
    Action<Document..::..OnLoadCanvasAsyncCallbackArgs^>^ onLoadCanvasAndResourcesCallback,
    Action<Link^>^ onLinkReadyCallback
)

Parameters

pageNumber
Type: System..::..Int32
The page number of the requested canvas.
onLoadCanvasCallback
Type: System..::..Action <(Of <(<' Document..::..OnLoadCanvasAsyncCallbackArgs >)>)>
A callback function that is called when the canvas is loaded. Note that canvas may be missing elements, which will be added to the canvas as they are loaded.
onLoadCanvasAndResourcesCallback
Type: System..::..Action <(Of <(<' Document..::..OnLoadCanvasAsyncCallbackArgs >)>)>
A callback function that is called when the canvas and all its associated resources are loaded. It is at this time that the canvas may be displayed without any missing elements.
onLinkReadyCallback
Type: System..::..Action <(Of <(<' Link >)>)>
A callback function that is called when a link is created on the canvas. The callback's argument provides access the link, which may be used to alter the behavior of the link such as its response to mouse events.

Remarks

A canvas is made available through the onLoadCanvasCallback callback as soon as it is loaded; however, the canvas may not contain all the elements needed to render it completely. In this case, this canvas will be automatically populated with each missing element as each element is loaded. When the canvas can be fully rendered, the canvas is made available through the onLoadCanvasAndResourcesCallback callback.

See Also

Document Class
PDFTron.SilverDox.Documents Namespace


LoadPartAsync Method

[image]

PDFTron SilverDox SDK
Document..::..LoadPartAsync Method
Document Class See Also Send Feedback
Loads the specified part. This is a low-level method that would not normally be used unless creating a custom document viewer with very specific loading requirements.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void LoadPartAsync(
    string partName,
    Action<Document..::..OnLoadPartAsyncCallbackArgs> onLoadPartCallback,
    Object userData
)
Visual Basic
Public Sub LoadPartAsync ( _
    partName As String, _
    onLoadPartCallback As Action(Of Document..::..OnLoadPartAsyncCallbackArgs), _
    userData As Object _
)
Visual C++
public:
void LoadPartAsync(
    String^ partName,
    Action<Document..::..OnLoadPartAsyncCallbackArgs^>^ onLoadPartCallback,
    Object^ userData
)

Parameters

partName
Type: System..::..String
The name of the part, typicially determined by referencing the properties of a particular page's PageInfo()()()().
onLoadPartCallback
Type: System..::..Action <(Of <(<' Document..::..OnLoadPartAsyncCallbackArgs >)>)>
The callback function that is called when the part has been loaded.
userData
Type: System..::..Object
Custom data that will be included in the callback function's arguments.

See Also

Document Class
PDFTron.SilverDox.Documents Namespace


LoadThumbnailAsync Method

[image]

PDFTron SilverDox SDK
Document..::..LoadThumbnailAsync Method
Document Class See Also Send Feedback
Loads a thumbnail image for a particular page.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void LoadThumbnailAsync(
    int pageNumber,
    Action<Document..::..OnLoadThumbnailAsyncCallbackArgs> onLoadThumbnailCallback
)
Visual Basic
Public Sub LoadThumbnailAsync ( _
    pageNumber As Integer, _
    onLoadThumbnailCallback As Action(Of Document..::..OnLoadThumbnailAsyncCallbackArgs) _
)
Visual C++
public:
void LoadThumbnailAsync(
    int pageNumber,
    Action<Document..::..OnLoadThumbnailAsyncCallbackArgs^>^ onLoadThumbnailCallback
)

Parameters

pageNumber
Type: System..::..Int32
The page number of the requested thumbnail.
onLoadThumbnailCallback
Type: System..::..Action <(Of <(<' Document..::..OnLoadThumbnailAsyncCallbackArgs >)>)>
The callback function that is called when the thumbnail has been loaded.

See Also

Document Class
PDFTron.SilverDox.Documents Namespace


Print Method

[image]

PDFTron SilverDox SDK
Document..::..Print Method
Document Class See Also Send Feedback
Invokes the system's print dialog box, allowing the user to print the document.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void Print(
    bool fitToPage,
    List<Canvas> annotationCanvases
)
Visual Basic
Public Sub Print ( _
    fitToPage As Boolean, _
    annotationCanvases As List(Of Canvas) _
)
Visual C++
public:
void Print(
    bool fitToPage,
    List<Canvas^>^ annotationCanvases
)

Parameters

fitToPage
Type: System..::..Boolean
If true pages will be scaled down to fit the page.
annotationCanvases
Type: System.Collections.Generic..::..List <(Of <(<' Canvas >)>)>
Canvases that appear on top of the document's pages.

Remarks

Calling this method will cause the the entire document to be loaded, regardless of which pages are printed. Silverlight's support for printing (added in version 4) is preliminary, and printing suspends the application's UI during the printing process.

See Also

Document Class
PDFTron.SilverDox.Documents Namespace


Document Properties

[image] [image]

PDFTron SilverDox SDK
Document Properties
Document Class See Also Send Feedback

The Document type exposes the following members.

Properties

 | Name | Description
Public property | Bookmarks | The collection of bookmarks created when the Document is initilized.
Public property | Metadata | The metadata associated with the document. Metadata contains information such as the document's author and creation date.
Public property | Pages | A collection PageInfo objects describing every page in the document.

See Also

Document Class
PDFTron.SilverDox.Documents Namespace


Bookmarks Property

[image]

PDFTron SilverDox SDK
Document..::..Bookmarks Property
Document Class See Also Send Feedback
The collection of bookmarks created when the Document is initilized.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public ObservableCollection<Bookmark> Bookmarks { get; private set; }
Visual Basic
Public Property Bookmarks As ObservableCollection(Of Bookmark)
    Get
    Private Set
Visual C++
public:
property ObservableCollection<Bookmark^>^ Bookmarks {
    ObservableCollection<Bookmark^>^ get ();
    private: void set (ObservableCollection<Bookmark^>^ value);
}

See Also

Document Class
PDFTron.SilverDox.Documents Namespace


Metadata Property

[image]

PDFTron SilverDox SDK
Document..::..Metadata Property
Document Class See Also Send Feedback
The metadata associated with the document. Metadata contains information such as the document's author and creation date.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Metadata Metadata { get; internal set; }
Visual Basic
Public Property Metadata As Metadata
    Get
    Friend Set
Visual C++
public:
property Metadata^ Metadata {
    Metadata^ get ();
    internal: void set (Metadata^ value);
}

See Also

Document Class
PDFTron.SilverDox.Documents Namespace


Pages Property

[image]

PDFTron SilverDox SDK
Document..::..Pages Property
Document Class See Also Send Feedback
A collection PageInfo objects describing every page in the document.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public List<PageInfo> Pages { get; private set; }
Visual Basic
Public Property Pages As List(Of PageInfo)
    Get
    Private Set
Visual C++
public:
property List<PageInfo^>^ Pages {
    List<PageInfo^>^ get ();
    private: void set (List<PageInfo^>^ value);
}

See Also

Document Class
PDFTron.SilverDox.Documents Namespace


Document.OnLoadCanvasAsyncCallbackArgs Class

[image]

PDFTron SilverDox SDK
Document..::..OnLoadCanvasAsyncCallbackArgs Class
Document Class Members See Also Send Feedback
Arguments used as a parameter in the user defined callback function provided to LoadCanvasAsync(Int32, Action<(Of <<'(Document..::..OnLoadCanvasAsyncCallbackArgs>)>>), Action<(Of <<'(Document..::..OnLoadCanvasAsyncCallbackArgs>)>>), Action<(Of <<'(Link>)>>)).

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class OnLoadCanvasAsyncCallbackArgs : IAsyncResult
Visual Basic
Public Class OnLoadCanvasAsyncCallbackArgs _
    Implements IAsyncResult
Visual C++
public ref class OnLoadCanvasAsyncCallbackArgs : IAsyncResult

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents..::..Document..::..OnLoadCanvasAsyncCallbackArgs

See Also

Document..::..OnLoadCanvasAsyncCallbackArgs Members
PDFTron.SilverDox.Documents Namespace


Document.OnLoadCanvasAsyncCallbackArgs Members

[image] [image]

PDFTron SilverDox SDK
Document..::..OnLoadCanvasAsyncCallbackArgs Members
Document..::..OnLoadCanvasAsyncCallbackArgs Class Properties See Also Send Feedback

Represents a document with individual pages (canvases) that can be displayed on screen and printed.

The Document..::..OnLoadCanvasAsyncCallbackArgs type exposes the following members.

Properties

 | Name | Description
Public property | AsyncState | Gets a user-defined object that qualifies or contains information about an asynchronous operation.
Public property | AsyncWaitHandle | Gets a WaitHandle that is used to wait for an asynchronous operation to complete.
Public property | CompletedSynchronously | Gets a value that indicates whether the asynchronous operation completed synchronously.
Public property | Error | If an error has occured, Error contains information about the error; otherwise, Error is null.
Public property | IsCompleted | Gets a value that indicates whether the asynchronous operation has completed.
Public property | PageCanvas | The canvas for the specified page of the Document.
Public property | PageNumber | The page number of PageCanvas.

See Also

Document..::..OnLoadCanvasAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


Document.OnLoadCanvasAsyncCallbackArgs Properties

[image] [image]

PDFTron SilverDox SDK
Document..::..OnLoadCanvasAsyncCallbackArgs Properties
Document..::..OnLoadCanvasAsyncCallbackArgs Class See Also Send Feedback

The Document..::..OnLoadCanvasAsyncCallbackArgs type exposes the following members.

Properties

 | Name | Description
Public property | AsyncState | Gets a user-defined object that qualifies or contains information about an asynchronous operation.
Public property | AsyncWaitHandle | Gets a WaitHandle that is used to wait for an asynchronous operation to complete.
Public property | CompletedSynchronously | Gets a value that indicates whether the asynchronous operation completed synchronously.
Public property | Error | If an error has occured, Error contains information about the error; otherwise, Error is null.
Public property | IsCompleted | Gets a value that indicates whether the asynchronous operation has completed.
Public property | PageCanvas | The canvas for the specified page of the Document.
Public property | PageNumber | The page number of PageCanvas.

See Also

Document..::..OnLoadCanvasAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


AsyncState Property

[image]

PDFTron SilverDox SDK
Document..::..OnLoadCanvasAsyncCallbackArgs..::..AsyncState Property
Document..::..OnLoadCanvasAsyncCallbackArgs Class See Also Send Feedback
Gets a user-defined object that qualifies or contains information about an asynchronous operation.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Object AsyncState { get; internal set; }
Visual Basic
Public Property AsyncState As Object
    Get
    Friend Set
Visual C++
public:
virtual property Object^ AsyncState {
    Object^ get () sealed;
    internal: void set (Object^ value) sealed;
}

Implements

IAsyncResult..::..AsyncState

See Also

Document..::..OnLoadCanvasAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


AsyncWaitHandle Property

[image]

PDFTron SilverDox SDK
Document..::..OnLoadCanvasAsyncCallbackArgs..::..AsyncWaitHandle Property
Document..::..OnLoadCanvasAsyncCallbackArgs Class See Also Send Feedback
Gets a WaitHandle that is used to wait for an asynchronous operation to complete.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public WaitHandle AsyncWaitHandle { get; private set; }
Visual Basic
Public Property AsyncWaitHandle As WaitHandle
    Get
    Private Set
Visual C++
public:
virtual property WaitHandle^ AsyncWaitHandle {
    WaitHandle^ get () sealed;
    private: void set (WaitHandle^ value) sealed;
}

Implements

IAsyncResult..::..AsyncWaitHandle

See Also

Document..::..OnLoadCanvasAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


CompletedSynchronously Property

[image]

PDFTron SilverDox SDK
Document..::..OnLoadCanvasAsyncCallbackArgs..::..CompletedSynchronously Property
Document..::..OnLoadCanvasAsyncCallbackArgs Class See Also Send Feedback
Gets a value that indicates whether the asynchronous operation completed synchronously.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool CompletedSynchronously { get; internal set; }
Visual Basic
Public Property CompletedSynchronously As Boolean
    Get
    Friend Set
Visual C++
public:
virtual property bool CompletedSynchronously {
    bool get () sealed;
    internal: void set (bool value) sealed;
}

Implements

IAsyncResult..::..CompletedSynchronously

See Also

Document..::..OnLoadCanvasAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


Error Property

[image]

PDFTron SilverDox SDK
Document..::..OnLoadCanvasAsyncCallbackArgs..::..Error Property
Document..::..OnLoadCanvasAsyncCallbackArgs Class See Also Send Feedback
If an error has occured, Error contains information about the error; otherwise, Error is null.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Exception Error { get; internal set; }
Visual Basic
Public Property Error As Exception
    Get
    Friend Set
Visual C++
public:
property Exception^ Error {
    Exception^ get ();
    internal: void set (Exception^ value);
}

See Also

Document..::..OnLoadCanvasAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


IsCompleted Property

[image]

PDFTron SilverDox SDK
Document..::..OnLoadCanvasAsyncCallbackArgs..::..IsCompleted Property
Document..::..OnLoadCanvasAsyncCallbackArgs Class See Also Send Feedback
Gets a value that indicates whether the asynchronous operation has completed.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool IsCompleted { get; private set; }
Visual Basic
Public Property IsCompleted As Boolean
    Get
    Private Set
Visual C++
public:
virtual property bool IsCompleted {
    bool get () sealed;
    private: void set (bool value) sealed;
}

Implements

IAsyncResult..::..IsCompleted

See Also

Document..::..OnLoadCanvasAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


PageCanvas Property

[image]

PDFTron SilverDox SDK
Document..::..OnLoadCanvasAsyncCallbackArgs..::..PageCanvas Property
Document..::..OnLoadCanvasAsyncCallbackArgs Class See Also Send Feedback
The canvas for the specified page of the Document.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Canvas PageCanvas { get; }
Visual Basic
Public ReadOnly Property PageCanvas As Canvas
    Get
Visual C++
public:
property Canvas^ PageCanvas {
    Canvas^ get ();
}

See Also

Document..::..OnLoadCanvasAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


PageNumber Property

[image]

PDFTron SilverDox SDK
Document..::..OnLoadCanvasAsyncCallbackArgs..::..PageNumber Property
Document..::..OnLoadCanvasAsyncCallbackArgs Class See Also Send Feedback
The page number of PageCanvas.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public int PageNumber { get; }
Visual Basic
Public ReadOnly Property PageNumber As Integer
    Get
Visual C++
public:
property int PageNumber {
    int get ();
}

See Also

Document..::..OnLoadCanvasAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


Document.OnLoadPartAsyncCallbackArgs Class

[image]

PDFTron SilverDox SDK
Document..::..OnLoadPartAsyncCallbackArgs Class
Document Class Members See Also Send Feedback
Arguments used as a parameter in the user defined callback function provided to LoadPartAsync(String, Action<(Of <<'(Document..::..OnLoadPartAsyncCallbackArgs>)>>), Object).

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class OnLoadPartAsyncCallbackArgs : IAsyncResult
Visual Basic
Public Class OnLoadPartAsyncCallbackArgs _
    Implements IAsyncResult
Visual C++
public ref class OnLoadPartAsyncCallbackArgs : IAsyncResult

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents..::..Document..::..OnLoadPartAsyncCallbackArgs

See Also

Document..::..OnLoadPartAsyncCallbackArgs Members
PDFTron.SilverDox.Documents Namespace


Document.OnLoadPartAsyncCallbackArgs Members

[image] [image]

PDFTron SilverDox SDK
Document..::..OnLoadPartAsyncCallbackArgs Members
Document..::..OnLoadPartAsyncCallbackArgs Class Properties See Also Send Feedback

Represents a document with individual pages (canvases) that can be displayed on screen and printed.

The Document..::..OnLoadPartAsyncCallbackArgs type exposes the following members.

Properties

 | Name | Description
Public property | AsyncState | Gets a user-defined object that qualifies or contains information about an asynchronous operation.
Public property | AsyncWaitHandle | Gets a WaitHandle that is used to wait for an asynchronous operation to complete.
Public property | CompletedSynchronously | Gets a value that indicates whether the asynchronous operation completed synchronously.
Public property | Error | If an error has occured, Error contains information about the error; otherwise, Error is null.
Public property | IsCompleted | Gets a value that indicates whether the asynchronous operation has completed.
Public property | Part | A byte array which is the part's data.
Public property | PartName | The name of the part.

See Also

Document..::..OnLoadPartAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


Document.OnLoadPartAsyncCallbackArgs Properties

[image] [image]

PDFTron SilverDox SDK
Document..::..OnLoadPartAsyncCallbackArgs Properties
Document..::..OnLoadPartAsyncCallbackArgs Class See Also Send Feedback

The Document..::..OnLoadPartAsyncCallbackArgs type exposes the following members.

Properties

 | Name | Description
Public property | AsyncState | Gets a user-defined object that qualifies or contains information about an asynchronous operation.
Public property | AsyncWaitHandle | Gets a WaitHandle that is used to wait for an asynchronous operation to complete.
Public property | CompletedSynchronously | Gets a value that indicates whether the asynchronous operation completed synchronously.
Public property | Error | If an error has occured, Error contains information about the error; otherwise, Error is null.
Public property | IsCompleted | Gets a value that indicates whether the asynchronous operation has completed.
Public property | Part | A byte array which is the part's data.
Public property | PartName | The name of the part.

See Also

Document..::..OnLoadPartAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


AsyncState Property

[image]

PDFTron SilverDox SDK
Document..::..OnLoadPartAsyncCallbackArgs..::..AsyncState Property
Document..::..OnLoadPartAsyncCallbackArgs Class See Also Send Feedback
Gets a user-defined object that qualifies or contains information about an asynchronous operation.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Object AsyncState { get; internal set; }
Visual Basic
Public Property AsyncState As Object
    Get
    Friend Set
Visual C++
public:
virtual property Object^ AsyncState {
    Object^ get () sealed;
    internal: void set (Object^ value) sealed;
}

Implements

IAsyncResult..::..AsyncState

See Also

Document..::..OnLoadPartAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


AsyncWaitHandle Property

[image]

PDFTron SilverDox SDK
Document..::..OnLoadPartAsyncCallbackArgs..::..AsyncWaitHandle Property
Document..::..OnLoadPartAsyncCallbackArgs Class See Also Send Feedback
Gets a WaitHandle that is used to wait for an asynchronous operation to complete.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public WaitHandle AsyncWaitHandle { get; private set; }
Visual Basic
Public Property AsyncWaitHandle As WaitHandle
    Get
    Private Set
Visual C++
public:
virtual property WaitHandle^ AsyncWaitHandle {
    WaitHandle^ get () sealed;
    private: void set (WaitHandle^ value) sealed;
}

Implements

IAsyncResult..::..AsyncWaitHandle

See Also

Document..::..OnLoadPartAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


CompletedSynchronously Property

[image]

PDFTron SilverDox SDK
Document..::..OnLoadPartAsyncCallbackArgs..::..CompletedSynchronously Property
Document..::..OnLoadPartAsyncCallbackArgs Class See Also Send Feedback
Gets a value that indicates whether the asynchronous operation completed synchronously.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool CompletedSynchronously { get; internal set; }
Visual Basic
Public Property CompletedSynchronously As Boolean
    Get
    Friend Set
Visual C++
public:
virtual property bool CompletedSynchronously {
    bool get () sealed;
    internal: void set (bool value) sealed;
}

Implements

IAsyncResult..::..CompletedSynchronously

See Also

Document..::..OnLoadPartAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


Error Property

[image]

PDFTron SilverDox SDK
Document..::..OnLoadPartAsyncCallbackArgs..::..Error Property
Document..::..OnLoadPartAsyncCallbackArgs Class See Also Send Feedback
If an error has occured, Error contains information about the error; otherwise, Error is null.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Exception Error { get; internal set; }
Visual Basic
Public Property Error As Exception
    Get
    Friend Set
Visual C++
public:
property Exception^ Error {
    Exception^ get ();
    internal: void set (Exception^ value);
}

See Also

Document..::..OnLoadPartAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


IsCompleted Property

[image]

PDFTron SilverDox SDK
Document..::..OnLoadPartAsyncCallbackArgs..::..IsCompleted Property
Document..::..OnLoadPartAsyncCallbackArgs Class See Also Send Feedback
Gets a value that indicates whether the asynchronous operation has completed.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool IsCompleted { get; private set; }
Visual Basic
Public Property IsCompleted As Boolean
    Get
    Private Set
Visual C++
public:
virtual property bool IsCompleted {
    bool get () sealed;
    private: void set (bool value) sealed;
}

Implements

IAsyncResult..::..IsCompleted

See Also

Document..::..OnLoadPartAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


Part Property

[image]

PDFTron SilverDox SDK
Document..::..OnLoadPartAsyncCallbackArgs..::..Part Property
Document..::..OnLoadPartAsyncCallbackArgs Class See Also Send Feedback
A byte array which is the part's data.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public byte[] Part { get; private set; }
Visual Basic
Public Property Part As Byte()
    Get
    Private Set
Visual C++
public:
property array<unsigned char>^ Part {
    array<unsigned char>^ get ();
    private: void set (array<unsigned char>^ value);
}

See Also

Document..::..OnLoadPartAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


PartName Property

[image]

PDFTron SilverDox SDK
Document..::..OnLoadPartAsyncCallbackArgs..::..PartName Property
Document..::..OnLoadPartAsyncCallbackArgs Class See Also Send Feedback
The name of the part.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string PartName { get; private set; }
Visual Basic
Public Property PartName As String
    Get
    Private Set
Visual C++
public:
property String^ PartName {
    String^ get ();
    private: void set (String^ value);
}

See Also

Document..::..OnLoadPartAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


Document.OnLoadThumbnailAsyncCallbackArgs Class

[image]

PDFTron SilverDox SDK
Document..::..OnLoadThumbnailAsyncCallbackArgs Class
Document Class Members See Also Send Feedback
Arguments used as a parameter in the user defined callback function provided to LoadThumbnailAsync(Int32, Action<(Of <<'(Document..::..OnLoadThumbnailAsyncCallbackArgs>)>>)).

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class OnLoadThumbnailAsyncCallbackArgs : IAsyncResult
Visual Basic
Public Class OnLoadThumbnailAsyncCallbackArgs _
    Implements IAsyncResult
Visual C++
public ref class OnLoadThumbnailAsyncCallbackArgs : IAsyncResult

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents..::..Document..::..OnLoadThumbnailAsyncCallbackArgs

See Also

Document..::..OnLoadThumbnailAsyncCallbackArgs Members
PDFTron.SilverDox.Documents Namespace


Document.OnLoadThumbnailAsyncCallbackArgs Members

[image] [image]

PDFTron SilverDox SDK
Document..::..OnLoadThumbnailAsyncCallbackArgs Members
Document..::..OnLoadThumbnailAsyncCallbackArgs Class Properties See Also Send Feedback

Represents a document with individual pages (canvases) that can be displayed on screen and printed.

The Document..::..OnLoadThumbnailAsyncCallbackArgs type exposes the following members.

Properties

 | Name | Description
Public property | AsyncState | Gets a user-defined object that qualifies or contains information about an asynchronous operation.
Public property | AsyncWaitHandle | Gets a WaitHandle that is used to wait for an asynchronous operation to complete.
Public property | BitmapImage | The thumbnail image.
Public property | CompletedSynchronously | Gets a value that indicates whether the asynchronous operation completed synchronously.
Public property | Error | If an error has occured, Error contains information about the error; otherwise, Error is null.
Public property | IsCompleted | Gets a value that indicates whether the asynchronous operation has completed.
Public property | PageNumber | The thumbnail's page number.

See Also

Document..::..OnLoadThumbnailAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


Document.OnLoadThumbnailAsyncCallbackArgs Properties

[image] [image]

PDFTron SilverDox SDK
Document..::..OnLoadThumbnailAsyncCallbackArgs Properties
Document..::..OnLoadThumbnailAsyncCallbackArgs Class See Also Send Feedback

The Document..::..OnLoadThumbnailAsyncCallbackArgs type exposes the following members.

Properties

 | Name | Description
Public property | AsyncState | Gets a user-defined object that qualifies or contains information about an asynchronous operation.
Public property | AsyncWaitHandle | Gets a WaitHandle that is used to wait for an asynchronous operation to complete.
Public property | BitmapImage | The thumbnail image.
Public property | CompletedSynchronously | Gets a value that indicates whether the asynchronous operation completed synchronously.
Public property | Error | If an error has occured, Error contains information about the error; otherwise, Error is null.
Public property | IsCompleted | Gets a value that indicates whether the asynchronous operation has completed.
Public property | PageNumber | The thumbnail's page number.

See Also

Document..::..OnLoadThumbnailAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


AsyncState Property

[image]

PDFTron SilverDox SDK
Document..::..OnLoadThumbnailAsyncCallbackArgs..::..AsyncState Property
Document..::..OnLoadThumbnailAsyncCallbackArgs Class See Also Send Feedback
Gets a user-defined object that qualifies or contains information about an asynchronous operation.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Object AsyncState { get; private set; }
Visual Basic
Public Property AsyncState As Object
    Get
    Private Set
Visual C++
public:
virtual property Object^ AsyncState {
    Object^ get () sealed;
    private: void set (Object^ value) sealed;
}

Implements

IAsyncResult..::..AsyncState

See Also

Document..::..OnLoadThumbnailAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


AsyncWaitHandle Property

[image]

PDFTron SilverDox SDK
Document..::..OnLoadThumbnailAsyncCallbackArgs..::..AsyncWaitHandle Property
Document..::..OnLoadThumbnailAsyncCallbackArgs Class See Also Send Feedback
Gets a WaitHandle that is used to wait for an asynchronous operation to complete.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public WaitHandle AsyncWaitHandle { get; private set; }
Visual Basic
Public Property AsyncWaitHandle As WaitHandle
    Get
    Private Set
Visual C++
public:
virtual property WaitHandle^ AsyncWaitHandle {
    WaitHandle^ get () sealed;
    private: void set (WaitHandle^ value) sealed;
}

Implements

IAsyncResult..::..AsyncWaitHandle

See Also

Document..::..OnLoadThumbnailAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


BitmapImage Property

[image]

PDFTron SilverDox SDK
Document..::..OnLoadThumbnailAsyncCallbackArgs..::..BitmapImage Property
Document..::..OnLoadThumbnailAsyncCallbackArgs Class See Also Send Feedback
The thumbnail image.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public BitmapSource BitmapImage { get; private set; }
Visual Basic
Public Property BitmapImage As BitmapSource
    Get
    Private Set
Visual C++
public:
property BitmapSource^ BitmapImage {
    BitmapSource^ get ();
    private: void set (BitmapSource^ value);
}

See Also

Document..::..OnLoadThumbnailAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


CompletedSynchronously Property

[image]

PDFTron SilverDox SDK
Document..::..OnLoadThumbnailAsyncCallbackArgs..::..CompletedSynchronously Property
Document..::..OnLoadThumbnailAsyncCallbackArgs Class See Also Send Feedback
Gets a value that indicates whether the asynchronous operation completed synchronously.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool CompletedSynchronously { get; internal set; }
Visual Basic
Public Property CompletedSynchronously As Boolean
    Get
    Friend Set
Visual C++
public:
virtual property bool CompletedSynchronously {
    bool get () sealed;
    internal: void set (bool value) sealed;
}

Implements

IAsyncResult..::..CompletedSynchronously

See Also

Document..::..OnLoadThumbnailAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


Error Property

[image]

PDFTron SilverDox SDK
Document..::..OnLoadThumbnailAsyncCallbackArgs..::..Error Property
Document..::..OnLoadThumbnailAsyncCallbackArgs Class See Also Send Feedback
If an error has occured, Error contains information about the error; otherwise, Error is null.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Exception Error { get; internal set; }
Visual Basic
Public Property Error As Exception
    Get
    Friend Set
Visual C++
public:
property Exception^ Error {
    Exception^ get ();
    internal: void set (Exception^ value);
}

See Also

Document..::..OnLoadThumbnailAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


IsCompleted Property

[image]

PDFTron SilverDox SDK
Document..::..OnLoadThumbnailAsyncCallbackArgs..::..IsCompleted Property
Document..::..OnLoadThumbnailAsyncCallbackArgs Class See Also Send Feedback
Gets a value that indicates whether the asynchronous operation has completed.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool IsCompleted { get; private set; }
Visual Basic
Public Property IsCompleted As Boolean
    Get
    Private Set
Visual C++
public:
virtual property bool IsCompleted {
    bool get () sealed;
    private: void set (bool value) sealed;
}

Implements

IAsyncResult..::..IsCompleted

See Also

Document..::..OnLoadThumbnailAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


PageNumber Property

[image]

PDFTron SilverDox SDK
Document..::..OnLoadThumbnailAsyncCallbackArgs..::..PageNumber Property
Document..::..OnLoadThumbnailAsyncCallbackArgs Class See Also Send Feedback
The thumbnail's page number.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public int PageNumber { get; private set; }
Visual Basic
Public Property PageNumber As Integer
    Get
    Private Set
Visual C++
public:
property int PageNumber {
    int get ();
    private: void set (int value);
}

See Also

Document..::..OnLoadThumbnailAsyncCallbackArgs Class
PDFTron.SilverDox.Documents Namespace


Link Class

[image]

PDFTron SilverDox SDK
Link Class
Members See Also Send Feedback
A link that is placed on a Document page. Links, which are used to navigate somewhere when clicked on, may point to an external URI, or a location within the document.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class Link : HyperlinkButton
Visual Basic
Public Class Link _
    Inherits HyperlinkButton
Visual C++
public ref class Link : public HyperlinkButton

Remarks

Link objects are created within LoadCanvasAsync(Int32, Action<(Of <<'(Document..::..OnLoadCanvasAsyncCallbackArgs>)>>), Action<(Of <<'(Document..::..OnLoadCanvasAsyncCallbackArgs>)>>), Action<(Of <<'(Link>)>>)), and are passed back as arguments to the user callback function defined in LoadCanvasAsync(Int32, Action<(Of <<'(Document..::..OnLoadCanvasAsyncCallbackArgs>)>>), Action<(Of <<'(Document..::..OnLoadCanvasAsyncCallbackArgs>)>>), Action<(Of <<'(Link>)>>))'s fourth parameter onLinkReadyCallback. It is within the user-defined callback function that the link's behavior can be altered, for example changing the mouse cursor during a mouseover event, or navigating to a new page after a mouseup event.

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
System.Windows.Controls.Primitives..::..ButtonBase
HyperlinkButton
PDFTron.SilverDox.Documents..::..Link

See Also

Link Members
PDFTron.SilverDox.Documents Namespace


Link Members

[image] [image]

PDFTron SilverDox SDK
Link Members
Link Class Properties See Also Send Feedback

The Link type exposes the following members.

Properties

 | Name | Description
Public property | PageNumber | The page number of the Document that the link points to.
Public property | ResidentPageNumber | The page number of the Document that the link exists on.
Public property | VerticalOffset | The number of units down from the top of the page that the link points to. A unit is 1/96th of an inch.

See Also

Link Class
PDFTron.SilverDox.Documents Namespace


Link Properties

[image] [image]

PDFTron SilverDox SDK
Link Properties
Link Class See Also Send Feedback

The Link type exposes the following members.

Properties

 | Name | Description
Public property | PageNumber | The page number of the Document that the link points to.
Public property | ResidentPageNumber | The page number of the Document that the link exists on.
Public property | VerticalOffset | The number of units down from the top of the page that the link points to. A unit is 1/96th of an inch.

See Also

Link Class
PDFTron.SilverDox.Documents Namespace


PageNumber Property

[image]

PDFTron SilverDox SDK
Link..::..PageNumber Property
Link Class See Also Send Feedback
The page number of the Document that the link points to.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public int PageNumber { get; internal set; }
Visual Basic
Public Property PageNumber As Integer
    Get
    Friend Set
Visual C++
public:
property int PageNumber {
    int get ();
    internal: void set (int value);
}

See Also

Link Class
PDFTron.SilverDox.Documents Namespace


ResidentPageNumber Property

[image]

PDFTron SilverDox SDK
Link..::..ResidentPageNumber Property
Link Class See Also Send Feedback
The page number of the Document that the link exists on.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public int ResidentPageNumber { get; internal set; }
Visual Basic
Public Property ResidentPageNumber As Integer
    Get
    Friend Set
Visual C++
public:
property int ResidentPageNumber {
    int get ();
    internal: void set (int value);
}

See Also

Link Class
PDFTron.SilverDox.Documents Namespace


VerticalOffset Property

[image]

PDFTron SilverDox SDK
Link..::..VerticalOffset Property
Link Class See Also Send Feedback
The number of units down from the top of the page that the link points to. A unit is 1/96th of an inch.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public double VerticalOffset { get; internal set; }
Visual Basic
Public Property VerticalOffset As Double
    Get
    Friend Set
Visual C++
public:
property double VerticalOffset {
    double get ();
    internal: void set (double value);
}

See Also

Link Class
PDFTron.SilverDox.Documents Namespace


Metadata Class

[image]

PDFTron SilverDox SDK
Metadata Class
Members See Also Send Feedback
A dictionary containing document metadata, such as the document's author and creation date.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class Metadata : Dictionary<string, string>
Visual Basic
Public Class Metadata _
    Inherits Dictionary(Of String, String)
Visual C++
public ref class Metadata : public Dictionary<String^, String^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
PDFTron.SilverDox.Documents..::..Metadata

See Also

Metadata Members
PDFTron.SilverDox.Documents Namespace


Metadata Members

[image] [image]

PDFTron SilverDox SDK
Metadata Members
Metadata Class Properties See Also Send Feedback

The Metadata type exposes the following members.

Properties

 | Name | Description
Public property | Created | The date when the source document was created.
Public property | Creator | The document's author.
Public property | Description | The document's description.
Public property | Keywords | The document's keywords, delimited by semi-colons.
Public property | Modified | The date when the source document was last modified.
Public property | Producer | If the source document was a PDF, the producer of the source PDF document.
Public property | Subject | The document's subject.
Public property | Title | The document's title.

See Also

Metadata Class
PDFTron.SilverDox.Documents Namespace


Metadata Properties

[image] [image]

PDFTron SilverDox SDK
Metadata Properties
Metadata Class See Also Send Feedback

The Metadata type exposes the following members.

Properties

 | Name | Description
Public property | Created | The date when the source document was created.
Public property | Creator | The document's author.
Public property | Description | The document's description.
Public property | Keywords | The document's keywords, delimited by semi-colons.
Public property | Modified | The date when the source document was last modified.
Public property | Producer | If the source document was a PDF, the producer of the source PDF document.
Public property | Subject | The document's subject.
Public property | Title | The document's title.

See Also

Metadata Class
PDFTron.SilverDox.Documents Namespace


Created Property

[image]

PDFTron SilverDox SDK
Metadata..::..Created Property
Metadata Class See Also Send Feedback
The date when the source document was created.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string Created { get; set; }
Visual Basic
Public Property Created As String
    Get
    Set
Visual C++
public:
property String^ Created {
    String^ get ();
    void set (String^ value);
}

See Also

Metadata Class
PDFTron.SilverDox.Documents Namespace


Creator Property

[image]

PDFTron SilverDox SDK
Metadata..::..Creator Property
Metadata Class See Also Send Feedback
The document's author.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string Creator { get; set; }
Visual Basic
Public Property Creator As String
    Get
    Set
Visual C++
public:
property String^ Creator {
    String^ get ();
    void set (String^ value);
}

See Also

Metadata Class
PDFTron.SilverDox.Documents Namespace


Description Property

[image]

PDFTron SilverDox SDK
Metadata..::..Description Property
Metadata Class See Also Send Feedback
The document's description.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

Metadata Class
PDFTron.SilverDox.Documents Namespace


Keywords Property

[image]

PDFTron SilverDox SDK
Metadata..::..Keywords Property
Metadata Class See Also Send Feedback
The document's keywords, delimited by semi-colons.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string Keywords { get; set; }
Visual Basic
Public Property Keywords As String
    Get
    Set
Visual C++
public:
property String^ Keywords {
    String^ get ();
    void set (String^ value);
}

See Also

Metadata Class
PDFTron.SilverDox.Documents Namespace


Modified Property

[image]

PDFTron SilverDox SDK
Metadata..::..Modified Property
Metadata Class See Also Send Feedback
The date when the source document was last modified.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string Modified { get; set; }
Visual Basic
Public Property Modified As String
    Get
    Set
Visual C++
public:
property String^ Modified {
    String^ get ();
    void set (String^ value);
}

See Also

Metadata Class
PDFTron.SilverDox.Documents Namespace


Producer Property

[image]

PDFTron SilverDox SDK
Metadata..::..Producer Property
Metadata Class See Also Send Feedback
If the source document was a PDF, the producer of the source PDF document.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string Producer { get; set; }
Visual Basic
Public Property Producer As String
    Get
    Set
Visual C++
public:
property String^ Producer {
    String^ get ();
    void set (String^ value);
}

See Also

Metadata Class
PDFTron.SilverDox.Documents Namespace


Subject Property

[image]

PDFTron SilverDox SDK
Metadata..::..Subject Property
Metadata Class See Also Send Feedback
The document's subject.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string Subject { get; set; }
Visual Basic
Public Property Subject As String
    Get
    Set
Visual C++
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}

See Also

Metadata Class
PDFTron.SilverDox.Documents Namespace


Title Property

[image]

PDFTron SilverDox SDK
Metadata..::..Title Property
Metadata Class See Also Send Feedback
The document's title.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

Metadata Class
PDFTron.SilverDox.Documents Namespace


PageInfo Class

[image]

PDFTron SilverDox SDK
PageInfo Class
Members See Also Send Feedback
Describes a page in terms of its dimensions, resources and whether all the resources have been fully loaded. A collection of PageInfo objects is created when a Document is initilized, and are accessible via Document's Pages property. Note that PageInfo does not contain the page content, which can be acquired using the LoadCanvasAsync(Int32, Action<(Of <<'(Document..::..OnLoadCanvasAsyncCallbackArgs>)>>), Action<(Of <<'(Document..::..OnLoadCanvasAsyncCallbackArgs>)>>), Action<(Of <<'(Link>)>>)) method.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class PageInfo
Visual Basic
Public Class PageInfo
Visual C++
public ref class PageInfo

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents..::..PageInfo

See Also

PageInfo Members
PDFTron.SilverDox.Documents Namespace


PageInfo Members

[image] [image]

PDFTron SilverDox SDK
PageInfo Members
PageInfo Class Properties See Also Send Feedback

The PageInfo type exposes the following members.

Properties

 | Name | Description
Public property | Annotations | A read-only list of the annotations managed by a DocumentViewer's AnnotationManager.
Public property | FullyLoaded | Indicates if all the resources required to render the page entirely have been loaded.
Public property | Height | The height of the page in units of 1/96th of an inch.
Public property | ResourceNames | A list of the names of the resources which are required to render the page. This is a low-level property that would not normally be used unless creating a custom document viewer with very specific loading requirements. If so, it would be used in conjunction with LoadPartAsync()()()().
Public property | Width | The width of the page in units of 1/96th of an inch.

See Also

PageInfo Class
PDFTron.SilverDox.Documents Namespace


PageInfo Properties

[image] [image]

PDFTron SilverDox SDK
PageInfo Properties
PageInfo Class See Also Send Feedback

The PageInfo type exposes the following members.

Properties

 | Name | Description
Public property | Annotations | A read-only list of the annotations managed by a DocumentViewer's AnnotationManager.
Public property | FullyLoaded | Indicates if all the resources required to render the page entirely have been loaded.
Public property | Height | The height of the page in units of 1/96th of an inch.
Public property | ResourceNames | A list of the names of the resources which are required to render the page. This is a low-level property that would not normally be used unless creating a custom document viewer with very specific loading requirements. If so, it would be used in conjunction with LoadPartAsync()()()().
Public property | Width | The width of the page in units of 1/96th of an inch.

See Also

PageInfo Class
PDFTron.SilverDox.Documents Namespace


Annotations Property

[image]

PDFTron SilverDox SDK
PageInfo..::..Annotations Property
PageInfo Class See Also Send Feedback
A read-only list of the annotations managed by a DocumentViewer's AnnotationManager.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public IList<Annotation> Annotations { get; }
Visual Basic
Public ReadOnly Property Annotations As IList(Of Annotation)
    Get
Visual C++
public:
property IList<Annotation^>^ Annotations {
    IList<Annotation^>^ get ();
}

See Also

PageInfo Class
PDFTron.SilverDox.Documents Namespace


FullyLoaded Property

[image]

PDFTron SilverDox SDK
PageInfo..::..FullyLoaded Property
PageInfo Class See Also Send Feedback
Indicates if all the resources required to render the page entirely have been loaded.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool FullyLoaded { get; internal set; }
Visual Basic
Public Property FullyLoaded As Boolean
    Get
    Friend Set
Visual C++
public:
property bool FullyLoaded {
    bool get ();
    internal: void set (bool value);
}

See Also

PageInfo Class
PDFTron.SilverDox.Documents Namespace


Height Property

[image]

PDFTron SilverDox SDK
PageInfo..::..Height Property
PageInfo Class See Also Send Feedback
The height of the page in units of 1/96th of an inch.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public int Height { get; internal set; }
Visual Basic
Public Property Height As Integer
    Get
    Friend Set
Visual C++
public:
property int Height {
    int get ();
    internal: void set (int value);
}

See Also

PageInfo Class
PDFTron.SilverDox.Documents Namespace


ResourceNames Property

[image]

PDFTron SilverDox SDK
PageInfo..::..ResourceNames Property
PageInfo Class See Also Send Feedback
A list of the names of the resources which are required to render the page. This is a low-level property that would not normally be used unless creating a custom document viewer with very specific loading requirements. If so, it would be used in conjunction with LoadPartAsync()()()().

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public List<string> ResourceNames { get; internal set; }
Visual Basic
Public Property ResourceNames As List(Of String)
    Get
    Friend Set
Visual C++
public:
property List<String^>^ ResourceNames {
    List<String^>^ get ();
    internal: void set (List<String^>^ value);
}

See Also

PageInfo Class
PDFTron.SilverDox.Documents Namespace


Width Property

[image]

PDFTron SilverDox SDK
PageInfo..::..Width Property
PageInfo Class See Also Send Feedback
The width of the page in units of 1/96th of an inch.

Namespace: PDFTron.SilverDox.Documents
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public int Width { get; internal set; }
Visual Basic
Public Property Width As Integer
    Get
    Friend Set
Visual C++
public:
property int Width {
    int get ();
    internal: void set (int value);
}

See Also

PageInfo Class
PDFTron.SilverDox.Documents Namespace


PDFTron.SilverDox.Documents.Annotations Namespace

[image]

PDFTron SilverDox SDK
PDFTron.SilverDox.Documents.Annotations Namespace
Send Feedback
Contains the tools to create, edit, save and load annotations, as well as create custom annotations.

Classes

 | Class | Description
Public class | Annotation | Abstract base class from which all annotations derive.
Public class | AnnotationManager | Represents an object that manages the Annotations that appear on a Document's pages when displayed in a DocumentViewer.
Public class | AnnotationPopupContentChangedEventArgs | Provides data for the AnnotationPopupContentChanged event
Public class | AnnotationResizedEventArgs | Provides data for the AnnotationResized event
Public class | AnnotationsEventArgs | Provides data for Annotation related events.
Public class | AnnotationsMoveCompletedEventArgs | Provides data for the AnnotationsMoveCompleted event
Public class | Ellipse | Represents an ellipse annotation.
Public class | FreeHand | Represents a line annotation. (This annotation type is typically drawn by a user using the mouse and is not usually straight.)
Public class | Line | Represents a straight line annotation.
Public class | Markup | A base class for annotation types that are used to mark up documents.
Public class | PopupBody |
Public class | Rectangle | Represents a rectagle annotation.
Public class | Sticky | Represents a sticky note annotation.
Public class | TextHighlight | Represents a text highlight annotation.
Public class | TextMarkup | A base class for annotation types that are used to mark up text in a document.
Public class | TextStrikeout | Represents a text strikeout annotation.
Public class | TextUnderline | Represents a text underline annotation.
Public class | ToolModeChangedEventArgs | Provides data for the ToolModeChanged event

Enumerations

 | Enumeration | Description
Public enumeration | AnnotationManager..::..TypeOfChange | Defines how an annotation has been changed since the last load


Annotation Class

[image]

PDFTron SilverDox SDK
Annotation Class
Members Example See Also Send Feedback
Abstract base class from which all annotations derive.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public abstract class Annotation : INotifyPropertyChanged
Visual Basic
Public MustInherit Class Annotation _
    Implements INotifyPropertyChanged
Visual C++
public ref class Annotation abstract : INotifyPropertyChanged

Remarks

To implement a new annotation type, the user must at a minimum implement the CreateAppearanceCanvas()()()() method, as well as a default contstructor, a constructor which takes an AnnotationManager as a paramater (and calls the equivalent base-class contructor), and a static method that takes as a parameter an AnnotationManager and returns the result of the non-default construct. See below for a minimal example, and the sample project "Annotations" for a more complete example.

Examples

CopyC#
public class MinimalCustomAnnotation : Annotation
{
     public override Canvas CreateAppearanceCanvas()
     {
         Canvas myCanvas = new Canvas();

         // Create the annotation's appearance canvas here.
         // The canvas that this method returns will be displayed on screen.

         return myCanvas;
     }

     public static MinimalCustomAnnotation Create(AnnotationManager annotationManager)
     {
         return new MinimalAnnotation(annotationManager);
     }

     public MinimalCustomAnnotation(AnnotationManager annotationManager) : base(annotationManager)
     {

     }

     public MinimalCustomAnnotation()
     {

     }
}

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents.Annotations..::..Annotation
PDFTron.SilverDox.Documents.Annotations..::..Markup
PDFTron.SilverDox.Documents.Annotations..::..Sticky

See Also

Annotation Members
PDFTron.SilverDox.Documents.Annotations Namespace


Annotation Members

[image] [image]

PDFTron SilverDox SDK
Annotation Members
Annotation Class Constructors Methods Fields Properties Events See Also Send Feedback

The Annotation type exposes the following members.

Constructors

 | Name | Description
Protected method | Annotation()()()() | Called by subclasses during construction to set properties common to all annotations.
Protected method | Annotation(AnnotationManager) | Initializes a new instance of the Annotation class

Methods

 | Name | Description
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen.
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas.
Public method | OnAnnotationResizeEnded | Called by the annotation's AnnotationManager when the user has finished resizing the annotation
Public method | OnAnnotationResizeStarted | Called by the annotation's AnnotationManager when the user has began resizing this annotation
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation.
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation.
Public method | OnCreateMouseUp | Called by the annotation's AnnotationManager when a MouseUp event is received and the AnnotationManager is set to create this type of annotation.

Fields

 | Name | Description
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager.
Public property | Author | Represents the author of the annotation. Default is an empty string.
Public property | Bottom | Gets the y-axis value of the bottom of the annotation.
Public property | DateModified | Gets or sets the last date and time that the annotation was modified.
Public property | Height | Gets or sets the annotation's height.
Public property | Id | A unique identifier that can be assigned to determine different annotations
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user.
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true
Public property | Left | Gets the x-axis value of the left side of the annotation.
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally.
Public property | MirroredVertically | True if the annotation has been mirrored vertically.
Public property | NoMove | Gets or sets if this annotation can be moved by the user.
Public property | NoResize | Gets or sets if this annotation can be resized by the user.
Public property | NoZoom | Gets or sets if this annotation scales with the page.
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on.
Public property | PopupContents | Gets or sets the contents of the annotation's popup.
Public property | PopupHeight | Gets or sets the annotation's popup's height.
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible.
Public property | PopupWidth | Gets or sets the annotation's popup's width.
Public property | PopupX | Gets or sets the annotation's popup's x-axis position.
Public property | PopupY | Gets or sets the annotation's popup's y-axis position.
Public property | Right | Gets the x-axis value of the right side of the annotation.
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type.
Public property | Top | Gets the y-axis position of the top of the annotation.
Public property | Width | Gets or sets the annotation's width;
Public property | X | Gets or sets the annotation's x-axis position.
Public property | Y | Gets or sets the annotation's y-axis position.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


Annotation Constructor

[image] [image]

PDFTron SilverDox SDK
Annotation Constructor
Annotation Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Annotation()()()() | Called by subclasses during construction to set properties common to all annotations.
Protected method | Annotation(AnnotationManager) | Initializes a new instance of the Annotation class

See Also

Annotation Class
Annotation Members
PDFTron.SilverDox.Documents.Annotations Namespace


Annotation Constructor

[image]

PDFTron SilverDox SDK
Annotation Constructor
Annotation Class See Also Send Feedback
Called by subclasses during construction to set properties common to all annotations.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected Annotation()
Visual Basic
Protected Sub New
Visual C++
protected:
Annotation()

See Also

Annotation Class
Annotation Overload
PDFTron.SilverDox.Documents.Annotations Namespace


Annotation Constructor (AnnotationManager)

[image]

PDFTron SilverDox SDK
Annotation Constructor (AnnotationManager)
Annotation Class See Also Send Feedback
Initializes a new instance of the Annotation class

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected Annotation(
    AnnotationManager annotationManager
)
Visual Basic
Protected Sub New ( _
    annotationManager As AnnotationManager _
)
Visual C++
protected:
Annotation(
    AnnotationManager^ annotationManager
)

Parameters

annotationManager
Type: PDFTron.SilverDox.Documents.Annotations..::..AnnotationManager

[Missing <param name="annotationManager"/> documentation for "M:PDFTron.SilverDox.Documents.Annotations.Annotation.#ctor(PDFTron.SilverDox.Documents.Annotations.AnnotationManager)"]

See Also

Annotation Class
Annotation Overload
PDFTron.SilverDox.Documents.Annotations Namespace


Annotation Fields

[image] [image]

PDFTron SilverDox SDK
Annotation Fields
Annotation Class See Also Send Feedback

The Annotation type exposes the following members.

Fields

 | Name | Description
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


shouldBeCreated Field

[image]

PDFTron SilverDox SDK
Annotation..::..shouldBeCreated Field
Annotation Class See Also Send Feedback
Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected bool shouldBeCreated
Visual Basic
Protected shouldBeCreated As Boolean
Visual C++
protected:
bool shouldBeCreated

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


Annotation Methods

[image] [image]

PDFTron SilverDox SDK
Annotation Methods
Annotation Class See Also Send Feedback

The Annotation type exposes the following members.

Methods

 | Name | Description
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen.
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas.
Public method | OnAnnotationResizeEnded | Called by the annotation's AnnotationManager when the user has finished resizing the annotation
Public method | OnAnnotationResizeStarted | Called by the annotation's AnnotationManager when the user has began resizing this annotation
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation.
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation.
Public method | OnCreateMouseUp | Called by the annotation's AnnotationManager when a MouseUp event is received and the AnnotationManager is set to create this type of annotation.

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


CreateAppearanceCanvas Method

[image]

PDFTron SilverDox SDK
Annotation..::..CreateAppearanceCanvas Method
Annotation Class See Also Send Feedback
Creates and returns the annotation's appearance canvas that will be displayed on screen.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public abstract Canvas CreateAppearanceCanvas()
Visual Basic
Public MustOverride Function CreateAppearanceCanvas As Canvas
Visual C++
public:
virtual Canvas^ CreateAppearanceCanvas() abstract

Return Value

The annotation's appearance canvas.

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


CreatePopupCanvas Method

[image]

PDFTron SilverDox SDK
Annotation..::..CreatePopupCanvas Method
Annotation Class See Also Send Feedback
Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected virtual Canvas CreatePopupCanvas()
Visual Basic
Protected Overridable Function CreatePopupCanvas As Canvas
Visual C++
protected:
virtual Canvas^ CreatePopupCanvas()

Return Value

The popup canvas.

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


OnAnnotationResizeEnded Method

[image]

PDFTron SilverDox SDK
Annotation..::..OnAnnotationResizeEnded Method
Annotation Class See Also Send Feedback
Called by the annotation's AnnotationManager when the user has finished resizing the annotation

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public virtual void OnAnnotationResizeEnded(
    AnnotationResizedEventArgs e
)
Visual Basic
Public Overridable Sub OnAnnotationResizeEnded ( _
    e As AnnotationResizedEventArgs _
)
Visual C++
public:
virtual void OnAnnotationResizeEnded(
    AnnotationResizedEventArgs^ e
)

Parameters

e
Type: PDFTron.SilverDox.Documents.Annotations..::..AnnotationResizedEventArgs
The event data.

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


OnAnnotationResizeStarted Method

[image]

PDFTron SilverDox SDK
Annotation..::..OnAnnotationResizeStarted Method
Annotation Class See Also Send Feedback
Called by the annotation's AnnotationManager when the user has began resizing this annotation

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public virtual void OnAnnotationResizeStarted()
Visual Basic
Public Overridable Sub OnAnnotationResizeStarted
Visual C++
public:
virtual void OnAnnotationResizeStarted()

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


OnCreateMouseDown Method

[image]

PDFTron SilverDox SDK
Annotation..::..OnCreateMouseDown Method
Annotation Class See Also Send Feedback
Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public virtual void OnCreateMouseDown(
    MouseButtonEventArgs e
)
Visual Basic
Public Overridable Sub OnCreateMouseDown ( _
    e As MouseButtonEventArgs _
)
Visual C++
public:
virtual void OnCreateMouseDown(
    MouseButtonEventArgs^ e
)

Parameters

e
Type: System.Windows.Input..::..MouseButtonEventArgs
The event data.

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


OnCreateMouseMove Method

[image]

PDFTron SilverDox SDK
Annotation..::..OnCreateMouseMove Method
Annotation Class See Also Send Feedback
Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public virtual void OnCreateMouseMove(
    MouseEventArgs mouseMoveEventArgs
)
Visual Basic
Public Overridable Sub OnCreateMouseMove ( _
    mouseMoveEventArgs As MouseEventArgs _
)
Visual C++
public:
virtual void OnCreateMouseMove(
    MouseEventArgs^ mouseMoveEventArgs
)

Parameters

mouseMoveEventArgs
Type: System.Windows.Input..::..MouseEventArgs
The event data.

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


OnCreateMouseUp Method

[image]

PDFTron SilverDox SDK
Annotation..::..OnCreateMouseUp Method
Annotation Class See Also Send Feedback
Called by the annotation's AnnotationManager when a MouseUp event is received and the AnnotationManager is set to create this type of annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public virtual void OnCreateMouseUp(
    MouseButtonEventArgs e,
    bool wasDoubleClick
)
Visual Basic
Public Overridable Sub OnCreateMouseUp ( _
    e As MouseButtonEventArgs, _
    wasDoubleClick As Boolean _
)
Visual C++
public:
virtual void OnCreateMouseUp(
    MouseButtonEventArgs^ e,
    bool wasDoubleClick
)

Parameters

e
Type: System.Windows.Input..::..MouseButtonEventArgs
The event data.
wasDoubleClick
Type: System..::..Boolean
True if the event marks the completion of a double click.

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


Annotation Properties

[image] [image]

PDFTron SilverDox SDK
Annotation Properties
Annotation Class See Also Send Feedback

The Annotation type exposes the following members.

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager.
Public property | Author | Represents the author of the annotation. Default is an empty string.
Public property | Bottom | Gets the y-axis value of the bottom of the annotation.
Public property | DateModified | Gets or sets the last date and time that the annotation was modified.
Public property | Height | Gets or sets the annotation's height.
Public property | Id | A unique identifier that can be assigned to determine different annotations
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user.
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true
Public property | Left | Gets the x-axis value of the left side of the annotation.
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally.
Public property | MirroredVertically | True if the annotation has been mirrored vertically.
Public property | NoMove | Gets or sets if this annotation can be moved by the user.
Public property | NoResize | Gets or sets if this annotation can be resized by the user.
Public property | NoZoom | Gets or sets if this annotation scales with the page.
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on.
Public property | PopupContents | Gets or sets the contents of the annotation's popup.
Public property | PopupHeight | Gets or sets the annotation's popup's height.
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible.
Public property | PopupWidth | Gets or sets the annotation's popup's width.
Public property | PopupX | Gets or sets the annotation's popup's x-axis position.
Public property | PopupY | Gets or sets the annotation's popup's y-axis position.
Public property | Right | Gets the x-axis value of the right side of the annotation.
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type.
Public property | Top | Gets the y-axis position of the top of the annotation.
Public property | Width | Gets or sets the annotation's width;
Public property | X | Gets or sets the annotation's x-axis position.
Public property | Y | Gets or sets the annotation's y-axis position.

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationManager Property

[image]

PDFTron SilverDox SDK
Annotation..::..AnnotationManager Property
Annotation Class See Also Send Feedback
Gets or sets the annotation's AnnotationManager.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public AnnotationManager AnnotationManager { get; set; }
Visual Basic
Public Property AnnotationManager As AnnotationManager
    Get
    Set
Visual C++
public:
property AnnotationManager^ AnnotationManager {
    AnnotationManager^ get ();
    void set (AnnotationManager^ value);
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


Author Property

[image]

PDFTron SilverDox SDK
Annotation..::..Author Property
Annotation Class See Also Send Feedback
Represents the author of the annotation. Default is an empty string.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string Author { get; set; }
Visual Basic
Public Property Author As String
    Get
    Set
Visual C++
public:
property String^ Author {
    String^ get ();
    void set (String^ value);
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


Bottom Property

[image]

PDFTron SilverDox SDK
Annotation..::..Bottom Property
Annotation Class See Also Send Feedback
Gets the y-axis value of the bottom of the annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public virtual double Bottom { get; }
Visual Basic
Public Overridable ReadOnly Property Bottom As Double
    Get
Visual C++
public:
virtual property double Bottom {
    double get ();
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


DateModified Property

[image]

PDFTron SilverDox SDK
Annotation..::..DateModified Property
Annotation Class See Also Send Feedback
Gets or sets the last date and time that the annotation was modified.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public DateTime DateModified { get; set; }
Visual Basic
Public Property DateModified As DateTime
    Get
    Set
Visual C++
public:
property DateTime DateModified {
    DateTime get ();
    void set (DateTime value);
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


Height Property

[image]

PDFTron SilverDox SDK
Annotation..::..Height Property
Annotation Class See Also Send Feedback
Gets or sets the annotation's height.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public virtual double Height { get; set; }
Visual Basic
Public Overridable Property Height As Double
    Get
    Set
Visual C++
public:
virtual property double Height {
    double get ();
    void set (double value);
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


Id Property

[image]

PDFTron SilverDox SDK
Annotation..::..Id Property
Annotation Class See Also Send Feedback
A unique identifier that can be assigned to determine different annotations

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


IsCopyable Property

[image]

PDFTron SilverDox SDK
Annotation..::..IsCopyable Property
Annotation Class See Also Send Feedback
Indicates whether or not the user should be able to copy this annotation

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public virtual bool IsCopyable { get; protected set; }
Visual Basic
Public Overridable Property IsCopyable As Boolean
    Get
    Protected Set
Visual C++
public:
virtual property bool IsCopyable {
    bool get ();
    protected: void set (bool value);
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


IsCreated Property

[image]

PDFTron SilverDox SDK
Annotation..::..IsCreated Property
Annotation Class See Also Send Feedback
Gets or sets if the annotation has finished being created by the user.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool IsCreated { get; set; }
Visual Basic
Public Property IsCreated As Boolean
    Get
    Set
Visual C++
public:
property bool IsCreated {
    bool get ();
    void set (bool value);
}

Remarks

This is usually set to true on the first MouseUp event received by OnCreateMouseUp(MouseButtonEventArgs, Boolean). However if the annotation requires multiple mouse clicks to construct (as is the case with a polyline or polygon), then it would not be set to true until the user had, for example, double clicked.

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


IsSelectable Property

[image]

PDFTron SilverDox SDK
Annotation..::..IsSelectable Property
Annotation Class See Also Send Feedback
Indicates whether or not the user can select this annotation Default is true

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool IsSelectable { get; set; }
Visual Basic
Public Property IsSelectable As Boolean
    Get
    Set
Visual C++
public:
property bool IsSelectable {
    bool get ();
    void set (bool value);
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


Left Property

[image]

PDFTron SilverDox SDK
Annotation..::..Left Property
Annotation Class See Also Send Feedback
Gets the x-axis value of the left side of the annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public virtual double Left { get; }
Visual Basic
Public Overridable ReadOnly Property Left As Double
    Get
Visual C++
public:
virtual property double Left {
    double get ();
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


MirroredHorizontally Property

[image]

PDFTron SilverDox SDK
Annotation..::..MirroredHorizontally Property
Annotation Class See Also Send Feedback
True if the annotation has been mirrored horizontally.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool MirroredHorizontally { get; set; }
Visual Basic
Public Property MirroredHorizontally As Boolean
    Get
    Set
Visual C++
public:
property bool MirroredHorizontally {
    bool get ();
    void set (bool value);
}

Remarks

This happens for example when an annotation is resized such that what was its right hand side is now its left hand side.

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


MirroredVertically Property

[image]

PDFTron SilverDox SDK
Annotation..::..MirroredVertically Property
Annotation Class See Also Send Feedback
True if the annotation has been mirrored vertically.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool MirroredVertically { get; set; }
Visual Basic
Public Property MirroredVertically As Boolean
    Get
    Set
Visual C++
public:
property bool MirroredVertically {
    bool get ();
    void set (bool value);
}

Remarks

This happens for example when an annotation is resized such that what was its top is now its bottom.

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


NoMove Property

[image]

PDFTron SilverDox SDK
Annotation..::..NoMove Property
Annotation Class See Also Send Feedback
Gets or sets if this annotation can be moved by the user.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool NoMove { get; set; }
Visual Basic
Public Property NoMove As Boolean
    Get
    Set
Visual C++
public:
property bool NoMove {
    bool get ();
    void set (bool value);
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


NoResize Property

[image]

PDFTron SilverDox SDK
Annotation..::..NoResize Property
Annotation Class See Also Send Feedback
Gets or sets if this annotation can be resized by the user.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool NoResize { get; set; }
Visual Basic
Public Property NoResize As Boolean
    Get
    Set
Visual C++
public:
property bool NoResize {
    bool get ();
    void set (bool value);
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


NoZoom Property

[image]

PDFTron SilverDox SDK
Annotation..::..NoZoom Property
Annotation Class See Also Send Feedback
Gets or sets if this annotation scales with the page.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool NoZoom { get; set; }
Visual Basic
Public Property NoZoom As Boolean
    Get
    Set
Visual C++
public:
property bool NoZoom {
    bool get ();
    void set (bool value);
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


PageNumber Property

[image]

PDFTron SilverDox SDK
Annotation..::..PageNumber Property
Annotation Class See Also Send Feedback
Gets or sets the page number of a document that the annotation appears on.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public int PageNumber { get; set; }
Visual Basic
Public Property PageNumber As Integer
    Get
    Set
Visual C++
public:
property int PageNumber {
    int get ();
    void set (int value);
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


PopupContents Property

[image]

PDFTron SilverDox SDK
Annotation..::..PopupContents Property
Annotation Class See Also Send Feedback
Gets or sets the contents of the annotation's popup.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string PopupContents { get; set; }
Visual Basic
Public Property PopupContents As String
    Get
    Set
Visual C++
public:
property String^ PopupContents {
    String^ get ();
    void set (String^ value);
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


PopupHeight Property

[image]

PDFTron SilverDox SDK
Annotation..::..PopupHeight Property
Annotation Class See Also Send Feedback
Gets or sets the annotation's popup's height.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public virtual double PopupHeight { get; set; }
Visual Basic
Public Overridable Property PopupHeight As Double
    Get
    Set
Visual C++
public:
virtual property double PopupHeight {
    double get ();
    void set (double value);
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


PopupIsVisible Property

[image]

PDFTron SilverDox SDK
Annotation..::..PopupIsVisible Property
Annotation Class See Also Send Feedback
Gets or sets if the annotation's popup is visible.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool PopupIsVisible { get; set; }
Visual Basic
Public Property PopupIsVisible As Boolean
    Get
    Set
Visual C++
public:
property bool PopupIsVisible {
    bool get ();
    void set (bool value);
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


PopupWidth Property

[image]

PDFTron SilverDox SDK
Annotation..::..PopupWidth Property
Annotation Class See Also Send Feedback
Gets or sets the annotation's popup's width.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public virtual double PopupWidth { get; set; }
Visual Basic
Public Overridable Property PopupWidth As Double
    Get
    Set
Visual C++
public:
virtual property double PopupWidth {
    double get ();
    void set (double value);
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


PopupX Property

[image]

PDFTron SilverDox SDK
Annotation..::..PopupX Property
Annotation Class See Also Send Feedback
Gets or sets the annotation's popup's x-axis position.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public virtual double PopupX { get; set; }
Visual Basic
Public Overridable Property PopupX As Double
    Get
    Set
Visual C++
public:
virtual property double PopupX {
    double get ();
    void set (double value);
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


PopupY Property

[image]

PDFTron SilverDox SDK
Annotation..::..PopupY Property
Annotation Class See Also Send Feedback
Gets or sets the annotation's popup's y-axis position.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public virtual double PopupY { get; set; }
Visual Basic
Public Overridable Property PopupY As Double
    Get
    Set
Visual C++
public:
virtual property double PopupY {
    double get ();
    void set (double value);
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


Right Property

[image]

PDFTron SilverDox SDK
Annotation..::..Right Property
Annotation Class See Also Send Feedback
Gets the x-axis value of the right side of the annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public virtual double Right { get; }
Visual Basic
Public Overridable ReadOnly Property Right As Double
    Get
Visual C++
public:
virtual property double Right {
    double get ();
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


Subject Property

[image]

PDFTron SilverDox SDK
Annotation..::..Subject Property
Annotation Class See Also Send Feedback
Represents the subject of the annotation. Default is the annotation's type.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string Subject { get; set; }
Visual Basic
Public Property Subject As String
    Get
    Set
Visual C++
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


Top Property

[image]

PDFTron SilverDox SDK
Annotation..::..Top Property
Annotation Class See Also Send Feedback
Gets the y-axis position of the top of the annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public virtual double Top { get; }
Visual Basic
Public Overridable ReadOnly Property Top As Double
    Get
Visual C++
public:
virtual property double Top {
    double get ();
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


Width Property

[image]

PDFTron SilverDox SDK
Annotation..::..Width Property
Annotation Class See Also Send Feedback
Gets or sets the annotation's width;

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public virtual double Width { get; set; }
Visual Basic
Public Overridable Property Width As Double
    Get
    Set
Visual C++
public:
virtual property double Width {
    double get ();
    void set (double value);
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


X Property

[image]

PDFTron SilverDox SDK
Annotation..::..X Property
Annotation Class See Also Send Feedback
Gets or sets the annotation's x-axis position.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public virtual double X { get; set; }
Visual Basic
Public Overridable Property X As Double
    Get
    Set
Visual C++
public:
virtual property double X {
    double get ();
    void set (double value);
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


Y Property

[image]

PDFTron SilverDox SDK
Annotation..::..Y Property
Annotation Class See Also Send Feedback
Gets or sets the annotation's y-axis position.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public virtual double Y { get; set; }
Visual Basic
Public Overridable Property Y As Double
    Get
    Set
Visual C++
public:
virtual property double Y {
    double get ();
    void set (double value);
}

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


Annotation Events

[image] [image]

PDFTron SilverDox SDK
Annotation Events
Annotation Class See Also Send Feedback

The Annotation type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


PropertyChanged Event

[image]

PDFTron SilverDox SDK
Annotation..::..PropertyChanged Event
Annotation Class See Also Send Feedback
Occurs when a property changes in the annotation

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

Annotation Class
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationManager Class

[image]

PDFTron SilverDox SDK
AnnotationManager Class
Members See Also Send Feedback
Represents an object that manages the Annotations that appear on a Document's pages when displayed in a DocumentViewer.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class AnnotationManager
Visual Basic
Public Class AnnotationManager
Visual C++
public ref class AnnotationManager

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents.Annotations..::..AnnotationManager

See Also

AnnotationManager Members
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationManager Members

[image] [image]

PDFTron SilverDox SDK
AnnotationManager Members
AnnotationManager Class Methods Properties See Also Send Feedback

The AnnotationManager type exposes the following members.

Methods

 | Name | Description
Public method | AddAnnotation | Adds and displays a new annotation.
Public method | AddCustomAnnotationTypes | This method must be used to register custom annotation types before they can be saved or loaded using SaveAnnotations()()()() and LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)). Built-in types do not need to be added.
Public method | AddUndoAnnotationState | Allows users to manually define an undo command on a specified annotation.
Public method | ClearAnnotations | Removes all of the annotations.
Public method | ClearUndoRedoHistory | Clears the stored history for the Undo() and Redo() methods.
Public method | CopySelectedAnnotations | Copies the selected annotations to a temporary buffer. Use the PasteCopiedAnnotations(Nullable<(Of <<'(Int32>)>>)) method to create a duplicate of the copied annotations to the document
Public method | CutSelectedAnnotations | Copies the selected annotations to a temporary buffer and then deletes them. Use the PasteCopiedAnnotations(Nullable<(Of <<'(Int32>)>>)) method to create a duplicate of the copied annotations to the document
Public method | DeselectAllAnnotations | Deselects all currently selected annotations
Public method | GetAllChangedAnnotations | Gets a Dictionary of changed annotations and how they were changed
Public method | GetAnnotationByPoint | Gets the annotation at a specified point in the DocumentViewer
Public method | GetNewAnnotationCanvases | Creates and returns a set of new annotation-containing canvases. Useful for printing.
Public method | LoadAnnotations | Creates annotations that were previously serialized using SaveAnnotations()()()().
Public method | PasteCopiedAnnotations | Creates copies of the annotations copied using the CutSelectedAnnotations()()()() or CopySelectedAnnotations()()()() methods onto the document
Public method | Redo | If the Undo()()()() method is called, Redo() reapplies its effects
Public method | RedrawAnnotation | Causes the specified annotation to be redrawn. Typically called after the annotation's properties have been changed.
Public method | RemoveAnnotation | Removes the specified annotation.
Public method | RemoveAnnotations | Removes the specified list of annotations.
Public method | SaveAnnotations | Serializes the annotations into a byte array containing XML (UTF-8 encoded). This data can be saved and then loaded using LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)) to re-create the annotations.
Public method | SelectAnnotation | Adds the specified annotation to the list of selected annotations. If the annotation cannot be selected, this method returns false.
Public method | Undo | Reverts the effects of the previous action preformed by the DocumentViewer on the annotations

Properties

 | Name | Description
Public property | AnnotationCreator | References a static method, defined by an annotation, that takes an AnnotationManager as a parameter and returns a new annotation. The method that is referenced is called when a MouseDown event is occurs and the ToolMode is set to a mode which creates an annotation.
Public property | AnnotationsList | Returns a list of all the annotations under the control of AnnotationManager
Public property | AnnotationsModified | Gets whether or not any changes has been made since the last time annotations were loaded
Public property | CanPaste | Gets whether or not annotations has been copied for PasteCopiedAnnotations(Nullable<(Of <<'(Int32>)>>))
Public property | CanRedo | Gets whether or not there is a command to redo
Public property | CanUndo | Gets whether or not there is a command to undo
Public property | CurrentAnnotationPage | The canvas that hosts annotations (displayed on top of the document) that last received and handled a MouseDown event.
Public property | DefaultAnnotation | The DefaultAnnotation is of the same type of annotation as that created by AnnotationCreator, and can be used as a reference when setting the initial property values of the new annotation.
Public property | Document | The document that this AnnotationManager is being used with. Needed for annotations that require information about text.
Public property | SelectedAnnotations | A list of the currently selected annotations.

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationManager Methods

[image] [image]

PDFTron SilverDox SDK
AnnotationManager Methods
AnnotationManager Class See Also Send Feedback

The AnnotationManager type exposes the following members.

Methods

 | Name | Description
Public method | AddAnnotation | Adds and displays a new annotation.
Public method | AddCustomAnnotationTypes | This method must be used to register custom annotation types before they can be saved or loaded using SaveAnnotations()()()() and LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)). Built-in types do not need to be added.
Public method | AddUndoAnnotationState | Allows users to manually define an undo command on a specified annotation.
Public method | ClearAnnotations | Removes all of the annotations.
Public method | ClearUndoRedoHistory | Clears the stored history for the Undo() and Redo() methods.
Public method | CopySelectedAnnotations | Copies the selected annotations to a temporary buffer. Use the PasteCopiedAnnotations(Nullable<(Of <<'(Int32>)>>)) method to create a duplicate of the copied annotations to the document
Public method | CutSelectedAnnotations | Copies the selected annotations to a temporary buffer and then deletes them. Use the PasteCopiedAnnotations(Nullable<(Of <<'(Int32>)>>)) method to create a duplicate of the copied annotations to the document
Public method | DeselectAllAnnotations | Deselects all currently selected annotations
Public method | GetAllChangedAnnotations | Gets a Dictionary of changed annotations and how they were changed
Public method | GetAnnotationByPoint | Gets the annotation at a specified point in the DocumentViewer
Public method | GetNewAnnotationCanvases | Creates and returns a set of new annotation-containing canvases. Useful for printing.
Public method | LoadAnnotations | Creates annotations that were previously serialized using SaveAnnotations()()()().
Public method | PasteCopiedAnnotations | Creates copies of the annotations copied using the CutSelectedAnnotations()()()() or CopySelectedAnnotations()()()() methods onto the document
Public method | Redo | If the Undo()()()() method is called, Redo() reapplies its effects
Public method | RedrawAnnotation | Causes the specified annotation to be redrawn. Typically called after the annotation's properties have been changed.
Public method | RemoveAnnotation | Removes the specified annotation.
Public method | RemoveAnnotations | Removes the specified list of annotations.
Public method | SaveAnnotations | Serializes the annotations into a byte array containing XML (UTF-8 encoded). This data can be saved and then loaded using LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)) to re-create the annotations.
Public method | SelectAnnotation | Adds the specified annotation to the list of selected annotations. If the annotation cannot be selected, this method returns false.
Public method | Undo | Reverts the effects of the previous action preformed by the DocumentViewer on the annotations

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


AddAnnotation Method

[image]

PDFTron SilverDox SDK
AnnotationManager..::..AddAnnotation Method
AnnotationManager Class See Also Send Feedback
Adds and displays a new annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void AddAnnotation(
    Annotation annotation
)
Visual Basic
Public Sub AddAnnotation ( _
    annotation As Annotation _
)
Visual C++
public:
void AddAnnotation(
    Annotation^ annotation
)

Parameters

annotation
Type: PDFTron.SilverDox.Documents.Annotations..::..Annotation
The new annotation.

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


AddCustomAnnotationTypes Method

[image]

PDFTron SilverDox SDK
AnnotationManager..::..AddCustomAnnotationTypes Method
AnnotationManager Class See Also Send Feedback
This method must be used to register custom annotation types before they can be saved or loaded using SaveAnnotations()()()() and LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)). Built-in types do not need to be added.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void AddCustomAnnotationTypes(
    Type[] additionalAnnotationTypes
)
Visual Basic
Public Sub AddCustomAnnotationTypes ( _
    additionalAnnotationTypes As Type() _
)
Visual C++
public:
void AddCustomAnnotationTypes(
    array<Type^>^ additionalAnnotationTypes
)

Parameters

additionalAnnotationTypes
Type: array< System..::..Type >[]()[][]
An array of the types to be added.

Remarks

If a new annotation type is created (by deriving from Annotation), the type must be added to the annotation manager using this method in order to save or load the new type.

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


AddUndoAnnotationState Method

[image]

PDFTron SilverDox SDK
AnnotationManager..::..AddUndoAnnotationState Method
AnnotationManager Class See Also Send Feedback
Allows users to manually define an undo command on a specified annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void AddUndoAnnotationState(
    Annotation annotation,
    Dictionary<string, Object> oldPropValues
)
Visual Basic
Public Sub AddUndoAnnotationState ( _
    annotation As Annotation, _
    oldPropValues As Dictionary(Of String, Object) _
)
Visual C++
public:
void AddUndoAnnotationState(
    Annotation^ annotation,
    Dictionary<String^, Object^>^ oldPropValues
)

Parameters

annotation
Type: PDFTron.SilverDox.Documents.Annotations..::..Annotation
The annotation that's the target of the undo
oldPropValues
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, Object >)>)>
A Dictionary containing the property name (key) and property value (value) for the annotation to revert back to in an undo

Remarks

This method allows users to manually define an undo command on a specified annotation. After using this method, the next time Undo()()()() is called, AnnotationManager will try to set the properties listed in oldPropertyValues.Keys of the specified anotation their corresponding values listed in oldPropertyValues.Values. This method is useful for building UI elements that change the property values of an annotation and registering the changes for an undo

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


ClearAnnotations Method

[image]

PDFTron SilverDox SDK
AnnotationManager..::..ClearAnnotations Method
AnnotationManager Class See Also Send Feedback
Removes all of the annotations.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void ClearAnnotations()
Visual Basic
Public Sub ClearAnnotations
Visual C++
public:
void ClearAnnotations()

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


ClearUndoRedoHistory Method

[image]

PDFTron SilverDox SDK
AnnotationManager..::..ClearUndoRedoHistory Method
AnnotationManager Class See Also Send Feedback
Clears the stored history for the Undo() and Redo() methods.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void ClearUndoRedoHistory()
Visual Basic
Public Sub ClearUndoRedoHistory
Visual C++
public:
void ClearUndoRedoHistory()

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


CopySelectedAnnotations Method

[image]

PDFTron SilverDox SDK
AnnotationManager..::..CopySelectedAnnotations Method
AnnotationManager Class See Also Send Feedback
Copies the selected annotations to a temporary buffer. Use the PasteCopiedAnnotations(Nullable<(Of <<'(Int32>)>>)) method to create a duplicate of the copied annotations to the document

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void CopySelectedAnnotations()
Visual Basic
Public Sub CopySelectedAnnotations
Visual C++
public:
void CopySelectedAnnotations()

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


CutSelectedAnnotations Method

[image]

PDFTron SilverDox SDK
AnnotationManager..::..CutSelectedAnnotations Method
AnnotationManager Class See Also Send Feedback
Copies the selected annotations to a temporary buffer and then deletes them. Use the PasteCopiedAnnotations(Nullable<(Of <<'(Int32>)>>)) method to create a duplicate of the copied annotations to the document

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void CutSelectedAnnotations()
Visual Basic
Public Sub CutSelectedAnnotations
Visual C++
public:
void CutSelectedAnnotations()

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


DeselectAllAnnotations Method

[image]

PDFTron SilverDox SDK
AnnotationManager..::..DeselectAllAnnotations Method
AnnotationManager Class See Also Send Feedback
Deselects all currently selected annotations

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void DeselectAllAnnotations()
Visual Basic
Public Sub DeselectAllAnnotations
Visual C++
public:
void DeselectAllAnnotations()

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


GetAllChangedAnnotations Method

[image]

PDFTron SilverDox SDK
AnnotationManager..::..GetAllChangedAnnotations Method
AnnotationManager Class See Also Send Feedback
Gets a Dictionary of changed annotations and how they were changed

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public IDictionary<Annotation, AnnotationManager..::..TypeOfChange> GetAllChangedAnnotations()
Visual Basic
Public Function GetAllChangedAnnotations As IDictionary(Of Annotation, AnnotationManager..::..TypeOfChange)
Visual C++
public:
IDictionary<Annotation^, AnnotationManager..::..TypeOfChange>^ GetAllChangedAnnotations()

Return Value

[Missing <returns> documentation for "M:PDFTron.SilverDox.Documents.Annotations.AnnotationManager.GetAllChangedAnnotations"]

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


GetAnnotationByPoint Method

[image]

PDFTron SilverDox SDK
AnnotationManager..::..GetAnnotationByPoint Method
AnnotationManager Class See Also Send Feedback
Gets the annotation at a specified point in the DocumentViewer

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Annotation GetAnnotationByPoint(
    Point point
)
Visual Basic
Public Function GetAnnotationByPoint ( _
    point As Point _
) As Annotation
Visual C++
public:
Annotation^ GetAnnotationByPoint(
    Point point
)

Parameters

point
Type: System.Windows..::..Point
A point relative to the overall Silverlight plug-in content area.

Return Value

The annotation at the specified point. If no annotation exists at the point or if the point is invalid, return value is null.

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


GetNewAnnotationCanvases Method

[image]

PDFTron SilverDox SDK
AnnotationManager..::..GetNewAnnotationCanvases Method
AnnotationManager Class See Also Send Feedback
Creates and returns a set of new annotation-containing canvases. Useful for printing.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public List<Canvas> GetNewAnnotationCanvases(
    bool withVisiblePopups
)
Visual Basic
Public Function GetNewAnnotationCanvases ( _
    withVisiblePopups As Boolean _
) As List(Of Canvas)
Visual C++
public:
List<Canvas^>^ GetNewAnnotationCanvases(
    bool withVisiblePopups
)

Parameters

withVisiblePopups
Type: System..::..Boolean
True if open popups are to be included in the canvases.

Return Value

A list of annotation containing canvases.

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


LoadAnnotations Method

[image]

PDFTron SilverDox SDK
AnnotationManager..::..LoadAnnotations Method
AnnotationManager Class See Also Send Feedback
Creates annotations that were previously serialized using SaveAnnotations()()()().

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public IEnumerable<Annotation> LoadAnnotations(
    Stream xmlAnnotations,
    Predicate<Annotation> filter
)
Visual Basic
Public Function LoadAnnotations ( _
    xmlAnnotations As Stream, _
    filter As Predicate(Of Annotation) _
) As IEnumerable(Of Annotation)
Visual C++
public:
IEnumerable<Annotation^>^ LoadAnnotations(
    Stream^ xmlAnnotations,
    Predicate<Annotation^>^ filter
)

Parameters

xmlAnnotations
Type: System.IO..::..Stream
The XML data produced by SaveAnnotations()()()().
filter
Type: System..::..Predicate <(Of <(<' Annotation >)>)>
A predicate specifying the conditions that need to be satisfied before a new deserialized annotation is added to the document. A return value of true means the annotation is added to the document. Null by default.

Return Value

A list of annotations that were deserialized and then added to the document

Remarks

Note that if any of the annotations are not native to SilverDox, they must be registered with AnnotationManager using AddCustomAnnotationTypes(array<Type>[]()[][]) before this method is used.

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


PasteCopiedAnnotations Method

[image]

PDFTron SilverDox SDK
AnnotationManager..::..PasteCopiedAnnotations Method
AnnotationManager Class See Also Send Feedback
Creates copies of the annotations copied using the CutSelectedAnnotations()()()() or CopySelectedAnnotations()()()() methods onto the document

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public IEnumerable<Annotation> PasteCopiedAnnotations(
    Nullable<int> newPageNumber
)
Visual Basic
Public Function PasteCopiedAnnotations ( _
    newPageNumber As Nullable(Of Integer) _
) As IEnumerable(Of Annotation)
Visual C++
public:
IEnumerable<Annotation^>^ PasteCopiedAnnotations(
    Nullable<int> newPageNumber
)

Parameters

newPageNumber
Type: System..::..Nullable <(Of <(<' Int32 >)>)>
The new page number of the annotation; if this is null, the page number of the original annotation will be used. Default value is null.

Return Value

List of newly created annotations. Return value is null if no annotations has been copied

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


Redo Method

[image]

PDFTron SilverDox SDK
AnnotationManager..::..Redo Method
AnnotationManager Class See Also Send Feedback
If the Undo()()()() method is called, Redo() reapplies its effects

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void Redo()
Visual Basic
Public Sub Redo
Visual C++
public:
void Redo()

Remarks

Redo() works in a FILO way reverting only the most recent Undo()()()() call. This method does nothing if CanRedo is false

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


RedrawAnnotation Method

[image]

PDFTron SilverDox SDK
AnnotationManager..::..RedrawAnnotation Method
AnnotationManager Class See Also Send Feedback
Causes the specified annotation to be redrawn. Typically called after the annotation's properties have been changed.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void RedrawAnnotation(
    Annotation annotation
)
Visual Basic
Public Sub RedrawAnnotation ( _
    annotation As Annotation _
)
Visual C++
public:
void RedrawAnnotation(
    Annotation^ annotation
)

Parameters

annotation
Type: PDFTron.SilverDox.Documents.Annotations..::..Annotation
The annotation to be redrawn.

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


RemoveAnnotation Method

[image]

PDFTron SilverDox SDK
AnnotationManager..::..RemoveAnnotation Method
AnnotationManager Class See Also Send Feedback
Removes the specified annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void RemoveAnnotation(
    Annotation annotation
)
Visual Basic
Public Sub RemoveAnnotation ( _
    annotation As Annotation _
)
Visual C++
public:
void RemoveAnnotation(
    Annotation^ annotation
)

Parameters

annotation
Type: PDFTron.SilverDox.Documents.Annotations..::..Annotation
The annotation to be removed.

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


RemoveAnnotations Method

[image]

PDFTron SilverDox SDK
AnnotationManager..::..RemoveAnnotations Method
AnnotationManager Class See Also Send Feedback
Removes the specified list of annotations.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void RemoveAnnotations(
    IEnumerable<Annotation> annotations
)
Visual Basic
Public Sub RemoveAnnotations ( _
    annotations As IEnumerable(Of Annotation) _
)
Visual C++
public:
void RemoveAnnotations(
    IEnumerable<Annotation^>^ annotations
)

Parameters

annotations
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Annotation >)>)>
The list of annotations to be removed.

Remarks

Use this method instead of RemoveAnnotation(Annotation) if you want Undo()()()() to revert back the deletion of a group of annotations at once.

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


SaveAnnotations Method

[image]

PDFTron SilverDox SDK
AnnotationManager..::..SaveAnnotations Method
AnnotationManager Class See Also Send Feedback
Serializes the annotations into a byte array containing XML (UTF-8 encoded). This data can be saved and then loaded using LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)) to re-create the annotations.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public byte[] SaveAnnotations()
Visual Basic
Public Function SaveAnnotations As Byte()
Visual C++
public:
array<unsigned char>^ SaveAnnotations()

Return Value

The annotations serialized into XML.

Remarks

Note that if any of the annotations are not native to SilverDox, they must be registered with AnnotationManager using AddCustomAnnotationTypes(array<Type>[]()[][]) before this method is used.

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


SelectAnnotation Method

[image]

PDFTron SilverDox SDK
AnnotationManager..::..SelectAnnotation Method
AnnotationManager Class See Also Send Feedback
Adds the specified annotation to the list of selected annotations. If the annotation cannot be selected, this method returns false.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool SelectAnnotation(
    Annotation annotation
)
Visual Basic
Public Function SelectAnnotation ( _
    annotation As Annotation _
) As Boolean
Visual C++
public:
bool SelectAnnotation(
    Annotation^ annotation
)

Parameters

annotation
Type: PDFTron.SilverDox.Documents.Annotations..::..Annotation
The annotation to select

Return Value

[Missing <returns> documentation for "M:PDFTron.SilverDox.Documents.Annotations.AnnotationManager.SelectAnnotation(PDFTron.SilverDox.Documents.Annotations.Annotation)"]

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


Undo Method

[image]

PDFTron SilverDox SDK
AnnotationManager..::..Undo Method
AnnotationManager Class See Also Send Feedback
Reverts the effects of the previous action preformed by the DocumentViewer on the annotations

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void Undo()
Visual Basic
Public Sub Undo
Visual C++
public:
void Undo()

Remarks

Commands include creating, removing, resizing, moving annotations, etc. This method does nothing if CanUndo is false

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationManager Properties

[image] [image]

PDFTron SilverDox SDK
AnnotationManager Properties
AnnotationManager Class See Also Send Feedback

The AnnotationManager type exposes the following members.

Properties

 | Name | Description
Public property | AnnotationCreator | References a static method, defined by an annotation, that takes an AnnotationManager as a parameter and returns a new annotation. The method that is referenced is called when a MouseDown event is occurs and the ToolMode is set to a mode which creates an annotation.
Public property | AnnotationsList | Returns a list of all the annotations under the control of AnnotationManager
Public property | AnnotationsModified | Gets whether or not any changes has been made since the last time annotations were loaded
Public property | CanPaste | Gets whether or not annotations has been copied for PasteCopiedAnnotations(Nullable<(Of <<'(Int32>)>>))
Public property | CanRedo | Gets whether or not there is a command to redo
Public property | CanUndo | Gets whether or not there is a command to undo
Public property | CurrentAnnotationPage | The canvas that hosts annotations (displayed on top of the document) that last received and handled a MouseDown event.
Public property | DefaultAnnotation | The DefaultAnnotation is of the same type of annotation as that created by AnnotationCreator, and can be used as a reference when setting the initial property values of the new annotation.
Public property | Document | The document that this AnnotationManager is being used with. Needed for annotations that require information about text.
Public property | SelectedAnnotations | A list of the currently selected annotations.

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationCreator Property

[image]

PDFTron SilverDox SDK
AnnotationManager..::..AnnotationCreator Property
AnnotationManager Class See Also Send Feedback
References a static method, defined by an annotation, that takes an AnnotationManager as a parameter and returns a new annotation. The method that is referenced is called when a MouseDown event is occurs and the ToolMode is set to a mode which creates an annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Func<AnnotationManager, Annotation> AnnotationCreator { get; set; }
Visual Basic
Public Property AnnotationCreator As Func(Of AnnotationManager, Annotation)
    Get
    Set
Visual C++
public:
property Func<AnnotationManager^, Annotation^>^ AnnotationCreator {
    Func<AnnotationManager^, Annotation^>^ get ();
    void set (Func<AnnotationManager^, Annotation^>^ value);
}

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationsList Property

[image]

PDFTron SilverDox SDK
AnnotationManager..::..AnnotationsList Property
AnnotationManager Class See Also Send Feedback
Returns a list of all the annotations under the control of AnnotationManager

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public IEnumerable<Annotation> AnnotationsList { get; }
Visual Basic
Public ReadOnly Property AnnotationsList As IEnumerable(Of Annotation)
    Get
Visual C++
public:
property IEnumerable<Annotation^>^ AnnotationsList {
    IEnumerable<Annotation^>^ get ();
}

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationsModified Property

[image]

PDFTron SilverDox SDK
AnnotationManager..::..AnnotationsModified Property
AnnotationManager Class See Also Send Feedback
Gets whether or not any changes has been made since the last time annotations were loaded

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool AnnotationsModified { get; set; }
Visual Basic
Public Property AnnotationsModified As Boolean
    Get
    Set
Visual C++
public:
property bool AnnotationsModified {
    bool get ();
    void set (bool value);
}

Remarks

Setting this property to false will clear the history for the changed annotations and would be equivalent to loading new annotations. Setting this property to true will set this property to true if the page has annotations

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


CanPaste Property

[image]

PDFTron SilverDox SDK
AnnotationManager..::..CanPaste Property
AnnotationManager Class See Also Send Feedback
Gets whether or not annotations has been copied for PasteCopiedAnnotations(Nullable<(Of <<'(Int32>)>>))

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool CanPaste { get; }
Visual Basic
Public ReadOnly Property CanPaste As Boolean
    Get
Visual C++
public:
property bool CanPaste {
    bool get ();
}

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


CanRedo Property

[image]

PDFTron SilverDox SDK
AnnotationManager..::..CanRedo Property
AnnotationManager Class See Also Send Feedback
Gets whether or not there is a command to redo

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool CanRedo { get; }
Visual Basic
Public ReadOnly Property CanRedo As Boolean
    Get
Visual C++
public:
property bool CanRedo {
    bool get ();
}

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


CanUndo Property

[image]

PDFTron SilverDox SDK
AnnotationManager..::..CanUndo Property
AnnotationManager Class See Also Send Feedback
Gets whether or not there is a command to undo

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool CanUndo { get; }
Visual Basic
Public ReadOnly Property CanUndo As Boolean
    Get
Visual C++
public:
property bool CanUndo {
    bool get ();
}

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


CurrentAnnotationPage Property

[image]

PDFTron SilverDox SDK
AnnotationManager..::..CurrentAnnotationPage Property
AnnotationManager Class See Also Send Feedback
The canvas that hosts annotations (displayed on top of the document) that last received and handled a MouseDown event.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Canvas CurrentAnnotationPage { get; private set; }
Visual Basic
Public Property CurrentAnnotationPage As Canvas
    Get
    Private Set
Visual C++
public:
property Canvas^ CurrentAnnotationPage {
    Canvas^ get ();
    private: void set (Canvas^ value);
}

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


DefaultAnnotation Property

[image]

PDFTron SilverDox SDK
AnnotationManager..::..DefaultAnnotation Property
AnnotationManager Class See Also Send Feedback
The DefaultAnnotation is of the same type of annotation as that created by AnnotationCreator, and can be used as a reference when setting the initial property values of the new annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Annotation DefaultAnnotation { get; set; }
Visual Basic
Public Property DefaultAnnotation As Annotation
    Get
    Set
Visual C++
public:
property Annotation^ DefaultAnnotation {
    Annotation^ get ();
    void set (Annotation^ value);
}

Remarks

For example, if an annotation has a property "Color", then when it is created the constructor can set "Color" to the same value as that of DefaultAnnotation.

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


Document Property

[image]

PDFTron SilverDox SDK
AnnotationManager..::..Document Property
AnnotationManager Class See Also Send Feedback
The document that this AnnotationManager is being used with. Needed for annotations that require information about text.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Document Document { get; private set; }
Visual Basic
Public Property Document As Document
    Get
    Private Set
Visual C++
public:
property Document^ Document {
    Document^ get ();
    private: void set (Document^ value);
}

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


SelectedAnnotations Property

[image]

PDFTron SilverDox SDK
AnnotationManager..::..SelectedAnnotations Property
AnnotationManager Class See Also Send Feedback
A list of the currently selected annotations.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public List<Annotation> SelectedAnnotations { get; private set; }
Visual Basic
Public Property SelectedAnnotations As List(Of Annotation)
    Get
    Private Set
Visual C++
public:
property List<Annotation^>^ SelectedAnnotations {
    List<Annotation^>^ get ();
    private: void set (List<Annotation^>^ value);
}

See Also

AnnotationManager Class
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationManager.TypeOfChange Enumeration

[image]

PDFTron SilverDox SDK
AnnotationManager..::..TypeOfChange Enumeration
AnnotationManager Class See Also Send Feedback
Defines how an annotation has been changed since the last load

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public enum TypeOfChange
Visual Basic
Public Enumeration TypeOfChange
Visual C++
public enum class TypeOfChange

Members

Member name | Value | Description
Removed | 0 | The annotation has been removed
Created | 1 | The annotation is newly created
Modified | 2 | The annotation has been modified

See Also

PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationPopupContentChangedEventArgs Class

[image]

PDFTron SilverDox SDK
AnnotationPopupContentChangedEventArgs Class
Members See Also Send Feedback
Provides data for the AnnotationPopupContentChanged event

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class AnnotationPopupContentChangedEventArgs : EventArgs
Visual Basic
Public Class AnnotationPopupContentChangedEventArgs _
    Inherits EventArgs
Visual C++
public ref class AnnotationPopupContentChangedEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
PDFTron.SilverDox.Documents.Annotations..::..AnnotationPopupContentChangedEventArgs

See Also

AnnotationPopupContentChangedEventArgs Members
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationPopupContentChangedEventArgs Members

[image] [image]

PDFTron SilverDox SDK
AnnotationPopupContentChangedEventArgs Members
AnnotationPopupContentChangedEventArgs Class Constructors Properties See Also Send Feedback

The AnnotationPopupContentChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AnnotationPopupContentChangedEventArgs | Constructs a new instance of AnnotationsPopupContentChangedEventArgs".

Properties

 | Name | Description
Public property | ChangedAnnotation | Gets the annotation that had its contents changed
Public property | NewContent | Gets the new content of the popup box
Public property | OldContent | Gets the old content of the popup box

See Also

AnnotationPopupContentChangedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationPopupContentChangedEventArgs Constructor

[image]

PDFTron SilverDox SDK
AnnotationPopupContentChangedEventArgs Constructor
AnnotationPopupContentChangedEventArgs Class See Also Send Feedback
Constructs a new instance of AnnotationsPopupContentChangedEventArgs".

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public AnnotationPopupContentChangedEventArgs(
    Annotation changedAnnotation,
    string oldContent
)
Visual Basic
Public Sub New ( _
    changedAnnotation As Annotation, _
    oldContent As String _
)
Visual C++
public:
AnnotationPopupContentChangedEventArgs(
    Annotation^ changedAnnotation,
    String^ oldContent
)

Parameters

changedAnnotation
Type: PDFTron.SilverDox.Documents.Annotations..::..Annotation

[Missing <param name="changedAnnotation"/> documentation for "M:PDFTron.SilverDox.Documents.Annotations.AnnotationPopupContentChangedEventArgs.#ctor(PDFTron.SilverDox.Documents.Annotations.Annotation,System.String)"]

oldContent
Type: System..::..String

[Missing <param name="oldContent"/> documentation for "M:PDFTron.SilverDox.Documents.Annotations.AnnotationPopupContentChangedEventArgs.#ctor(PDFTron.SilverDox.Documents.Annotations.Annotation,System.String)"]

See Also

AnnotationPopupContentChangedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationPopupContentChangedEventArgs Properties

[image] [image]

PDFTron SilverDox SDK
AnnotationPopupContentChangedEventArgs Properties
AnnotationPopupContentChangedEventArgs Class See Also Send Feedback

The AnnotationPopupContentChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ChangedAnnotation | Gets the annotation that had its contents changed
Public property | NewContent | Gets the new content of the popup box
Public property | OldContent | Gets the old content of the popup box

See Also

AnnotationPopupContentChangedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


ChangedAnnotation Property

[image]

PDFTron SilverDox SDK
AnnotationPopupContentChangedEventArgs..::..ChangedAnnotation Property
AnnotationPopupContentChangedEventArgs Class See Also Send Feedback
Gets the annotation that had its contents changed

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Annotation ChangedAnnotation { get; internal set; }
Visual Basic
Public Property ChangedAnnotation As Annotation
    Get
    Friend Set
Visual C++
public:
property Annotation^ ChangedAnnotation {
    Annotation^ get ();
    internal: void set (Annotation^ value);
}

See Also

AnnotationPopupContentChangedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


NewContent Property

[image]

PDFTron SilverDox SDK
AnnotationPopupContentChangedEventArgs..::..NewContent Property
AnnotationPopupContentChangedEventArgs Class See Also Send Feedback
Gets the new content of the popup box

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string NewContent { get; set; }
Visual Basic
Public Property NewContent As String
    Get
    Set
Visual C++
public:
property String^ NewContent {
    String^ get ();
    void set (String^ value);
}

See Also

AnnotationPopupContentChangedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


OldContent Property

[image]

PDFTron SilverDox SDK
AnnotationPopupContentChangedEventArgs..::..OldContent Property
AnnotationPopupContentChangedEventArgs Class See Also Send Feedback
Gets the old content of the popup box

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string OldContent { get; set; }
Visual Basic
Public Property OldContent As String
    Get
    Set
Visual C++
public:
property String^ OldContent {
    String^ get ();
    void set (String^ value);
}

See Also

AnnotationPopupContentChangedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationResizedEventArgs Class

[image]

PDFTron SilverDox SDK
AnnotationResizedEventArgs Class
Members See Also Send Feedback
Provides data for the AnnotationResized event

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class AnnotationResizedEventArgs : EventArgs
Visual Basic
Public Class AnnotationResizedEventArgs _
    Inherits EventArgs
Visual C++
public ref class AnnotationResizedEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
PDFTron.SilverDox.Documents.Annotations..::..AnnotationResizedEventArgs

See Also

AnnotationResizedEventArgs Members
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationResizedEventArgs Members

[image] [image]

PDFTron SilverDox SDK
AnnotationResizedEventArgs Members
AnnotationResizedEventArgs Class Constructors Properties See Also Send Feedback

The AnnotationResizedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AnnotationResizedEventArgs | Constructs a new instance of AnnotationResizedEventArgs.

Properties

 | Name | Description
Public property | NewMirroredHorizontally | Gets whether or not the resized annotation is mirrored horizontally after the resize
Public property | NewMirroredVertically | Gets whether or not the resized annotation is mirrored vertically after the resize
Public property | NewRect | Gets the new coordinates, height and width Rect of the resized annotation
Public property | OldMirroredHorizontally | Gets whether or not the resized annotation was mirrored horizontally before the resize
Public property | OldMirroredVertically | Gets whether or not the resized annotation was mirrored vertically before the resize
Public property | OldRect | The old coordinates, height and width Rect of the resized annotation
Public property | ResizedAnnotation | Gets the Annotation object that was moved

See Also

AnnotationResizedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationResizedEventArgs Constructor

[image]

PDFTron SilverDox SDK
AnnotationResizedEventArgs Constructor
AnnotationResizedEventArgs Class See Also Send Feedback
Constructs a new instance of AnnotationResizedEventArgs.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public AnnotationResizedEventArgs(
    Annotation resizedAnnotation,
    Rect oldRect,
    bool oldMirroredHorizontally,
    bool oldMirroredVertically
)
Visual Basic
Public Sub New ( _
    resizedAnnotation As Annotation, _
    oldRect As Rect, _
    oldMirroredHorizontally As Boolean, _
    oldMirroredVertically As Boolean _
)
Visual C++
public:
AnnotationResizedEventArgs(
    Annotation^ resizedAnnotation,
    Rect oldRect,
    bool oldMirroredHorizontally,
    bool oldMirroredVertically
)

Parameters

resizedAnnotation
Type: PDFTron.SilverDox.Documents.Annotations..::..Annotation

[Missing <param name="resizedAnnotation"/> documentation for "M:PDFTron.SilverDox.Documents.Annotations.AnnotationResizedEventArgs.#ctor(PDFTron.SilverDox.Documents.Annotations.Annotation,System.Windows.Rect,System.Boolean,System.Boolean)"]

oldRect
Type: System.Windows..::..Rect

[Missing <param name="oldRect"/> documentation for "M:PDFTron.SilverDox.Documents.Annotations.AnnotationResizedEventArgs.#ctor(PDFTron.SilverDox.Documents.Annotations.Annotation,System.Windows.Rect,System.Boolean,System.Boolean)"]

oldMirroredHorizontally
Type: System..::..Boolean

[Missing <param name="oldMirroredHorizontally"/> documentation for "M:PDFTron.SilverDox.Documents.Annotations.AnnotationResizedEventArgs.#ctor(PDFTron.SilverDox.Documents.Annotations.Annotation,System.Windows.Rect,System.Boolean,System.Boolean)"]

oldMirroredVertically
Type: System..::..Boolean

[Missing <param name="oldMirroredVertically"/> documentation for "M:PDFTron.SilverDox.Documents.Annotations.AnnotationResizedEventArgs.#ctor(PDFTron.SilverDox.Documents.Annotations.Annotation,System.Windows.Rect,System.Boolean,System.Boolean)"]

See Also

AnnotationResizedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationResizedEventArgs Properties

[image] [image]

PDFTron SilverDox SDK
AnnotationResizedEventArgs Properties
AnnotationResizedEventArgs Class See Also Send Feedback

The AnnotationResizedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | NewMirroredHorizontally | Gets whether or not the resized annotation is mirrored horizontally after the resize
Public property | NewMirroredVertically | Gets whether or not the resized annotation is mirrored vertically after the resize
Public property | NewRect | Gets the new coordinates, height and width Rect of the resized annotation
Public property | OldMirroredHorizontally | Gets whether or not the resized annotation was mirrored horizontally before the resize
Public property | OldMirroredVertically | Gets whether or not the resized annotation was mirrored vertically before the resize
Public property | OldRect | The old coordinates, height and width Rect of the resized annotation
Public property | ResizedAnnotation | Gets the Annotation object that was moved

See Also

AnnotationResizedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


NewMirroredHorizontally Property

[image]

PDFTron SilverDox SDK
AnnotationResizedEventArgs..::..NewMirroredHorizontally Property
AnnotationResizedEventArgs Class See Also Send Feedback
Gets whether or not the resized annotation is mirrored horizontally after the resize

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool NewMirroredHorizontally { get; private set; }
Visual Basic
Public Property NewMirroredHorizontally As Boolean
    Get
    Private Set
Visual C++
public:
property bool NewMirroredHorizontally {
    bool get ();
    private: void set (bool value);
}

See Also

AnnotationResizedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


NewMirroredVertically Property

[image]

PDFTron SilverDox SDK
AnnotationResizedEventArgs..::..NewMirroredVertically Property
AnnotationResizedEventArgs Class See Also Send Feedback
Gets whether or not the resized annotation is mirrored vertically after the resize

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool NewMirroredVertically { get; private set; }
Visual Basic
Public Property NewMirroredVertically As Boolean
    Get
    Private Set
Visual C++
public:
property bool NewMirroredVertically {
    bool get ();
    private: void set (bool value);
}

See Also

AnnotationResizedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


NewRect Property

[image]

PDFTron SilverDox SDK
AnnotationResizedEventArgs..::..NewRect Property
AnnotationResizedEventArgs Class See Also Send Feedback
Gets the new coordinates, height and width Rect of the resized annotation

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Rect NewRect { get; private set; }
Visual Basic
Public Property NewRect As Rect
    Get
    Private Set
Visual C++
public:
property Rect NewRect {
    Rect get ();
    private: void set (Rect value);
}

See Also

AnnotationResizedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


OldMirroredHorizontally Property

[image]

PDFTron SilverDox SDK
AnnotationResizedEventArgs..::..OldMirroredHorizontally Property
AnnotationResizedEventArgs Class See Also Send Feedback
Gets whether or not the resized annotation was mirrored horizontally before the resize

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool OldMirroredHorizontally { get; private set; }
Visual Basic
Public Property OldMirroredHorizontally As Boolean
    Get
    Private Set
Visual C++
public:
property bool OldMirroredHorizontally {
    bool get ();
    private: void set (bool value);
}

See Also

AnnotationResizedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


OldMirroredVertically Property

[image]

PDFTron SilverDox SDK
AnnotationResizedEventArgs..::..OldMirroredVertically Property
AnnotationResizedEventArgs Class See Also Send Feedback
Gets whether or not the resized annotation was mirrored vertically before the resize

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool OldMirroredVertically { get; private set; }
Visual Basic
Public Property OldMirroredVertically As Boolean
    Get
    Private Set
Visual C++
public:
property bool OldMirroredVertically {
    bool get ();
    private: void set (bool value);
}

See Also

AnnotationResizedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


OldRect Property

[image]

PDFTron SilverDox SDK
AnnotationResizedEventArgs..::..OldRect Property
AnnotationResizedEventArgs Class See Also Send Feedback
The old coordinates, height and width Rect of the resized annotation

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Rect OldRect { get; private set; }
Visual Basic
Public Property OldRect As Rect
    Get
    Private Set
Visual C++
public:
property Rect OldRect {
    Rect get ();
    private: void set (Rect value);
}

See Also

AnnotationResizedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


ResizedAnnotation Property

[image]

PDFTron SilverDox SDK
AnnotationResizedEventArgs..::..ResizedAnnotation Property
AnnotationResizedEventArgs Class See Also Send Feedback
Gets the Annotation object that was moved

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Annotation ResizedAnnotation { get; internal set; }
Visual Basic
Public Property ResizedAnnotation As Annotation
    Get
    Friend Set
Visual C++
public:
property Annotation^ ResizedAnnotation {
    Annotation^ get ();
    internal: void set (Annotation^ value);
}

See Also

AnnotationResizedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationsEventArgs Class

[image]

PDFTron SilverDox SDK
AnnotationsEventArgs Class
Members See Also Send Feedback
Provides data for Annotation related events.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class AnnotationsEventArgs : EventArgs
Visual Basic
Public Class AnnotationsEventArgs _
    Inherits EventArgs
Visual C++
public ref class AnnotationsEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
PDFTron.SilverDox.Documents.Annotations..::..AnnotationsEventArgs

See Also

AnnotationsEventArgs Members
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationsEventArgs Members

[image] [image]

PDFTron SilverDox SDK
AnnotationsEventArgs Members
AnnotationsEventArgs Class Constructors Properties See Also Send Feedback

The AnnotationsEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AnnotationsEventArgs | Constructs a new instance of AnnotationsEventArgs.

Properties

 | Name | Description
Public property | Annotations | Gets the collection of Annotation objects that are relevant to the event.

See Also

AnnotationsEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationsEventArgs Constructor

[image]

PDFTron SilverDox SDK
AnnotationsEventArgs Constructor
AnnotationsEventArgs Class See Also Send Feedback
Constructs a new instance of AnnotationsEventArgs.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public AnnotationsEventArgs(
    List<Annotation> annotations
)
Visual Basic
Public Sub New ( _
    annotations As List(Of Annotation) _
)
Visual C++
public:
AnnotationsEventArgs(
    List<Annotation^>^ annotations
)

Parameters

annotations
Type: System.Collections.Generic..::..List <(Of <(<' Annotation >)>)>

[Missing <param name="annotations"/> documentation for "M:PDFTron.SilverDox.Documents.Annotations.AnnotationsEventArgs.#ctor(System.Collections.Generic.List{PDFTron.SilverDox.Documents.Annotations.Annotation})"]

See Also

AnnotationsEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationsEventArgs Properties

[image] [image]

PDFTron SilverDox SDK
AnnotationsEventArgs Properties
AnnotationsEventArgs Class See Also Send Feedback

The AnnotationsEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Annotations | Gets the collection of Annotation objects that are relevant to the event.

See Also

AnnotationsEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


Annotations Property

[image]

PDFTron SilverDox SDK
AnnotationsEventArgs..::..Annotations Property
AnnotationsEventArgs Class See Also Send Feedback
Gets the collection of Annotation objects that are relevant to the event.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public List<Annotation> Annotations { get; internal set; }
Visual Basic
Public Property Annotations As List(Of Annotation)
    Get
    Friend Set
Visual C++
public:
property List<Annotation^>^ Annotations {
    List<Annotation^>^ get ();
    internal: void set (List<Annotation^>^ value);
}

See Also

AnnotationsEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationsMoveCompletedEventArgs Class

[image]

PDFTron SilverDox SDK
AnnotationsMoveCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the AnnotationsMoveCompleted event

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class AnnotationsMoveCompletedEventArgs : EventArgs
Visual Basic
Public Class AnnotationsMoveCompletedEventArgs _
    Inherits EventArgs
Visual C++
public ref class AnnotationsMoveCompletedEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
PDFTron.SilverDox.Documents.Annotations..::..AnnotationsMoveCompletedEventArgs

See Also

AnnotationsMoveCompletedEventArgs Members
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationsMoveCompletedEventArgs Members

[image] [image]

PDFTron SilverDox SDK
AnnotationsMoveCompletedEventArgs Members
AnnotationsMoveCompletedEventArgs Class Constructors Properties See Also Send Feedback

The AnnotationsMoveCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AnnotationsMoveCompletedEventArgs | Constructs a new instance of AnnotationsMoveCompletedEventArgs".

Properties

 | Name | Description
Public property | MovedAnnotations | Gets a list of the moved annotations
Public property | NewLocations | Gets a dictionary of Annotation objects and their new location coordinates
Public property | OldLocations | Gets a dictionary of Annotation objects and their old location coordinates

See Also

AnnotationsMoveCompletedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationsMoveCompletedEventArgs Constructor

[image]

PDFTron SilverDox SDK
AnnotationsMoveCompletedEventArgs Constructor
AnnotationsMoveCompletedEventArgs Class See Also Send Feedback
Constructs a new instance of AnnotationsMoveCompletedEventArgs".

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public AnnotationsMoveCompletedEventArgs(
    Dictionary<Annotation, Point> oldLocations,
    Dictionary<Annotation, Point> newLocations
)
Visual Basic
Public Sub New ( _
    oldLocations As Dictionary(Of Annotation, Point), _
    newLocations As Dictionary(Of Annotation, Point) _
)
Visual C++
public:
AnnotationsMoveCompletedEventArgs(
    Dictionary<Annotation^, Point>^ oldLocations,
    Dictionary<Annotation^, Point>^ newLocations
)

Parameters

oldLocations
Type: System.Collections.Generic..::..Dictionary <(Of <(<' Annotation, Point >)>)>

[Missing <param name="oldLocations"/> documentation for "M:PDFTron.SilverDox.Documents.Annotations.AnnotationsMoveCompletedEventArgs.#ctor(System.Collections.Generic.Dictionary{PDFTron.SilverDox.Documents.Annotations.Annotation,System.Windows.Point},System.Collections.Generic.Dictionary{PDFTron.SilverDox.Documents.Annotations.Annotation,System.Windows.Point})"]

newLocations
Type: System.Collections.Generic..::..Dictionary <(Of <(<' Annotation, Point >)>)>

[Missing <param name="newLocations"/> documentation for "M:PDFTron.SilverDox.Documents.Annotations.AnnotationsMoveCompletedEventArgs.#ctor(System.Collections.Generic.Dictionary{PDFTron.SilverDox.Documents.Annotations.Annotation,System.Windows.Point},System.Collections.Generic.Dictionary{PDFTron.SilverDox.Documents.Annotations.Annotation,System.Windows.Point})"]

See Also

AnnotationsMoveCompletedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationsMoveCompletedEventArgs Properties

[image] [image]

PDFTron SilverDox SDK
AnnotationsMoveCompletedEventArgs Properties
AnnotationsMoveCompletedEventArgs Class See Also Send Feedback

The AnnotationsMoveCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | MovedAnnotations | Gets a list of the moved annotations
Public property | NewLocations | Gets a dictionary of Annotation objects and their new location coordinates
Public property | OldLocations | Gets a dictionary of Annotation objects and their old location coordinates

See Also

AnnotationsMoveCompletedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


MovedAnnotations Property

[image]

PDFTron SilverDox SDK
AnnotationsMoveCompletedEventArgs..::..MovedAnnotations Property
AnnotationsMoveCompletedEventArgs Class See Also Send Feedback
Gets a list of the moved annotations

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public IList<Annotation> MovedAnnotations { get; }
Visual Basic
Public ReadOnly Property MovedAnnotations As IList(Of Annotation)
    Get
Visual C++
public:
property IList<Annotation^>^ MovedAnnotations {
    IList<Annotation^>^ get ();
}

See Also

AnnotationsMoveCompletedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


NewLocations Property

[image]

PDFTron SilverDox SDK
AnnotationsMoveCompletedEventArgs..::..NewLocations Property
AnnotationsMoveCompletedEventArgs Class See Also Send Feedback
Gets a dictionary of Annotation objects and their new location coordinates

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Dictionary<Annotation, Point> NewLocations { get; internal set; }
Visual Basic
Public Property NewLocations As Dictionary(Of Annotation, Point)
    Get
    Friend Set
Visual C++
public:
property Dictionary<Annotation^, Point>^ NewLocations {
    Dictionary<Annotation^, Point>^ get ();
    internal: void set (Dictionary<Annotation^, Point>^ value);
}

See Also

AnnotationsMoveCompletedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


OldLocations Property

[image]

PDFTron SilverDox SDK
AnnotationsMoveCompletedEventArgs..::..OldLocations Property
AnnotationsMoveCompletedEventArgs Class See Also Send Feedback
Gets a dictionary of Annotation objects and their old location coordinates

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Dictionary<Annotation, Point> OldLocations { get; internal set; }
Visual Basic
Public Property OldLocations As Dictionary(Of Annotation, Point)
    Get
    Friend Set
Visual C++
public:
property Dictionary<Annotation^, Point>^ OldLocations {
    Dictionary<Annotation^, Point>^ get ();
    internal: void set (Dictionary<Annotation^, Point>^ value);
}

See Also

AnnotationsMoveCompletedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


Ellipse Class

[image]

PDFTron SilverDox SDK
Ellipse Class
Members See Also Send Feedback
Represents an ellipse annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class Ellipse : Markup
Visual Basic
Public Class Ellipse _
    Inherits Markup
Visual C++
public ref class Ellipse : public Markup

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents.Annotations..::..Annotation
PDFTron.SilverDox.Documents.Annotations..::..Markup
PDFTron.SilverDox.Documents.Annotations..::..Ellipse

See Also

Ellipse Members
PDFTron.SilverDox.Documents.Annotations Namespace


Ellipse Members

[image] [image]

PDFTron SilverDox SDK
Ellipse Members
Ellipse Class Constructors Methods Fields Properties Events See Also Send Feedback

The Ellipse type exposes the following members.

Constructors

 | Name | Description
Public method | Ellipse()()()() | Creates a new instance of the Ellipse class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).
Public method | Ellipse(AnnotationManager) | Creates a new instance of the Ellipse class.

Methods

 | Name | Description
 | Create | Creates a new instance of the Ellipse class.
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen. (Overrides Annotation..::..CreateAppearanceCanvas()()()().)
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas. (Inherited from Annotation.)
Public method | OnAnnotationResizeEnded | Called by the annotation's AnnotationManager when the user has finished resizing the annotation (Inherited from Annotation.)
Public method | OnAnnotationResizeStarted | Called by the annotation's AnnotationManager when the user has began resizing this annotation (Inherited from Annotation.)
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseUp | Called by the annotation's AnnotationManager when a MouseUp event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)

Fields

 | Name | Description
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse (Inherited from Annotation.)

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager. (Inherited from Annotation.)
Public property | Author | Represents the author of the annotation. Default is an empty string. (Inherited from Annotation.)
Public property | Bottom | Gets the y-axis value of the bottom of the annotation. (Inherited from Annotation.)
Public property | DateModified | Gets or sets the last date and time that the annotation was modified. (Inherited from Annotation.)
Public property | FillColor | Gets or sets the color of the annotation's interior. (Inherited from Markup.)
Public property | Height | Gets or sets the annotation's height. (Inherited from Markup.)
Public property | Id | A unique identifier that can be assigned to determine different annotations (Inherited from Annotation.)
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation (Inherited from Annotation.)
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user. (Inherited from Annotation.)
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true (Inherited from Annotation.)
Public property | Left | Gets the x-axis value of the left side of the annotation. (Inherited from Annotation.)
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally. (Inherited from Annotation.)
Public property | MirroredVertically | True if the annotation has been mirrored vertically. (Inherited from Annotation.)
Public property | NoMove | Gets or sets if this annotation can be moved by the user. (Inherited from Annotation.)
Public property | NoResize | Gets or sets if this annotation can be resized by the user. (Inherited from Annotation.)
Public property | NoZoom | Gets or sets if this annotation scales with the page. (Inherited from Annotation.)
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on. (Inherited from Annotation.)
Public property | PopupContents | Gets or sets the contents of the annotation's popup. (Inherited from Annotation.)
Public property | PopupHeight | Gets or sets the annotation's popup's height. (Inherited from Annotation.)
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible. (Inherited from Annotation.)
Public property | PopupWidth | Gets or sets the annotation's popup's width. (Inherited from Annotation.)
Public property | PopupX | Gets or sets the annotation's popup's x-axis position. (Inherited from Annotation.)
Public property | PopupY | Gets or sets the annotation's popup's y-axis position. (Inherited from Annotation.)
Public property | Right | Gets the x-axis value of the right side of the annotation. (Inherited from Annotation.)
Public property | StrokeColor | Gets or sets the color of the annotation's stroke. (Inherited from Markup.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline the annotation. (Inherited from Markup.)
Public property | StrokeThickness | Gets or sets the width of the annotation's stroke outline. (Inherited from Markup.)
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type. (Inherited from Annotation.)
Public property | Top | Gets the y-axis position of the top of the annotation. (Inherited from Annotation.)
Public property | Width | Gets or sets the annotation's width. (Inherited from Markup.)
Public property | X | Gets or sets the annotation's x-axis position. (Inherited from Markup.)
Public property | Y | Gets or sets the annotation's y-axis position. (Inherited from Markup.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation (Inherited from Annotation.)

See Also

Ellipse Class
PDFTron.SilverDox.Documents.Annotations Namespace


Ellipse Constructor

[image] [image]

PDFTron SilverDox SDK
Ellipse Constructor
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Ellipse()()()() | Creates a new instance of the Ellipse class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).
Public method | Ellipse(AnnotationManager) | Creates a new instance of the Ellipse class.

See Also

Ellipse Class
Ellipse Members
PDFTron.SilverDox.Documents.Annotations Namespace


Ellipse Constructor

[image]

PDFTron SilverDox SDK
Ellipse Constructor
Ellipse Class See Also Send Feedback
Creates a new instance of the Ellipse class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Ellipse()
Visual Basic
Public Sub New
Visual C++
public:
Ellipse()

See Also

Ellipse Class
Ellipse Overload
PDFTron.SilverDox.Documents.Annotations Namespace


Ellipse Constructor (AnnotationManager)

[image]

PDFTron SilverDox SDK
Ellipse Constructor (AnnotationManager)
Ellipse Class See Also Send Feedback
Creates a new instance of the Ellipse class.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Ellipse(
    AnnotationManager annotationManager
)
Visual Basic
Public Sub New ( _
    annotationManager As AnnotationManager _
)
Visual C++
public:
Ellipse(
    AnnotationManager^ annotationManager
)

Parameters

annotationManager
Type: PDFTron.SilverDox.Documents.Annotations..::..AnnotationManager
The AnnotationManager that is associated with the annotation.

See Also

Ellipse Class
Ellipse Overload
PDFTron.SilverDox.Documents.Annotations Namespace


Ellipse Fields

[image] [image]

PDFTron SilverDox SDK
Ellipse Fields
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Fields

 | Name | Description
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse (Inherited from Annotation.)

See Also

Ellipse Class
PDFTron.SilverDox.Documents.Annotations Namespace


Ellipse Methods

[image] [image]

PDFTron SilverDox SDK
Ellipse Methods
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new instance of the Ellipse class.
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen. (Overrides Annotation..::..CreateAppearanceCanvas()()()().)
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas. (Inherited from Annotation.)
Public method | OnAnnotationResizeEnded | Called by the annotation's AnnotationManager when the user has finished resizing the annotation (Inherited from Annotation.)
Public method | OnAnnotationResizeStarted | Called by the annotation's AnnotationManager when the user has began resizing this annotation (Inherited from Annotation.)
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseUp | Called by the annotation's AnnotationManager when a MouseUp event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)

See Also

Ellipse Class
PDFTron.SilverDox.Documents.Annotations Namespace


Create Method

[image]

PDFTron SilverDox SDK
Ellipse..::..Create Method
Ellipse Class See Also Send Feedback
Creates a new instance of the Ellipse class.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public static Ellipse Create(
    AnnotationManager annotationManager
)
Visual Basic
Public Shared Function Create ( _
    annotationManager As AnnotationManager _
) As Ellipse
Visual C++
public:
static Ellipse^ Create(
    AnnotationManager^ annotationManager
)

Parameters

annotationManager
Type: PDFTron.SilverDox.Documents.Annotations..::..AnnotationManager
The AnnotationManager that is associated with the annotation.

Return Value

A new Ellipse annotation.

See Also

Ellipse Class
PDFTron.SilverDox.Documents.Annotations Namespace


CreateAppearanceCanvas Method

[image]

PDFTron SilverDox SDK
Ellipse..::..CreateAppearanceCanvas Method
Ellipse Class See Also Send Feedback
Creates and returns the annotation's appearance canvas that will be displayed on screen.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override Canvas CreateAppearanceCanvas()
Visual Basic
Public Overrides Function CreateAppearanceCanvas As Canvas
Visual C++
public:
virtual Canvas^ CreateAppearanceCanvas() override

Return Value

The annotation's appearance canvas.

See Also

Ellipse Class
PDFTron.SilverDox.Documents.Annotations Namespace


Ellipse Properties

[image] [image]

PDFTron SilverDox SDK
Ellipse Properties
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager. (Inherited from Annotation.)
Public property | Author | Represents the author of the annotation. Default is an empty string. (Inherited from Annotation.)
Public property | Bottom | Gets the y-axis value of the bottom of the annotation. (Inherited from Annotation.)
Public property | DateModified | Gets or sets the last date and time that the annotation was modified. (Inherited from Annotation.)
Public property | FillColor | Gets or sets the color of the annotation's interior. (Inherited from Markup.)
Public property | Height | Gets or sets the annotation's height. (Inherited from Markup.)
Public property | Id | A unique identifier that can be assigned to determine different annotations (Inherited from Annotation.)
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation (Inherited from Annotation.)
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user. (Inherited from Annotation.)
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true (Inherited from Annotation.)
Public property | Left | Gets the x-axis value of the left side of the annotation. (Inherited from Annotation.)
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally. (Inherited from Annotation.)
Public property | MirroredVertically | True if the annotation has been mirrored vertically. (Inherited from Annotation.)
Public property | NoMove | Gets or sets if this annotation can be moved by the user. (Inherited from Annotation.)
Public property | NoResize | Gets or sets if this annotation can be resized by the user. (Inherited from Annotation.)
Public property | NoZoom | Gets or sets if this annotation scales with the page. (Inherited from Annotation.)
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on. (Inherited from Annotation.)
Public property | PopupContents | Gets or sets the contents of the annotation's popup. (Inherited from Annotation.)
Public property | PopupHeight | Gets or sets the annotation's popup's height. (Inherited from Annotation.)
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible. (Inherited from Annotation.)
Public property | PopupWidth | Gets or sets the annotation's popup's width. (Inherited from Annotation.)
Public property | PopupX | Gets or sets the annotation's popup's x-axis position. (Inherited from Annotation.)
Public property | PopupY | Gets or sets the annotation's popup's y-axis position. (Inherited from Annotation.)
Public property | Right | Gets the x-axis value of the right side of the annotation. (Inherited from Annotation.)
Public property | StrokeColor | Gets or sets the color of the annotation's stroke. (Inherited from Markup.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline the annotation. (Inherited from Markup.)
Public property | StrokeThickness | Gets or sets the width of the annotation's stroke outline. (Inherited from Markup.)
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type. (Inherited from Annotation.)
Public property | Top | Gets the y-axis position of the top of the annotation. (Inherited from Annotation.)
Public property | Width | Gets or sets the annotation's width. (Inherited from Markup.)
Public property | X | Gets or sets the annotation's x-axis position. (Inherited from Markup.)
Public property | Y | Gets or sets the annotation's y-axis position. (Inherited from Markup.)

See Also

Ellipse Class
PDFTron.SilverDox.Documents.Annotations Namespace


Ellipse Events

[image] [image]

PDFTron SilverDox SDK
Ellipse Events
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation (Inherited from Annotation.)

See Also

Ellipse Class
PDFTron.SilverDox.Documents.Annotations Namespace


FreeHand Class

[image]

PDFTron SilverDox SDK
FreeHand Class
Members See Also Send Feedback
Represents a line annotation. (This annotation type is typically drawn by a user using the mouse and is not usually straight.)

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class FreeHand : Markup
Visual Basic
Public Class FreeHand _
    Inherits Markup
Visual C++
public ref class FreeHand : public Markup

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents.Annotations..::..Annotation
PDFTron.SilverDox.Documents.Annotations..::..Markup
PDFTron.SilverDox.Documents.Annotations..::..FreeHand

See Also

FreeHand Members
PDFTron.SilverDox.Documents.Annotations Namespace


FreeHand Members

[image] [image]

PDFTron SilverDox SDK
FreeHand Members
FreeHand Class Constructors Methods Fields Properties Events See Also Send Feedback

The FreeHand type exposes the following members.

Constructors

 | Name | Description
Public method | FreeHand()()()() | Creates a new instance of the FreeHand class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).
Public method | FreeHand(AnnotationManager) | Creates a new instance of the FreeHand class.

Methods

 | Name | Description
 | Create | Creates a new instance of the FreeHand class.
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen. (Overrides Annotation..::..CreateAppearanceCanvas()()()().)
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas. (Inherited from Annotation.)
Public method | OnAnnotationResizeEnded | (Overrides Annotation..::..OnAnnotationResizeEnded(AnnotationResizedEventArgs).)
Public method | OnAnnotationResizeStarted | (Overrides Annotation..::..OnAnnotationResizeStarted()()()().)
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation. (Overrides Annotation..::..OnCreateMouseMove(MouseEventArgs).)
Public method | OnCreateMouseUp | (Overrides Annotation..::..OnCreateMouseUp(MouseButtonEventArgs, Boolean).)

Fields

 | Name | Description
Public field | BottomMost |
Public field | LeftMost |
Public field | RightMost |
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse (Inherited from Annotation.)
Public field | TopMost |

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager. (Inherited from Annotation.)
Public property | Author | Represents the author of the annotation. Default is an empty string. (Inherited from Annotation.)
Public property | Bottom | Gets the y-axis value of the bottom of the annotation. (Inherited from Annotation.)
Public property | DateModified | Gets or sets the last date and time that the annotation was modified. (Inherited from Annotation.)
Public property | FillColor | Gets or sets the color of the annotation's interior. (Inherited from Markup.)
Public property | Height | (Overrides Markup..::..Height.)
Public property | Id | A unique identifier that can be assigned to determine different annotations (Inherited from Annotation.)
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation (Inherited from Annotation.)
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user. (Inherited from Annotation.)
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true (Inherited from Annotation.)
Public property | Left | Gets the x-axis value of the left side of the annotation. (Inherited from Annotation.)
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally. (Inherited from Annotation.)
Public property | MirroredVertically | True if the annotation has been mirrored vertically. (Inherited from Annotation.)
Public property | NoMove | Gets or sets if this annotation can be moved by the user. (Inherited from Annotation.)
Public property | NoResize | Gets or sets if this annotation can be resized by the user. (Inherited from Annotation.)
Public property | NoZoom | Gets or sets if this annotation scales with the page. (Inherited from Annotation.)
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on. (Inherited from Annotation.)
Public property | PopupContents | Gets or sets the contents of the annotation's popup. (Inherited from Annotation.)
Public property | PopupHeight | Gets or sets the annotation's popup's height. (Inherited from Annotation.)
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible. (Inherited from Annotation.)
Public property | PopupWidth | Gets or sets the annotation's popup's width. (Inherited from Annotation.)
Public property | PopupX | Gets or sets the annotation's popup's x-axis position. (Inherited from Annotation.)
Public property | PopupY | Gets or sets the annotation's popup's y-axis position. (Inherited from Annotation.)
Public property | Right | Gets the x-axis value of the right side of the annotation. (Inherited from Annotation.)
Public property | Stroke |
Public property | StrokeColor | Gets or sets the color of the annotation's stroke. (Inherited from Markup.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline the annotation. (Inherited from Markup.)
Public property | StrokeThickness | Gets or sets the width of the annotation's stroke outline. (Inherited from Markup.)
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type. (Inherited from Annotation.)
Public property | Top | Gets the y-axis position of the top of the annotation. (Inherited from Annotation.)
Public property | Width | (Overrides Markup..::..Width.)
Public property | X | Gets or sets the annotation's x-axis position. (Overrides Markup..::..X.)
Public property | Y | Gets or sets the annotation's y-axis position. (Overrides Markup..::..Y.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation (Inherited from Annotation.)

See Also

FreeHand Class
PDFTron.SilverDox.Documents.Annotations Namespace


FreeHand Constructor

[image] [image]

PDFTron SilverDox SDK
FreeHand Constructor
FreeHand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FreeHand()()()() | Creates a new instance of the FreeHand class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).
Public method | FreeHand(AnnotationManager) | Creates a new instance of the FreeHand class.

See Also

FreeHand Class
FreeHand Members
PDFTron.SilverDox.Documents.Annotations Namespace


FreeHand Constructor

[image]

PDFTron SilverDox SDK
FreeHand Constructor
FreeHand Class See Also Send Feedback
Creates a new instance of the FreeHand class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public FreeHand()
Visual Basic
Public Sub New
Visual C++
public:
FreeHand()

See Also

FreeHand Class
FreeHand Overload
PDFTron.SilverDox.Documents.Annotations Namespace


FreeHand Constructor (AnnotationManager)

[image]

PDFTron SilverDox SDK
FreeHand Constructor (AnnotationManager)
FreeHand Class See Also Send Feedback
Creates a new instance of the FreeHand class.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public FreeHand(
    AnnotationManager annotationManager
)
Visual Basic
Public Sub New ( _
    annotationManager As AnnotationManager _
)
Visual C++
public:
FreeHand(
    AnnotationManager^ annotationManager
)

Parameters

annotationManager
Type: PDFTron.SilverDox.Documents.Annotations..::..AnnotationManager
The AnnotationManager that is associated with the annotation.

See Also

FreeHand Class
FreeHand Overload
PDFTron.SilverDox.Documents.Annotations Namespace


FreeHand Fields

[image] [image]

PDFTron SilverDox SDK
FreeHand Fields
FreeHand Class See Also Send Feedback

The FreeHand type exposes the following members.

Fields

 | Name | Description
Public field | BottomMost |
Public field | LeftMost |
Public field | RightMost |
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse (Inherited from Annotation.)
Public field | TopMost |

See Also

FreeHand Class
PDFTron.SilverDox.Documents.Annotations Namespace


BottomMost Field

[image]

PDFTron SilverDox SDK
FreeHand..::..BottomMost Field
FreeHand Class See Also Send Feedback

[Missing <summary> documentation for "F:PDFTron.SilverDox.Documents.Annotations.FreeHand.BottomMost"]

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public double BottomMost
Visual Basic
Public BottomMost As Double
Visual C++
public:
double BottomMost

See Also

FreeHand Class
PDFTron.SilverDox.Documents.Annotations Namespace


LeftMost Field

[image]

PDFTron SilverDox SDK
FreeHand..::..LeftMost Field
FreeHand Class See Also Send Feedback

[Missing <summary> documentation for "F:PDFTron.SilverDox.Documents.Annotations.FreeHand.LeftMost"]

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public double LeftMost
Visual Basic
Public LeftMost As Double
Visual C++
public:
double LeftMost

See Also

FreeHand Class
PDFTron.SilverDox.Documents.Annotations Namespace


RightMost Field

[image]

PDFTron SilverDox SDK
FreeHand..::..RightMost Field
FreeHand Class See Also Send Feedback

[Missing <summary> documentation for "F:PDFTron.SilverDox.Documents.Annotations.FreeHand.RightMost"]

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public double RightMost
Visual Basic
Public RightMost As Double
Visual C++
public:
double RightMost

See Also

FreeHand Class
PDFTron.SilverDox.Documents.Annotations Namespace


TopMost Field

[image]

PDFTron SilverDox SDK
FreeHand..::..TopMost Field
FreeHand Class See Also Send Feedback

[Missing <summary> documentation for "F:PDFTron.SilverDox.Documents.Annotations.FreeHand.TopMost"]

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public double TopMost
Visual Basic
Public TopMost As Double
Visual C++
public:
double TopMost

See Also

FreeHand Class
PDFTron.SilverDox.Documents.Annotations Namespace


FreeHand Methods

[image] [image]

PDFTron SilverDox SDK
FreeHand Methods
FreeHand Class See Also Send Feedback

The FreeHand type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new instance of the FreeHand class.
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen. (Overrides Annotation..::..CreateAppearanceCanvas()()()().)
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas. (Inherited from Annotation.)
Public method | OnAnnotationResizeEnded | (Overrides Annotation..::..OnAnnotationResizeEnded(AnnotationResizedEventArgs).)
Public method | OnAnnotationResizeStarted | (Overrides Annotation..::..OnAnnotationResizeStarted()()()().)
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation. (Overrides Annotation..::..OnCreateMouseMove(MouseEventArgs).)
Public method | OnCreateMouseUp | (Overrides Annotation..::..OnCreateMouseUp(MouseButtonEventArgs, Boolean).)

See Also

FreeHand Class
PDFTron.SilverDox.Documents.Annotations Namespace


Create Method

[image]

PDFTron SilverDox SDK
FreeHand..::..Create Method
FreeHand Class See Also Send Feedback
Creates a new instance of the FreeHand class.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public static FreeHand Create(
    AnnotationManager annotationManager
)
Visual Basic
Public Shared Function Create ( _
    annotationManager As AnnotationManager _
) As FreeHand
Visual C++
public:
static FreeHand^ Create(
    AnnotationManager^ annotationManager
)

Parameters

annotationManager
Type: PDFTron.SilverDox.Documents.Annotations..::..AnnotationManager
The AnnotationManager that is associated with the annotation.

Return Value

A new FreeHand annotation.

See Also

FreeHand Class
PDFTron.SilverDox.Documents.Annotations Namespace


CreateAppearanceCanvas Method

[image]

PDFTron SilverDox SDK
FreeHand..::..CreateAppearanceCanvas Method
FreeHand Class See Also Send Feedback
Creates and returns the annotation's appearance canvas that will be displayed on screen.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override Canvas CreateAppearanceCanvas()
Visual Basic
Public Overrides Function CreateAppearanceCanvas As Canvas
Visual C++
public:
virtual Canvas^ CreateAppearanceCanvas() override

Return Value

The annotation's appearance canvas.

See Also

FreeHand Class
PDFTron.SilverDox.Documents.Annotations Namespace


OnAnnotationResizeEnded Method

[image]

PDFTron SilverDox SDK
FreeHand..::..OnAnnotationResizeEnded Method
FreeHand Class See Also Send Feedback

[Missing <summary> documentation for "M:PDFTron.SilverDox.Documents.Annotations.FreeHand.OnAnnotationResizeEnded(PDFTron.SilverDox.Documents.Annotations.AnnotationResizedEventArgs)"]

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override void OnAnnotationResizeEnded(
    AnnotationResizedEventArgs e
)
Visual Basic
Public Overrides Sub OnAnnotationResizeEnded ( _
    e As AnnotationResizedEventArgs _
)
Visual C++
public:
virtual void OnAnnotationResizeEnded(
    AnnotationResizedEventArgs^ e
) override

Parameters

e
Type: PDFTron.SilverDox.Documents.Annotations..::..AnnotationResizedEventArgs

[Missing <param name="e"/> documentation for "M:PDFTron.SilverDox.Documents.Annotations.FreeHand.OnAnnotationResizeEnded(PDFTron.SilverDox.Documents.Annotations.AnnotationResizedEventArgs)"]

See Also

FreeHand Class
PDFTron.SilverDox.Documents.Annotations Namespace


OnAnnotationResizeStarted Method

[image]

PDFTron SilverDox SDK
FreeHand..::..OnAnnotationResizeStarted Method
FreeHand Class See Also Send Feedback

[Missing <summary> documentation for "M:PDFTron.SilverDox.Documents.Annotations.FreeHand.OnAnnotationResizeStarted"]

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override void OnAnnotationResizeStarted()
Visual Basic
Public Overrides Sub OnAnnotationResizeStarted
Visual C++
public:
virtual void OnAnnotationResizeStarted() override

See Also

FreeHand Class
PDFTron.SilverDox.Documents.Annotations Namespace


OnCreateMouseMove Method

[image]

PDFTron SilverDox SDK
FreeHand..::..OnCreateMouseMove Method
FreeHand Class See Also Send Feedback
Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override void OnCreateMouseMove(
    MouseEventArgs mouseMoveEventArgs
)
Visual Basic
Public Overrides Sub OnCreateMouseMove ( _
    mouseMoveEventArgs As MouseEventArgs _
)
Visual C++
public:
virtual void OnCreateMouseMove(
    MouseEventArgs^ mouseMoveEventArgs
) override

Parameters

mouseMoveEventArgs
Type: System.Windows.Input..::..MouseEventArgs
The event data.

See Also

FreeHand Class
PDFTron.SilverDox.Documents.Annotations Namespace


OnCreateMouseUp Method

[image]

PDFTron SilverDox SDK
FreeHand..::..OnCreateMouseUp Method
FreeHand Class See Also Send Feedback

[Missing <summary> documentation for "M:PDFTron.SilverDox.Documents.Annotations.FreeHand.OnCreateMouseUp(System.Windows.Input.MouseButtonEventArgs,System.Boolean)"]

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override void OnCreateMouseUp(
    MouseButtonEventArgs e,
    bool wasDoubleClick
)
Visual Basic
Public Overrides Sub OnCreateMouseUp ( _
    e As MouseButtonEventArgs, _
    wasDoubleClick As Boolean _
)
Visual C++
public:
virtual void OnCreateMouseUp(
    MouseButtonEventArgs^ e,
    bool wasDoubleClick
) override

Parameters

e
Type: System.Windows.Input..::..MouseButtonEventArgs

[Missing <param name="e"/> documentation for "M:PDFTron.SilverDox.Documents.Annotations.FreeHand.OnCreateMouseUp(System.Windows.Input.MouseButtonEventArgs,System.Boolean)"]

wasDoubleClick
Type: System..::..Boolean

[Missing <param name="wasDoubleClick"/> documentation for "M:PDFTron.SilverDox.Documents.Annotations.FreeHand.OnCreateMouseUp(System.Windows.Input.MouseButtonEventArgs,System.Boolean)"]

See Also

FreeHand Class
PDFTron.SilverDox.Documents.Annotations Namespace


FreeHand Properties

[image] [image]

PDFTron SilverDox SDK
FreeHand Properties
FreeHand Class See Also Send Feedback

The FreeHand type exposes the following members.

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager. (Inherited from Annotation.)
Public property | Author | Represents the author of the annotation. Default is an empty string. (Inherited from Annotation.)
Public property | Bottom | Gets the y-axis value of the bottom of the annotation. (Inherited from Annotation.)
Public property | DateModified | Gets or sets the last date and time that the annotation was modified. (Inherited from Annotation.)
Public property | FillColor | Gets or sets the color of the annotation's interior. (Inherited from Markup.)
Public property | Height | (Overrides Markup..::..Height.)
Public property | Id | A unique identifier that can be assigned to determine different annotations (Inherited from Annotation.)
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation (Inherited from Annotation.)
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user. (Inherited from Annotation.)
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true (Inherited from Annotation.)
Public property | Left | Gets the x-axis value of the left side of the annotation. (Inherited from Annotation.)
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally. (Inherited from Annotation.)
Public property | MirroredVertically | True if the annotation has been mirrored vertically. (Inherited from Annotation.)
Public property | NoMove | Gets or sets if this annotation can be moved by the user. (Inherited from Annotation.)
Public property | NoResize | Gets or sets if this annotation can be resized by the user. (Inherited from Annotation.)
Public property | NoZoom | Gets or sets if this annotation scales with the page. (Inherited from Annotation.)
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on. (Inherited from Annotation.)
Public property | PopupContents | Gets or sets the contents of the annotation's popup. (Inherited from Annotation.)
Public property | PopupHeight | Gets or sets the annotation's popup's height. (Inherited from Annotation.)
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible. (Inherited from Annotation.)
Public property | PopupWidth | Gets or sets the annotation's popup's width. (Inherited from Annotation.)
Public property | PopupX | Gets or sets the annotation's popup's x-axis position. (Inherited from Annotation.)
Public property | PopupY | Gets or sets the annotation's popup's y-axis position. (Inherited from Annotation.)
Public property | Right | Gets the x-axis value of the right side of the annotation. (Inherited from Annotation.)
Public property | Stroke |
Public property | StrokeColor | Gets or sets the color of the annotation's stroke. (Inherited from Markup.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline the annotation. (Inherited from Markup.)
Public property | StrokeThickness | Gets or sets the width of the annotation's stroke outline. (Inherited from Markup.)
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type. (Inherited from Annotation.)
Public property | Top | Gets the y-axis position of the top of the annotation. (Inherited from Annotation.)
Public property | Width | (Overrides Markup..::..Width.)
Public property | X | Gets or sets the annotation's x-axis position. (Overrides Markup..::..X.)
Public property | Y | Gets or sets the annotation's y-axis position. (Overrides Markup..::..Y.)

See Also

FreeHand Class
PDFTron.SilverDox.Documents.Annotations Namespace


Height Property

[image]

PDFTron SilverDox SDK
FreeHand..::..Height Property
FreeHand Class See Also Send Feedback

[Missing <summary> documentation for "P:PDFTron.SilverDox.Documents.Annotations.FreeHand.Height"]

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override double Height { get; set; }
Visual Basic
Public Overrides Property Height As Double
    Get
    Set
Visual C++
public:
virtual property double Height {
    double get () override;
    void set (double value) override;
}

See Also

FreeHand Class
PDFTron.SilverDox.Documents.Annotations Namespace


Stroke Property

[image]

PDFTron SilverDox SDK
FreeHand..::..Stroke Property
FreeHand Class See Also Send Feedback

[Missing <summary> documentation for "P:PDFTron.SilverDox.Documents.Annotations.FreeHand.Stroke"]

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Stroke Stroke { get; set; }
Visual Basic
Public Property Stroke As Stroke
    Get
    Set
Visual C++
public:
property Stroke^ Stroke {
    Stroke^ get ();
    void set (Stroke^ value);
}

See Also

FreeHand Class
PDFTron.SilverDox.Documents.Annotations Namespace


Width Property

[image]

PDFTron SilverDox SDK
FreeHand..::..Width Property
FreeHand Class See Also Send Feedback

[Missing <summary> documentation for "P:PDFTron.SilverDox.Documents.Annotations.FreeHand.Width"]

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override double Width { get; set; }
Visual Basic
Public Overrides Property Width As Double
    Get
    Set
Visual C++
public:
virtual property double Width {
    double get () override;
    void set (double value) override;
}

See Also

FreeHand Class
PDFTron.SilverDox.Documents.Annotations Namespace


X Property

[image]

PDFTron SilverDox SDK
FreeHand..::..X Property
FreeHand Class See Also Send Feedback
Gets or sets the annotation's x-axis position.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override double X { get; set; }
Visual Basic
Public Overrides Property X As Double
    Get
    Set
Visual C++
public:
virtual property double X {
    double get () override;
    void set (double value) override;
}

See Also

FreeHand Class
PDFTron.SilverDox.Documents.Annotations Namespace


Y Property

[image]

PDFTron SilverDox SDK
FreeHand..::..Y Property
FreeHand Class See Also Send Feedback
Gets or sets the annotation's y-axis position.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override double Y { get; set; }
Visual Basic
Public Overrides Property Y As Double
    Get
    Set
Visual C++
public:
virtual property double Y {
    double get () override;
    void set (double value) override;
}

See Also

FreeHand Class
PDFTron.SilverDox.Documents.Annotations Namespace


FreeHand Events

[image] [image]

PDFTron SilverDox SDK
FreeHand Events
FreeHand Class See Also Send Feedback

The FreeHand type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation (Inherited from Annotation.)

See Also

FreeHand Class
PDFTron.SilverDox.Documents.Annotations Namespace


Line Class

[image]

PDFTron SilverDox SDK
Line Class
Members See Also Send Feedback
Represents a straight line annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class Line : Markup
Visual Basic
Public Class Line _
    Inherits Markup
Visual C++
public ref class Line : public Markup

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents.Annotations..::..Annotation
PDFTron.SilverDox.Documents.Annotations..::..Markup
PDFTron.SilverDox.Documents.Annotations..::..Line

See Also

Line Members
PDFTron.SilverDox.Documents.Annotations Namespace


Line Members

[image] [image]

PDFTron SilverDox SDK
Line Members
Line Class Constructors Methods Fields Properties Events See Also Send Feedback

The Line type exposes the following members.

Constructors

 | Name | Description
Public method | Line()()()() | Creates a new instance of the Line class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).
Public method | Line(AnnotationManager) | Creates a new instance of the Line class.

Methods

 | Name | Description
 | Create | Creates a new instance of the Line class.
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen. (Overrides Annotation..::..CreateAppearanceCanvas()()()().)
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas. (Inherited from Annotation.)
Public method | OnAnnotationResizeEnded | Called by the annotation's AnnotationManager when the user has finished resizing the annotation (Inherited from Annotation.)
Public method | OnAnnotationResizeStarted | Called by the annotation's AnnotationManager when the user has began resizing this annotation (Inherited from Annotation.)
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation. (Overrides Annotation..::..OnCreateMouseMove(MouseEventArgs).)
Public method | OnCreateMouseUp | Called by the annotation's AnnotationManager when a MouseUp event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)

Fields

 | Name | Description
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse (Inherited from Annotation.)

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager. (Inherited from Annotation.)
Public property | Author | Represents the author of the annotation. Default is an empty string. (Inherited from Annotation.)
Public property | Bottom | Gets the y-axis value of the bottom of the annotation. (Inherited from Annotation.)
Public property | DateModified | Gets or sets the last date and time that the annotation was modified. (Inherited from Annotation.)
Public property | FillColor | Gets or sets the color of the annotation's interior. (Inherited from Markup.)
Public property | Height | Gets or sets the annotation's height. (Inherited from Markup.)
Public property | Id | A unique identifier that can be assigned to determine different annotations (Inherited from Annotation.)
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation (Inherited from Annotation.)
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user. (Inherited from Annotation.)
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true (Inherited from Annotation.)
Public property | Left | Gets the x-axis value of the left side of the annotation. (Inherited from Annotation.)
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally. (Inherited from Annotation.)
Public property | MirroredVertically | True if the annotation has been mirrored vertically. (Inherited from Annotation.)
Public property | NoMove | Gets or sets if this annotation can be moved by the user. (Inherited from Annotation.)
Public property | NoResize | Gets or sets if this annotation can be resized by the user. (Inherited from Annotation.)
Public property | NoZoom | Gets or sets if this annotation scales with the page. (Inherited from Annotation.)
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on. (Inherited from Annotation.)
Public property | PopupContents | Gets or sets the contents of the annotation's popup. (Inherited from Annotation.)
Public property | PopupHeight | Gets or sets the annotation's popup's height. (Inherited from Annotation.)
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible. (Inherited from Annotation.)
Public property | PopupWidth | Gets or sets the annotation's popup's width. (Inherited from Annotation.)
Public property | PopupX | Gets or sets the annotation's popup's x-axis position. (Inherited from Annotation.)
Public property | PopupY | Gets or sets the annotation's popup's y-axis position. (Inherited from Annotation.)
Public property | Right | Gets the x-axis value of the right side of the annotation. (Inherited from Annotation.)
Public property | StrokeColor | Gets or sets the color of the annotation's stroke. (Inherited from Markup.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline the annotation. (Inherited from Markup.)
Public property | StrokeThickness | Gets or sets the width of the annotation's stroke outline. (Inherited from Markup.)
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type. (Inherited from Annotation.)
Public property | Top | Gets the y-axis position of the top of the annotation. (Inherited from Annotation.)
Public property | Width | Gets or sets the annotation's width. (Inherited from Markup.)
Public property | X | Gets or sets the annotation's x-axis position. (Inherited from Markup.)
Public property | Y | Gets or sets the annotation's y-axis position. (Inherited from Markup.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation (Inherited from Annotation.)

See Also

Line Class
PDFTron.SilverDox.Documents.Annotations Namespace


Line Constructor

[image] [image]

PDFTron SilverDox SDK
Line Constructor
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Line()()()() | Creates a new instance of the Line class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).
Public method | Line(AnnotationManager) | Creates a new instance of the Line class.

See Also

Line Class
Line Members
PDFTron.SilverDox.Documents.Annotations Namespace


Line Constructor

[image]

PDFTron SilverDox SDK
Line Constructor
Line Class See Also Send Feedback
Creates a new instance of the Line class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Line()
Visual Basic
Public Sub New
Visual C++
public:
Line()

See Also

Line Class
Line Overload
PDFTron.SilverDox.Documents.Annotations Namespace


Line Constructor (AnnotationManager)

[image]

PDFTron SilverDox SDK
Line Constructor (AnnotationManager)
Line Class See Also Send Feedback
Creates a new instance of the Line class.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Line(
    AnnotationManager annotationManager
)
Visual Basic
Public Sub New ( _
    annotationManager As AnnotationManager _
)
Visual C++
public:
Line(
    AnnotationManager^ annotationManager
)

Parameters

annotationManager
Type: PDFTron.SilverDox.Documents.Annotations..::..AnnotationManager
The AnnotationManager that is associated with the annotation.

See Also

Line Class
Line Overload
PDFTron.SilverDox.Documents.Annotations Namespace


Line Fields

[image] [image]

PDFTron SilverDox SDK
Line Fields
Line Class See Also Send Feedback

The Line type exposes the following members.

Fields

 | Name | Description
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse (Inherited from Annotation.)

See Also

Line Class
PDFTron.SilverDox.Documents.Annotations Namespace


Line Methods

[image] [image]

PDFTron SilverDox SDK
Line Methods
Line Class See Also Send Feedback

The Line type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new instance of the Line class.
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen. (Overrides Annotation..::..CreateAppearanceCanvas()()()().)
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas. (Inherited from Annotation.)
Public method | OnAnnotationResizeEnded | Called by the annotation's AnnotationManager when the user has finished resizing the annotation (Inherited from Annotation.)
Public method | OnAnnotationResizeStarted | Called by the annotation's AnnotationManager when the user has began resizing this annotation (Inherited from Annotation.)
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation. (Overrides Annotation..::..OnCreateMouseMove(MouseEventArgs).)
Public method | OnCreateMouseUp | Called by the annotation's AnnotationManager when a MouseUp event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)

See Also

Line Class
PDFTron.SilverDox.Documents.Annotations Namespace


Create Method

[image]

PDFTron SilverDox SDK
Line..::..Create Method
Line Class See Also Send Feedback
Creates a new instance of the Line class.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public static Line Create(
    AnnotationManager annotationManager
)
Visual Basic
Public Shared Function Create ( _
    annotationManager As AnnotationManager _
) As Line
Visual C++
public:
static Line^ Create(
    AnnotationManager^ annotationManager
)

Parameters

annotationManager
Type: PDFTron.SilverDox.Documents.Annotations..::..AnnotationManager
The AnnotationManager that is associated with the annotation.

Return Value

A new Line annotation.

See Also

Line Class
PDFTron.SilverDox.Documents.Annotations Namespace


CreateAppearanceCanvas Method

[image]

PDFTron SilverDox SDK
Line..::..CreateAppearanceCanvas Method
Line Class See Also Send Feedback
Creates and returns the annotation's appearance canvas that will be displayed on screen.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override Canvas CreateAppearanceCanvas()
Visual Basic
Public Overrides Function CreateAppearanceCanvas As Canvas
Visual C++
public:
virtual Canvas^ CreateAppearanceCanvas() override

Return Value

The annotation's appearance canvas.

See Also

Line Class
PDFTron.SilverDox.Documents.Annotations Namespace


OnCreateMouseMove Method

[image]

PDFTron SilverDox SDK
Line..::..OnCreateMouseMove Method
Line Class See Also Send Feedback
Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override void OnCreateMouseMove(
    MouseEventArgs mouseMoveEventArgs
)
Visual Basic
Public Overrides Sub OnCreateMouseMove ( _
    mouseMoveEventArgs As MouseEventArgs _
)
Visual C++
public:
virtual void OnCreateMouseMove(
    MouseEventArgs^ mouseMoveEventArgs
) override

Parameters

mouseMoveEventArgs
Type: System.Windows.Input..::..MouseEventArgs
The event data.

See Also

Line Class
PDFTron.SilverDox.Documents.Annotations Namespace


Line Properties

[image] [image]

PDFTron SilverDox SDK
Line Properties
Line Class See Also Send Feedback

The Line type exposes the following members.

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager. (Inherited from Annotation.)
Public property | Author | Represents the author of the annotation. Default is an empty string. (Inherited from Annotation.)
Public property | Bottom | Gets the y-axis value of the bottom of the annotation. (Inherited from Annotation.)
Public property | DateModified | Gets or sets the last date and time that the annotation was modified. (Inherited from Annotation.)
Public property | FillColor | Gets or sets the color of the annotation's interior. (Inherited from Markup.)
Public property | Height | Gets or sets the annotation's height. (Inherited from Markup.)
Public property | Id | A unique identifier that can be assigned to determine different annotations (Inherited from Annotation.)
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation (Inherited from Annotation.)
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user. (Inherited from Annotation.)
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true (Inherited from Annotation.)
Public property | Left | Gets the x-axis value of the left side of the annotation. (Inherited from Annotation.)
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally. (Inherited from Annotation.)
Public property | MirroredVertically | True if the annotation has been mirrored vertically. (Inherited from Annotation.)
Public property | NoMove | Gets or sets if this annotation can be moved by the user. (Inherited from Annotation.)
Public property | NoResize | Gets or sets if this annotation can be resized by the user. (Inherited from Annotation.)
Public property | NoZoom | Gets or sets if this annotation scales with the page. (Inherited from Annotation.)
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on. (Inherited from Annotation.)
Public property | PopupContents | Gets or sets the contents of the annotation's popup. (Inherited from Annotation.)
Public property | PopupHeight | Gets or sets the annotation's popup's height. (Inherited from Annotation.)
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible. (Inherited from Annotation.)
Public property | PopupWidth | Gets or sets the annotation's popup's width. (Inherited from Annotation.)
Public property | PopupX | Gets or sets the annotation's popup's x-axis position. (Inherited from Annotation.)
Public property | PopupY | Gets or sets the annotation's popup's y-axis position. (Inherited from Annotation.)
Public property | Right | Gets the x-axis value of the right side of the annotation. (Inherited from Annotation.)
Public property | StrokeColor | Gets or sets the color of the annotation's stroke. (Inherited from Markup.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline the annotation. (Inherited from Markup.)
Public property | StrokeThickness | Gets or sets the width of the annotation's stroke outline. (Inherited from Markup.)
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type. (Inherited from Annotation.)
Public property | Top | Gets the y-axis position of the top of the annotation. (Inherited from Annotation.)
Public property | Width | Gets or sets the annotation's width. (Inherited from Markup.)
Public property | X | Gets or sets the annotation's x-axis position. (Inherited from Markup.)
Public property | Y | Gets or sets the annotation's y-axis position. (Inherited from Markup.)

See Also

Line Class
PDFTron.SilverDox.Documents.Annotations Namespace


Line Events

[image] [image]

PDFTron SilverDox SDK
Line Events
Line Class See Also Send Feedback

The Line type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation (Inherited from Annotation.)

See Also

Line Class
PDFTron.SilverDox.Documents.Annotations Namespace


Markup Class

[image]

PDFTron SilverDox SDK
Markup Class
Members See Also Send Feedback
A base class for annotation types that are used to mark up documents.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public abstract class Markup : Annotation
Visual Basic
Public MustInherit Class Markup _
    Inherits Annotation
Visual C++
public ref class Markup abstract : public Annotation

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents.Annotations..::..Annotation
PDFTron.SilverDox.Documents.Annotations..::..Markup
PDFTron.SilverDox.Documents.Annotations..::..Ellipse
PDFTron.SilverDox.Documents.Annotations..::..FreeHand
PDFTron.SilverDox.Documents.Annotations..::..Line
PDFTron.SilverDox.Documents.Annotations..::..Rectangle
PDFTron.SilverDox.Documents.Annotations..::..TextMarkup

See Also

Markup Members
PDFTron.SilverDox.Documents.Annotations Namespace


Markup Members

[image] [image]

PDFTron SilverDox SDK
Markup Members
Markup Class Constructors Methods Fields Properties Events See Also Send Feedback

The Markup type exposes the following members.

Constructors

 | Name | Description
Protected method | Markup()()()() | Called by subclasses during construction to set properties common to Markup annotations.
Protected method | Markup(AnnotationManager) | Called by subclasses during construction to set properties common to Markup annotations.

Methods

 | Name | Description
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen. (Inherited from Annotation.)
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas. (Inherited from Annotation.)
Public method | OnAnnotationResizeEnded | Called by the annotation's AnnotationManager when the user has finished resizing the annotation (Inherited from Annotation.)
Public method | OnAnnotationResizeStarted | Called by the annotation's AnnotationManager when the user has began resizing this annotation (Inherited from Annotation.)
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseUp | Called by the annotation's AnnotationManager when a MouseUp event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)

Fields

 | Name | Description
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse (Inherited from Annotation.)

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager. (Inherited from Annotation.)
Public property | Author | Represents the author of the annotation. Default is an empty string. (Inherited from Annotation.)
Public property | Bottom | Gets the y-axis value of the bottom of the annotation. (Inherited from Annotation.)
Public property | DateModified | Gets or sets the last date and time that the annotation was modified. (Inherited from Annotation.)
Public property | FillColor | Gets or sets the color of the annotation's interior.
Public property | Height | Gets or sets the annotation's height. (Overrides Annotation..::..Height.)
Public property | Id | A unique identifier that can be assigned to determine different annotations (Inherited from Annotation.)
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation (Inherited from Annotation.)
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user. (Inherited from Annotation.)
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true (Inherited from Annotation.)
Public property | Left | Gets the x-axis value of the left side of the annotation. (Inherited from Annotation.)
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally. (Inherited from Annotation.)
Public property | MirroredVertically | True if the annotation has been mirrored vertically. (Inherited from Annotation.)
Public property | NoMove | Gets or sets if this annotation can be moved by the user. (Inherited from Annotation.)
Public property | NoResize | Gets or sets if this annotation can be resized by the user. (Inherited from Annotation.)
Public property | NoZoom | Gets or sets if this annotation scales with the page. (Inherited from Annotation.)
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on. (Inherited from Annotation.)
Public property | PopupContents | Gets or sets the contents of the annotation's popup. (Inherited from Annotation.)
Public property | PopupHeight | Gets or sets the annotation's popup's height. (Inherited from Annotation.)
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible. (Inherited from Annotation.)
Public property | PopupWidth | Gets or sets the annotation's popup's width. (Inherited from Annotation.)
Public property | PopupX | Gets or sets the annotation's popup's x-axis position. (Inherited from Annotation.)
Public property | PopupY | Gets or sets the annotation's popup's y-axis position. (Inherited from Annotation.)
Public property | Right | Gets the x-axis value of the right side of the annotation. (Inherited from Annotation.)
Public property | StrokeColor | Gets or sets the color of the annotation's stroke.
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline the annotation.
Public property | StrokeThickness | Gets or sets the width of the annotation's stroke outline.
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type. (Inherited from Annotation.)
Public property | Top | Gets the y-axis position of the top of the annotation. (Inherited from Annotation.)
Public property | Width | Gets or sets the annotation's width. (Overrides Annotation..::..Width.)
Public property | X | Gets or sets the annotation's x-axis position. (Overrides Annotation..::..X.)
Public property | Y | Gets or sets the annotation's y-axis position. (Overrides Annotation..::..Y.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation (Inherited from Annotation.)

See Also

Markup Class
PDFTron.SilverDox.Documents.Annotations Namespace


Markup Constructor

[image] [image]

PDFTron SilverDox SDK
Markup Constructor
Markup Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Markup()()()() | Called by subclasses during construction to set properties common to Markup annotations.
Protected method | Markup(AnnotationManager) | Called by subclasses during construction to set properties common to Markup annotations.

See Also

Markup Class
Markup Members
PDFTron.SilverDox.Documents.Annotations Namespace


Markup Constructor

[image]

PDFTron SilverDox SDK
Markup Constructor
Markup Class See Also Send Feedback
Called by subclasses during construction to set properties common to Markup annotations.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected Markup()
Visual Basic
Protected Sub New
Visual C++
protected:
Markup()

See Also

Markup Class
Markup Overload
PDFTron.SilverDox.Documents.Annotations Namespace


Markup Constructor (AnnotationManager)

[image]

PDFTron SilverDox SDK
Markup Constructor (AnnotationManager)
Markup Class See Also Send Feedback
Called by subclasses during construction to set properties common to Markup annotations.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected Markup(
    AnnotationManager annotationManager
)
Visual Basic
Protected Sub New ( _
    annotationManager As AnnotationManager _
)
Visual C++
protected:
Markup(
    AnnotationManager^ annotationManager
)

Parameters

annotationManager
Type: PDFTron.SilverDox.Documents.Annotations..::..AnnotationManager
The AnnotationManager that is associated with the annotation.

See Also

Markup Class
Markup Overload
PDFTron.SilverDox.Documents.Annotations Namespace


Markup Fields

[image] [image]

PDFTron SilverDox SDK
Markup Fields
Markup Class See Also Send Feedback

The Markup type exposes the following members.

Fields

 | Name | Description
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse (Inherited from Annotation.)

See Also

Markup Class
PDFTron.SilverDox.Documents.Annotations Namespace


Markup Methods

[image] [image]

PDFTron SilverDox SDK
Markup Methods
Markup Class See Also Send Feedback

The Markup type exposes the following members.

Methods

 | Name | Description
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen. (Inherited from Annotation.)
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas. (Inherited from Annotation.)
Public method | OnAnnotationResizeEnded | Called by the annotation's AnnotationManager when the user has finished resizing the annotation (Inherited from Annotation.)
Public method | OnAnnotationResizeStarted | Called by the annotation's AnnotationManager when the user has began resizing this annotation (Inherited from Annotation.)
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseUp | Called by the annotation's AnnotationManager when a MouseUp event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)

See Also

Markup Class
PDFTron.SilverDox.Documents.Annotations Namespace


Markup Properties

[image] [image]

PDFTron SilverDox SDK
Markup Properties
Markup Class See Also Send Feedback

The Markup type exposes the following members.

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager. (Inherited from Annotation.)
Public property | Author | Represents the author of the annotation. Default is an empty string. (Inherited from Annotation.)
Public property | Bottom | Gets the y-axis value of the bottom of the annotation. (Inherited from Annotation.)
Public property | DateModified | Gets or sets the last date and time that the annotation was modified. (Inherited from Annotation.)
Public property | FillColor | Gets or sets the color of the annotation's interior.
Public property | Height | Gets or sets the annotation's height. (Overrides Annotation..::..Height.)
Public property | Id | A unique identifier that can be assigned to determine different annotations (Inherited from Annotation.)
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation (Inherited from Annotation.)
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user. (Inherited from Annotation.)
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true (Inherited from Annotation.)
Public property | Left | Gets the x-axis value of the left side of the annotation. (Inherited from Annotation.)
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally. (Inherited from Annotation.)
Public property | MirroredVertically | True if the annotation has been mirrored vertically. (Inherited from Annotation.)
Public property | NoMove | Gets or sets if this annotation can be moved by the user. (Inherited from Annotation.)
Public property | NoResize | Gets or sets if this annotation can be resized by the user. (Inherited from Annotation.)
Public property | NoZoom | Gets or sets if this annotation scales with the page. (Inherited from Annotation.)
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on. (Inherited from Annotation.)
Public property | PopupContents | Gets or sets the contents of the annotation's popup. (Inherited from Annotation.)
Public property | PopupHeight | Gets or sets the annotation's popup's height. (Inherited from Annotation.)
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible. (Inherited from Annotation.)
Public property | PopupWidth | Gets or sets the annotation's popup's width. (Inherited from Annotation.)
Public property | PopupX | Gets or sets the annotation's popup's x-axis position. (Inherited from Annotation.)
Public property | PopupY | Gets or sets the annotation's popup's y-axis position. (Inherited from Annotation.)
Public property | Right | Gets the x-axis value of the right side of the annotation. (Inherited from Annotation.)
Public property | StrokeColor | Gets or sets the color of the annotation's stroke.
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline the annotation.
Public property | StrokeThickness | Gets or sets the width of the annotation's stroke outline.
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type. (Inherited from Annotation.)
Public property | Top | Gets the y-axis position of the top of the annotation. (Inherited from Annotation.)
Public property | Width | Gets or sets the annotation's width. (Overrides Annotation..::..Width.)
Public property | X | Gets or sets the annotation's x-axis position. (Overrides Annotation..::..X.)
Public property | Y | Gets or sets the annotation's y-axis position. (Overrides Annotation..::..Y.)

See Also

Markup Class
PDFTron.SilverDox.Documents.Annotations Namespace


FillColor Property

[image]

PDFTron SilverDox SDK
Markup..::..FillColor Property
Markup Class See Also Send Feedback
Gets or sets the color of the annotation's interior.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Color FillColor { get; set; }
Visual Basic
Public Property FillColor As Color
    Get
    Set
Visual C++
public:
property Color FillColor {
    Color get ();
    void set (Color value);
}

See Also

Markup Class
PDFTron.SilverDox.Documents.Annotations Namespace


Height Property

[image]

PDFTron SilverDox SDK
Markup..::..Height Property
Markup Class See Also Send Feedback
Gets or sets the annotation's height.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override double Height { get; set; }
Visual Basic
Public Overrides Property Height As Double
    Get
    Set
Visual C++
public:
virtual property double Height {
    double get () override;
    void set (double value) override;
}

See Also

Markup Class
PDFTron.SilverDox.Documents.Annotations Namespace


StrokeColor Property

[image]

PDFTron SilverDox SDK
Markup..::..StrokeColor Property
Markup Class See Also Send Feedback
Gets or sets the color of the annotation's stroke.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Color StrokeColor { get; set; }
Visual Basic
Public Property StrokeColor As Color
    Get
    Set
Visual C++
public:
property Color StrokeColor {
    Color get ();
    void set (Color value);
}

See Also

Markup Class
PDFTron.SilverDox.Documents.Annotations Namespace


StrokeDashArray Property

[image]

PDFTron SilverDox SDK
Markup..::..StrokeDashArray Property
Markup Class See Also Send Feedback
Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline the annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public DoubleCollection StrokeDashArray { get; set; }
Visual Basic
Public Property StrokeDashArray As DoubleCollection
    Get
    Set
Visual C++
public:
property DoubleCollection^ StrokeDashArray {
    DoubleCollection^ get ();
    void set (DoubleCollection^ value);
}

See Also

Markup Class
PDFTron.SilverDox.Documents.Annotations Namespace


StrokeThickness Property

[image]

PDFTron SilverDox SDK
Markup..::..StrokeThickness Property
Markup Class See Also Send Feedback
Gets or sets the width of the annotation's stroke outline.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public double StrokeThickness { get; set; }
Visual Basic
Public Property StrokeThickness As Double
    Get
    Set
Visual C++
public:
property double StrokeThickness {
    double get ();
    void set (double value);
}

See Also

Markup Class
PDFTron.SilverDox.Documents.Annotations Namespace


Width Property

[image]

PDFTron SilverDox SDK
Markup..::..Width Property
Markup Class See Also Send Feedback
Gets or sets the annotation's width.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override double Width { get; set; }
Visual Basic
Public Overrides Property Width As Double
    Get
    Set
Visual C++
public:
virtual property double Width {
    double get () override;
    void set (double value) override;
}

See Also

Markup Class
PDFTron.SilverDox.Documents.Annotations Namespace


X Property

[image]

PDFTron SilverDox SDK
Markup..::..X Property
Markup Class See Also Send Feedback
Gets or sets the annotation's x-axis position.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override double X { get; set; }
Visual Basic
Public Overrides Property X As Double
    Get
    Set
Visual C++
public:
virtual property double X {
    double get () override;
    void set (double value) override;
}

See Also

Markup Class
PDFTron.SilverDox.Documents.Annotations Namespace


Y Property

[image]

PDFTron SilverDox SDK
Markup..::..Y Property
Markup Class See Also Send Feedback
Gets or sets the annotation's y-axis position.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override double Y { get; set; }
Visual Basic
Public Overrides Property Y As Double
    Get
    Set
Visual C++
public:
virtual property double Y {
    double get () override;
    void set (double value) override;
}

See Also

Markup Class
PDFTron.SilverDox.Documents.Annotations Namespace


Markup Events

[image] [image]

PDFTron SilverDox SDK
Markup Events
Markup Class See Also Send Feedback

The Markup type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation (Inherited from Annotation.)

See Also

Markup Class
PDFTron.SilverDox.Documents.Annotations Namespace


PopupBody Class

[image]

PDFTron SilverDox SDK
PopupBody Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PDFTron.SilverDox.Documents.Annotations.PopupBody"]

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class PopupBody : UserControl, INotifyPropertyChanged
Visual Basic
Public Class PopupBody _
    Inherits UserControl _
    Implements INotifyPropertyChanged
Visual C++
public ref class PopupBody : public UserControl,
    INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..UserControl
PDFTron.SilverDox.Documents.Annotations..::..PopupBody

See Also

PopupBody Members
PDFTron.SilverDox.Documents.Annotations Namespace


PopupBody Members

[image] [image]

PDFTron SilverDox SDK
PopupBody Members
PopupBody Class Constructors Methods Fields Properties Events See Also Send Feedback

The PopupBody type exposes the following members.

Constructors

 | Name | Description
Public method | PopupBody | The popup that is displayed when an annotation is double-clicked.

Methods

 | Name | Description
 | GetPopupBodyBackgroundColor | Gets the annotation's PopupBody's background color.
 | GetPopupBodyForegroundColor | Returns the color that will be used by the text on the PopupBody.
Public method | InitializeComponent | InitializeComponent

Fields

Name | Description
AnnotationProperty | Dependency Property for Annotation

Properties

 | Name | Description
Public property | Annotation | The Annotation for this popup body
Public property | BackgroundColor | The background color of this popup body.
Public property | ForegroundColor | The foreground (text) color of this popup body.

Events

 | Name | Description
Public event | CloseBoxClicked | Occurs when the close (minimize) box is clicked.
Public event | CommentTextBoxLostFocus | Occurs when the comment text box looses focus.
Public event | CommentTextBoxMouseEnter | Occurs when the mouse enters the comment text box.
Public event | CommentTextBoxMouseLeave | Occures when the mouse leaves the comment text box.
Public event | PropertyChanged |

See Also

PopupBody Class
PDFTron.SilverDox.Documents.Annotations Namespace


PopupBody Constructor

[image]

PDFTron SilverDox SDK
PopupBody Constructor
PopupBody Class See Also Send Feedback
The popup that is displayed when an annotation is double-clicked.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public PopupBody()
Visual Basic
Public Sub New
Visual C++
public:
PopupBody()

See Also

PopupBody Class
PDFTron.SilverDox.Documents.Annotations Namespace


PopupBody Fields

[image] [image]

PDFTron SilverDox SDK
PopupBody Fields
PopupBody Class See Also Send Feedback

The PopupBody type exposes the following members.

Fields

Name | Description
AnnotationProperty | Dependency Property for Annotation

See Also

PopupBody Class
PDFTron.SilverDox.Documents.Annotations Namespace


AnnotationProperty Field

[image]

PDFTron SilverDox SDK
PopupBody..::..AnnotationProperty Field
PopupBody Class See Also Send Feedback
Dependency Property for Annotation

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public static readonly DependencyProperty AnnotationProperty
Visual Basic
Public Shared ReadOnly AnnotationProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ AnnotationProperty

See Also

PopupBody Class
PDFTron.SilverDox.Documents.Annotations Namespace


PopupBody Methods

[image] [image]

PDFTron SilverDox SDK
PopupBody Methods
PopupBody Class See Also Send Feedback

The PopupBody type exposes the following members.

Methods

 | Name | Description
 | GetPopupBodyBackgroundColor | Gets the annotation's PopupBody's background color.
 | GetPopupBodyForegroundColor | Returns the color that will be used by the text on the PopupBody.
Public method | InitializeComponent | InitializeComponent

See Also

PopupBody Class
PDFTron.SilverDox.Documents.Annotations Namespace


GetPopupBodyBackgroundColor Method

[image]

PDFTron SilverDox SDK
PopupBody..::..GetPopupBodyBackgroundColor Method
PopupBody Class See Also Send Feedback
Gets the annotation's PopupBody's background color.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public static Color GetPopupBodyBackgroundColor(
    Annotation annot
)
Visual Basic
Public Shared Function GetPopupBodyBackgroundColor ( _
    annot As Annotation _
) As Color
Visual C++
public:
static Color GetPopupBodyBackgroundColor(
    Annotation^ annot
)

Parameters

annot
Type: PDFTron.SilverDox.Documents.Annotations..::..Annotation
An annotation.

Return Value

The annotation's PopupBody's background color.

Remarks

If the annotation is of type Markup, then the color is equal to the annotation's fill color, or if the fill color is transparent, then the stroke color.

See Also

PopupBody Class
PDFTron.SilverDox.Documents.Annotations Namespace


GetPopupBodyForegroundColor Method

[image]

PDFTron SilverDox SDK
PopupBody..::..GetPopupBodyForegroundColor Method
PopupBody Class See Also Send Feedback
Returns the color that will be used by the text on the PopupBody.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public static Color GetPopupBodyForegroundColor(
    Annotation annot
)
Visual Basic
Public Shared Function GetPopupBodyForegroundColor ( _
    annot As Annotation _
) As Color
Visual C++
public:
static Color GetPopupBodyForegroundColor(
    Annotation^ annot
)

Parameters

annot
Type: PDFTron.SilverDox.Documents.Annotations..::..Annotation
An annotation.

Return Value

The color of the text on the PopupBody.

Remarks

The color is either black or white, depending on which has the higher contrast with the PopupBody's BackgroundColor.

See Also

PopupBody Class
PDFTron.SilverDox.Documents.Annotations Namespace


InitializeComponent Method

[image]

PDFTron SilverDox SDK
PopupBody..::..InitializeComponent Method
PopupBody Class See Also Send Feedback
InitializeComponent

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void InitializeComponent()
Visual Basic
Public Sub InitializeComponent
Visual C++
public:
void InitializeComponent()

See Also

PopupBody Class
PDFTron.SilverDox.Documents.Annotations Namespace


PopupBody Properties

[image] [image]

PDFTron SilverDox SDK
PopupBody Properties
PopupBody Class See Also Send Feedback

The PopupBody type exposes the following members.

Properties

 | Name | Description
Public property | Annotation | The Annotation for this popup body
Public property | BackgroundColor | The background color of this popup body.
Public property | ForegroundColor | The foreground (text) color of this popup body.

See Also

PopupBody Class
PDFTron.SilverDox.Documents.Annotations Namespace


Annotation Property

[image]

PDFTron SilverDox SDK
PopupBody..::..Annotation Property
PopupBody Class See Also Send Feedback
The Annotation for this popup body

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Annotation Annotation { get; set; }
Visual Basic
Public Property Annotation As Annotation
    Get
    Set
Visual C++
public:
property Annotation^ Annotation {
    Annotation^ get ();
    void set (Annotation^ value);
}

See Also

PopupBody Class
PDFTron.SilverDox.Documents.Annotations Namespace


BackgroundColor Property

[image]

PDFTron SilverDox SDK
PopupBody..::..BackgroundColor Property
PopupBody Class See Also Send Feedback
The background color of this popup body.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public SolidColorBrush BackgroundColor { get; private set; }
Visual Basic
Public Property BackgroundColor As SolidColorBrush
    Get
    Private Set
Visual C++
public:
property SolidColorBrush^ BackgroundColor {
    SolidColorBrush^ get ();
    private: void set (SolidColorBrush^ value);
}

See Also

PopupBody Class
PDFTron.SilverDox.Documents.Annotations Namespace


ForegroundColor Property

[image]

PDFTron SilverDox SDK
PopupBody..::..ForegroundColor Property
PopupBody Class See Also Send Feedback
The foreground (text) color of this popup body.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public SolidColorBrush ForegroundColor { get; private set; }
Visual Basic
Public Property ForegroundColor As SolidColorBrush
    Get
    Private Set
Visual C++
public:
property SolidColorBrush^ ForegroundColor {
    SolidColorBrush^ get ();
    private: void set (SolidColorBrush^ value);
}

See Also

PopupBody Class
PDFTron.SilverDox.Documents.Annotations Namespace


PopupBody Events

[image] [image]

PDFTron SilverDox SDK
PopupBody Events
PopupBody Class See Also Send Feedback

The PopupBody type exposes the following members.

Events

 | Name | Description
Public event | CloseBoxClicked | Occurs when the close (minimize) box is clicked.
Public event | CommentTextBoxLostFocus | Occurs when the comment text box looses focus.
Public event | CommentTextBoxMouseEnter | Occurs when the mouse enters the comment text box.
Public event | CommentTextBoxMouseLeave | Occures when the mouse leaves the comment text box.
Public event | PropertyChanged |

See Also

PopupBody Class
PDFTron.SilverDox.Documents.Annotations Namespace


CloseBoxClicked Event

[image]

PDFTron SilverDox SDK
PopupBody..::..CloseBoxClicked Event
PopupBody Class See Also Send Feedback
Occurs when the close (minimize) box is clicked.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public event EventHandler<MouseButtonEventArgs> CloseBoxClicked
Visual Basic
Public Event CloseBoxClicked As EventHandler(Of MouseButtonEventArgs)
Visual C++
public:
 event EventHandler<MouseButtonEventArgs^>^ CloseBoxClicked {
    void add (EventHandler<MouseButtonEventArgs^>^ value);
    void remove (EventHandler<MouseButtonEventArgs^>^ value);
}

See Also

PopupBody Class
PDFTron.SilverDox.Documents.Annotations Namespace


CommentTextBoxLostFocus Event

[image]

PDFTron SilverDox SDK
PopupBody..::..CommentTextBoxLostFocus Event
PopupBody Class See Also Send Feedback
Occurs when the comment text box looses focus.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public event EventHandler<RoutedEventArgs> CommentTextBoxLostFocus
Visual Basic
Public Event CommentTextBoxLostFocus As EventHandler(Of RoutedEventArgs)
Visual C++
public:
 event EventHandler<RoutedEventArgs^>^ CommentTextBoxLostFocus {
    void add (EventHandler<RoutedEventArgs^>^ value);
    void remove (EventHandler<RoutedEventArgs^>^ value);
}

See Also

PopupBody Class
PDFTron.SilverDox.Documents.Annotations Namespace


CommentTextBoxMouseEnter Event

[image]

PDFTron SilverDox SDK
PopupBody..::..CommentTextBoxMouseEnter Event
PopupBody Class See Also Send Feedback
Occurs when the mouse enters the comment text box.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public event EventHandler<MouseEventArgs> CommentTextBoxMouseEnter
Visual Basic
Public Event CommentTextBoxMouseEnter As EventHandler(Of MouseEventArgs)
Visual C++
public:
 event EventHandler<MouseEventArgs^>^ CommentTextBoxMouseEnter {
    void add (EventHandler<MouseEventArgs^>^ value);
    void remove (EventHandler<MouseEventArgs^>^ value);
}

See Also

PopupBody Class
PDFTron.SilverDox.Documents.Annotations Namespace


CommentTextBoxMouseLeave Event

[image]

PDFTron SilverDox SDK
PopupBody..::..CommentTextBoxMouseLeave Event
PopupBody Class See Also Send Feedback
Occures when the mouse leaves the comment text box.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public event EventHandler<MouseEventArgs> CommentTextBoxMouseLeave
Visual Basic
Public Event CommentTextBoxMouseLeave As EventHandler(Of MouseEventArgs)
Visual C++
public:
 event EventHandler<MouseEventArgs^>^ CommentTextBoxMouseLeave {
    void add (EventHandler<MouseEventArgs^>^ value);
    void remove (EventHandler<MouseEventArgs^>^ value);
}

See Also

PopupBody Class
PDFTron.SilverDox.Documents.Annotations Namespace


PropertyChanged Event

[image]

PDFTron SilverDox SDK
PopupBody..::..PropertyChanged Event
PopupBody Class See Also Send Feedback

[Missing <summary> documentation for "E:PDFTron.SilverDox.Documents.Annotations.PopupBody.PropertyChanged"]

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

PopupBody Class
PDFTron.SilverDox.Documents.Annotations Namespace


Rectangle Class

[image]

PDFTron SilverDox SDK
Rectangle Class
Members See Also Send Feedback
Represents a rectagle annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class Rectangle : Markup
Visual Basic
Public Class Rectangle _
    Inherits Markup
Visual C++
public ref class Rectangle : public Markup

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents.Annotations..::..Annotation
PDFTron.SilverDox.Documents.Annotations..::..Markup
PDFTron.SilverDox.Documents.Annotations..::..Rectangle

See Also

Rectangle Members
PDFTron.SilverDox.Documents.Annotations Namespace


Rectangle Members

[image] [image]

PDFTron SilverDox SDK
Rectangle Members
Rectangle Class Constructors Methods Fields Properties Events See Also Send Feedback

The Rectangle type exposes the following members.

Constructors

 | Name | Description
Public method | Rectangle()()()() | Creates a new instance of the Rectangle class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).
Public method | Rectangle(AnnotationManager) | Creates a new instance of the Rectangle class.

Methods

 | Name | Description
 | Create | Creates a new instance of the Rectangle class.
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen. (Overrides Annotation..::..CreateAppearanceCanvas()()()().)
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas. (Inherited from Annotation.)
Public method | OnAnnotationResizeEnded | Called by the annotation's AnnotationManager when the user has finished resizing the annotation (Inherited from Annotation.)
Public method | OnAnnotationResizeStarted | Called by the annotation's AnnotationManager when the user has began resizing this annotation (Inherited from Annotation.)
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseUp | Called by the annotation's AnnotationManager when a MouseUp event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)

Fields

 | Name | Description
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse (Inherited from Annotation.)

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager. (Inherited from Annotation.)
Public property | Author | Represents the author of the annotation. Default is an empty string. (Inherited from Annotation.)
Public property | Bottom | Gets the y-axis value of the bottom of the annotation. (Inherited from Annotation.)
Public property | DateModified | Gets or sets the last date and time that the annotation was modified. (Inherited from Annotation.)
Public property | FillColor | Gets or sets the color of the annotation's interior. (Inherited from Markup.)
Public property | Height | Gets or sets the annotation's height. (Inherited from Markup.)
Public property | Id | A unique identifier that can be assigned to determine different annotations (Inherited from Annotation.)
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation (Inherited from Annotation.)
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user. (Inherited from Annotation.)
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true (Inherited from Annotation.)
Public property | Left | Gets the x-axis value of the left side of the annotation. (Inherited from Annotation.)
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally. (Inherited from Annotation.)
Public property | MirroredVertically | True if the annotation has been mirrored vertically. (Inherited from Annotation.)
Public property | NoMove | Gets or sets if this annotation can be moved by the user. (Inherited from Annotation.)
Public property | NoResize | Gets or sets if this annotation can be resized by the user. (Inherited from Annotation.)
Public property | NoZoom | Gets or sets if this annotation scales with the page. (Inherited from Annotation.)
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on. (Inherited from Annotation.)
Public property | PopupContents | Gets or sets the contents of the annotation's popup. (Inherited from Annotation.)
Public property | PopupHeight | Gets or sets the annotation's popup's height. (Inherited from Annotation.)
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible. (Inherited from Annotation.)
Public property | PopupWidth | Gets or sets the annotation's popup's width. (Inherited from Annotation.)
Public property | PopupX | Gets or sets the annotation's popup's x-axis position. (Inherited from Annotation.)
Public property | PopupY | Gets or sets the annotation's popup's y-axis position. (Inherited from Annotation.)
Public property | Right | Gets the x-axis value of the right side of the annotation. (Inherited from Annotation.)
Public property | StrokeColor | Gets or sets the color of the annotation's stroke. (Inherited from Markup.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline the annotation. (Inherited from Markup.)
Public property | StrokeThickness | Gets or sets the width of the annotation's stroke outline. (Inherited from Markup.)
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type. (Inherited from Annotation.)
Public property | Top | Gets the y-axis position of the top of the annotation. (Inherited from Annotation.)
Public property | Width | Gets or sets the annotation's width. (Inherited from Markup.)
Public property | X | Gets or sets the annotation's x-axis position. (Inherited from Markup.)
Public property | Y | Gets or sets the annotation's y-axis position. (Inherited from Markup.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation (Inherited from Annotation.)

See Also

Rectangle Class
PDFTron.SilverDox.Documents.Annotations Namespace


Rectangle Constructor

[image] [image]

PDFTron SilverDox SDK
Rectangle Constructor
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Rectangle()()()() | Creates a new instance of the Rectangle class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).
Public method | Rectangle(AnnotationManager) | Creates a new instance of the Rectangle class.

See Also

Rectangle Class
Rectangle Members
PDFTron.SilverDox.Documents.Annotations Namespace


Rectangle Constructor

[image]

PDFTron SilverDox SDK
Rectangle Constructor
Rectangle Class See Also Send Feedback
Creates a new instance of the Rectangle class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Rectangle()
Visual Basic
Public Sub New
Visual C++
public:
Rectangle()

See Also

Rectangle Class
Rectangle Overload
PDFTron.SilverDox.Documents.Annotations Namespace


Rectangle Constructor (AnnotationManager)

[image]

PDFTron SilverDox SDK
Rectangle Constructor (AnnotationManager)
Rectangle Class See Also Send Feedback
Creates a new instance of the Rectangle class.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Rectangle(
    AnnotationManager annotationManager
)
Visual Basic
Public Sub New ( _
    annotationManager As AnnotationManager _
)
Visual C++
public:
Rectangle(
    AnnotationManager^ annotationManager
)

Parameters

annotationManager
Type: PDFTron.SilverDox.Documents.Annotations..::..AnnotationManager
The AnnotationManager that is associated with the annotation.

See Also

Rectangle Class
Rectangle Overload
PDFTron.SilverDox.Documents.Annotations Namespace


Rectangle Fields

[image] [image]

PDFTron SilverDox SDK
Rectangle Fields
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Fields

 | Name | Description
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse (Inherited from Annotation.)

See Also

Rectangle Class
PDFTron.SilverDox.Documents.Annotations Namespace


Rectangle Methods

[image] [image]

PDFTron SilverDox SDK
Rectangle Methods
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new instance of the Rectangle class.
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen. (Overrides Annotation..::..CreateAppearanceCanvas()()()().)
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas. (Inherited from Annotation.)
Public method | OnAnnotationResizeEnded | Called by the annotation's AnnotationManager when the user has finished resizing the annotation (Inherited from Annotation.)
Public method | OnAnnotationResizeStarted | Called by the annotation's AnnotationManager when the user has began resizing this annotation (Inherited from Annotation.)
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseUp | Called by the annotation's AnnotationManager when a MouseUp event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)

See Also

Rectangle Class
PDFTron.SilverDox.Documents.Annotations Namespace


Create Method

[image]

PDFTron SilverDox SDK
Rectangle..::..Create Method
Rectangle Class See Also Send Feedback
Creates a new instance of the Rectangle class.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public static Rectangle Create(
    AnnotationManager annotationManager
)
Visual Basic
Public Shared Function Create ( _
    annotationManager As AnnotationManager _
) As Rectangle
Visual C++
public:
static Rectangle^ Create(
    AnnotationManager^ annotationManager
)

Parameters

annotationManager
Type: PDFTron.SilverDox.Documents.Annotations..::..AnnotationManager
The AnnotationManager that is associated with the annotation.

Return Value

A new Rectangle annotation.

See Also

Rectangle Class
PDFTron.SilverDox.Documents.Annotations Namespace


CreateAppearanceCanvas Method

[image]

PDFTron SilverDox SDK
Rectangle..::..CreateAppearanceCanvas Method
Rectangle Class See Also Send Feedback
Creates and returns the annotation's appearance canvas that will be displayed on screen.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override Canvas CreateAppearanceCanvas()
Visual Basic
Public Overrides Function CreateAppearanceCanvas As Canvas
Visual C++
public:
virtual Canvas^ CreateAppearanceCanvas() override

Return Value

The annotation's appearance canvas.

See Also

Rectangle Class
PDFTron.SilverDox.Documents.Annotations Namespace


Rectangle Properties

[image] [image]

PDFTron SilverDox SDK
Rectangle Properties
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager. (Inherited from Annotation.)
Public property | Author | Represents the author of the annotation. Default is an empty string. (Inherited from Annotation.)
Public property | Bottom | Gets the y-axis value of the bottom of the annotation. (Inherited from Annotation.)
Public property | DateModified | Gets or sets the last date and time that the annotation was modified. (Inherited from Annotation.)
Public property | FillColor | Gets or sets the color of the annotation's interior. (Inherited from Markup.)
Public property | Height | Gets or sets the annotation's height. (Inherited from Markup.)
Public property | Id | A unique identifier that can be assigned to determine different annotations (Inherited from Annotation.)
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation (Inherited from Annotation.)
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user. (Inherited from Annotation.)
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true (Inherited from Annotation.)
Public property | Left | Gets the x-axis value of the left side of the annotation. (Inherited from Annotation.)
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally. (Inherited from Annotation.)
Public property | MirroredVertically | True if the annotation has been mirrored vertically. (Inherited from Annotation.)
Public property | NoMove | Gets or sets if this annotation can be moved by the user. (Inherited from Annotation.)
Public property | NoResize | Gets or sets if this annotation can be resized by the user. (Inherited from Annotation.)
Public property | NoZoom | Gets or sets if this annotation scales with the page. (Inherited from Annotation.)
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on. (Inherited from Annotation.)
Public property | PopupContents | Gets or sets the contents of the annotation's popup. (Inherited from Annotation.)
Public property | PopupHeight | Gets or sets the annotation's popup's height. (Inherited from Annotation.)
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible. (Inherited from Annotation.)
Public property | PopupWidth | Gets or sets the annotation's popup's width. (Inherited from Annotation.)
Public property | PopupX | Gets or sets the annotation's popup's x-axis position. (Inherited from Annotation.)
Public property | PopupY | Gets or sets the annotation's popup's y-axis position. (Inherited from Annotation.)
Public property | Right | Gets the x-axis value of the right side of the annotation. (Inherited from Annotation.)
Public property | StrokeColor | Gets or sets the color of the annotation's stroke. (Inherited from Markup.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline the annotation. (Inherited from Markup.)
Public property | StrokeThickness | Gets or sets the width of the annotation's stroke outline. (Inherited from Markup.)
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type. (Inherited from Annotation.)
Public property | Top | Gets the y-axis position of the top of the annotation. (Inherited from Annotation.)
Public property | Width | Gets or sets the annotation's width. (Inherited from Markup.)
Public property | X | Gets or sets the annotation's x-axis position. (Inherited from Markup.)
Public property | Y | Gets or sets the annotation's y-axis position. (Inherited from Markup.)

See Also

Rectangle Class
PDFTron.SilverDox.Documents.Annotations Namespace


Rectangle Events

[image] [image]

PDFTron SilverDox SDK
Rectangle Events
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation (Inherited from Annotation.)

See Also

Rectangle Class
PDFTron.SilverDox.Documents.Annotations Namespace


Sticky Class

[image]

PDFTron SilverDox SDK
Sticky Class
Members See Also Send Feedback
Represents a sticky note annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class Sticky : Annotation
Visual Basic
Public Class Sticky _
    Inherits Annotation
Visual C++
public ref class Sticky : public Annotation

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents.Annotations..::..Annotation
PDFTron.SilverDox.Documents.Annotations..::..Sticky

See Also

Sticky Members
PDFTron.SilverDox.Documents.Annotations Namespace


Sticky Members

[image] [image]

PDFTron SilverDox SDK
Sticky Members
Sticky Class Constructors Methods Fields Properties Events See Also Send Feedback

The Sticky type exposes the following members.

Constructors

 | Name | Description
Public method | Sticky()()()() | Creates a new instance of the Sticky class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).
Public method | Sticky(AnnotationManager) | Creates a new instance of the Sticky class.

Methods

 | Name | Description
 | Create | Creates a new instance of the Sticky class.
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen. (Overrides Annotation..::..CreateAppearanceCanvas()()()().)
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas. (Inherited from Annotation.)
Public method | OnAnnotationResizeEnded | Called by the annotation's AnnotationManager when the user has finished resizing the annotation (Inherited from Annotation.)
Public method | OnAnnotationResizeStarted | Called by the annotation's AnnotationManager when the user has began resizing this annotation (Inherited from Annotation.)
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation. (Overrides Annotation..::..OnCreateMouseMove(MouseEventArgs).)
Public method | OnCreateMouseUp | Called by the annotation's AnnotationManager when a MouseUp event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)

Fields

 | Name | Description
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse (Inherited from Annotation.)

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager. (Inherited from Annotation.)
Public property | Author | Represents the author of the annotation. Default is an empty string. (Inherited from Annotation.)
Public property | Bottom | Gets the y-axis value of the bottom of the annotation. (Inherited from Annotation.)
Public property | DateModified | Gets or sets the last date and time that the annotation was modified. (Inherited from Annotation.)
Public property | Height | Gets the height of the annotation. (Overrides Annotation..::..Height.)
Public property | Id | A unique identifier that can be assigned to determine different annotations (Inherited from Annotation.)
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation (Inherited from Annotation.)
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user. (Inherited from Annotation.)
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true (Inherited from Annotation.)
Public property | Left | Gets the x-axis value of the left side of the annotation. (Inherited from Annotation.)
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally. (Inherited from Annotation.)
Public property | MirroredVertically | True if the annotation has been mirrored vertically. (Inherited from Annotation.)
Public property | NoMove | Gets or sets if this annotation can be moved by the user. (Inherited from Annotation.)
Public property | NoResize | Gets or sets if this annotation can be resized by the user. (Inherited from Annotation.)
Public property | NoZoom | Gets or sets if this annotation scales with the page. (Inherited from Annotation.)
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on. (Inherited from Annotation.)
Public property | PopupContents | Gets or sets the contents of the annotation's popup. (Inherited from Annotation.)
Public property | PopupHeight | Gets or sets the annotation's popup's height. (Inherited from Annotation.)
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible. (Inherited from Annotation.)
Public property | PopupWidth | Gets or sets the annotation's popup's width. (Inherited from Annotation.)
Public property | PopupX | Gets or sets the annotation's popup's x-axis position. (Inherited from Annotation.)
Public property | PopupY | Gets or sets the annotation's popup's y-axis position. (Inherited from Annotation.)
Public property | Right | Gets the x-axis value of the right side of the annotation. (Inherited from Annotation.)
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type. (Inherited from Annotation.)
Public property | Top | Gets the y-axis position of the top of the annotation. (Inherited from Annotation.)
Public property | Width | Gets the width of the annotation. (Overrides Annotation..::..Width.)
Public property | X | Gets or sets the annotation's x-axis position. (Inherited from Annotation.)
Public property | Y | Gets or sets the annotation's y-axis position. (Inherited from Annotation.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation (Inherited from Annotation.)

See Also

Sticky Class
PDFTron.SilverDox.Documents.Annotations Namespace


Sticky Constructor

[image] [image]

PDFTron SilverDox SDK
Sticky Constructor
Sticky Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sticky()()()() | Creates a new instance of the Sticky class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).
Public method | Sticky(AnnotationManager) | Creates a new instance of the Sticky class.

See Also

Sticky Class
Sticky Members
PDFTron.SilverDox.Documents.Annotations Namespace


Sticky Constructor

[image]

PDFTron SilverDox SDK
Sticky Constructor
Sticky Class See Also Send Feedback
Creates a new instance of the Sticky class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Sticky()
Visual Basic
Public Sub New
Visual C++
public:
Sticky()

See Also

Sticky Class
Sticky Overload
PDFTron.SilverDox.Documents.Annotations Namespace


Sticky Constructor (AnnotationManager)

[image]

PDFTron SilverDox SDK
Sticky Constructor (AnnotationManager)
Sticky Class See Also Send Feedback
Creates a new instance of the Sticky class.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Sticky(
    AnnotationManager annotationManager
)
Visual Basic
Public Sub New ( _
    annotationManager As AnnotationManager _
)
Visual C++
public:
Sticky(
    AnnotationManager^ annotationManager
)

Parameters

annotationManager
Type: PDFTron.SilverDox.Documents.Annotations..::..AnnotationManager
The AnnotationManager that is associated with the annotation.

See Also

Sticky Class
Sticky Overload
PDFTron.SilverDox.Documents.Annotations Namespace


Sticky Fields

[image] [image]

PDFTron SilverDox SDK
Sticky Fields
Sticky Class See Also Send Feedback

The Sticky type exposes the following members.

Fields

 | Name | Description
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse (Inherited from Annotation.)

See Also

Sticky Class
PDFTron.SilverDox.Documents.Annotations Namespace


Sticky Methods

[image] [image]

PDFTron SilverDox SDK
Sticky Methods
Sticky Class See Also Send Feedback

The Sticky type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new instance of the Sticky class.
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen. (Overrides Annotation..::..CreateAppearanceCanvas()()()().)
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas. (Inherited from Annotation.)
Public method | OnAnnotationResizeEnded | Called by the annotation's AnnotationManager when the user has finished resizing the annotation (Inherited from Annotation.)
Public method | OnAnnotationResizeStarted | Called by the annotation's AnnotationManager when the user has began resizing this annotation (Inherited from Annotation.)
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation. (Overrides Annotation..::..OnCreateMouseMove(MouseEventArgs).)
Public method | OnCreateMouseUp | Called by the annotation's AnnotationManager when a MouseUp event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)

See Also

Sticky Class
PDFTron.SilverDox.Documents.Annotations Namespace


Create Method

[image]

PDFTron SilverDox SDK
Sticky..::..Create Method
Sticky Class See Also Send Feedback
Creates a new instance of the Sticky class.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public static Sticky Create(
    AnnotationManager annotationManager
)
Visual Basic
Public Shared Function Create ( _
    annotationManager As AnnotationManager _
) As Sticky
Visual C++
public:
static Sticky^ Create(
    AnnotationManager^ annotationManager
)

Parameters

annotationManager
Type: PDFTron.SilverDox.Documents.Annotations..::..AnnotationManager
The AnnotationManager that is associated with the annotation.

Return Value

A new Sticky annotation.

See Also

Sticky Class
PDFTron.SilverDox.Documents.Annotations Namespace


CreateAppearanceCanvas Method

[image]

PDFTron SilverDox SDK
Sticky..::..CreateAppearanceCanvas Method
Sticky Class See Also Send Feedback
Creates and returns the annotation's appearance canvas that will be displayed on screen.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override Canvas CreateAppearanceCanvas()
Visual Basic
Public Overrides Function CreateAppearanceCanvas As Canvas
Visual C++
public:
virtual Canvas^ CreateAppearanceCanvas() override

Return Value

The annotation's appearance canvas.

See Also

Sticky Class
PDFTron.SilverDox.Documents.Annotations Namespace


OnCreateMouseMove Method

[image]

PDFTron SilverDox SDK
Sticky..::..OnCreateMouseMove Method
Sticky Class See Also Send Feedback
Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override void OnCreateMouseMove(
    MouseEventArgs mouseMoveEventArgs
)
Visual Basic
Public Overrides Sub OnCreateMouseMove ( _
    mouseMoveEventArgs As MouseEventArgs _
)
Visual C++
public:
virtual void OnCreateMouseMove(
    MouseEventArgs^ mouseMoveEventArgs
) override

Parameters

mouseMoveEventArgs
Type: System.Windows.Input..::..MouseEventArgs
The event data.

See Also

Sticky Class
PDFTron.SilverDox.Documents.Annotations Namespace


Sticky Properties

[image] [image]

PDFTron SilverDox SDK
Sticky Properties
Sticky Class See Also Send Feedback

The Sticky type exposes the following members.

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager. (Inherited from Annotation.)
Public property | Author | Represents the author of the annotation. Default is an empty string. (Inherited from Annotation.)
Public property | Bottom | Gets the y-axis value of the bottom of the annotation. (Inherited from Annotation.)
Public property | DateModified | Gets or sets the last date and time that the annotation was modified. (Inherited from Annotation.)
Public property | Height | Gets the height of the annotation. (Overrides Annotation..::..Height.)
Public property | Id | A unique identifier that can be assigned to determine different annotations (Inherited from Annotation.)
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation (Inherited from Annotation.)
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user. (Inherited from Annotation.)
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true (Inherited from Annotation.)
Public property | Left | Gets the x-axis value of the left side of the annotation. (Inherited from Annotation.)
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally. (Inherited from Annotation.)
Public property | MirroredVertically | True if the annotation has been mirrored vertically. (Inherited from Annotation.)
Public property | NoMove | Gets or sets if this annotation can be moved by the user. (Inherited from Annotation.)
Public property | NoResize | Gets or sets if this annotation can be resized by the user. (Inherited from Annotation.)
Public property | NoZoom | Gets or sets if this annotation scales with the page. (Inherited from Annotation.)
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on. (Inherited from Annotation.)
Public property | PopupContents | Gets or sets the contents of the annotation's popup. (Inherited from Annotation.)
Public property | PopupHeight | Gets or sets the annotation's popup's height. (Inherited from Annotation.)
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible. (Inherited from Annotation.)
Public property | PopupWidth | Gets or sets the annotation's popup's width. (Inherited from Annotation.)
Public property | PopupX | Gets or sets the annotation's popup's x-axis position. (Inherited from Annotation.)
Public property | PopupY | Gets or sets the annotation's popup's y-axis position. (Inherited from Annotation.)
Public property | Right | Gets the x-axis value of the right side of the annotation. (Inherited from Annotation.)
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type. (Inherited from Annotation.)
Public property | Top | Gets the y-axis position of the top of the annotation. (Inherited from Annotation.)
Public property | Width | Gets the width of the annotation. (Overrides Annotation..::..Width.)
Public property | X | Gets or sets the annotation's x-axis position. (Inherited from Annotation.)
Public property | Y | Gets or sets the annotation's y-axis position. (Inherited from Annotation.)

See Also

Sticky Class
PDFTron.SilverDox.Documents.Annotations Namespace


Height Property

[image]

PDFTron SilverDox SDK
Sticky..::..Height Property
Sticky Class See Also Send Feedback
Gets the height of the annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override double Height { get; set; }
Visual Basic
Public Overrides Property Height As Double
    Get
    Set
Visual C++
public:
virtual property double Height {
    double get () override;
    void set (double value) override;
}

See Also

Sticky Class
PDFTron.SilverDox.Documents.Annotations Namespace


Width Property

[image]

PDFTron SilverDox SDK
Sticky..::..Width Property
Sticky Class See Also Send Feedback
Gets the width of the annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override double Width { get; set; }
Visual Basic
Public Overrides Property Width As Double
    Get
    Set
Visual C++
public:
virtual property double Width {
    double get () override;
    void set (double value) override;
}

See Also

Sticky Class
PDFTron.SilverDox.Documents.Annotations Namespace


Sticky Events

[image] [image]

PDFTron SilverDox SDK
Sticky Events
Sticky Class See Also Send Feedback

The Sticky type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation (Inherited from Annotation.)

See Also

Sticky Class
PDFTron.SilverDox.Documents.Annotations Namespace


TextHighlight Class

[image]

PDFTron SilverDox SDK
TextHighlight Class
Members See Also Send Feedback
Represents a text highlight annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class TextHighlight : TextMarkup
Visual Basic
Public Class TextHighlight _
    Inherits TextMarkup
Visual C++
public ref class TextHighlight : public TextMarkup

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents.Annotations..::..Annotation
PDFTron.SilverDox.Documents.Annotations..::..Markup
PDFTron.SilverDox.Documents.Annotations..::..TextMarkup
PDFTron.SilverDox.Documents.Annotations..::..TextHighlight

See Also

TextHighlight Members
PDFTron.SilverDox.Documents.Annotations Namespace


TextHighlight Members

[image] [image]

PDFTron SilverDox SDK
TextHighlight Members
TextHighlight Class Constructors Methods Fields Properties Events See Also Send Feedback

The TextHighlight type exposes the following members.

Constructors

 | Name | Description
Public method | TextHighlight()()()() | Creates a new instance of the TextHighlight class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).
Public method | TextHighlight(AnnotationManager) | Creates a new instance of the TextHighlight class.

Methods

 | Name | Description
 | Create | Creates a new instance of the TextHighlight class.
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen. (Inherited from TextMarkup.)
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas. (Inherited from Annotation.)
Protected method | DrawTextAnnotation | Alters Appearance using the TextQuads so that the text is highlighted. (Overrides TextMarkup..::..DrawTextAnnotation()()()().)
Public method | OnAnnotationResizeEnded | Called by the annotation's AnnotationManager when the user has finished resizing the annotation (Inherited from Annotation.)
Public method | OnAnnotationResizeStarted | Called by the annotation's AnnotationManager when the user has began resizing this annotation (Inherited from Annotation.)
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation. (Inherited from TextMarkup.)
Public method | OnCreateMouseUp | Called by the annotation's AnnotationManager when a MouseUp event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)

Fields

 | Name | Description
Protected field | Appearance | The canvas that was last returned by the method CreateAppearanceCanvas()()()(). (Inherited from TextMarkup.)
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse (Inherited from Annotation.)

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager. (Inherited from Annotation.)
Public property | Author | Represents the author of the annotation. Default is an empty string. (Inherited from Annotation.)
Public property | Bottom | Gets the y-axis value of the bottom of the annotation. (Inherited from Annotation.)
Public property | DateModified | Gets or sets the last date and time that the annotation was modified. (Inherited from Annotation.)
Protected property | Document | The document that is used to determine the location of the text on a page. (Inherited from TextMarkup.)
Public property | FillColor | Gets or sets the color of the annotation's interior. (Inherited from Markup.)
Public property | Height | Gets or sets the annotation's height. (Inherited from Markup.)
Public property | Id | A unique identifier that can be assigned to determine different annotations (Inherited from Annotation.)
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation Returns false by default for TextMarkup annotations (Inherited from TextMarkup.)
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user. (Inherited from Annotation.)
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true (Inherited from Annotation.)
Public property | Left | Gets the x-axis value of the left side of the annotation. (Inherited from Annotation.)
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally. (Inherited from Annotation.)
Public property | MirroredVertically | True if the annotation has been mirrored vertically. (Inherited from Annotation.)
Public property | NoMove | Gets or sets if this annotation can be moved by the user. (Inherited from Annotation.)
Public property | NoResize | Gets or sets if this annotation can be resized by the user. (Inherited from Annotation.)
Public property | NoZoom | Gets or sets if this annotation scales with the page. (Inherited from Annotation.)
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on. (Inherited from Annotation.)
Public property | PopupContents | Gets or sets the contents of the annotation's popup. (Inherited from Annotation.)
Public property | PopupHeight | Gets or sets the annotation's popup's height. (Inherited from Annotation.)
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible. (Inherited from Annotation.)
Public property | PopupWidth | Gets or sets the annotation's popup's width. (Inherited from Annotation.)
Public property | PopupX | Gets or sets the annotation's popup's x-axis position. (Inherited from Annotation.)
Public property | PopupY | Gets or sets the annotation's popup's y-axis position. (Inherited from Annotation.)
Public property | Right | Gets the x-axis value of the right side of the annotation. (Inherited from Annotation.)
Public property | SelectEnd | The point at which text selection ends. (Inherited from TextMarkup.)
Public property | SelectStart | The point at which text selection starts. (Inherited from TextMarkup.)
Public property | StrokeColor | Gets or sets the color of the annotation's stroke. (Inherited from Markup.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline the annotation. (Inherited from Markup.)
Public property | StrokeThickness | Gets or sets the width of the annotation's stroke outline. (Inherited from Markup.)
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type. (Inherited from Annotation.)
Public property | TextQuads | Represents the boundaries of the text selected between the corner points defined by SelectStart and SelectEnd. (Inherited from TextMarkup.)
Public property | Top | Gets the y-axis position of the top of the annotation. (Inherited from Annotation.)
Public property | Width | Gets or sets the annotation's width. (Inherited from Markup.)
Public property | X | Gets or sets the annotation's x-axis position. (Inherited from Markup.)
Public property | Y | Gets or sets the annotation's y-axis position. (Inherited from Markup.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation (Inherited from Annotation.)

See Also

TextHighlight Class
PDFTron.SilverDox.Documents.Annotations Namespace


TextHighlight Constructor

[image] [image]

PDFTron SilverDox SDK
TextHighlight Constructor
TextHighlight Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TextHighlight()()()() | Creates a new instance of the TextHighlight class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).
Public method | TextHighlight(AnnotationManager) | Creates a new instance of the TextHighlight class.

See Also

TextHighlight Class
TextHighlight Members
PDFTron.SilverDox.Documents.Annotations Namespace


TextHighlight Constructor

[image]

PDFTron SilverDox SDK
TextHighlight Constructor
TextHighlight Class See Also Send Feedback
Creates a new instance of the TextHighlight class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public TextHighlight()
Visual Basic
Public Sub New
Visual C++
public:
TextHighlight()

See Also

TextHighlight Class
TextHighlight Overload
PDFTron.SilverDox.Documents.Annotations Namespace


TextHighlight Constructor (AnnotationManager)

[image]

PDFTron SilverDox SDK
TextHighlight Constructor (AnnotationManager)
TextHighlight Class See Also Send Feedback
Creates a new instance of the TextHighlight class.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public TextHighlight(
    AnnotationManager annotationManager
)
Visual Basic
Public Sub New ( _
    annotationManager As AnnotationManager _
)
Visual C++
public:
TextHighlight(
    AnnotationManager^ annotationManager
)

Parameters

annotationManager
Type: PDFTron.SilverDox.Documents.Annotations..::..AnnotationManager
The AnnotationManager to associate with this annotation.

See Also

TextHighlight Class
TextHighlight Overload
PDFTron.SilverDox.Documents.Annotations Namespace


TextHighlight Fields

[image] [image]

PDFTron SilverDox SDK
TextHighlight Fields
TextHighlight Class See Also Send Feedback

The TextHighlight type exposes the following members.

Fields

 | Name | Description
Protected field | Appearance | The canvas that was last returned by the method CreateAppearanceCanvas()()()(). (Inherited from TextMarkup.)
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse (Inherited from Annotation.)

See Also

TextHighlight Class
PDFTron.SilverDox.Documents.Annotations Namespace


TextHighlight Methods

[image] [image]

PDFTron SilverDox SDK
TextHighlight Methods
TextHighlight Class See Also Send Feedback

The TextHighlight type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new instance of the TextHighlight class.
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen. (Inherited from TextMarkup.)
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas. (Inherited from Annotation.)
Protected method | DrawTextAnnotation | Alters Appearance using the TextQuads so that the text is highlighted. (Overrides TextMarkup..::..DrawTextAnnotation()()()().)
Public method | OnAnnotationResizeEnded | Called by the annotation's AnnotationManager when the user has finished resizing the annotation (Inherited from Annotation.)
Public method | OnAnnotationResizeStarted | Called by the annotation's AnnotationManager when the user has began resizing this annotation (Inherited from Annotation.)
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation. (Inherited from TextMarkup.)
Public method | OnCreateMouseUp | Called by the annotation's AnnotationManager when a MouseUp event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)

See Also

TextHighlight Class
PDFTron.SilverDox.Documents.Annotations Namespace


Create Method

[image]

PDFTron SilverDox SDK
TextHighlight..::..Create Method
TextHighlight Class See Also Send Feedback
Creates a new instance of the TextHighlight class.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public static TextHighlight Create(
    AnnotationManager annotationManager
)
Visual Basic
Public Shared Function Create ( _
    annotationManager As AnnotationManager _
) As TextHighlight
Visual C++
public:
static TextHighlight^ Create(
    AnnotationManager^ annotationManager
)

Parameters

annotationManager
Type: PDFTron.SilverDox.Documents.Annotations..::..AnnotationManager
The AnnotationManager to associate with this annotation.

Return Value

A new TextHighlight annotation.

See Also

TextHighlight Class
PDFTron.SilverDox.Documents.Annotations Namespace


DrawTextAnnotation Method

[image]

PDFTron SilverDox SDK
TextHighlight..::..DrawTextAnnotation Method
TextHighlight Class See Also Send Feedback
Alters Appearance using the TextQuads so that the text is highlighted.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected override void DrawTextAnnotation()
Visual Basic
Protected Overrides Sub DrawTextAnnotation
Visual C++
protected:
virtual void DrawTextAnnotation() override

Remarks

The method CreateAppearanceCanvas()()()() may return a blank canvas while text location information is retrieved from the document. When the location information (as stored in TextQuads) is ready, DrawTextAnnotation()()()() is asychronously called so that it can mark up the AppearanceCanvas that has already been returned as is being displayed.

See Also

TextHighlight Class
PDFTron.SilverDox.Documents.Annotations Namespace


TextHighlight Properties

[image] [image]

PDFTron SilverDox SDK
TextHighlight Properties
TextHighlight Class See Also Send Feedback

The TextHighlight type exposes the following members.

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager. (Inherited from Annotation.)
Public property | Author | Represents the author of the annotation. Default is an empty string. (Inherited from Annotation.)
Public property | Bottom | Gets the y-axis value of the bottom of the annotation. (Inherited from Annotation.)
Public property | DateModified | Gets or sets the last date and time that the annotation was modified. (Inherited from Annotation.)
Protected property | Document | The document that is used to determine the location of the text on a page. (Inherited from TextMarkup.)
Public property | FillColor | Gets or sets the color of the annotation's interior. (Inherited from Markup.)
Public property | Height | Gets or sets the annotation's height. (Inherited from Markup.)
Public property | Id | A unique identifier that can be assigned to determine different annotations (Inherited from Annotation.)
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation Returns false by default for TextMarkup annotations (Inherited from TextMarkup.)
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user. (Inherited from Annotation.)
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true (Inherited from Annotation.)
Public property | Left | Gets the x-axis value of the left side of the annotation. (Inherited from Annotation.)
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally. (Inherited from Annotation.)
Public property | MirroredVertically | True if the annotation has been mirrored vertically. (Inherited from Annotation.)
Public property | NoMove | Gets or sets if this annotation can be moved by the user. (Inherited from Annotation.)
Public property | NoResize | Gets or sets if this annotation can be resized by the user. (Inherited from Annotation.)
Public property | NoZoom | Gets or sets if this annotation scales with the page. (Inherited from Annotation.)
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on. (Inherited from Annotation.)
Public property | PopupContents | Gets or sets the contents of the annotation's popup. (Inherited from Annotation.)
Public property | PopupHeight | Gets or sets the annotation's popup's height. (Inherited from Annotation.)
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible. (Inherited from Annotation.)
Public property | PopupWidth | Gets or sets the annotation's popup's width. (Inherited from Annotation.)
Public property | PopupX | Gets or sets the annotation's popup's x-axis position. (Inherited from Annotation.)
Public property | PopupY | Gets or sets the annotation's popup's y-axis position. (Inherited from Annotation.)
Public property | Right | Gets the x-axis value of the right side of the annotation. (Inherited from Annotation.)
Public property | SelectEnd | The point at which text selection ends. (Inherited from TextMarkup.)
Public property | SelectStart | The point at which text selection starts. (Inherited from TextMarkup.)
Public property | StrokeColor | Gets or sets the color of the annotation's stroke. (Inherited from Markup.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline the annotation. (Inherited from Markup.)
Public property | StrokeThickness | Gets or sets the width of the annotation's stroke outline. (Inherited from Markup.)
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type. (Inherited from Annotation.)
Public property | TextQuads | Represents the boundaries of the text selected between the corner points defined by SelectStart and SelectEnd. (Inherited from TextMarkup.)
Public property | Top | Gets the y-axis position of the top of the annotation. (Inherited from Annotation.)
Public property | Width | Gets or sets the annotation's width. (Inherited from Markup.)
Public property | X | Gets or sets the annotation's x-axis position. (Inherited from Markup.)
Public property | Y | Gets or sets the annotation's y-axis position. (Inherited from Markup.)

See Also

TextHighlight Class
PDFTron.SilverDox.Documents.Annotations Namespace


TextHighlight Events

[image] [image]

PDFTron SilverDox SDK
TextHighlight Events
TextHighlight Class See Also Send Feedback

The TextHighlight type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation (Inherited from Annotation.)

See Also

TextHighlight Class
PDFTron.SilverDox.Documents.Annotations Namespace


TextMarkup Class

[image]

PDFTron SilverDox SDK
TextMarkup Class
Members See Also Send Feedback
A base class for annotation types that are used to mark up text in a document.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public abstract class TextMarkup : Markup
Visual Basic
Public MustInherit Class TextMarkup _
    Inherits Markup
Visual C++
public ref class TextMarkup abstract : public Markup

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents.Annotations..::..Annotation
PDFTron.SilverDox.Documents.Annotations..::..Markup
PDFTron.SilverDox.Documents.Annotations..::..TextMarkup
PDFTron.SilverDox.Documents.Annotations..::..TextHighlight
PDFTron.SilverDox.Documents.Annotations..::..TextStrikeout
PDFTron.SilverDox.Documents.Annotations..::..TextUnderline

See Also

TextMarkup Members
PDFTron.SilverDox.Documents.Annotations Namespace


TextMarkup Members

[image] [image]

PDFTron SilverDox SDK
TextMarkup Members
TextMarkup Class Constructors Methods Fields Properties Events See Also Send Feedback

The TextMarkup type exposes the following members.

Constructors

 | Name | Description
Protected method | TextMarkup()()()() | Called by subclasses during construction to set properties common to TextMarkup annotations.
Protected method | TextMarkup(AnnotationManager) | Called by subclasses during construction to set properties common to TextMarkup annotations.

Methods

 | Name | Description
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen. (Overrides Annotation..::..CreateAppearanceCanvas()()()().)
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas. (Inherited from Annotation.)
Protected method | DrawTextAnnotation | Alters Appearance using the TextQuads so that the text is marked up as desired.
Public method | OnAnnotationResizeEnded | Called by the annotation's AnnotationManager when the user has finished resizing the annotation (Inherited from Annotation.)
Public method | OnAnnotationResizeStarted | Called by the annotation's AnnotationManager when the user has began resizing this annotation (Inherited from Annotation.)
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation. (Overrides Annotation..::..OnCreateMouseMove(MouseEventArgs).)
Public method | OnCreateMouseUp | Called by the annotation's AnnotationManager when a MouseUp event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)

Fields

 | Name | Description
Protected field | Appearance | The canvas that was last returned by the method CreateAppearanceCanvas()()()().
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse (Inherited from Annotation.)

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager. (Inherited from Annotation.)
Public property | Author | Represents the author of the annotation. Default is an empty string. (Inherited from Annotation.)
Public property | Bottom | Gets the y-axis value of the bottom of the annotation. (Inherited from Annotation.)
Public property | DateModified | Gets or sets the last date and time that the annotation was modified. (Inherited from Annotation.)
Protected property | Document | The document that is used to determine the location of the text on a page.
Public property | FillColor | Gets or sets the color of the annotation's interior. (Inherited from Markup.)
Public property | Height | Gets or sets the annotation's height. (Inherited from Markup.)
Public property | Id | A unique identifier that can be assigned to determine different annotations (Inherited from Annotation.)
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation Returns false by default for TextMarkup annotations (Overrides Annotation..::..IsCopyable.)
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user. (Inherited from Annotation.)
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true (Inherited from Annotation.)
Public property | Left | Gets the x-axis value of the left side of the annotation. (Inherited from Annotation.)
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally. (Inherited from Annotation.)
Public property | MirroredVertically | True if the annotation has been mirrored vertically. (Inherited from Annotation.)
Public property | NoMove | Gets or sets if this annotation can be moved by the user. (Inherited from Annotation.)
Public property | NoResize | Gets or sets if this annotation can be resized by the user. (Inherited from Annotation.)
Public property | NoZoom | Gets or sets if this annotation scales with the page. (Inherited from Annotation.)
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on. (Inherited from Annotation.)
Public property | PopupContents | Gets or sets the contents of the annotation's popup. (Inherited from Annotation.)
Public property | PopupHeight | Gets or sets the annotation's popup's height. (Inherited from Annotation.)
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible. (Inherited from Annotation.)
Public property | PopupWidth | Gets or sets the annotation's popup's width. (Inherited from Annotation.)
Public property | PopupX | Gets or sets the annotation's popup's x-axis position. (Inherited from Annotation.)
Public property | PopupY | Gets or sets the annotation's popup's y-axis position. (Inherited from Annotation.)
Public property | Right | Gets the x-axis value of the right side of the annotation. (Inherited from Annotation.)
Public property | SelectEnd | The point at which text selection ends.
Public property | SelectStart | The point at which text selection starts.
Public property | StrokeColor | Gets or sets the color of the annotation's stroke. (Inherited from Markup.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline the annotation. (Inherited from Markup.)
Public property | StrokeThickness | Gets or sets the width of the annotation's stroke outline. (Inherited from Markup.)
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type. (Inherited from Annotation.)
Public property | TextQuads | Represents the boundaries of the text selected between the corner points defined by SelectStart and SelectEnd.
Public property | Top | Gets the y-axis position of the top of the annotation. (Inherited from Annotation.)
Public property | Width | Gets or sets the annotation's width. (Inherited from Markup.)
Public property | X | Gets or sets the annotation's x-axis position. (Inherited from Markup.)
Public property | Y | Gets or sets the annotation's y-axis position. (Inherited from Markup.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation (Inherited from Annotation.)

See Also

TextMarkup Class
PDFTron.SilverDox.Documents.Annotations Namespace


TextMarkup Constructor

[image] [image]

PDFTron SilverDox SDK
TextMarkup Constructor
TextMarkup Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | TextMarkup()()()() | Called by subclasses during construction to set properties common to TextMarkup annotations.
Protected method | TextMarkup(AnnotationManager) | Called by subclasses during construction to set properties common to TextMarkup annotations.

See Also

TextMarkup Class
TextMarkup Members
PDFTron.SilverDox.Documents.Annotations Namespace


TextMarkup Constructor

[image]

PDFTron SilverDox SDK
TextMarkup Constructor
TextMarkup Class See Also Send Feedback
Called by subclasses during construction to set properties common to TextMarkup annotations.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected TextMarkup()
Visual Basic
Protected Sub New
Visual C++
protected:
TextMarkup()

See Also

TextMarkup Class
TextMarkup Overload
PDFTron.SilverDox.Documents.Annotations Namespace


TextMarkup Constructor (AnnotationManager)

[image]

PDFTron SilverDox SDK
TextMarkup Constructor (AnnotationManager)
TextMarkup Class See Also Send Feedback
Called by subclasses during construction to set properties common to TextMarkup annotations.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected TextMarkup(
    AnnotationManager annotationManager
)
Visual Basic
Protected Sub New ( _
    annotationManager As AnnotationManager _
)
Visual C++
protected:
TextMarkup(
    AnnotationManager^ annotationManager
)

Parameters

annotationManager
Type: PDFTron.SilverDox.Documents.Annotations..::..AnnotationManager

[Missing <param name="annotationManager"/> documentation for "M:PDFTron.SilverDox.Documents.Annotations.TextMarkup.#ctor(PDFTron.SilverDox.Documents.Annotations.AnnotationManager)"]

See Also

TextMarkup Class
TextMarkup Overload
PDFTron.SilverDox.Documents.Annotations Namespace


TextMarkup Fields

[image] [image]

PDFTron SilverDox SDK
TextMarkup Fields
TextMarkup Class See Also Send Feedback

The TextMarkup type exposes the following members.

Fields

 | Name | Description
Protected field | Appearance | The canvas that was last returned by the method CreateAppearanceCanvas()()()().
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse (Inherited from Annotation.)

See Also

TextMarkup Class
PDFTron.SilverDox.Documents.Annotations Namespace


Appearance Field

[image]

PDFTron SilverDox SDK
TextMarkup..::..Appearance Field
TextMarkup Class See Also Send Feedback
The canvas that was last returned by the method CreateAppearanceCanvas()()()().

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected Canvas Appearance
Visual Basic
Protected Appearance As Canvas
Visual C++
protected:
Canvas^ Appearance

See Also

TextMarkup Class
PDFTron.SilverDox.Documents.Annotations Namespace


TextMarkup Methods

[image] [image]

PDFTron SilverDox SDK
TextMarkup Methods
TextMarkup Class See Also Send Feedback

The TextMarkup type exposes the following members.

Methods

 | Name | Description
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen. (Overrides Annotation..::..CreateAppearanceCanvas()()()().)
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas. (Inherited from Annotation.)
Protected method | DrawTextAnnotation | Alters Appearance using the TextQuads so that the text is marked up as desired.
Public method | OnAnnotationResizeEnded | Called by the annotation's AnnotationManager when the user has finished resizing the annotation (Inherited from Annotation.)
Public method | OnAnnotationResizeStarted | Called by the annotation's AnnotationManager when the user has began resizing this annotation (Inherited from Annotation.)
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation. (Overrides Annotation..::..OnCreateMouseMove(MouseEventArgs).)
Public method | OnCreateMouseUp | Called by the annotation's AnnotationManager when a MouseUp event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)

See Also

TextMarkup Class
PDFTron.SilverDox.Documents.Annotations Namespace


CreateAppearanceCanvas Method

[image]

PDFTron SilverDox SDK
TextMarkup..::..CreateAppearanceCanvas Method
TextMarkup Class See Also Send Feedback
Creates and returns the annotation's appearance canvas that will be displayed on screen.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override Canvas CreateAppearanceCanvas()
Visual Basic
Public Overrides Function CreateAppearanceCanvas As Canvas
Visual C++
public:
virtual Canvas^ CreateAppearanceCanvas() override

Return Value

The annotation's appearance canvas.

See Also

TextMarkup Class
PDFTron.SilverDox.Documents.Annotations Namespace


DrawTextAnnotation Method

[image]

PDFTron SilverDox SDK
TextMarkup..::..DrawTextAnnotation Method
TextMarkup Class See Also Send Feedback
Alters Appearance using the TextQuads so that the text is marked up as desired.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected abstract void DrawTextAnnotation()
Visual Basic
Protected MustOverride Sub DrawTextAnnotation
Visual C++
protected:
virtual void DrawTextAnnotation() abstract

Remarks

The method CreateAppearanceCanvas()()()() may return a blank canvas while text location information is retrieved from the document. When the location information (as stored in TextQuads is ready, DrawTextAnnotation()()()() is asychronously called so that it can mark up the AppearanceCanvas that has already been returned as is being displayed.

See Also

TextMarkup Class
PDFTron.SilverDox.Documents.Annotations Namespace


OnCreateMouseMove Method

[image]

PDFTron SilverDox SDK
TextMarkup..::..OnCreateMouseMove Method
TextMarkup Class See Also Send Feedback
Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override void OnCreateMouseMove(
    MouseEventArgs mouseMoveEventArgs
)
Visual Basic
Public Overrides Sub OnCreateMouseMove ( _
    mouseMoveEventArgs As MouseEventArgs _
)
Visual C++
public:
virtual void OnCreateMouseMove(
    MouseEventArgs^ mouseMoveEventArgs
) override

Parameters

mouseMoveEventArgs
Type: System.Windows.Input..::..MouseEventArgs
The event data.

See Also

TextMarkup Class
PDFTron.SilverDox.Documents.Annotations Namespace


TextMarkup Properties

[image] [image]

PDFTron SilverDox SDK
TextMarkup Properties
TextMarkup Class See Also Send Feedback

The TextMarkup type exposes the following members.

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager. (Inherited from Annotation.)
Public property | Author | Represents the author of the annotation. Default is an empty string. (Inherited from Annotation.)
Public property | Bottom | Gets the y-axis value of the bottom of the annotation. (Inherited from Annotation.)
Public property | DateModified | Gets or sets the last date and time that the annotation was modified. (Inherited from Annotation.)
Protected property | Document | The document that is used to determine the location of the text on a page.
Public property | FillColor | Gets or sets the color of the annotation's interior. (Inherited from Markup.)
Public property | Height | Gets or sets the annotation's height. (Inherited from Markup.)
Public property | Id | A unique identifier that can be assigned to determine different annotations (Inherited from Annotation.)
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation Returns false by default for TextMarkup annotations (Overrides Annotation..::..IsCopyable.)
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user. (Inherited from Annotation.)
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true (Inherited from Annotation.)
Public property | Left | Gets the x-axis value of the left side of the annotation. (Inherited from Annotation.)
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally. (Inherited from Annotation.)
Public property | MirroredVertically | True if the annotation has been mirrored vertically. (Inherited from Annotation.)
Public property | NoMove | Gets or sets if this annotation can be moved by the user. (Inherited from Annotation.)
Public property | NoResize | Gets or sets if this annotation can be resized by the user. (Inherited from Annotation.)
Public property | NoZoom | Gets or sets if this annotation scales with the page. (Inherited from Annotation.)
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on. (Inherited from Annotation.)
Public property | PopupContents | Gets or sets the contents of the annotation's popup. (Inherited from Annotation.)
Public property | PopupHeight | Gets or sets the annotation's popup's height. (Inherited from Annotation.)
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible. (Inherited from Annotation.)
Public property | PopupWidth | Gets or sets the annotation's popup's width. (Inherited from Annotation.)
Public property | PopupX | Gets or sets the annotation's popup's x-axis position. (Inherited from Annotation.)
Public property | PopupY | Gets or sets the annotation's popup's y-axis position. (Inherited from Annotation.)
Public property | Right | Gets the x-axis value of the right side of the annotation. (Inherited from Annotation.)
Public property | SelectEnd | The point at which text selection ends.
Public property | SelectStart | The point at which text selection starts.
Public property | StrokeColor | Gets or sets the color of the annotation's stroke. (Inherited from Markup.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline the annotation. (Inherited from Markup.)
Public property | StrokeThickness | Gets or sets the width of the annotation's stroke outline. (Inherited from Markup.)
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type. (Inherited from Annotation.)
Public property | TextQuads | Represents the boundaries of the text selected between the corner points defined by SelectStart and SelectEnd.
Public property | Top | Gets the y-axis position of the top of the annotation. (Inherited from Annotation.)
Public property | Width | Gets or sets the annotation's width. (Inherited from Markup.)
Public property | X | Gets or sets the annotation's x-axis position. (Inherited from Markup.)
Public property | Y | Gets or sets the annotation's y-axis position. (Inherited from Markup.)

See Also

TextMarkup Class
PDFTron.SilverDox.Documents.Annotations Namespace


Document Property

[image]

PDFTron SilverDox SDK
TextMarkup..::..Document Property
TextMarkup Class See Also Send Feedback
The document that is used to determine the location of the text on a page.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected virtual Document Document { get; set; }
Visual Basic
Protected Overridable Property Document As Document
    Get
    Set
Visual C++
protected:
virtual property Document^ Document {
    Document^ get ();
    void set (Document^ value);
}

See Also

TextMarkup Class
PDFTron.SilverDox.Documents.Annotations Namespace


IsCopyable Property

[image]

PDFTron SilverDox SDK
TextMarkup..::..IsCopyable Property
TextMarkup Class See Also Send Feedback
Indicates whether or not the user should be able to copy this annotation Returns false by default for TextMarkup annotations

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public override bool IsCopyable { get; }
Visual Basic
Public Overrides ReadOnly Property IsCopyable As Boolean
    Get
Visual C++
public:
virtual property bool IsCopyable {
    bool get () override;
}

See Also

TextMarkup Class
PDFTron.SilverDox.Documents.Annotations Namespace


SelectEnd Property

[image]

PDFTron SilverDox SDK
TextMarkup..::..SelectEnd Property
TextMarkup Class See Also Send Feedback
The point at which text selection ends.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Point SelectEnd { get; set; }
Visual Basic
Public Property SelectEnd As Point
    Get
    Set
Visual C++
public:
property Point SelectEnd {
    Point get ();
    void set (Point value);
}

See Also

TextMarkup Class
PDFTron.SilverDox.Documents.Annotations Namespace


SelectStart Property

[image]

PDFTron SilverDox SDK
TextMarkup..::..SelectStart Property
TextMarkup Class See Also Send Feedback
The point at which text selection starts.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Point SelectStart { get; set; }
Visual Basic
Public Property SelectStart As Point
    Get
    Set
Visual C++
public:
property Point SelectStart {
    Point get ();
    void set (Point value);
}

See Also

TextMarkup Class
PDFTron.SilverDox.Documents.Annotations Namespace


TextQuads Property

[image]

PDFTron SilverDox SDK
TextMarkup..::..TextQuads Property
TextMarkup Class See Also Send Feedback
Represents the boundaries of the text selected between the corner points defined by SelectStart and SelectEnd.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public List<Quad> TextQuads { get; set; }
Visual Basic
Public Property TextQuads As List(Of Quad)
    Get
    Set
Visual C++
public:
property List<Quad>^ TextQuads {
    List<Quad>^ get ();
    void set (List<Quad>^ value);
}

See Also

TextMarkup Class
PDFTron.SilverDox.Documents.Annotations Namespace


TextMarkup Events

[image] [image]

PDFTron SilverDox SDK
TextMarkup Events
TextMarkup Class See Also Send Feedback

The TextMarkup type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation (Inherited from Annotation.)

See Also

TextMarkup Class
PDFTron.SilverDox.Documents.Annotations Namespace


TextStrikeout Class

[image]

PDFTron SilverDox SDK
TextStrikeout Class
Members See Also Send Feedback
Represents a text strikeout annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class TextStrikeout : TextMarkup
Visual Basic
Public Class TextStrikeout _
    Inherits TextMarkup
Visual C++
public ref class TextStrikeout : public TextMarkup

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents.Annotations..::..Annotation
PDFTron.SilverDox.Documents.Annotations..::..Markup
PDFTron.SilverDox.Documents.Annotations..::..TextMarkup
PDFTron.SilverDox.Documents.Annotations..::..TextStrikeout

See Also

TextStrikeout Members
PDFTron.SilverDox.Documents.Annotations Namespace


TextStrikeout Members

[image] [image]

PDFTron SilverDox SDK
TextStrikeout Members
TextStrikeout Class Constructors Methods Fields Properties Events See Also Send Feedback

The TextStrikeout type exposes the following members.

Constructors

 | Name | Description
Public method | TextStrikeout()()()() | Creates a new instance of the TextStrikeout class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).
Public method | TextStrikeout(AnnotationManager) | Creates a new instance of the TextStrikeout class.

Methods

 | Name | Description
 | Create | Creates a new instance of the TextStrikeout class.
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen. (Inherited from TextMarkup.)
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas. (Inherited from Annotation.)
Protected method | DrawTextAnnotation | Alters Appearance using the TextQuads so that the text is highlighted. (Overrides TextMarkup..::..DrawTextAnnotation()()()().)
Public method | OnAnnotationResizeEnded | Called by the annotation's AnnotationManager when the user has finished resizing the annotation (Inherited from Annotation.)
Public method | OnAnnotationResizeStarted | Called by the annotation's AnnotationManager when the user has began resizing this annotation (Inherited from Annotation.)
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation. (Inherited from TextMarkup.)
Public method | OnCreateMouseUp | Called by the annotation's AnnotationManager when a MouseUp event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)

Fields

 | Name | Description
Protected field | Appearance | The canvas that was last returned by the method CreateAppearanceCanvas()()()(). (Inherited from TextMarkup.)
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse (Inherited from Annotation.)

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager. (Inherited from Annotation.)
Public property | Author | Represents the author of the annotation. Default is an empty string. (Inherited from Annotation.)
Public property | Bottom | Gets the y-axis value of the bottom of the annotation. (Inherited from Annotation.)
Public property | DateModified | Gets or sets the last date and time that the annotation was modified. (Inherited from Annotation.)
Protected property | Document | The document that is used to determine the location of the text on a page. (Inherited from TextMarkup.)
Public property | FillColor | Gets or sets the color of the annotation's interior. (Inherited from Markup.)
Public property | Height | Gets or sets the annotation's height. (Inherited from Markup.)
Public property | Id | A unique identifier that can be assigned to determine different annotations (Inherited from Annotation.)
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation Returns false by default for TextMarkup annotations (Inherited from TextMarkup.)
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user. (Inherited from Annotation.)
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true (Inherited from Annotation.)
Public property | Left | Gets the x-axis value of the left side of the annotation. (Inherited from Annotation.)
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally. (Inherited from Annotation.)
Public property | MirroredVertically | True if the annotation has been mirrored vertically. (Inherited from Annotation.)
Public property | NoMove | Gets or sets if this annotation can be moved by the user. (Inherited from Annotation.)
Public property | NoResize | Gets or sets if this annotation can be resized by the user. (Inherited from Annotation.)
Public property | NoZoom | Gets or sets if this annotation scales with the page. (Inherited from Annotation.)
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on. (Inherited from Annotation.)
Public property | PopupContents | Gets or sets the contents of the annotation's popup. (Inherited from Annotation.)
Public property | PopupHeight | Gets or sets the annotation's popup's height. (Inherited from Annotation.)
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible. (Inherited from Annotation.)
Public property | PopupWidth | Gets or sets the annotation's popup's width. (Inherited from Annotation.)
Public property | PopupX | Gets or sets the annotation's popup's x-axis position. (Inherited from Annotation.)
Public property | PopupY | Gets or sets the annotation's popup's y-axis position. (Inherited from Annotation.)
Public property | Right | Gets the x-axis value of the right side of the annotation. (Inherited from Annotation.)
Public property | SelectEnd | The point at which text selection ends. (Inherited from TextMarkup.)
Public property | SelectStart | The point at which text selection starts. (Inherited from TextMarkup.)
Public property | StrokeColor | Gets or sets the color of the annotation's stroke. (Inherited from Markup.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline the annotation. (Inherited from Markup.)
Public property | StrokeThickness | Gets or sets the width of the annotation's stroke outline. (Inherited from Markup.)
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type. (Inherited from Annotation.)
Public property | TextQuads | Represents the boundaries of the text selected between the corner points defined by SelectStart and SelectEnd. (Inherited from TextMarkup.)
Public property | Top | Gets the y-axis position of the top of the annotation. (Inherited from Annotation.)
Public property | Width | Gets or sets the annotation's width. (Inherited from Markup.)
Public property | X | Gets or sets the annotation's x-axis position. (Inherited from Markup.)
Public property | Y | Gets or sets the annotation's y-axis position. (Inherited from Markup.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation (Inherited from Annotation.)

See Also

TextStrikeout Class
PDFTron.SilverDox.Documents.Annotations Namespace


TextStrikeout Constructor

[image] [image]

PDFTron SilverDox SDK
TextStrikeout Constructor
TextStrikeout Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TextStrikeout()()()() | Creates a new instance of the TextStrikeout class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).
Public method | TextStrikeout(AnnotationManager) | Creates a new instance of the TextStrikeout class.

See Also

TextStrikeout Class
TextStrikeout Members
PDFTron.SilverDox.Documents.Annotations Namespace


TextStrikeout Constructor

[image]

PDFTron SilverDox SDK
TextStrikeout Constructor
TextStrikeout Class See Also Send Feedback
Creates a new instance of the TextStrikeout class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public TextStrikeout()
Visual Basic
Public Sub New
Visual C++
public:
TextStrikeout()

See Also

TextStrikeout Class
TextStrikeout Overload
PDFTron.SilverDox.Documents.Annotations Namespace


TextStrikeout Constructor (AnnotationManager)

[image]

PDFTron SilverDox SDK
TextStrikeout Constructor (AnnotationManager)
TextStrikeout Class See Also Send Feedback
Creates a new instance of the TextStrikeout class.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public TextStrikeout(
    AnnotationManager annotationManager
)
Visual Basic
Public Sub New ( _
    annotationManager As AnnotationManager _
)
Visual C++
public:
TextStrikeout(
    AnnotationManager^ annotationManager
)

Parameters

annotationManager
Type: PDFTron.SilverDox.Documents.Annotations..::..AnnotationManager
The AnnotationManager to associate with this annotation.

See Also

TextStrikeout Class
TextStrikeout Overload
PDFTron.SilverDox.Documents.Annotations Namespace


TextStrikeout Fields

[image] [image]

PDFTron SilverDox SDK
TextStrikeout Fields
TextStrikeout Class See Also Send Feedback

The TextStrikeout type exposes the following members.

Fields

 | Name | Description
Protected field | Appearance | The canvas that was last returned by the method CreateAppearanceCanvas()()()(). (Inherited from TextMarkup.)
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse (Inherited from Annotation.)

See Also

TextStrikeout Class
PDFTron.SilverDox.Documents.Annotations Namespace


TextStrikeout Methods

[image] [image]

PDFTron SilverDox SDK
TextStrikeout Methods
TextStrikeout Class See Also Send Feedback

The TextStrikeout type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new instance of the TextStrikeout class.
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen. (Inherited from TextMarkup.)
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas. (Inherited from Annotation.)
Protected method | DrawTextAnnotation | Alters Appearance using the TextQuads so that the text is highlighted. (Overrides TextMarkup..::..DrawTextAnnotation()()()().)
Public method | OnAnnotationResizeEnded | Called by the annotation's AnnotationManager when the user has finished resizing the annotation (Inherited from Annotation.)
Public method | OnAnnotationResizeStarted | Called by the annotation's AnnotationManager when the user has began resizing this annotation (Inherited from Annotation.)
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation. (Inherited from TextMarkup.)
Public method | OnCreateMouseUp | Called by the annotation's AnnotationManager when a MouseUp event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)

See Also

TextStrikeout Class
PDFTron.SilverDox.Documents.Annotations Namespace


Create Method

[image]

PDFTron SilverDox SDK
TextStrikeout..::..Create Method
TextStrikeout Class See Also Send Feedback
Creates a new instance of the TextStrikeout class.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public static TextStrikeout Create(
    AnnotationManager annotationManager
)
Visual Basic
Public Shared Function Create ( _
    annotationManager As AnnotationManager _
) As TextStrikeout
Visual C++
public:
static TextStrikeout^ Create(
    AnnotationManager^ annotationManager
)

Parameters

annotationManager
Type: PDFTron.SilverDox.Documents.Annotations..::..AnnotationManager
The AnnotationManager to associate with this annotation.

Return Value

A new TextStrikeout annotation.

See Also

TextStrikeout Class
PDFTron.SilverDox.Documents.Annotations Namespace


DrawTextAnnotation Method

[image]

PDFTron SilverDox SDK
TextStrikeout..::..DrawTextAnnotation Method
TextStrikeout Class See Also Send Feedback
Alters Appearance using the TextQuads so that the text is highlighted.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected override void DrawTextAnnotation()
Visual Basic
Protected Overrides Sub DrawTextAnnotation
Visual C++
protected:
virtual void DrawTextAnnotation() override

Remarks

The method CreateAppearanceCanvas()()()() may return a blank canvas while text location information is retrieved from the document. When the location information (as stored in TextQuads) is ready, DrawTextAnnotation()()()() is asychronously called so that it can mark up the AppearanceCanvas that has already been returned as is being displayed.

See Also

TextStrikeout Class
PDFTron.SilverDox.Documents.Annotations Namespace


TextStrikeout Properties

[image] [image]

PDFTron SilverDox SDK
TextStrikeout Properties
TextStrikeout Class See Also Send Feedback

The TextStrikeout type exposes the following members.

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager. (Inherited from Annotation.)
Public property | Author | Represents the author of the annotation. Default is an empty string. (Inherited from Annotation.)
Public property | Bottom | Gets the y-axis value of the bottom of the annotation. (Inherited from Annotation.)
Public property | DateModified | Gets or sets the last date and time that the annotation was modified. (Inherited from Annotation.)
Protected property | Document | The document that is used to determine the location of the text on a page. (Inherited from TextMarkup.)
Public property | FillColor | Gets or sets the color of the annotation's interior. (Inherited from Markup.)
Public property | Height | Gets or sets the annotation's height. (Inherited from Markup.)
Public property | Id | A unique identifier that can be assigned to determine different annotations (Inherited from Annotation.)
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation Returns false by default for TextMarkup annotations (Inherited from TextMarkup.)
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user. (Inherited from Annotation.)
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true (Inherited from Annotation.)
Public property | Left | Gets the x-axis value of the left side of the annotation. (Inherited from Annotation.)
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally. (Inherited from Annotation.)
Public property | MirroredVertically | True if the annotation has been mirrored vertically. (Inherited from Annotation.)
Public property | NoMove | Gets or sets if this annotation can be moved by the user. (Inherited from Annotation.)
Public property | NoResize | Gets or sets if this annotation can be resized by the user. (Inherited from Annotation.)
Public property | NoZoom | Gets or sets if this annotation scales with the page. (Inherited from Annotation.)
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on. (Inherited from Annotation.)
Public property | PopupContents | Gets or sets the contents of the annotation's popup. (Inherited from Annotation.)
Public property | PopupHeight | Gets or sets the annotation's popup's height. (Inherited from Annotation.)
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible. (Inherited from Annotation.)
Public property | PopupWidth | Gets or sets the annotation's popup's width. (Inherited from Annotation.)
Public property | PopupX | Gets or sets the annotation's popup's x-axis position. (Inherited from Annotation.)
Public property | PopupY | Gets or sets the annotation's popup's y-axis position. (Inherited from Annotation.)
Public property | Right | Gets the x-axis value of the right side of the annotation. (Inherited from Annotation.)
Public property | SelectEnd | The point at which text selection ends. (Inherited from TextMarkup.)
Public property | SelectStart | The point at which text selection starts. (Inherited from TextMarkup.)
Public property | StrokeColor | Gets or sets the color of the annotation's stroke. (Inherited from Markup.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline the annotation. (Inherited from Markup.)
Public property | StrokeThickness | Gets or sets the width of the annotation's stroke outline. (Inherited from Markup.)
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type. (Inherited from Annotation.)
Public property | TextQuads | Represents the boundaries of the text selected between the corner points defined by SelectStart and SelectEnd. (Inherited from TextMarkup.)
Public property | Top | Gets the y-axis position of the top of the annotation. (Inherited from Annotation.)
Public property | Width | Gets or sets the annotation's width. (Inherited from Markup.)
Public property | X | Gets or sets the annotation's x-axis position. (Inherited from Markup.)
Public property | Y | Gets or sets the annotation's y-axis position. (Inherited from Markup.)

See Also

TextStrikeout Class
PDFTron.SilverDox.Documents.Annotations Namespace


TextStrikeout Events

[image] [image]

PDFTron SilverDox SDK
TextStrikeout Events
TextStrikeout Class See Also Send Feedback

The TextStrikeout type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation (Inherited from Annotation.)

See Also

TextStrikeout Class
PDFTron.SilverDox.Documents.Annotations Namespace


TextUnderline Class

[image]

PDFTron SilverDox SDK
TextUnderline Class
Members See Also Send Feedback
Represents a text underline annotation.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class TextUnderline : TextMarkup
Visual Basic
Public Class TextUnderline _
    Inherits TextMarkup
Visual C++
public ref class TextUnderline : public TextMarkup

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents.Annotations..::..Annotation
PDFTron.SilverDox.Documents.Annotations..::..Markup
PDFTron.SilverDox.Documents.Annotations..::..TextMarkup
PDFTron.SilverDox.Documents.Annotations..::..TextUnderline

See Also

TextUnderline Members
PDFTron.SilverDox.Documents.Annotations Namespace


TextUnderline Members

[image] [image]

PDFTron SilverDox SDK
TextUnderline Members
TextUnderline Class Constructors Methods Fields Properties Events See Also Send Feedback

The TextUnderline type exposes the following members.

Constructors

 | Name | Description
Public method | TextUnderline()()()() | Creates a new instance of the TextUnderline class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).
Public method | TextUnderline(AnnotationManager) | Creates a new instance of the TextUnderline class.

Methods

 | Name | Description
 | Create | Creates a new instance of the TextUnderline class.
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen. (Inherited from TextMarkup.)
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas. (Inherited from Annotation.)
Protected method | DrawTextAnnotation | Alters Appearance using the TextQuads so that the text is highlighted. (Overrides TextMarkup..::..DrawTextAnnotation()()()().)
Public method | OnAnnotationResizeEnded | Called by the annotation's AnnotationManager when the user has finished resizing the annotation (Inherited from Annotation.)
Public method | OnAnnotationResizeStarted | Called by the annotation's AnnotationManager when the user has began resizing this annotation (Inherited from Annotation.)
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation. (Inherited from TextMarkup.)
Public method | OnCreateMouseUp | Called by the annotation's AnnotationManager when a MouseUp event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)

Fields

 | Name | Description
Protected field | Appearance | The canvas that was last returned by the method CreateAppearanceCanvas()()()(). (Inherited from TextMarkup.)
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse (Inherited from Annotation.)

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager. (Inherited from Annotation.)
Public property | Author | Represents the author of the annotation. Default is an empty string. (Inherited from Annotation.)
Public property | Bottom | Gets the y-axis value of the bottom of the annotation. (Inherited from Annotation.)
Public property | DateModified | Gets or sets the last date and time that the annotation was modified. (Inherited from Annotation.)
Protected property | Document | The document that is used to determine the location of the text on a page. (Inherited from TextMarkup.)
Public property | FillColor | Gets or sets the color of the annotation's interior. (Inherited from Markup.)
Public property | Height | Gets or sets the annotation's height. (Inherited from Markup.)
Public property | Id | A unique identifier that can be assigned to determine different annotations (Inherited from Annotation.)
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation Returns false by default for TextMarkup annotations (Inherited from TextMarkup.)
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user. (Inherited from Annotation.)
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true (Inherited from Annotation.)
Public property | Left | Gets the x-axis value of the left side of the annotation. (Inherited from Annotation.)
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally. (Inherited from Annotation.)
Public property | MirroredVertically | True if the annotation has been mirrored vertically. (Inherited from Annotation.)
Public property | NoMove | Gets or sets if this annotation can be moved by the user. (Inherited from Annotation.)
Public property | NoResize | Gets or sets if this annotation can be resized by the user. (Inherited from Annotation.)
Public property | NoZoom | Gets or sets if this annotation scales with the page. (Inherited from Annotation.)
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on. (Inherited from Annotation.)
Public property | PopupContents | Gets or sets the contents of the annotation's popup. (Inherited from Annotation.)
Public property | PopupHeight | Gets or sets the annotation's popup's height. (Inherited from Annotation.)
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible. (Inherited from Annotation.)
Public property | PopupWidth | Gets or sets the annotation's popup's width. (Inherited from Annotation.)
Public property | PopupX | Gets or sets the annotation's popup's x-axis position. (Inherited from Annotation.)
Public property | PopupY | Gets or sets the annotation's popup's y-axis position. (Inherited from Annotation.)
Public property | Right | Gets the x-axis value of the right side of the annotation. (Inherited from Annotation.)
Public property | SelectEnd | The point at which text selection ends. (Inherited from TextMarkup.)
Public property | SelectStart | The point at which text selection starts. (Inherited from TextMarkup.)
Public property | StrokeColor | Gets or sets the color of the annotation's stroke. (Inherited from Markup.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline the annotation. (Inherited from Markup.)
Public property | StrokeThickness | Gets or sets the width of the annotation's stroke outline. (Inherited from Markup.)
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type. (Inherited from Annotation.)
Public property | TextQuads | Represents the boundaries of the text selected between the corner points defined by SelectStart and SelectEnd. (Inherited from TextMarkup.)
Public property | Top | Gets the y-axis position of the top of the annotation. (Inherited from Annotation.)
Public property | Width | Gets or sets the annotation's width. (Inherited from Markup.)
Public property | X | Gets or sets the annotation's x-axis position. (Inherited from Markup.)
Public property | Y | Gets or sets the annotation's y-axis position. (Inherited from Markup.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation (Inherited from Annotation.)

See Also

TextUnderline Class
PDFTron.SilverDox.Documents.Annotations Namespace


TextUnderline Constructor

[image] [image]

PDFTron SilverDox SDK
TextUnderline Constructor
TextUnderline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TextUnderline()()()() | Creates a new instance of the TextUnderline class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).
Public method | TextUnderline(AnnotationManager) | Creates a new instance of the TextUnderline class.

See Also

TextUnderline Class
TextUnderline Members
PDFTron.SilverDox.Documents.Annotations Namespace


TextUnderline Constructor

[image]

PDFTron SilverDox SDK
TextUnderline Constructor
TextUnderline Class See Also Send Feedback
Creates a new instance of the TextUnderline class. This constructor is used when loading annotations with LoadAnnotations(Stream, Predicate<(Of <<'(Annotation>)>>)).

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public TextUnderline()
Visual Basic
Public Sub New
Visual C++
public:
TextUnderline()

See Also

TextUnderline Class
TextUnderline Overload
PDFTron.SilverDox.Documents.Annotations Namespace


TextUnderline Constructor (AnnotationManager)

[image]

PDFTron SilverDox SDK
TextUnderline Constructor (AnnotationManager)
TextUnderline Class See Also Send Feedback
Creates a new instance of the TextUnderline class.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public TextUnderline(
    AnnotationManager annotationManager
)
Visual Basic
Public Sub New ( _
    annotationManager As AnnotationManager _
)
Visual C++
public:
TextUnderline(
    AnnotationManager^ annotationManager
)

Parameters

annotationManager
Type: PDFTron.SilverDox.Documents.Annotations..::..AnnotationManager
The AnnotationManager to associate with this annotation.

See Also

TextUnderline Class
TextUnderline Overload
PDFTron.SilverDox.Documents.Annotations Namespace


TextUnderline Fields

[image] [image]

PDFTron SilverDox SDK
TextUnderline Fields
TextUnderline Class See Also Send Feedback

The TextUnderline type exposes the following members.

Fields

 | Name | Description
Protected field | Appearance | The canvas that was last returned by the method CreateAppearanceCanvas()()()(). (Inherited from TextMarkup.)
Protected field | shouldBeCreated | Determines whether or not the annotation should be created in OnCreateMouseUp This is used for TextMarkups that do not select any text to prevent it from being created when the user releases the mouse (Inherited from Annotation.)

See Also

TextUnderline Class
PDFTron.SilverDox.Documents.Annotations Namespace


TextUnderline Methods

[image] [image]

PDFTron SilverDox SDK
TextUnderline Methods
TextUnderline Class See Also Send Feedback

The TextUnderline type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new instance of the TextUnderline class.
Public method | CreateAppearanceCanvas | Creates and returns the annotation's appearance canvas that will be displayed on screen. (Inherited from TextMarkup.)
Protected method | CreatePopupCanvas | Creates canvas used as the popup when an annotation is double clicked on. Override this method to provide a customized popup canvas. (Inherited from Annotation.)
Protected method | DrawTextAnnotation | Alters Appearance using the TextQuads so that the text is highlighted. (Overrides TextMarkup..::..DrawTextAnnotation()()()().)
Public method | OnAnnotationResizeEnded | Called by the annotation's AnnotationManager when the user has finished resizing the annotation (Inherited from Annotation.)
Public method | OnAnnotationResizeStarted | Called by the annotation's AnnotationManager when the user has began resizing this annotation (Inherited from Annotation.)
Public method | OnCreateMouseDown | Called by the annotation's AnnotationManager when a MouseDown event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)
Public method | OnCreateMouseMove | Called by the annotation's AnnotationManager when a MouseMove event is received and the AnnotationManager is set to create this type of annotation. (Inherited from TextMarkup.)
Public method | OnCreateMouseUp | Called by the annotation's AnnotationManager when a MouseUp event is received and the AnnotationManager is set to create this type of annotation. (Inherited from Annotation.)

See Also

TextUnderline Class
PDFTron.SilverDox.Documents.Annotations Namespace


Create Method

[image]

PDFTron SilverDox SDK
TextUnderline..::..Create Method
TextUnderline Class See Also Send Feedback
Creates a new instance of the TextUnderline class.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public static TextUnderline Create(
    AnnotationManager annotationManager
)
Visual Basic
Public Shared Function Create ( _
    annotationManager As AnnotationManager _
) As TextUnderline
Visual C++
public:
static TextUnderline^ Create(
    AnnotationManager^ annotationManager
)

Parameters

annotationManager
Type: PDFTron.SilverDox.Documents.Annotations..::..AnnotationManager
The AnnotationManager to associate with this annotation.

Return Value

A new TextStrikeout annotation.

See Also

TextUnderline Class
PDFTron.SilverDox.Documents.Annotations Namespace


DrawTextAnnotation Method

[image]

PDFTron SilverDox SDK
TextUnderline..::..DrawTextAnnotation Method
TextUnderline Class See Also Send Feedback
Alters Appearance using the TextQuads so that the text is highlighted.

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected override void DrawTextAnnotation()
Visual Basic
Protected Overrides Sub DrawTextAnnotation
Visual C++
protected:
virtual void DrawTextAnnotation() override

Remarks

The method CreateAppearanceCanvas()()()() may return a blank canvas while text location information is retrieved from the document. When the location information (as stored in TextQuads) is ready, DrawTextAnnotation()()()() is asychronously called so that it can mark up the AppearanceCanvas that has already been returned as is being displayed.

See Also

TextUnderline Class
PDFTron.SilverDox.Documents.Annotations Namespace


TextUnderline Properties

[image] [image]

PDFTron SilverDox SDK
TextUnderline Properties
TextUnderline Class See Also Send Feedback

The TextUnderline type exposes the following members.

Properties

 | Name | Description
Public property | AnnotationManager | Gets or sets the annotation's AnnotationManager. (Inherited from Annotation.)
Public property | Author | Represents the author of the annotation. Default is an empty string. (Inherited from Annotation.)
Public property | Bottom | Gets the y-axis value of the bottom of the annotation. (Inherited from Annotation.)
Public property | DateModified | Gets or sets the last date and time that the annotation was modified. (Inherited from Annotation.)
Protected property | Document | The document that is used to determine the location of the text on a page. (Inherited from TextMarkup.)
Public property | FillColor | Gets or sets the color of the annotation's interior. (Inherited from Markup.)
Public property | Height | Gets or sets the annotation's height. (Inherited from Markup.)
Public property | Id | A unique identifier that can be assigned to determine different annotations (Inherited from Annotation.)
Public property | IsCopyable | Indicates whether or not the user should be able to copy this annotation Returns false by default for TextMarkup annotations (Inherited from TextMarkup.)
Public property | IsCreated | Gets or sets if the annotation has finished being created by the user. (Inherited from Annotation.)
Public property | IsSelectable | Indicates whether or not the user can select this annotation Default is true (Inherited from Annotation.)
Public property | Left | Gets the x-axis value of the left side of the annotation. (Inherited from Annotation.)
Public property | MirroredHorizontally | True if the annotation has been mirrored horizontally. (Inherited from Annotation.)
Public property | MirroredVertically | True if the annotation has been mirrored vertically. (Inherited from Annotation.)
Public property | NoMove | Gets or sets if this annotation can be moved by the user. (Inherited from Annotation.)
Public property | NoResize | Gets or sets if this annotation can be resized by the user. (Inherited from Annotation.)
Public property | NoZoom | Gets or sets if this annotation scales with the page. (Inherited from Annotation.)
Public property | PageNumber | Gets or sets the page number of a document that the annotation appears on. (Inherited from Annotation.)
Public property | PopupContents | Gets or sets the contents of the annotation's popup. (Inherited from Annotation.)
Public property | PopupHeight | Gets or sets the annotation's popup's height. (Inherited from Annotation.)
Public property | PopupIsVisible | Gets or sets if the annotation's popup is visible. (Inherited from Annotation.)
Public property | PopupWidth | Gets or sets the annotation's popup's width. (Inherited from Annotation.)
Public property | PopupX | Gets or sets the annotation's popup's x-axis position. (Inherited from Annotation.)
Public property | PopupY | Gets or sets the annotation's popup's y-axis position. (Inherited from Annotation.)
Public property | Right | Gets the x-axis value of the right side of the annotation. (Inherited from Annotation.)
Public property | SelectEnd | The point at which text selection ends. (Inherited from TextMarkup.)
Public property | SelectStart | The point at which text selection starts. (Inherited from TextMarkup.)
Public property | StrokeColor | Gets or sets the color of the annotation's stroke. (Inherited from Markup.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline the annotation. (Inherited from Markup.)
Public property | StrokeThickness | Gets or sets the width of the annotation's stroke outline. (Inherited from Markup.)
Public property | Subject | Represents the subject of the annotation. Default is the annotation's type. (Inherited from Annotation.)
Public property | TextQuads | Represents the boundaries of the text selected between the corner points defined by SelectStart and SelectEnd. (Inherited from TextMarkup.)
Public property | Top | Gets the y-axis position of the top of the annotation. (Inherited from Annotation.)
Public property | Width | Gets or sets the annotation's width. (Inherited from Markup.)
Public property | X | Gets or sets the annotation's x-axis position. (Inherited from Markup.)
Public property | Y | Gets or sets the annotation's y-axis position. (Inherited from Markup.)

See Also

TextUnderline Class
PDFTron.SilverDox.Documents.Annotations Namespace


TextUnderline Events

[image] [image]

PDFTron SilverDox SDK
TextUnderline Events
TextUnderline Class See Also Send Feedback

The TextUnderline type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes in the annotation (Inherited from Annotation.)

See Also

TextUnderline Class
PDFTron.SilverDox.Documents.Annotations Namespace


ToolModeChangedEventArgs Class

[image]

PDFTron SilverDox SDK
ToolModeChangedEventArgs Class
Members See Also Send Feedback
Provides data for the ToolModeChanged event

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class ToolModeChangedEventArgs : EventArgs
Visual Basic
Public Class ToolModeChangedEventArgs _
    Inherits EventArgs
Visual C++
public ref class ToolModeChangedEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
PDFTron.SilverDox.Documents.Annotations..::..ToolModeChangedEventArgs

See Also

ToolModeChangedEventArgs Members
PDFTron.SilverDox.Documents.Annotations Namespace


ToolModeChangedEventArgs Members

[image] [image]

PDFTron SilverDox SDK
ToolModeChangedEventArgs Members
ToolModeChangedEventArgs Class Constructors Properties See Also Send Feedback

The ToolModeChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ToolModeChangedEventArgs | Constructs a new instance of ToolModeChangedEventArgs".

Properties

 | Name | Description
Public property | NewToolMode | Gets the new ToolMode of the DocumentViewer
Public property | OldToolMode | Gets the old ToolMode of the DocumentViewer

See Also

ToolModeChangedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


ToolModeChangedEventArgs Constructor

[image]

PDFTron SilverDox SDK
ToolModeChangedEventArgs Constructor
ToolModeChangedEventArgs Class See Also Send Feedback
Constructs a new instance of ToolModeChangedEventArgs".

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public ToolModeChangedEventArgs(
    DocumentViewer..::..ToolModes oldToolMode,
    DocumentViewer..::..ToolModes newToolMode
)
Visual Basic
Public Sub New ( _
    oldToolMode As DocumentViewer..::..ToolModes, _
    newToolMode As DocumentViewer..::..ToolModes _
)
Visual C++
public:
ToolModeChangedEventArgs(
    DocumentViewer..::..ToolModes oldToolMode,
    DocumentViewer..::..ToolModes newToolMode
)

Parameters

oldToolMode
Type: PDFTron.SilverDox.Controls..::..DocumentViewer..::..ToolModes

[Missing <param name="oldToolMode"/> documentation for "M:PDFTron.SilverDox.Documents.Annotations.ToolModeChangedEventArgs.#ctor(PDFTron.SilverDox.Controls.DocumentViewer.ToolModes,PDFTron.SilverDox.Controls.DocumentViewer.ToolModes)"]

newToolMode
Type: PDFTron.SilverDox.Controls..::..DocumentViewer..::..ToolModes

[Missing <param name="newToolMode"/> documentation for "M:PDFTron.SilverDox.Documents.Annotations.ToolModeChangedEventArgs.#ctor(PDFTron.SilverDox.Controls.DocumentViewer.ToolModes,PDFTron.SilverDox.Controls.DocumentViewer.ToolModes)"]

See Also

ToolModeChangedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


ToolModeChangedEventArgs Properties

[image] [image]

PDFTron SilverDox SDK
ToolModeChangedEventArgs Properties
ToolModeChangedEventArgs Class See Also Send Feedback

The ToolModeChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | NewToolMode | Gets the new ToolMode of the DocumentViewer
Public property | OldToolMode | Gets the old ToolMode of the DocumentViewer

See Also

ToolModeChangedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


NewToolMode Property

[image]

PDFTron SilverDox SDK
ToolModeChangedEventArgs..::..NewToolMode Property
ToolModeChangedEventArgs Class See Also Send Feedback
Gets the new ToolMode of the DocumentViewer

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public DocumentViewer..::..ToolModes NewToolMode { get; internal set; }
Visual Basic
Public Property NewToolMode As DocumentViewer..::..ToolModes
    Get
    Friend Set
Visual C++
public:
property DocumentViewer..::..ToolModes NewToolMode {
    DocumentViewer..::..ToolModes get ();
    internal: void set (DocumentViewer..::..ToolModes value);
}

See Also

ToolModeChangedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


OldToolMode Property

[image]

PDFTron SilverDox SDK
ToolModeChangedEventArgs..::..OldToolMode Property
ToolModeChangedEventArgs Class See Also Send Feedback
Gets the old ToolMode of the DocumentViewer

Namespace: PDFTron.SilverDox.Documents.Annotations
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public DocumentViewer..::..ToolModes OldToolMode { get; internal set; }
Visual Basic
Public Property OldToolMode As DocumentViewer..::..ToolModes
    Get
    Friend Set
Visual C++
public:
property DocumentViewer..::..ToolModes OldToolMode {
    DocumentViewer..::..ToolModes get ();
    internal: void set (DocumentViewer..::..ToolModes value);
}

See Also

ToolModeChangedEventArgs Class
PDFTron.SilverDox.Documents.Annotations Namespace


PDFTron.SilverDox.Documents.Text Namespace

[image]

PDFTron SilverDox SDK
PDFTron.SilverDox.Documents.Text Namespace
Send Feedback
Contains classes that provide text search and text selection services for a Document.

Classes

 | Class | Description
Public class | TextSearch | TextSearch searches through a Document for a user-given search pattern. TextSearch provides users with several useful search modes and extra information besides the found string that matches the pattern. TextSearch can either keep running until a matched string is found or be set to return periodically in order for the caller to perform any necessary updates (e.g., UI updates).
Public class | TextSearch..::..OnTextSearchAsyncCallbackArgs | Arguments used as a parameter in the user defined callback function provided to SearchNextAsync(Action<(Of <<'(TextSearch..::..OnTextSearchAsyncCallbackArgs>)>>), Object).
Public class | TextSelector | Used to identify the location of text on a page. Useful for implementing text highlighting and copying.
Public class | TextSelector..::..OnTextSelectionAsyncCallbackArgs | Arguments used as a parameter in the user defined callback function provided to SelectByRectAsync(Int32, Point, Point, Action<(Of <<'(TextSelector..::..OnTextSelectionAsyncCallbackArgs>)>>)) and SelectByStructAsync(Int32, Point, Point, Action<(Of <<'(TextSelector..::..OnTextSelectionAsyncCallbackArgs>)>>)).

Structures

 | Structure | Description
Public structure | Quad | Represents a bounding box quadrangle around text. The points are ordered counter-clockwise, starting at the glyph's lower-left corner.

Enumerations

 | Enumeration | Description
Public enumeration | TextSearch..::..SearchModes | Search modes that control how searching is conducted.
Public enumeration | TextSearch..::..SearchResultCode | The code indicating the reason that the search process concluded.


Quad Structure

[image]

PDFTron SilverDox SDK
Quad Structure
Members See Also Send Feedback
Represents a bounding box quadrangle around text. The points are ordered counter-clockwise, starting at the glyph's lower-left corner.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public struct Quad
Visual Basic
Public Structure Quad
Visual C++
public value class Quad

See Also

Quad Members
PDFTron.SilverDox.Documents.Text Namespace


Quad Members

[image] [image]

PDFTron SilverDox SDK
Quad Members
Quad Structure Fields See Also Send Feedback

The Quad type exposes the following members.

Fields

 | Name | Description
Public field | x1 | The x coordinate of the first point.
Public field | x2 | The x coordinate of the second point.
Public field | x3 | The x coordinate of the third point.
Public field | x4 | The x coordinate of the fourth point.
Public field | y1 | The y coordinate of the first point.
Public field | y2 | The y coordinate of the second point.
Public field | y3 | The y coordinate of the third point.
Public field | y4 | The y coordinate of the fourth point.

See Also

Quad Structure
PDFTron.SilverDox.Documents.Text Namespace


Quad Fields

[image] [image]

PDFTron SilverDox SDK
Quad Fields
Quad Structure See Also Send Feedback

The Quad type exposes the following members.

Fields

 | Name | Description
Public field | x1 | The x coordinate of the first point.
Public field | x2 | The x coordinate of the second point.
Public field | x3 | The x coordinate of the third point.
Public field | x4 | The x coordinate of the fourth point.
Public field | y1 | The y coordinate of the first point.
Public field | y2 | The y coordinate of the second point.
Public field | y3 | The y coordinate of the third point.
Public field | y4 | The y coordinate of the fourth point.

See Also

Quad Structure
PDFTron.SilverDox.Documents.Text Namespace


x1 Field

[image]

PDFTron SilverDox SDK
Quad..::..x1 Field
Quad Structure See Also Send Feedback
The x coordinate of the first point.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public double x1
Visual Basic
Public x1 As Double
Visual C++
public:
double x1

See Also

Quad Structure
PDFTron.SilverDox.Documents.Text Namespace


x2 Field

[image]

PDFTron SilverDox SDK
Quad..::..x2 Field
Quad Structure See Also Send Feedback
The x coordinate of the second point.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public double x2
Visual Basic
Public x2 As Double
Visual C++
public:
double x2

See Also

Quad Structure
PDFTron.SilverDox.Documents.Text Namespace


x3 Field

[image]

PDFTron SilverDox SDK
Quad..::..x3 Field
Quad Structure See Also Send Feedback
The x coordinate of the third point.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public double x3
Visual Basic
Public x3 As Double
Visual C++
public:
double x3

See Also

Quad Structure
PDFTron.SilverDox.Documents.Text Namespace


x4 Field

[image]

PDFTron SilverDox SDK
Quad..::..x4 Field
Quad Structure See Also Send Feedback
The x coordinate of the fourth point.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public double x4
Visual Basic
Public x4 As Double
Visual C++
public:
double x4

See Also

Quad Structure
PDFTron.SilverDox.Documents.Text Namespace


y1 Field

[image]

PDFTron SilverDox SDK
Quad..::..y1 Field
Quad Structure See Also Send Feedback
The y coordinate of the first point.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public double y1
Visual Basic
Public y1 As Double
Visual C++
public:
double y1

See Also

Quad Structure
PDFTron.SilverDox.Documents.Text Namespace


y2 Field

[image]

PDFTron SilverDox SDK
Quad..::..y2 Field
Quad Structure See Also Send Feedback
The y coordinate of the second point.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public double y2
Visual Basic
Public y2 As Double
Visual C++
public:
double y2

See Also

Quad Structure
PDFTron.SilverDox.Documents.Text Namespace


y3 Field

[image]

PDFTron SilverDox SDK
Quad..::..y3 Field
Quad Structure See Also Send Feedback
The y coordinate of the third point.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public double y3
Visual Basic
Public y3 As Double
Visual C++
public:
double y3

See Also

Quad Structure
PDFTron.SilverDox.Documents.Text Namespace


y4 Field

[image]

PDFTron SilverDox SDK
Quad..::..y4 Field
Quad Structure See Also Send Feedback
The y coordinate of the fourth point.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public double y4
Visual Basic
Public y4 As Double
Visual C++
public:
double y4

See Also

Quad Structure
PDFTron.SilverDox.Documents.Text Namespace


TextSearch Class

[image]

PDFTron SilverDox SDK
TextSearch Class
Members See Also Send Feedback
TextSearch searches through a Document for a user-given search pattern. TextSearch provides users with several useful search modes and extra information besides the found string that matches the pattern. TextSearch can either keep running until a matched string is found or be set to return periodically in order for the caller to perform any necessary updates (e.g., UI updates).

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class TextSearch
Visual Basic
Public Class TextSearch
Visual C++
public ref class TextSearch

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents.Text..::..TextSearch

See Also

TextSearch Members
PDFTron.SilverDox.Documents.Text Namespace


TextSearch Members

[image] [image]

PDFTron SilverDox SDK
TextSearch Members
TextSearch Class Constructors Methods See Also Send Feedback

The TextSearch type exposes the following members.

Constructors

 | Name | Description
Public method | TextSearch | Constructs a new TextSearch object.

Methods

 | Name | Description
Public method | SearchBegin | Initilizes a new search. To perform a search, it must be followed by at least one call to SearchNextAsync(Action<(Of <<'(TextSearch..::..OnTextSearchAsyncCallbackArgs>)>>), Object).
Public method | SearchNextAsync | Attempts to find the next instance of the search string specified in SearchBegin(String, TextSearch..::..SearchModes, Int32).

See Also

TextSearch Class
PDFTron.SilverDox.Documents.Text Namespace


TextSearch Constructor

[image]

PDFTron SilverDox SDK
TextSearch Constructor
TextSearch Class See Also Send Feedback
Constructs a new TextSearch object.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public TextSearch(
    Document document
)
Visual Basic
Public Sub New ( _
    document As Document _
)
Visual C++
public:
TextSearch(
    Document^ document
)

Parameters

document
Type: PDFTron.SilverDox.Documents..::..Document
The Document that will be searched.

See Also

TextSearch Class
PDFTron.SilverDox.Documents.Text Namespace


TextSearch Methods

[image] [image]

PDFTron SilverDox SDK
TextSearch Methods
TextSearch Class See Also Send Feedback

The TextSearch type exposes the following members.

Methods

 | Name | Description
Public method | SearchBegin | Initilizes a new search. To perform a search, it must be followed by at least one call to SearchNextAsync(Action<(Of <<'(TextSearch..::..OnTextSearchAsyncCallbackArgs>)>>), Object).
Public method | SearchNextAsync | Attempts to find the next instance of the search string specified in SearchBegin(String, TextSearch..::..SearchModes, Int32).

See Also

TextSearch Class
PDFTron.SilverDox.Documents.Text Namespace


SearchBegin Method

[image]

PDFTron SilverDox SDK
TextSearch..::..SearchBegin Method
TextSearch Class See Also Send Feedback
Initilizes a new search. To perform a search, it must be followed by at least one call to SearchNextAsync(Action<(Of <<'(TextSearch..::..OnTextSearchAsyncCallbackArgs>)>>), Object).

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void SearchBegin(
    string pattern,
    TextSearch..::..SearchModes mode,
    int startOnPageNumber
)
Visual Basic
Public Sub SearchBegin ( _
    pattern As String, _
    mode As TextSearch..::..SearchModes, _
    startOnPageNumber As Integer _
)
Visual C++
public:
void SearchBegin(
    String^ pattern,
    TextSearch..::..SearchModes mode,
    int startOnPageNumber
)

Parameters

pattern
Type: System..::..String
The search string.
mode
Type: PDFTron.SilverDox.Documents.Text..::..TextSearch..::..SearchModes
The options for the search, such as search direction and case sensitvity.
startOnPageNumber
Type: System..::..Int32
The page number of the Document on which to start the search.

See Also

TextSearch Class
PDFTron.SilverDox.Documents.Text Namespace


SearchNextAsync Method

[image]

PDFTron SilverDox SDK
TextSearch..::..SearchNextAsync Method
TextSearch Class See Also Send Feedback
Attempts to find the next instance of the search string specified in SearchBegin(String, TextSearch..::..SearchModes, Int32).

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void SearchNextAsync(
    Action<TextSearch..::..OnTextSearchAsyncCallbackArgs> onTextSearchAsyncCallback,
    Object userData
)
Visual Basic
Public Sub SearchNextAsync ( _
    onTextSearchAsyncCallback As Action(Of TextSearch..::..OnTextSearchAsyncCallbackArgs), _
    userData As Object _
)
Visual C++
public:
void SearchNextAsync(
    Action<TextSearch..::..OnTextSearchAsyncCallbackArgs^>^ onTextSearchAsyncCallback,
    Object^ userData
)

Parameters

onTextSearchAsyncCallback
Type: System..::..Action <(Of <(<' TextSearch..::..OnTextSearchAsyncCallbackArgs >)>)>
The callback function to call when the search completes. The search may complete when the search term is found, when the entire document has been searched, and, depending on the search options, at the end of every page.
userData
Type: System..::..Object
Custom data that will be included in the callback function's arguments.

See Also

TextSearch Class
PDFTron.SilverDox.Documents.Text Namespace


TextSearch.OnTextSearchAsyncCallbackArgs Class

[image]

PDFTron SilverDox SDK
TextSearch..::..OnTextSearchAsyncCallbackArgs Class
TextSearch Class Members See Also Send Feedback
Arguments used as a parameter in the user defined callback function provided to SearchNextAsync(Action<(Of <<'(TextSearch..::..OnTextSearchAsyncCallbackArgs>)>>), Object).

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class OnTextSearchAsyncCallbackArgs : IAsyncResult
Visual Basic
Public Class OnTextSearchAsyncCallbackArgs _
    Implements IAsyncResult
Visual C++
public ref class OnTextSearchAsyncCallbackArgs : IAsyncResult

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents.Text..::..TextSearch..::..OnTextSearchAsyncCallbackArgs

See Also

TextSearch..::..OnTextSearchAsyncCallbackArgs Members
PDFTron.SilverDox.Documents.Text Namespace


TextSearch.OnTextSearchAsyncCallbackArgs Members

[image] [image]

PDFTron SilverDox SDK
TextSearch..::..OnTextSearchAsyncCallbackArgs Members
TextSearch..::..OnTextSearchAsyncCallbackArgs Class Properties See Also Send Feedback

TextSearch searches through a Document for a user-given search pattern. TextSearch provides users with several useful search modes and extra information besides the found string that matches the pattern. TextSearch can either keep running until a matched string is found or be set to return periodically in order for the caller to perform any necessary updates (e.g., UI updates).

The TextSearch..::..OnTextSearchAsyncCallbackArgs type exposes the following members.

Properties

 | Name | Description
Public property | AmbientString | The text surrounding the ResultString.
Public property | AsyncState | Gets a user-defined object that qualifies or contains information about an asynchronous operation.
Public property | AsyncWaitHandle | Gets a WaitHandle that is used to wait for an asynchronous operation to complete.
Public property | CompletedSynchronously | Gets a value that indicates whether the asynchronous operation completed synchronously.
Public property | Error | If an error has occured, Error contains information about the error; otherwise, Error is null.
Public property | IsCompleted | Gets a value that indicates whether the asynchronous operation has completed.
Public property | PageNumber | The page number which the search was conducted on.
Public property | Quads | A list of Quads, representing the bounding box(es) of the found text. Useful for highlighting the text.
Public property | ResultCode | The reason the search completed.
Public property | ResultString | The found text.

See Also

TextSearch..::..OnTextSearchAsyncCallbackArgs Class
PDFTron.SilverDox.Documents.Text Namespace


TextSearch.OnTextSearchAsyncCallbackArgs Properties

[image] [image]

PDFTron SilverDox SDK
TextSearch..::..OnTextSearchAsyncCallbackArgs Properties
TextSearch..::..OnTextSearchAsyncCallbackArgs Class See Also Send Feedback

The TextSearch..::..OnTextSearchAsyncCallbackArgs type exposes the following members.

Properties

 | Name | Description
Public property | AmbientString | The text surrounding the ResultString.
Public property | AsyncState | Gets a user-defined object that qualifies or contains information about an asynchronous operation.
Public property | AsyncWaitHandle | Gets a WaitHandle that is used to wait for an asynchronous operation to complete.
Public property | CompletedSynchronously | Gets a value that indicates whether the asynchronous operation completed synchronously.
Public property | Error | If an error has occured, Error contains information about the error; otherwise, Error is null.
Public property | IsCompleted | Gets a value that indicates whether the asynchronous operation has completed.
Public property | PageNumber | The page number which the search was conducted on.
Public property | Quads | A list of Quads, representing the bounding box(es) of the found text. Useful for highlighting the text.
Public property | ResultCode | The reason the search completed.
Public property | ResultString | The found text.

See Also

TextSearch..::..OnTextSearchAsyncCallbackArgs Class
PDFTron.SilverDox.Documents.Text Namespace


AmbientString Property

[image]

PDFTron SilverDox SDK
TextSearch..::..OnTextSearchAsyncCallbackArgs..::..AmbientString Property
TextSearch..::..OnTextSearchAsyncCallbackArgs Class See Also Send Feedback
The text surrounding the ResultString.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string AmbientString { get; internal set; }
Visual Basic
Public Property AmbientString As String
    Get
    Friend Set
Visual C++
public:
property String^ AmbientString {
    String^ get ();
    internal: void set (String^ value);
}

See Also

TextSearch..::..OnTextSearchAsyncCallbackArgs Class
PDFTron.SilverDox.Documents.Text Namespace


AsyncState Property

[image]

PDFTron SilverDox SDK
TextSearch..::..OnTextSearchAsyncCallbackArgs..::..AsyncState Property
TextSearch..::..OnTextSearchAsyncCallbackArgs Class See Also Send Feedback
Gets a user-defined object that qualifies or contains information about an asynchronous operation.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Object AsyncState { get; internal set; }
Visual Basic
Public Property AsyncState As Object
    Get
    Friend Set
Visual C++
public:
virtual property Object^ AsyncState {
    Object^ get () sealed;
    internal: void set (Object^ value) sealed;
}

Implements

IAsyncResult..::..AsyncState

See Also

TextSearch..::..OnTextSearchAsyncCallbackArgs Class
PDFTron.SilverDox.Documents.Text Namespace


AsyncWaitHandle Property

[image]

PDFTron SilverDox SDK
TextSearch..::..OnTextSearchAsyncCallbackArgs..::..AsyncWaitHandle Property
TextSearch..::..OnTextSearchAsyncCallbackArgs Class See Also Send Feedback
Gets a WaitHandle that is used to wait for an asynchronous operation to complete.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public WaitHandle AsyncWaitHandle { get; private set; }
Visual Basic
Public Property AsyncWaitHandle As WaitHandle
    Get
    Private Set
Visual C++
public:
virtual property WaitHandle^ AsyncWaitHandle {
    WaitHandle^ get () sealed;
    private: void set (WaitHandle^ value) sealed;
}

Implements

IAsyncResult..::..AsyncWaitHandle

See Also

TextSearch..::..OnTextSearchAsyncCallbackArgs Class
PDFTron.SilverDox.Documents.Text Namespace


CompletedSynchronously Property

[image]

PDFTron SilverDox SDK
TextSearch..::..OnTextSearchAsyncCallbackArgs..::..CompletedSynchronously Property
TextSearch..::..OnTextSearchAsyncCallbackArgs Class See Also Send Feedback
Gets a value that indicates whether the asynchronous operation completed synchronously.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool CompletedSynchronously { get; internal set; }
Visual Basic
Public Property CompletedSynchronously As Boolean
    Get
    Friend Set
Visual C++
public:
virtual property bool CompletedSynchronously {
    bool get () sealed;
    internal: void set (bool value) sealed;
}

Implements

IAsyncResult..::..CompletedSynchronously

See Also

TextSearch..::..OnTextSearchAsyncCallbackArgs Class
PDFTron.SilverDox.Documents.Text Namespace


Error Property

[image]

PDFTron SilverDox SDK
TextSearch..::..OnTextSearchAsyncCallbackArgs..::..Error Property
TextSearch..::..OnTextSearchAsyncCallbackArgs Class See Also Send Feedback
If an error has occured, Error contains information about the error; otherwise, Error is null.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Exception Error { get; internal set; }
Visual Basic
Public Property Error As Exception
    Get
    Friend Set
Visual C++
public:
property Exception^ Error {
    Exception^ get ();
    internal: void set (Exception^ value);
}

See Also

TextSearch..::..OnTextSearchAsyncCallbackArgs Class
PDFTron.SilverDox.Documents.Text Namespace


IsCompleted Property

[image]

PDFTron SilverDox SDK
TextSearch..::..OnTextSearchAsyncCallbackArgs..::..IsCompleted Property
TextSearch..::..OnTextSearchAsyncCallbackArgs Class See Also Send Feedback
Gets a value that indicates whether the asynchronous operation has completed.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool IsCompleted { get; private set; }
Visual Basic
Public Property IsCompleted As Boolean
    Get
    Private Set
Visual C++
public:
virtual property bool IsCompleted {
    bool get () sealed;
    private: void set (bool value) sealed;
}

Implements

IAsyncResult..::..IsCompleted

See Also

TextSearch..::..OnTextSearchAsyncCallbackArgs Class
PDFTron.SilverDox.Documents.Text Namespace


PageNumber Property

[image]

PDFTron SilverDox SDK
TextSearch..::..OnTextSearchAsyncCallbackArgs..::..PageNumber Property
TextSearch..::..OnTextSearchAsyncCallbackArgs Class See Also Send Feedback
The page number which the search was conducted on.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public int PageNumber { get; internal set; }
Visual Basic
Public Property PageNumber As Integer
    Get
    Friend Set
Visual C++
public:
property int PageNumber {
    int get ();
    internal: void set (int value);
}

See Also

TextSearch..::..OnTextSearchAsyncCallbackArgs Class
PDFTron.SilverDox.Documents.Text Namespace


Quads Property

[image]

PDFTron SilverDox SDK
TextSearch..::..OnTextSearchAsyncCallbackArgs..::..Quads Property
TextSearch..::..OnTextSearchAsyncCallbackArgs Class See Also Send Feedback
A list of Quads, representing the bounding box(es) of the found text. Useful for highlighting the text.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public List<Quad> Quads { get; internal set; }
Visual Basic
Public Property Quads As List(Of Quad)
    Get
    Friend Set
Visual C++
public:
property List<Quad>^ Quads {
    List<Quad>^ get ();
    internal: void set (List<Quad>^ value);
}

See Also

TextSearch..::..OnTextSearchAsyncCallbackArgs Class
PDFTron.SilverDox.Documents.Text Namespace


ResultCode Property

[image]

PDFTron SilverDox SDK
TextSearch..::..OnTextSearchAsyncCallbackArgs..::..ResultCode Property
TextSearch..::..OnTextSearchAsyncCallbackArgs Class See Also Send Feedback
The reason the search completed.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public TextSearch..::..SearchResultCode ResultCode { get; internal set; }
Visual Basic
Public Property ResultCode As TextSearch..::..SearchResultCode
    Get
    Friend Set
Visual C++
public:
property TextSearch..::..SearchResultCode ResultCode {
    TextSearch..::..SearchResultCode get ();
    internal: void set (TextSearch..::..SearchResultCode value);
}

See Also

TextSearch..::..OnTextSearchAsyncCallbackArgs Class
PDFTron.SilverDox.Documents.Text Namespace


ResultString Property

[image]

PDFTron SilverDox SDK
TextSearch..::..OnTextSearchAsyncCallbackArgs..::..ResultString Property
TextSearch..::..OnTextSearchAsyncCallbackArgs Class See Also Send Feedback
The found text.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string ResultString { get; internal set; }
Visual Basic
Public Property ResultString As String
    Get
    Friend Set
Visual C++
public:
property String^ ResultString {
    String^ get ();
    internal: void set (String^ value);
}

See Also

TextSearch..::..OnTextSearchAsyncCallbackArgs Class
PDFTron.SilverDox.Documents.Text Namespace


TextSearch.SearchModes Enumeration

[image]

PDFTron SilverDox SDK
TextSearch..::..SearchModes Enumeration
TextSearch Class See Also Send Feedback
Search modes that control how searching is conducted.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public enum SearchModes
Visual Basic
Public Enumeration SearchModes
Visual C++
public enum class SearchModes

Members

Member name | Value | Description
None | 0 | Default flag, does not alter search mode.
CaseSensitive | 1 | If set, the found text must match the case of the search term.
WholeWord | 2 | If set, the found text must be a whole word (preceeded and followed by a non-alphabetical character, or in the case of a number, a non-numerical character.
SearchUp | 4 | If set, the document pages will be searched in descending order, from bottom to top.
PageStop | 8 | If set, the search will return with a result code of Page at the end of every page. Useful for updating the UI.
ProvideQuads | 16 | If set, the bounding box the found term will be included. Useful for highlighting text and positioning the page.
AmbientString | 32 | If set, the characters surrounding the found term will be included. This gives context to the search result may be useful when providing a list of search results.

See Also

PDFTron.SilverDox.Documents.Text Namespace


TextSearch.SearchResultCode Enumeration

[image]

PDFTron SilverDox SDK
TextSearch..::..SearchResultCode Enumeration
TextSearch Class See Also Send Feedback
The code indicating the reason that the search process concluded.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public enum SearchResultCode
Visual Basic
Public Enumeration SearchResultCode
Visual C++
public enum class SearchResultCode

Members

Member name | Value | Description
Done | 0 | Entire document searched.
Page | 1 | Search reached end of page with no (more) found terms.
Found | 2 | The search found a match.
NotFound | 3 | The search did not find a match.
Error | 4 | An exception was found, see the associated exception for more information

See Also

PDFTron.SilverDox.Documents.Text Namespace


TextSelector Class

[image]

PDFTron SilverDox SDK
TextSelector Class
Members See Also Send Feedback
Used to identify the location of text on a page. Useful for implementing text highlighting and copying.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class TextSelector
Visual Basic
Public Class TextSelector
Visual C++
public ref class TextSelector

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents.Text..::..TextSelector

See Also

TextSelector Members
PDFTron.SilverDox.Documents.Text Namespace


TextSelector Members

[image] [image]

PDFTron SilverDox SDK
TextSelector Members
TextSelector Class Constructors Methods See Also Send Feedback

The TextSelector type exposes the following members.

Constructors

 | Name | Description
Public method | TextSelector | Constructs a new TextSelector.

Methods

 | Name | Description
Public method | SelectByRectAsync | Performs rectangular text selection. The selected text is what is found within the input selection points (specified by the two Point arguments), with whole words always selected.
Public method | SelectByStructAsync | Performs structural text selection. Which text is selected is determined using both the input selection points (specified by the two Point arguments) and the layout of the text.

See Also

TextSelector Class
PDFTron.SilverDox.Documents.Text Namespace


TextSelector Constructor

[image]

PDFTron SilverDox SDK
TextSelector Constructor
TextSelector Class See Also Send Feedback
Constructs a new TextSelector.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public TextSelector(
    Document document
)
Visual Basic
Public Sub New ( _
    document As Document _
)
Visual C++
public:
TextSelector(
    Document^ document
)

Parameters

document
Type: PDFTron.SilverDox.Documents..::..Document
The Document that will be used for text selection.

See Also

TextSelector Class
PDFTron.SilverDox.Documents.Text Namespace


TextSelector Methods

[image] [image]

PDFTron SilverDox SDK
TextSelector Methods
TextSelector Class See Also Send Feedback

The TextSelector type exposes the following members.

Methods

 | Name | Description
Public method | SelectByRectAsync | Performs rectangular text selection. The selected text is what is found within the input selection points (specified by the two Point arguments), with whole words always selected.
Public method | SelectByStructAsync | Performs structural text selection. Which text is selected is determined using both the input selection points (specified by the two Point arguments) and the layout of the text.

See Also

TextSelector Class
PDFTron.SilverDox.Documents.Text Namespace


SelectByRectAsync Method

[image]

PDFTron SilverDox SDK
TextSelector..::..SelectByRectAsync Method
TextSelector Class See Also Send Feedback
Performs rectangular text selection. The selected text is what is found within the input selection points (specified by the two Point arguments), with whole words always selected.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void SelectByRectAsync(
    int pageNumber,
    Point startPoint,
    Point endPoint,
    Action<TextSelector..::..OnTextSelectionAsyncCallbackArgs> onTextSelectionAsyncCallback
)
Visual Basic
Public Sub SelectByRectAsync ( _
    pageNumber As Integer, _
    startPoint As Point, _
    endPoint As Point, _
    onTextSelectionAsyncCallback As Action(Of TextSelector..::..OnTextSelectionAsyncCallbackArgs) _
)
Visual C++
public:
void SelectByRectAsync(
    int pageNumber,
    Point startPoint,
    Point endPoint,
    Action<TextSelector..::..OnTextSelectionAsyncCallbackArgs^>^ onTextSelectionAsyncCallback
)

Parameters

pageNumber
Type: System..::..Int32
The page number of the Document on which to select text.
startPoint
Type: System.Windows..::..Point
The first point of the selection rectangle.
endPoint
Type: System.Windows..::..Point
The second point of the selection rectangle.
onTextSelectionAsyncCallback
Type: System..::..Action <(Of <(<' TextSelector..::..OnTextSelectionAsyncCallbackArgs >)>)>
The callback function that is called when the method returns.

See Also

TextSelector Class
PDFTron.SilverDox.Documents.Text Namespace


SelectByStructAsync Method

[image]

PDFTron SilverDox SDK
TextSelector..::..SelectByStructAsync Method
TextSelector Class See Also Send Feedback
Performs structural text selection. Which text is selected is determined using both the input selection points (specified by the two Point arguments) and the layout of the text.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void SelectByStructAsync(
    int pageNumber,
    Point startPoint,
    Point endPoint,
    Action<TextSelector..::..OnTextSelectionAsyncCallbackArgs> onTextSelectionAsyncCallback
)
Visual Basic
Public Sub SelectByStructAsync ( _
    pageNumber As Integer, _
    startPoint As Point, _
    endPoint As Point, _
    onTextSelectionAsyncCallback As Action(Of TextSelector..::..OnTextSelectionAsyncCallbackArgs) _
)
Visual C++
public:
void SelectByStructAsync(
    int pageNumber,
    Point startPoint,
    Point endPoint,
    Action<TextSelector..::..OnTextSelectionAsyncCallbackArgs^>^ onTextSelectionAsyncCallback
)

Parameters

pageNumber
Type: System..::..Int32
The page number of the Document()()()() on which to select text.
startPoint
Type: System.Windows..::..Point
The first point of the selection rectangle.
endPoint
Type: System.Windows..::..Point
The second point of the selection rectangle.
onTextSelectionAsyncCallback
Type: System..::..Action <(Of <(<' TextSelector..::..OnTextSelectionAsyncCallbackArgs >)>)>
The callback function that is called when the method returns.

See Also

TextSelector Class
PDFTron.SilverDox.Documents.Text Namespace


TextSelector.OnTextSelectionAsyncCallbackArgs Class

[image]

PDFTron SilverDox SDK
TextSelector..::..OnTextSelectionAsyncCallbackArgs Class
TextSelector Class Members See Also Send Feedback
Arguments used as a parameter in the user defined callback function provided to SelectByRectAsync(Int32, Point, Point, Action<(Of <<'(TextSelector..::..OnTextSelectionAsyncCallbackArgs>)>>)) and SelectByStructAsync(Int32, Point, Point, Action<(Of <<'(TextSelector..::..OnTextSelectionAsyncCallbackArgs>)>>)).

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class OnTextSelectionAsyncCallbackArgs : IAsyncResult
Visual Basic
Public Class OnTextSelectionAsyncCallbackArgs _
    Implements IAsyncResult
Visual C++
public ref class OnTextSelectionAsyncCallbackArgs : IAsyncResult

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.Documents.Text..::..TextSelector..::..OnTextSelectionAsyncCallbackArgs

See Also

TextSelector..::..OnTextSelectionAsyncCallbackArgs Members
PDFTron.SilverDox.Documents.Text Namespace


TextSelector.OnTextSelectionAsyncCallbackArgs Members

[image] [image]

PDFTron SilverDox SDK
TextSelector..::..OnTextSelectionAsyncCallbackArgs Members
TextSelector..::..OnTextSelectionAsyncCallbackArgs Class Properties See Also Send Feedback

Used to identify the location of text on a page. Useful for implementing text highlighting and copying.

The TextSelector..::..OnTextSelectionAsyncCallbackArgs type exposes the following members.

Properties

 | Name | Description
Public property | AsyncState | Gets a user-defined object that qualifies or contains information about an asynchronous operation.
Public property | AsyncWaitHandle | Gets a WaitHandle that is used to wait for an asynchronous operation to complete.
Public property | CompletedSynchronously | Gets a value that indicates whether the asynchronous operation completed synchronously.
Public property | Error | If an error has occured, Error contains information about the error; otherwise, Error is null.
Public property | IsCompleted | Gets a value that indicates whether the asynchronous operation has completed.
Public property | Quads | A list of Quads, representing the bounding box(es) of selected text. Useful for highlighting the text.
Public property | Text | The string representing the selected text.

See Also

TextSelector..::..OnTextSelectionAsyncCallbackArgs Class
PDFTron.SilverDox.Documents.Text Namespace


TextSelector.OnTextSelectionAsyncCallbackArgs Properties

[image] [image]

PDFTron SilverDox SDK
TextSelector..::..OnTextSelectionAsyncCallbackArgs Properties
TextSelector..::..OnTextSelectionAsyncCallbackArgs Class See Also Send Feedback

The TextSelector..::..OnTextSelectionAsyncCallbackArgs type exposes the following members.

Properties

 | Name | Description
Public property | AsyncState | Gets a user-defined object that qualifies or contains information about an asynchronous operation.
Public property | AsyncWaitHandle | Gets a WaitHandle that is used to wait for an asynchronous operation to complete.
Public property | CompletedSynchronously | Gets a value that indicates whether the asynchronous operation completed synchronously.
Public property | Error | If an error has occured, Error contains information about the error; otherwise, Error is null.
Public property | IsCompleted | Gets a value that indicates whether the asynchronous operation has completed.
Public property | Quads | A list of Quads, representing the bounding box(es) of selected text. Useful for highlighting the text.
Public property | Text | The string representing the selected text.

See Also

TextSelector..::..OnTextSelectionAsyncCallbackArgs Class
PDFTron.SilverDox.Documents.Text Namespace


AsyncState Property

[image]

PDFTron SilverDox SDK
TextSelector..::..OnTextSelectionAsyncCallbackArgs..::..AsyncState Property
TextSelector..::..OnTextSelectionAsyncCallbackArgs Class See Also Send Feedback
Gets a user-defined object that qualifies or contains information about an asynchronous operation.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Object AsyncState { get; internal set; }
Visual Basic
Public Property AsyncState As Object
    Get
    Friend Set
Visual C++
public:
virtual property Object^ AsyncState {
    Object^ get () sealed;
    internal: void set (Object^ value) sealed;
}

Implements

IAsyncResult..::..AsyncState

See Also

TextSelector..::..OnTextSelectionAsyncCallbackArgs Class
PDFTron.SilverDox.Documents.Text Namespace


AsyncWaitHandle Property

[image]

PDFTron SilverDox SDK
TextSelector..::..OnTextSelectionAsyncCallbackArgs..::..AsyncWaitHandle Property
TextSelector..::..OnTextSelectionAsyncCallbackArgs Class See Also Send Feedback
Gets a WaitHandle that is used to wait for an asynchronous operation to complete.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public WaitHandle AsyncWaitHandle { get; private set; }
Visual Basic
Public Property AsyncWaitHandle As WaitHandle
    Get
    Private Set
Visual C++
public:
virtual property WaitHandle^ AsyncWaitHandle {
    WaitHandle^ get () sealed;
    private: void set (WaitHandle^ value) sealed;
}

Implements

IAsyncResult..::..AsyncWaitHandle

See Also

TextSelector..::..OnTextSelectionAsyncCallbackArgs Class
PDFTron.SilverDox.Documents.Text Namespace


CompletedSynchronously Property

[image]

PDFTron SilverDox SDK
TextSelector..::..OnTextSelectionAsyncCallbackArgs..::..CompletedSynchronously Property
TextSelector..::..OnTextSelectionAsyncCallbackArgs Class See Also Send Feedback
Gets a value that indicates whether the asynchronous operation completed synchronously.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool CompletedSynchronously { get; internal set; }
Visual Basic
Public Property CompletedSynchronously As Boolean
    Get
    Friend Set
Visual C++
public:
virtual property bool CompletedSynchronously {
    bool get () sealed;
    internal: void set (bool value) sealed;
}

Implements

IAsyncResult..::..CompletedSynchronously

See Also

TextSelector..::..OnTextSelectionAsyncCallbackArgs Class
PDFTron.SilverDox.Documents.Text Namespace


Error Property

[image]

PDFTron SilverDox SDK
TextSelector..::..OnTextSelectionAsyncCallbackArgs..::..Error Property
TextSelector..::..OnTextSelectionAsyncCallbackArgs Class See Also Send Feedback
If an error has occured, Error contains information about the error; otherwise, Error is null.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Exception Error { get; private set; }
Visual Basic
Public Property Error As Exception
    Get
    Private Set
Visual C++
public:
property Exception^ Error {
    Exception^ get ();
    private: void set (Exception^ value);
}

See Also

TextSelector..::..OnTextSelectionAsyncCallbackArgs Class
PDFTron.SilverDox.Documents.Text Namespace


IsCompleted Property

[image]

PDFTron SilverDox SDK
TextSelector..::..OnTextSelectionAsyncCallbackArgs..::..IsCompleted Property
TextSelector..::..OnTextSelectionAsyncCallbackArgs Class See Also Send Feedback
Gets a value that indicates whether the asynchronous operation has completed.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool IsCompleted { get; private set; }
Visual Basic
Public Property IsCompleted As Boolean
    Get
    Private Set
Visual C++
public:
virtual property bool IsCompleted {
    bool get () sealed;
    private: void set (bool value) sealed;
}

Implements

IAsyncResult..::..IsCompleted

See Also

TextSelector..::..OnTextSelectionAsyncCallbackArgs Class
PDFTron.SilverDox.Documents.Text Namespace


Quads Property

[image]

PDFTron SilverDox SDK
TextSelector..::..OnTextSelectionAsyncCallbackArgs..::..Quads Property
TextSelector..::..OnTextSelectionAsyncCallbackArgs Class See Also Send Feedback
A list of Quads, representing the bounding box(es) of selected text. Useful for highlighting the text.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public List<Quad> Quads { get; internal set; }
Visual Basic
Public Property Quads As List(Of Quad)
    Get
    Friend Set
Visual C++
public:
property List<Quad>^ Quads {
    List<Quad>^ get ();
    internal: void set (List<Quad>^ value);
}

See Also

TextSelector..::..OnTextSelectionAsyncCallbackArgs Class
PDFTron.SilverDox.Documents.Text Namespace


Text Property

[image]

PDFTron SilverDox SDK
TextSelector..::..OnTextSelectionAsyncCallbackArgs..::..Text Property
TextSelector..::..OnTextSelectionAsyncCallbackArgs Class See Also Send Feedback
The string representing the selected text.

Namespace: PDFTron.SilverDox.Documents.Text
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string Text { get; internal set; }
Visual Basic
Public Property Text As String
    Get
    Friend Set
Visual C++
public:
property String^ Text {
    String^ get ();
    internal: void set (String^ value);
}

See Also

TextSelector..::..OnTextSelectionAsyncCallbackArgs Class
PDFTron.SilverDox.Documents.Text Namespace


PDFTron.SilverDox.IO Namespace

[image]

PDFTron SilverDox SDK
PDFTron.SilverDox.IO Namespace
Send Feedback
Contains classes used to load a Document from a local file system or a web server, and an interface that can be extended to allow a Document to be loaded from any storage location.

Classes

 | Class | Description
Public class | HttpPartRetriever | Retrieves Document parts asynchronously from a .xod file hosted on a web server. The server is required to support the HTTP/1.1 protocol.
Public class | HttpStreamingPartRetriever | Streams a .xod file hosted on a web server and display pages as they are available.
Public class | LocalPartRetriever | Retrieves Document parts asynchronously from locally hosted .xod file.
Public class | OnPartReadyEventArgs | Arguments that are a parameter to the OnPartReady event handler.

Interfaces

 | Interface | Description
Public interface | IPartRetriever | The interface which is implemented by a part retriever. A part retriever is an object that is responsible for accessing a .xod document, and returning the requested document parts.

Remarks

Unless one is creating a custom part retriever, normal usage is to construct either a HttpPartRetriever or a LocalPartRetriever and pass it as an argument to to Document's LoadAsync(IPartRetriever, Action<(Of <<'(Exception>)>>)) method or DocumentViewer's LoadAsync(IPartRetriever, Action<(Of <<'(Exception>)>>)) method to facilitate loading a Document.


HttpPartRetriever Class

[image]

PDFTron SilverDox SDK
HttpPartRetriever Class
Members See Also Send Feedback
Retrieves Document parts asynchronously from a .xod file hosted on a web server. The server is required to support the HTTP/1.1 protocol.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class HttpPartRetriever : IPartRetriever
Visual Basic
Public Class HttpPartRetriever _
    Implements IPartRetriever
Visual C++
public ref class HttpPartRetriever : IPartRetriever

Remarks

This retriever (like all retrievers) is typically passed to Document's LoadAsync(IPartRetriever, Action<(Of <<'(Exception>)>>)) method or DocumentViewer's LoadAsync(IPartRetriever, Action<(Of <<'(Exception>)>>)) method to facilitate loading a Document. This particular retriever is used to retrieve a Silverlight files from an HTTP server that supports byte-serving. Byte serving allows the retriever to transfer arbitrary parts of the file, allowing whatever page is visible to be transferred before other pages that have not yet been transferred. This is the preferred part retriever when requesting previously-converted documents from a web server.

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.IO..::..HttpPartRetriever

See Also

HttpPartRetriever Members
PDFTron.SilverDox.IO Namespace
PDFTron.SilverDox.IO..::..IPartRetriever


HttpPartRetriever Members

[image] [image]

PDFTron SilverDox SDK
HttpPartRetriever Members
HttpPartRetriever Class Constructors Methods Properties Events See Also Send Feedback

The HttpPartRetriever type exposes the following members.

Constructors

 | Name | Description
Public method | HttpPartRetriever | Constructs a new HttpPartRetriever.

Methods

 | Name | Description
Public method | CancelAllRequests | Cancels all outstanding requests.
Public method | CancelRequests | Cancels requests for specific Document parts.
Public method | Request | Requests specfic Document document parts.
Public method | RequestDocument | Requests the information necessary to initilize the Document.

Properties

 | Name | Description
Public property | BackgroundLoadDocument | If true, the part retriever will continued to download content for pages that are not currently being displayed.
Public property | Cookies | HTTP cookies that will be sent with every request. Individual cookies are delimited with semi-colons (e.g. "Name1=value1;Name2=value2"). Useful if an autentication cookies needs to be included for document access. This property is accessible via JavaScript.
Public property | ShowThumbnailBeforePageContent | If true, shows an upscaled thumbnail on a page while the page's content is downloadd.
Public property | Uri | The URI of the HTTP server-hosted .xod file.
Public property | UseDocumentThumbnailIfAvailable | If true, uses a document's pre-rendered thumbnail rather than rendering one on the fly from the page's content.

Events

 | Name | Description
Public event | OnPartReady | Raised when a part has been acquired. It is necessary to subscribe to this event to receive the parts returned by a call to the Request(List<(Of <<'(String>)>>), Object) or RequestDocument()()()() methods.

See Also

HttpPartRetriever Class
PDFTron.SilverDox.IO Namespace


HttpPartRetriever Constructor

[image]

PDFTron SilverDox SDK
HttpPartRetriever Constructor
HttpPartRetriever Class See Also Send Feedback
Constructs a new HttpPartRetriever.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public HttpPartRetriever(
    Uri uri,
    bool backgroundLoadDocument,
    string cookies
)
Visual Basic
Public Sub New ( _
    uri As Uri, _
    backgroundLoadDocument As Boolean, _
    cookies As String _
)
Visual C++
public:
HttpPartRetriever(
    Uri^ uri,
    bool backgroundLoadDocument,
    String^ cookies
)

Parameters

uri
Type: System..::..Uri
The URI of the HTTP server-hosted .xod file.
backgroundLoadDocument
Type: System..::..Boolean
If background loading should be initially set to true or false. Default is true.
cookies
Type: System..::..String
HTTP cookies that will be sent with every request. Individual cookies are delimited with semi-colons. Useful if an autentication cookies needs to be included for document access.

See Also

HttpPartRetriever Class
PDFTron.SilverDox.IO Namespace


HttpPartRetriever Methods

[image] [image]

PDFTron SilverDox SDK
HttpPartRetriever Methods
HttpPartRetriever Class See Also Send Feedback

The HttpPartRetriever type exposes the following members.

Methods

 | Name | Description
Public method | CancelAllRequests | Cancels all outstanding requests.
Public method | CancelRequests | Cancels requests for specific Document parts.
Public method | Request | Requests specfic Document document parts.
Public method | RequestDocument | Requests the information necessary to initilize the Document.

See Also

HttpPartRetriever Class
PDFTron.SilverDox.IO Namespace


CancelAllRequests Method

[image]

PDFTron SilverDox SDK
HttpPartRetriever..::..CancelAllRequests Method
HttpPartRetriever Class See Also Send Feedback
Cancels all outstanding requests.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void CancelAllRequests()
Visual Basic
Public Sub CancelAllRequests
Visual C++
public:
virtual void CancelAllRequests() sealed

Implements

IPartRetriever..::..CancelAllRequests()()()()

See Also

HttpPartRetriever Class
PDFTron.SilverDox.IO Namespace


CancelRequests Method

[image]

PDFTron SilverDox SDK
HttpPartRetriever..::..CancelRequests Method
HttpPartRetriever Class See Also Send Feedback
Cancels requests for specific Document parts.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void CancelRequests(
    List<string> parts
)
Visual Basic
Public Sub CancelRequests ( _
    parts As List(Of String) _
)
Visual C++
public:
virtual void CancelRequests(
    List<String^>^ parts
) sealed

Parameters

parts
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
The names of the parts which are no longer to be requested. Part names are typically retrieved from a Document's Pages's ResourceNames property.

Implements

IPartRetriever..::..CancelRequests(List<(Of <<'(String>)>>))

See Also

HttpPartRetriever Class
PDFTron.SilverDox.IO Namespace


Request Method

[image]

PDFTron SilverDox SDK
HttpPartRetriever..::..Request Method
HttpPartRetriever Class See Also Send Feedback
Requests specfic Document document parts.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void Request(
    List<string> parts,
    Object customData
)
Visual Basic
Public Sub Request ( _
    parts As List(Of String), _
    customData As Object _
)
Visual C++
public:
virtual void Request(
    List<String^>^ parts,
    Object^ customData
) sealed

Parameters

parts
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
The names of the requested parts, typically retrieved from a Document's Pages's ResourceNames property.
customData
Type: System..::..Object
An object that will be included as part of the OnPartReadyEventArgs.

Implements

IPartRetriever..::..Request(List<(Of <<'(String>)>>), Object)

See Also

HttpPartRetriever Class
PDFTron.SilverDox.IO Namespace


RequestDocument Method

[image]

PDFTron SilverDox SDK
HttpPartRetriever..::..RequestDocument Method
HttpPartRetriever Class See Also Send Feedback
Requests the information necessary to initilize the Document.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void RequestDocument()
Visual Basic
Public Sub RequestDocument
Visual C++
public:
virtual void RequestDocument() sealed

Implements

IPartRetriever..::..RequestDocument()()()()

See Also

HttpPartRetriever Class
PDFTron.SilverDox.IO Namespace


HttpPartRetriever Properties

[image] [image]

PDFTron SilverDox SDK
HttpPartRetriever Properties
HttpPartRetriever Class See Also Send Feedback

The HttpPartRetriever type exposes the following members.

Properties

 | Name | Description
Public property | BackgroundLoadDocument | If true, the part retriever will continued to download content for pages that are not currently being displayed.
Public property | Cookies | HTTP cookies that will be sent with every request. Individual cookies are delimited with semi-colons (e.g. "Name1=value1;Name2=value2"). Useful if an autentication cookies needs to be included for document access. This property is accessible via JavaScript.
Public property | ShowThumbnailBeforePageContent | If true, shows an upscaled thumbnail on a page while the page's content is downloadd.
Public property | Uri | The URI of the HTTP server-hosted .xod file.
Public property | UseDocumentThumbnailIfAvailable | If true, uses a document's pre-rendered thumbnail rather than rendering one on the fly from the page's content.

See Also

HttpPartRetriever Class
PDFTron.SilverDox.IO Namespace


BackgroundLoadDocument Property

[image]

PDFTron SilverDox SDK
HttpPartRetriever..::..BackgroundLoadDocument Property
HttpPartRetriever Class See Also Send Feedback
If true, the part retriever will continued to download content for pages that are not currently being displayed.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool BackgroundLoadDocument { get; set; }
Visual Basic
Public Property BackgroundLoadDocument As Boolean
    Get
    Set
Visual C++
public:
virtual property bool BackgroundLoadDocument {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IPartRetriever..::..BackgroundLoadDocument

See Also

HttpPartRetriever Class
PDFTron.SilverDox.IO Namespace


Cookies Property

[image]

PDFTron SilverDox SDK
HttpPartRetriever..::..Cookies Property
HttpPartRetriever Class See Also Send Feedback
HTTP cookies that will be sent with every request. Individual cookies are delimited with semi-colons (e.g. "Name1=value1;Name2=value2"). Useful if an autentication cookies needs to be included for document access. This property is accessible via JavaScript.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string Cookies { get; set; }
Visual Basic
Public Property Cookies As String
    Get
    Set
Visual C++
public:
property String^ Cookies {
    String^ get ();
    void set (String^ value);
}

See Also

HttpPartRetriever Class
PDFTron.SilverDox.IO Namespace


ShowThumbnailBeforePageContent Property

[image]

PDFTron SilverDox SDK
HttpPartRetriever..::..ShowThumbnailBeforePageContent Property
HttpPartRetriever Class See Also Send Feedback
If true, shows an upscaled thumbnail on a page while the page's content is downloadd.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool ShowThumbnailBeforePageContent { get; set; }
Visual Basic
Public Property ShowThumbnailBeforePageContent As Boolean
    Get
    Set
Visual C++
public:
virtual property bool ShowThumbnailBeforePageContent {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IPartRetriever..::..ShowThumbnailBeforePageContent

See Also

HttpPartRetriever Class
PDFTron.SilverDox.IO Namespace


Uri Property

[image]

PDFTron SilverDox SDK
HttpPartRetriever..::..Uri Property
HttpPartRetriever Class See Also Send Feedback
The URI of the HTTP server-hosted .xod file.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Uri Uri { get; set; }
Visual Basic
Public Property Uri As Uri
    Get
    Set
Visual C++
public:
virtual property Uri^ Uri {
    Uri^ get () sealed;
    void set (Uri^ value) sealed;
}

Implements

IPartRetriever..::..Uri

See Also

HttpPartRetriever Class
PDFTron.SilverDox.IO Namespace


UseDocumentThumbnailIfAvailable Property

[image]

PDFTron SilverDox SDK
HttpPartRetriever..::..UseDocumentThumbnailIfAvailable Property
HttpPartRetriever Class See Also Send Feedback
If true, uses a document's pre-rendered thumbnail rather than rendering one on the fly from the page's content.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool UseDocumentThumbnailIfAvailable { get; set; }
Visual Basic
Public Property UseDocumentThumbnailIfAvailable As Boolean
    Get
    Set
Visual C++
public:
virtual property bool UseDocumentThumbnailIfAvailable {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IPartRetriever..::..UseDocumentThumbnailIfAvailable

See Also

HttpPartRetriever Class
PDFTron.SilverDox.IO Namespace


HttpPartRetriever Events

[image] [image]

PDFTron SilverDox SDK
HttpPartRetriever Events
HttpPartRetriever Class See Also Send Feedback

The HttpPartRetriever type exposes the following members.

Events

 | Name | Description
Public event | OnPartReady | Raised when a part has been acquired. It is necessary to subscribe to this event to receive the parts returned by a call to the Request(List<(Of <<'(String>)>>), Object) or RequestDocument()()()() methods.

See Also

HttpPartRetriever Class
PDFTron.SilverDox.IO Namespace


OnPartReady Event

[image]

PDFTron SilverDox SDK
HttpPartRetriever..::..OnPartReady Event
HttpPartRetriever Class See Also Send Feedback
Raised when a part has been acquired. It is necessary to subscribe to this event to receive the parts returned by a call to the Request(List<(Of <<'(String>)>>), Object) or RequestDocument()()()() methods.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public event EventHandler<OnPartReadyEventArgs> OnPartReady
Visual Basic
Public Event OnPartReady As EventHandler(Of OnPartReadyEventArgs)
Visual C++
public:
virtual  event EventHandler<OnPartReadyEventArgs^>^ OnPartReady {
    void add (EventHandler<OnPartReadyEventArgs^>^ value);
    void remove (EventHandler<OnPartReadyEventArgs^>^ value);
}

Implements

IPartRetriever..::..OnPartReady

See Also

HttpPartRetriever Class
PDFTron.SilverDox.IO Namespace


HttpStreamingPartRetriever Class

[image]

PDFTron SilverDox SDK
HttpStreamingPartRetriever Class
Members See Also Send Feedback
Streams a .xod file hosted on a web server and display pages as they are available.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class HttpStreamingPartRetriever : IPartRetriever
Visual Basic
Public Class HttpStreamingPartRetriever _
    Implements IPartRetriever
Visual C++
public ref class HttpStreamingPartRetriever : IPartRetriever

Remarks

This retriever (like all retrievers) is typically passed to Document's LoadAsync(IPartRetriever, Action<(Of <<'(Exception>)>>)) method or DocumentViewer's LoadAsync(IPartRetriever, Action<(Of <<'(Exception>)>>)) method to facilitate loading a Document. This particular retriever is used to retrieve a document from an HTTP server that does not support byte-serving, or optionally when the document is converted to Silverlight XPS (XOD) on demand. This retriever transfers the entire document in order from beginning to end, with pages and thumbnails displayed as each page arrives.

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.IO..::..HttpStreamingPartRetriever

See Also

HttpStreamingPartRetriever Members
PDFTron.SilverDox.IO Namespace
PDFTron.SilverDox.IO..::..IPartRetriever


HttpStreamingPartRetriever Members

[image] [image]

PDFTron SilverDox SDK
HttpStreamingPartRetriever Members
HttpStreamingPartRetriever Class Constructors Methods Properties Events See Also Send Feedback

The HttpStreamingPartRetriever type exposes the following members.

Constructors

 | Name | Description
Public method | HttpStreamingPartRetriever | Constructs a new HttpStreamingPartRetriever.

Methods

 | Name | Description
Public method | AddBytes | If the .xod if not accessed via a URI but via some other mechanism that can provide a stream of bytes (e.g. directly from a WCF service), then this method may be used to provide the retriever with bytes as they become available. Do not provide the constructor with a URI if you intend to use this method.
Public method | CancelAllRequests | Cancels all outstanding requests.
Public method | CancelRequests | Cancels requests for specific Document parts.
Public method | Request | Requests specfic Document document parts.
Public method | RequestDocument | Requests the information necessary to initilize the Document.

Properties

 | Name | Description
Public property | BackgroundLoadDocument | If true, the part retriever will continued to download content for pages that are not currently being displayed.
Public property | ShowThumbnailBeforePageContent | If true, shows an upscaled thumbnail on a page while the page's content is downloadd.
Public property | Uri | The URI of the HTTP server-hosted .xod file.
Public property | UseDocumentThumbnailIfAvailable | If true, uses a document's pre-rendered thumbnail rather than rendering one on the fly from the page's content.

Events

 | Name | Description
Public event | OnPartReady | Raised when a part has been acquired. It is necessary to subscribe to this event to receive the parts returned by a call to the Request(List<(Of <<'(String>)>>), Object) or RequestDocument()()()() methods.

See Also

HttpStreamingPartRetriever Class
PDFTron.SilverDox.IO Namespace


HttpStreamingPartRetriever Constructor

[image]

PDFTron SilverDox SDK
HttpStreamingPartRetriever Constructor
HttpStreamingPartRetriever Class See Also Send Feedback
Constructs a new HttpStreamingPartRetriever.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public HttpStreamingPartRetriever(
    Uri uri,
    bool backgroundLoadDocument
)
Visual Basic
Public Sub New ( _
    uri As Uri, _
    backgroundLoadDocument As Boolean _
)
Visual C++
public:
HttpStreamingPartRetriever(
    Uri^ uri,
    bool backgroundLoadDocument
)

Parameters

uri
Type: System..::..Uri
The URI of the HTTP server-hosted .xod file.
backgroundLoadDocument
Type: System..::..Boolean
This parameter is included for consistency between part retrievers; however, as the streaming part retriever loads the entire document from beginning to end, this parameter has no effect.

See Also

HttpStreamingPartRetriever Class
PDFTron.SilverDox.IO Namespace


HttpStreamingPartRetriever Methods

[image] [image]

PDFTron SilverDox SDK
HttpStreamingPartRetriever Methods
HttpStreamingPartRetriever Class See Also Send Feedback

The HttpStreamingPartRetriever type exposes the following members.

Methods

 | Name | Description
Public method | AddBytes | If the .xod if not accessed via a URI but via some other mechanism that can provide a stream of bytes (e.g. directly from a WCF service), then this method may be used to provide the retriever with bytes as they become available. Do not provide the constructor with a URI if you intend to use this method.
Public method | CancelAllRequests | Cancels all outstanding requests.
Public method | CancelRequests | Cancels requests for specific Document parts.
Public method | Request | Requests specfic Document document parts.
Public method | RequestDocument | Requests the information necessary to initilize the Document.

See Also

HttpStreamingPartRetriever Class
PDFTron.SilverDox.IO Namespace


AddBytes Method

[image]

PDFTron SilverDox SDK
HttpStreamingPartRetriever..::..AddBytes Method
HttpStreamingPartRetriever Class See Also Send Feedback
If the .xod if not accessed via a URI but via some other mechanism that can provide a stream of bytes (e.g. directly from a WCF service), then this method may be used to provide the retriever with bytes as they become available. Do not provide the constructor with a URI if you intend to use this method.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void AddBytes(
    byte[] newBytes,
    int numNewBytes
)
Visual Basic
Public Sub AddBytes ( _
    newBytes As Byte(), _
    numNewBytes As Integer _
)
Visual C++
public:
void AddBytes(
    array<unsigned char>^ newBytes,
    int numNewBytes
)

Parameters

newBytes
Type: array< System..::..Byte >[]()[][]
A byte array containing the new bytes.
numNewBytes
Type: System..::..Int32
The number of valid bytes in the array.

Remarks

This method is not normally used as most scenarios involve transfering the document from a URI provided to the retriever in the constructor.

See Also

HttpStreamingPartRetriever Class
PDFTron.SilverDox.IO Namespace


CancelAllRequests Method

[image]

PDFTron SilverDox SDK
HttpStreamingPartRetriever..::..CancelAllRequests Method
HttpStreamingPartRetriever Class See Also Send Feedback
Cancels all outstanding requests.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void CancelAllRequests()
Visual Basic
Public Sub CancelAllRequests
Visual C++
public:
virtual void CancelAllRequests() sealed

Implements

IPartRetriever..::..CancelAllRequests()()()()

See Also

HttpStreamingPartRetriever Class
PDFTron.SilverDox.IO Namespace


CancelRequests Method

[image]

PDFTron SilverDox SDK
HttpStreamingPartRetriever..::..CancelRequests Method
HttpStreamingPartRetriever Class See Also Send Feedback
Cancels requests for specific Document parts.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void CancelRequests(
    List<string> parts
)
Visual Basic
Public Sub CancelRequests ( _
    parts As List(Of String) _
)
Visual C++
public:
virtual void CancelRequests(
    List<String^>^ parts
) sealed

Parameters

parts
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
The names of the parts which are no longer to be requested. Part names are typically retrieved from a Document's Pages's ResourceNames property.

Implements

IPartRetriever..::..CancelRequests(List<(Of <<'(String>)>>))

See Also

HttpStreamingPartRetriever Class
PDFTron.SilverDox.IO Namespace


Request Method

[image]

PDFTron SilverDox SDK
HttpStreamingPartRetriever..::..Request Method
HttpStreamingPartRetriever Class See Also Send Feedback
Requests specfic Document document parts.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void Request(
    List<string> parts,
    Object customData
)
Visual Basic
Public Sub Request ( _
    parts As List(Of String), _
    customData As Object _
)
Visual C++
public:
virtual void Request(
    List<String^>^ parts,
    Object^ customData
) sealed

Parameters

parts
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
The names of the requested parts, typically retrieved from a Document's Pages's ResourceNames property.
customData
Type: System..::..Object
An object that will be included as part of the OnPartReadyEventArgs.

Implements

IPartRetriever..::..Request(List<(Of <<'(String>)>>), Object)

See Also

HttpStreamingPartRetriever Class
PDFTron.SilverDox.IO Namespace


RequestDocument Method

[image]

PDFTron SilverDox SDK
HttpStreamingPartRetriever..::..RequestDocument Method
HttpStreamingPartRetriever Class See Also Send Feedback
Requests the information necessary to initilize the Document.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void RequestDocument()
Visual Basic
Public Sub RequestDocument
Visual C++
public:
virtual void RequestDocument() sealed

Implements

IPartRetriever..::..RequestDocument()()()()

See Also

HttpStreamingPartRetriever Class
PDFTron.SilverDox.IO Namespace


HttpStreamingPartRetriever Properties

[image] [image]

PDFTron SilverDox SDK
HttpStreamingPartRetriever Properties
HttpStreamingPartRetriever Class See Also Send Feedback

The HttpStreamingPartRetriever type exposes the following members.

Properties

 | Name | Description
Public property | BackgroundLoadDocument | If true, the part retriever will continued to download content for pages that are not currently being displayed.
Public property | ShowThumbnailBeforePageContent | If true, shows an upscaled thumbnail on a page while the page's content is downloadd.
Public property | Uri | The URI of the HTTP server-hosted .xod file.
Public property | UseDocumentThumbnailIfAvailable | If true, uses a document's pre-rendered thumbnail rather than rendering one on the fly from the page's content.

See Also

HttpStreamingPartRetriever Class
PDFTron.SilverDox.IO Namespace


BackgroundLoadDocument Property

[image]

PDFTron SilverDox SDK
HttpStreamingPartRetriever..::..BackgroundLoadDocument Property
HttpStreamingPartRetriever Class See Also Send Feedback
If true, the part retriever will continued to download content for pages that are not currently being displayed.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool BackgroundLoadDocument { get; set; }
Visual Basic
Public Property BackgroundLoadDocument As Boolean
    Get
    Set
Visual C++
public:
virtual property bool BackgroundLoadDocument {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IPartRetriever..::..BackgroundLoadDocument

See Also

HttpStreamingPartRetriever Class
PDFTron.SilverDox.IO Namespace


ShowThumbnailBeforePageContent Property

[image]

PDFTron SilverDox SDK
HttpStreamingPartRetriever..::..ShowThumbnailBeforePageContent Property
HttpStreamingPartRetriever Class See Also Send Feedback
If true, shows an upscaled thumbnail on a page while the page's content is downloadd.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool ShowThumbnailBeforePageContent { get; set; }
Visual Basic
Public Property ShowThumbnailBeforePageContent As Boolean
    Get
    Set
Visual C++
public:
virtual property bool ShowThumbnailBeforePageContent {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IPartRetriever..::..ShowThumbnailBeforePageContent

See Also

HttpStreamingPartRetriever Class
PDFTron.SilverDox.IO Namespace


Uri Property

[image]

PDFTron SilverDox SDK
HttpStreamingPartRetriever..::..Uri Property
HttpStreamingPartRetriever Class See Also Send Feedback
The URI of the HTTP server-hosted .xod file.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Uri Uri { get; set; }
Visual Basic
Public Property Uri As Uri
    Get
    Set
Visual C++
public:
virtual property Uri^ Uri {
    Uri^ get () sealed;
    void set (Uri^ value) sealed;
}

Implements

IPartRetriever..::..Uri

See Also

HttpStreamingPartRetriever Class
PDFTron.SilverDox.IO Namespace


UseDocumentThumbnailIfAvailable Property

[image]

PDFTron SilverDox SDK
HttpStreamingPartRetriever..::..UseDocumentThumbnailIfAvailable Property
HttpStreamingPartRetriever Class See Also Send Feedback
If true, uses a document's pre-rendered thumbnail rather than rendering one on the fly from the page's content.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool UseDocumentThumbnailIfAvailable { get; set; }
Visual Basic
Public Property UseDocumentThumbnailIfAvailable As Boolean
    Get
    Set
Visual C++
public:
virtual property bool UseDocumentThumbnailIfAvailable {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IPartRetriever..::..UseDocumentThumbnailIfAvailable

See Also

HttpStreamingPartRetriever Class
PDFTron.SilverDox.IO Namespace


HttpStreamingPartRetriever Events

[image] [image]

PDFTron SilverDox SDK
HttpStreamingPartRetriever Events
HttpStreamingPartRetriever Class See Also Send Feedback

The HttpStreamingPartRetriever type exposes the following members.

Events

 | Name | Description
Public event | OnPartReady | Raised when a part has been acquired. It is necessary to subscribe to this event to receive the parts returned by a call to the Request(List<(Of <<'(String>)>>), Object) or RequestDocument()()()() methods.

See Also

HttpStreamingPartRetriever Class
PDFTron.SilverDox.IO Namespace


OnPartReady Event

[image]

PDFTron SilverDox SDK
HttpStreamingPartRetriever..::..OnPartReady Event
HttpStreamingPartRetriever Class See Also Send Feedback
Raised when a part has been acquired. It is necessary to subscribe to this event to receive the parts returned by a call to the Request(List<(Of <<'(String>)>>), Object) or RequestDocument()()()() methods.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public event EventHandler<OnPartReadyEventArgs> OnPartReady
Visual Basic
Public Event OnPartReady As EventHandler(Of OnPartReadyEventArgs)
Visual C++
public:
virtual  event EventHandler<OnPartReadyEventArgs^>^ OnPartReady {
    void add (EventHandler<OnPartReadyEventArgs^>^ value);
    void remove (EventHandler<OnPartReadyEventArgs^>^ value);
}

Implements

IPartRetriever..::..OnPartReady

See Also

HttpStreamingPartRetriever Class
PDFTron.SilverDox.IO Namespace


IPartRetriever Interface

[image]

PDFTron SilverDox SDK
IPartRetriever Interface
Members See Also Send Feedback
The interface which is implemented by a part retriever. A part retriever is an object that is responsible for accessing a .xod document, and returning the requested document parts.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public interface IPartRetriever
Visual Basic
Public Interface IPartRetriever
Visual C++
public interface class IPartRetriever

Remarks

Two part retrievers are currently defined: LocalPartRetriever, which is used to access files on the local file system, and HttpPartRetriever, which is used to access files on a web server. A concrete instance of a part retriever is passed to Document's LoadAsync(IPartRetriever, Action<(Of <<'(Exception>)>>)) method or DocumentViewer's LoadAsync(IPartRetriever, Action<(Of <<'(Exception>)>>)) method to facilitate loading a Document.

See Also

IPartRetriever Members
PDFTron.SilverDox.IO Namespace


IPartRetriever Members

[image] [image]

PDFTron SilverDox SDK
IPartRetriever Members
IPartRetriever Interface Methods Properties Events See Also Send Feedback

The IPartRetriever type exposes the following members.

Methods

 | Name | Description
Public method | CancelAllRequests | Cancels all outstanding requests.
Public method | CancelRequests | Cancels requests for specific Document parts.
Public method | Request | Request specfic Document parts.
Public method | RequestDocument | Requests the information necessary to initilize the Document.

Properties

 | Name | Description
Public property | BackgroundLoadDocument | Gets or sets whether the Document will continue to load in the background during idle periods.
Public property | ShowThumbnailBeforePageContent | Gets or sets whether the viewer will display an enlarged thumbnail of a document's page when the page is scrolled to but has not yet been loaded.
Public property | Uri | The URI of the .xod document.
Public property | UseDocumentThumbnailIfAvailable | Gets or sets whether the method Document.LoadThumbnailAsync() will return pre-generated page thumbnails (if they are available in the document), or will create thumbnail created from the page contents.

Events

 | Name | Description
Public event | OnPartReady | Raised when a part has been acquired.

See Also

IPartRetriever Interface
PDFTron.SilverDox.IO Namespace


IPartRetriever Methods

[image] [image]

PDFTron SilverDox SDK
IPartRetriever Methods
IPartRetriever Interface See Also Send Feedback

The IPartRetriever type exposes the following members.

Methods

 | Name | Description
Public method | CancelAllRequests | Cancels all outstanding requests.
Public method | CancelRequests | Cancels requests for specific Document parts.
Public method | Request | Request specfic Document parts.
Public method | RequestDocument | Requests the information necessary to initilize the Document.

See Also

IPartRetriever Interface
PDFTron.SilverDox.IO Namespace


CancelAllRequests Method

[image]

PDFTron SilverDox SDK
IPartRetriever..::..CancelAllRequests Method
IPartRetriever Interface See Also Send Feedback
Cancels all outstanding requests.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
void CancelAllRequests()
Visual Basic
Sub CancelAllRequests
Visual C++
void CancelAllRequests()

See Also

IPartRetriever Interface
PDFTron.SilverDox.IO Namespace


CancelRequests Method

[image]

PDFTron SilverDox SDK
IPartRetriever..::..CancelRequests Method
IPartRetriever Interface See Also Send Feedback
Cancels requests for specific Document parts.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
void CancelRequests(
    List<string> parts
)
Visual Basic
Sub CancelRequests ( _
    parts As List(Of String) _
)
Visual C++
void CancelRequests(
    List<String^>^ parts
)

Parameters

parts
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
The names of the parts which are no longer to be requested. Part names are typically retrieved from a Document's Pages's ResourceNames property.

See Also

IPartRetriever Interface
PDFTron.SilverDox.IO Namespace


Request Method

[image]

PDFTron SilverDox SDK
IPartRetriever..::..Request Method
IPartRetriever Interface See Also Send Feedback
Request specfic Document parts.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
void Request(
    List<string> parts,
    Object customData
)
Visual Basic
Sub Request ( _
    parts As List(Of String), _
    customData As Object _
)
Visual C++
void Request(
    List<String^>^ parts,
    Object^ customData
)

Parameters

parts
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
The names of the requested parts, typically retrieved from a Document's Pages's ResourceNames property.
customData
Type: System..::..Object
An object that will be included as part of the OnPartReadyEventArgs.

See Also

IPartRetriever Interface
PDFTron.SilverDox.IO Namespace


RequestDocument Method

[image]

PDFTron SilverDox SDK
IPartRetriever..::..RequestDocument Method
IPartRetriever Interface See Also Send Feedback
Requests the information necessary to initilize the Document.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
void RequestDocument()
Visual Basic
Sub RequestDocument
Visual C++
void RequestDocument()

See Also

IPartRetriever Interface
PDFTron.SilverDox.IO Namespace


IPartRetriever Properties

[image] [image]

PDFTron SilverDox SDK
IPartRetriever Properties
IPartRetriever Interface See Also Send Feedback

The IPartRetriever type exposes the following members.

Properties

 | Name | Description
Public property | BackgroundLoadDocument | Gets or sets whether the Document will continue to load in the background during idle periods.
Public property | ShowThumbnailBeforePageContent | Gets or sets whether the viewer will display an enlarged thumbnail of a document's page when the page is scrolled to but has not yet been loaded.
Public property | Uri | The URI of the .xod document.
Public property | UseDocumentThumbnailIfAvailable | Gets or sets whether the method Document.LoadThumbnailAsync() will return pre-generated page thumbnails (if they are available in the document), or will create thumbnail created from the page contents.

See Also

IPartRetriever Interface
PDFTron.SilverDox.IO Namespace


BackgroundLoadDocument Property

[image]

PDFTron SilverDox SDK
IPartRetriever..::..BackgroundLoadDocument Property
IPartRetriever Interface See Also Send Feedback
Gets or sets whether the Document will continue to load in the background during idle periods.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
bool BackgroundLoadDocument { get; set; }
Visual Basic
Property BackgroundLoadDocument As Boolean
    Get
    Set
Visual C++
property bool BackgroundLoadDocument {
    bool get ();
    void set (bool value);
}

Remarks

Background loading is only useful for HttpPartRetriever. HttpStreamingPartRetriever inherently loads all resources, and LocalPartRetriever is sufficiently fast that background loading provides no advantage.

See Also

IPartRetriever Interface
PDFTron.SilverDox.IO Namespace


ShowThumbnailBeforePageContent Property

[image]

PDFTron SilverDox SDK
IPartRetriever..::..ShowThumbnailBeforePageContent Property
IPartRetriever Interface See Also Send Feedback
Gets or sets whether the viewer will display an enlarged thumbnail of a document's page when the page is scrolled to but has not yet been loaded.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
bool ShowThumbnailBeforePageContent { get; set; }
Visual Basic
Property ShowThumbnailBeforePageContent As Boolean
    Get
    Set
Visual C++
property bool ShowThumbnailBeforePageContent {
    bool get ();
    void set (bool value);
}

Remarks

Showing an enlarged thumbnail on a full page before the content is available is useful for HttpPartRetriever because the time to acquire the entire page content can be noticeable, but the time to acquire a thumbnail is minimal. LocalPartRetriever does not need to show a thumbnail first because the entire page content can be quickly retrieved, and HttpStreamingPartRetriever loads page content before any thumbnails, so it is not possible to show a thumbnail first.

See Also

IPartRetriever Interface
PDFTron.SilverDox.IO Namespace


Uri Property

[image]

PDFTron SilverDox SDK
IPartRetriever..::..Uri Property
IPartRetriever Interface See Also Send Feedback
The URI of the .xod document.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
Uri Uri { get; set; }
Visual Basic
Property Uri As Uri
    Get
    Set
Visual C++
property Uri^ Uri {
    Uri^ get ();
    void set (Uri^ value);
}

See Also

IPartRetriever Interface
PDFTron.SilverDox.IO Namespace


UseDocumentThumbnailIfAvailable Property

[image]

PDFTron SilverDox SDK
IPartRetriever..::..UseDocumentThumbnailIfAvailable Property
IPartRetriever Interface See Also Send Feedback
Gets or sets whether the method Document.LoadThumbnailAsync() will return pre-generated page thumbnails (if they are available in the document), or will create thumbnail created from the page contents.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
bool UseDocumentThumbnailIfAvailable { get; set; }
Visual Basic
Property UseDocumentThumbnailIfAvailable As Boolean
    Get
    Set
Visual C++
property bool UseDocumentThumbnailIfAvailable {
    bool get ();
    void set (bool value);
}

Remarks

If a document contains pre-rendered thumbnails, the viewer has the option to use them, or alernatively, to generate thumbnails internally by rendering and scaling the page content. Using the built-in thumbnails is preferred except for the case of HttpStreamingPartRetriever, when it is faster to display internally generated thumbnails.

See Also

IPartRetriever Interface
PDFTron.SilverDox.IO Namespace


IPartRetriever Events

[image] [image]

PDFTron SilverDox SDK
IPartRetriever Events
IPartRetriever Interface See Also Send Feedback

The IPartRetriever type exposes the following members.

Events

 | Name | Description
Public event | OnPartReady | Raised when a part has been acquired.

See Also

IPartRetriever Interface
PDFTron.SilverDox.IO Namespace


OnPartReady Event

[image]

PDFTron SilverDox SDK
IPartRetriever..::..OnPartReady Event
IPartRetriever Interface See Also Send Feedback
Raised when a part has been acquired.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
event EventHandler<OnPartReadyEventArgs> OnPartReady
Visual Basic
Event OnPartReady As EventHandler(Of OnPartReadyEventArgs)
Visual C++
 event EventHandler<OnPartReadyEventArgs^>^ OnPartReady {
    void add (EventHandler<OnPartReadyEventArgs^>^ value);
    void remove (EventHandler<OnPartReadyEventArgs^>^ value);
}

See Also

IPartRetriever Interface
PDFTron.SilverDox.IO Namespace


LocalPartRetriever Class

[image]

PDFTron SilverDox SDK
LocalPartRetriever Class
Members See Also Send Feedback
Retrieves Document parts asynchronously from locally hosted .xod file.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class LocalPartRetriever : IPartRetriever,
    IDisposable
Visual Basic
Public Class LocalPartRetriever _
    Implements IPartRetriever, IDisposable
Visual C++
public ref class LocalPartRetriever : IPartRetriever,
    IDisposable

Remarks

This retriever (like all retrievers) is typically passed to Document's LoadAsync(IPartRetriever, Action<(Of <<'(Exception>)>>)) method or DocumentViewer's LoadAsync(IPartRetriever, Action<(Of <<'(Exception>)>>)) method to facilitate loading a Document. This particular retriever is used to retrieve documents from the local file system. This part retriever is constructed using a seekable Stream, such as a FileStream. Note, however, that any seekable Stream (e.g. a MemoryStream) can be used, expanding the number of scenarios in which this retriever could be used.

Inheritance Hierarchy

System..::..Object
PDFTron.SilverDox.IO..::..LocalPartRetriever

See Also

LocalPartRetriever Members
PDFTron.SilverDox.IO Namespace
PDFTron.SilverDox.IO..::..IPartRetriever


LocalPartRetriever Members

[image] [image]

PDFTron SilverDox SDK
LocalPartRetriever Members
LocalPartRetriever Class Constructors Methods Properties Events See Also Send Feedback

The LocalPartRetriever type exposes the following members.

Constructors

 | Name | Description
Public method | LocalPartRetriever | Constructs a new LocalPartRetriever.

Methods

 | Name | Description
Public method | CancelAllRequests | Cancels all outstanding requests.
Public method | CancelRequests | Cancels requests for specific Document parts.
Public method | Dispose | Closes the file stream created when opening the .xod file using the RequestDocument() method.
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | Request | Request specfic document resources.
Public method | RequestDocument | Creates an open file dialog box in order to acquire a stream from the locally hosted .xod file, then requests the information necessary to initilize the Document.

Properties

 | Name | Description
Public property | BackgroundLoadDocument | If true, the part retriever will continued to download content for pages that are not currently being displayed.
Public property | ShowThumbnailBeforePageContent | If true, shows an upscaled thumbnail on a page while the page's content is downloadd.
Public property | Uri | Unused in this part retriever because of the local file system security restrictions imposed by Silverlight. This part retriever is constructed using a stream to a .xod document.
Public property | UseDocumentThumbnailIfAvailable | If true, uses a document's pre-rendered thumbnail rather than rendering one on the fly from the page's content.

Events

 | Name | Description
Public event | OnPartReady | Raised when a part has been acquired. It is necessary to subscribe to this event to receive the parts returned by a call to the Request(List<(Of <<'(String>)>>), Object) or RequestDocument()()()() methods.

See Also

LocalPartRetriever Class
PDFTron.SilverDox.IO Namespace


LocalPartRetriever Constructor

[image]

PDFTron SilverDox SDK
LocalPartRetriever Constructor
LocalPartRetriever Class Example See Also Send Feedback
Constructs a new LocalPartRetriever.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public LocalPartRetriever(
    Stream stream,
    bool backgroundLoadDocument
)
Visual Basic
Public Sub New ( _
    stream As Stream, _
    backgroundLoadDocument As Boolean _
)
Visual C++
public:
LocalPartRetriever(
    Stream^ stream,
    bool backgroundLoadDocument
)

Parameters

stream
Type: System.IO..::..Stream
A stream to a .xod file, typically acquired from a local file using an open file dialog.
backgroundLoadDocument
Type: System..::..Boolean

[Missing <param name="backgroundLoadDocument"/> documentation for "M:PDFTron.SilverDox.IO.LocalPartRetriever.#ctor(System.IO.Stream,System.Boolean)"]

Remarks

Note that while this part retriever is intended for use with a local file system, it will work with a stream acquired from any source. The stream must be seekable.

Examples

CopyC#
 //Shows using an open dialog box to acquire a stream to
 //a local .xod file, and using it to construct a LocalPartRetriver.

private LocalPartRetriever MyRetriever;
public void LoadLocalDocument()
{
    OpenFileDialog dlg = new OpenFileDialog();
    dlg.Multiselect = false;
    dlg.Filter = "XOD Files (*.xod)|*.xod";

    // open dialog
    bool ok = (bool)dlg.ShowDialog();

    if (ok)
    {
        if (MyRetriever as LocalPartRetriever != null)
            ((LocalPartRetriever) MyRetriever).Dispose();
        FileStream fileStream = dlg.File.OpenRead();
        MyRetriever = new LocalPartRetriever(fileStream);
        MyDocumentViewer.LoadAsync(MyRetriever, OnLoadAsyncCallback);
    }
}

See Also

LocalPartRetriever Class
PDFTron.SilverDox.IO Namespace


LocalPartRetriever Methods

[image] [image]

PDFTron SilverDox SDK
LocalPartRetriever Methods
LocalPartRetriever Class See Also Send Feedback

The LocalPartRetriever type exposes the following members.

Methods

 | Name | Description
Public method | CancelAllRequests | Cancels all outstanding requests.
Public method | CancelRequests | Cancels requests for specific Document parts.
Public method | Dispose | Closes the file stream created when opening the .xod file using the RequestDocument() method.
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | Request | Request specfic document resources.
Public method | RequestDocument | Creates an open file dialog box in order to acquire a stream from the locally hosted .xod file, then requests the information necessary to initilize the Document.

See Also

LocalPartRetriever Class
PDFTron.SilverDox.IO Namespace


CancelAllRequests Method

[image]

PDFTron SilverDox SDK
LocalPartRetriever..::..CancelAllRequests Method
LocalPartRetriever Class See Also Send Feedback
Cancels all outstanding requests.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void CancelAllRequests()
Visual Basic
Public Sub CancelAllRequests
Visual C++
public:
virtual void CancelAllRequests() sealed

Implements

IPartRetriever..::..CancelAllRequests()()()()

See Also

LocalPartRetriever Class
PDFTron.SilverDox.IO Namespace


CancelRequests Method

[image]

PDFTron SilverDox SDK
LocalPartRetriever..::..CancelRequests Method
LocalPartRetriever Class See Also Send Feedback
Cancels requests for specific Document parts.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void CancelRequests(
    List<string> parts
)
Visual Basic
Public Sub CancelRequests ( _
    parts As List(Of String) _
)
Visual C++
public:
virtual void CancelRequests(
    List<String^>^ parts
) sealed

Parameters

parts
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
The names of the parts which are no longer to be requested. Part names are typically retrieved from a Document's Pages's ResourceNames property.

Implements

IPartRetriever..::..CancelRequests(List<(Of <<'(String>)>>))

See Also

LocalPartRetriever Class
PDFTron.SilverDox.IO Namespace


Dispose Method

[image]

PDFTron SilverDox SDK
LocalPartRetriever..::..Dispose Method
LocalPartRetriever Class See Also Send Feedback
Closes the file stream created when opening the .xod file using the RequestDocument() method.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

LocalPartRetriever Class
PDFTron.SilverDox.IO Namespace


Finalize Method

[image]

PDFTron SilverDox SDK
LocalPartRetriever..::..Finalize Method
LocalPartRetriever Class See Also Send Feedback

[Missing <summary> documentation for "M:PDFTron.SilverDox.IO.LocalPartRetriever.Finalize"]

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

LocalPartRetriever Class
PDFTron.SilverDox.IO Namespace


Request Method

[image]

PDFTron SilverDox SDK
LocalPartRetriever..::..Request Method
LocalPartRetriever Class See Also Send Feedback
Request specfic document resources.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void Request(
    List<string> parts,
    Object CustomData
)
Visual Basic
Public Sub Request ( _
    parts As List(Of String), _
    CustomData As Object _
)
Visual C++
public:
virtual void Request(
    List<String^>^ parts,
    Object^ CustomData
) sealed

Parameters

parts
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
The names of the requested resources.
CustomData
Type: System..::..Object
An object that will be included as part of the OnPartReadyEventArgs.

Implements

IPartRetriever..::..Request(List<(Of <<'(String>)>>), Object)

See Also

LocalPartRetriever Class
PDFTron.SilverDox.IO Namespace


RequestDocument Method

[image]

PDFTron SilverDox SDK
LocalPartRetriever..::..RequestDocument Method
LocalPartRetriever Class See Also Send Feedback
Creates an open file dialog box in order to acquire a stream from the locally hosted .xod file, then requests the information necessary to initilize the Document.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public void RequestDocument()
Visual Basic
Public Sub RequestDocument
Visual C++
public:
virtual void RequestDocument() sealed

Implements

IPartRetriever..::..RequestDocument()()()()

See Also

LocalPartRetriever Class
PDFTron.SilverDox.IO Namespace


LocalPartRetriever Properties

[image] [image]

PDFTron SilverDox SDK
LocalPartRetriever Properties
LocalPartRetriever Class See Also Send Feedback

The LocalPartRetriever type exposes the following members.

Properties

 | Name | Description
Public property | BackgroundLoadDocument | If true, the part retriever will continued to download content for pages that are not currently being displayed.
Public property | ShowThumbnailBeforePageContent | If true, shows an upscaled thumbnail on a page while the page's content is downloadd.
Public property | Uri | Unused in this part retriever because of the local file system security restrictions imposed by Silverlight. This part retriever is constructed using a stream to a .xod document.
Public property | UseDocumentThumbnailIfAvailable | If true, uses a document's pre-rendered thumbnail rather than rendering one on the fly from the page's content.

See Also

LocalPartRetriever Class
PDFTron.SilverDox.IO Namespace


BackgroundLoadDocument Property

[image]

PDFTron SilverDox SDK
LocalPartRetriever..::..BackgroundLoadDocument Property
LocalPartRetriever Class See Also Send Feedback
If true, the part retriever will continued to download content for pages that are not currently being displayed.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool BackgroundLoadDocument { get; set; }
Visual Basic
Public Property BackgroundLoadDocument As Boolean
    Get
    Set
Visual C++
public:
virtual property bool BackgroundLoadDocument {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IPartRetriever..::..BackgroundLoadDocument

See Also

LocalPartRetriever Class
PDFTron.SilverDox.IO Namespace


ShowThumbnailBeforePageContent Property

[image]

PDFTron SilverDox SDK
LocalPartRetriever..::..ShowThumbnailBeforePageContent Property
LocalPartRetriever Class See Also Send Feedback
If true, shows an upscaled thumbnail on a page while the page's content is downloadd.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool ShowThumbnailBeforePageContent { get; set; }
Visual Basic
Public Property ShowThumbnailBeforePageContent As Boolean
    Get
    Set
Visual C++
public:
virtual property bool ShowThumbnailBeforePageContent {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IPartRetriever..::..ShowThumbnailBeforePageContent

See Also

LocalPartRetriever Class
PDFTron.SilverDox.IO Namespace


Uri Property

[image]

PDFTron SilverDox SDK
LocalPartRetriever..::..Uri Property
LocalPartRetriever Class See Also Send Feedback
Unused in this part retriever because of the local file system security restrictions imposed by Silverlight. This part retriever is constructed using a stream to a .xod document.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Uri Uri { get; set; }
Visual Basic
Public Property Uri As Uri
    Get
    Set
Visual C++
public:
virtual property Uri^ Uri {
    Uri^ get () sealed;
    void set (Uri^ value) sealed;
}

Implements

IPartRetriever..::..Uri

See Also

LocalPartRetriever Class
PDFTron.SilverDox.IO Namespace


UseDocumentThumbnailIfAvailable Property

[image]

PDFTron SilverDox SDK
LocalPartRetriever..::..UseDocumentThumbnailIfAvailable Property
LocalPartRetriever Class See Also Send Feedback
If true, uses a document's pre-rendered thumbnail rather than rendering one on the fly from the page's content.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool UseDocumentThumbnailIfAvailable { get; set; }
Visual Basic
Public Property UseDocumentThumbnailIfAvailable As Boolean
    Get
    Set
Visual C++
public:
virtual property bool UseDocumentThumbnailIfAvailable {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IPartRetriever..::..UseDocumentThumbnailIfAvailable

See Also

LocalPartRetriever Class
PDFTron.SilverDox.IO Namespace


LocalPartRetriever Events

[image] [image]

PDFTron SilverDox SDK
LocalPartRetriever Events
LocalPartRetriever Class See Also Send Feedback

The LocalPartRetriever type exposes the following members.

Events

 | Name | Description
Public event | OnPartReady | Raised when a part has been acquired. It is necessary to subscribe to this event to receive the parts returned by a call to the Request(List<(Of <<'(String>)>>), Object) or RequestDocument()()()() methods.

See Also

LocalPartRetriever Class
PDFTron.SilverDox.IO Namespace


OnPartReady Event

[image]

PDFTron SilverDox SDK
LocalPartRetriever..::..OnPartReady Event
LocalPartRetriever Class See Also Send Feedback
Raised when a part has been acquired. It is necessary to subscribe to this event to receive the parts returned by a call to the Request(List<(Of <<'(String>)>>), Object) or RequestDocument()()()() methods.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public event EventHandler<OnPartReadyEventArgs> OnPartReady
Visual Basic
Public Event OnPartReady As EventHandler(Of OnPartReadyEventArgs)
Visual C++
public:
virtual  event EventHandler<OnPartReadyEventArgs^>^ OnPartReady {
    void add (EventHandler<OnPartReadyEventArgs^>^ value);
    void remove (EventHandler<OnPartReadyEventArgs^>^ value);
}

Implements

IPartRetriever..::..OnPartReady

See Also

LocalPartRetriever Class
PDFTron.SilverDox.IO Namespace


OnPartReadyEventArgs Class

[image]

PDFTron SilverDox SDK
OnPartReadyEventArgs Class
Members See Also Send Feedback
Arguments that are a parameter to the OnPartReady event handler.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public class OnPartReadyEventArgs : EventArgs,
    IAsyncResult
Visual Basic
Public Class OnPartReadyEventArgs _
    Inherits EventArgs _
    Implements IAsyncResult
Visual C++
public ref class OnPartReadyEventArgs : public EventArgs,
    IAsyncResult

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
PDFTron.SilverDox.IO..::..OnPartReadyEventArgs

See Also

OnPartReadyEventArgs Members
PDFTron.SilverDox.IO Namespace


OnPartReadyEventArgs Members

[image] [image]

PDFTron SilverDox SDK
OnPartReadyEventArgs Members
OnPartReadyEventArgs Class Constructors Properties See Also Send Feedback

The OnPartReadyEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | OnPartReadyEventArgs | Constructor.

Properties

 | Name | Description
Public property | AsyncState | Gets a user-defined object that qualifies or contains information about an asynchronous operation.
Public property | AsyncWaitHandle | Gets a WaitHandle that is used to wait for an asynchronous operation to complete.
Public property | Cancelled | Indicates if the request was cancelled.
Public property | CompletedSynchronously | Gets a value that indicates whether the asynchronous operation completed synchronously.
Public property | Data | The data of the part being returned.
Public property | Error | If an error has occured, Error contains information about the error; otherwise, Error is null.
Public property | IsCompleted | Gets a value that indicates whether the asynchronous operation has completed.
Public property | IsCompressed | Indicates if the bytes in Data are compressed flate compressed.
Public property | PartName | The name of the part being returend.

See Also

OnPartReadyEventArgs Class
PDFTron.SilverDox.IO Namespace


OnPartReadyEventArgs Constructor

[image]

PDFTron SilverDox SDK
OnPartReadyEventArgs Constructor
OnPartReadyEventArgs Class See Also Send Feedback
Constructor.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public OnPartReadyEventArgs(
    string fileName,
    byte[] data,
    Object customData,
    bool completedSynchronously,
    bool compressedData,
    bool cancelled,
    Exception error
)
Visual Basic
Public Sub New ( _
    fileName As String, _
    data As Byte(), _
    customData As Object, _
    completedSynchronously As Boolean, _
    compressedData As Boolean, _
    cancelled As Boolean, _
    error As Exception _
)
Visual C++
public:
OnPartReadyEventArgs(
    String^ fileName,
    array<unsigned char>^ data,
    Object^ customData,
    bool completedSynchronously,
    bool compressedData,
    bool cancelled,
    Exception^ error
)

Parameters

fileName
Type: System..::..String
The file name of the part being returend.
data
Type: array< System..::..Byte >[]()[][]
The data of the part being returned.
customData
Type: System..::..Object
An object that may be used to pass through custom data.
completedSynchronously
Type: System..::..Boolean
Indicates if the callback was called synchronously.
compressedData
Type: System..::..Boolean

[Missing <param name="compressedData"/> documentation for "M:PDFTron.SilverDox.IO.OnPartReadyEventArgs.#ctor(System.String,System.Byte[],System.Object,System.Boolean,System.Boolean,System.Boolean,System.Exception)"]

cancelled
Type: System..::..Boolean
Indicates if the request has been cancelled.
error
Type: System..::..Exception
If an error has occured, Error contains information about the error; otherwise, Error is null.

See Also

OnPartReadyEventArgs Class
PDFTron.SilverDox.IO Namespace


OnPartReadyEventArgs Properties

[image] [image]

PDFTron SilverDox SDK
OnPartReadyEventArgs Properties
OnPartReadyEventArgs Class See Also Send Feedback

The OnPartReadyEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AsyncState | Gets a user-defined object that qualifies or contains information about an asynchronous operation.
Public property | AsyncWaitHandle | Gets a WaitHandle that is used to wait for an asynchronous operation to complete.
Public property | Cancelled | Indicates if the request was cancelled.
Public property | CompletedSynchronously | Gets a value that indicates whether the asynchronous operation completed synchronously.
Public property | Data | The data of the part being returned.
Public property | Error | If an error has occured, Error contains information about the error; otherwise, Error is null.
Public property | IsCompleted | Gets a value that indicates whether the asynchronous operation has completed.
Public property | IsCompressed | Indicates if the bytes in Data are compressed flate compressed.
Public property | PartName | The name of the part being returend.

See Also

OnPartReadyEventArgs Class
PDFTron.SilverDox.IO Namespace


AsyncState Property

[image]

PDFTron SilverDox SDK
OnPartReadyEventArgs..::..AsyncState Property
OnPartReadyEventArgs Class See Also Send Feedback
Gets a user-defined object that qualifies or contains information about an asynchronous operation.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Object AsyncState { get; set; }
Visual Basic
Public Property AsyncState As Object
    Get
    Set
Visual C++
public:
virtual property Object^ AsyncState {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Implements

IAsyncResult..::..AsyncState

See Also

OnPartReadyEventArgs Class
PDFTron.SilverDox.IO Namespace


AsyncWaitHandle Property

[image]

PDFTron SilverDox SDK
OnPartReadyEventArgs..::..AsyncWaitHandle Property
OnPartReadyEventArgs Class See Also Send Feedback
Gets a WaitHandle that is used to wait for an asynchronous operation to complete.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public WaitHandle AsyncWaitHandle { get; set; }
Visual Basic
Public Property AsyncWaitHandle As WaitHandle
    Get
    Set
Visual C++
public:
virtual property WaitHandle^ AsyncWaitHandle {
    WaitHandle^ get () sealed;
    void set (WaitHandle^ value) sealed;
}

Implements

IAsyncResult..::..AsyncWaitHandle

See Also

OnPartReadyEventArgs Class
PDFTron.SilverDox.IO Namespace


Cancelled Property

[image]

PDFTron SilverDox SDK
OnPartReadyEventArgs..::..Cancelled Property
OnPartReadyEventArgs Class See Also Send Feedback
Indicates if the request was cancelled.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool Cancelled { get; set; }
Visual Basic
Public Property Cancelled As Boolean
    Get
    Set
Visual C++
public:
property bool Cancelled {
    bool get ();
    void set (bool value);
}

See Also

OnPartReadyEventArgs Class
PDFTron.SilverDox.IO Namespace


CompletedSynchronously Property

[image]

PDFTron SilverDox SDK
OnPartReadyEventArgs..::..CompletedSynchronously Property
OnPartReadyEventArgs Class See Also Send Feedback
Gets a value that indicates whether the asynchronous operation completed synchronously.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool CompletedSynchronously { get; set; }
Visual Basic
Public Property CompletedSynchronously As Boolean
    Get
    Set
Visual C++
public:
virtual property bool CompletedSynchronously {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IAsyncResult..::..CompletedSynchronously

See Also

OnPartReadyEventArgs Class
PDFTron.SilverDox.IO Namespace


Data Property

[image]

PDFTron SilverDox SDK
OnPartReadyEventArgs..::..Data Property
OnPartReadyEventArgs Class See Also Send Feedback
The data of the part being returned.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public byte[] Data { get; set; }
Visual Basic
Public Property Data As Byte()
    Get
    Set
Visual C++
public:
property array<unsigned char>^ Data {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

OnPartReadyEventArgs Class
PDFTron.SilverDox.IO Namespace


Error Property

[image]

PDFTron SilverDox SDK
OnPartReadyEventArgs..::..Error Property
OnPartReadyEventArgs Class See Also Send Feedback
If an error has occured, Error contains information about the error; otherwise, Error is null.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public Exception Error { get; set; }
Visual Basic
Public Property Error As Exception
    Get
    Set
Visual C++
public:
property Exception^ Error {
    Exception^ get ();
    void set (Exception^ value);
}

See Also

OnPartReadyEventArgs Class
PDFTron.SilverDox.IO Namespace


IsCompleted Property

[image]

PDFTron SilverDox SDK
OnPartReadyEventArgs..::..IsCompleted Property
OnPartReadyEventArgs Class See Also Send Feedback
Gets a value that indicates whether the asynchronous operation has completed.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool IsCompleted { get; set; }
Visual Basic
Public Property IsCompleted As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsCompleted {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IAsyncResult..::..IsCompleted

See Also

OnPartReadyEventArgs Class
PDFTron.SilverDox.IO Namespace


IsCompressed Property

[image]

PDFTron SilverDox SDK
OnPartReadyEventArgs..::..IsCompressed Property
OnPartReadyEventArgs Class See Also Send Feedback
Indicates if the bytes in Data are compressed flate compressed.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public bool IsCompressed { get; set; }
Visual Basic
Public Property IsCompressed As Boolean
    Get
    Set
Visual C++
public:
property bool IsCompressed {
    bool get ();
    void set (bool value);
}

See Also

OnPartReadyEventArgs Class
PDFTron.SilverDox.IO Namespace


PartName Property

[image]

PDFTron SilverDox SDK
OnPartReadyEventArgs..::..PartName Property
OnPartReadyEventArgs Class See Also Send Feedback
The name of the part being returend.

Namespace: PDFTron.SilverDox.IO
Assembly: SilverDox (in SilverDox.dll) Version: 1.2.4413.29010

Syntax

C#
public string PartName { get; set; }
Visual Basic
Public Property PartName As String
    Get
    Set
Visual C++
public:
property String^ PartName {
    String^ get ();
    void set (String^ value);
}

See Also

OnPartReadyEventArgs Class
PDFTron.SilverDox.IO Namespace